Премини към съдържанието
  • Добре дошли!

    Добре дошли в нашите форуми, пълни с полезна информация. Имате проблем с компютъра или телефона си? Публикувайте нова тема и ще намерите решение на всичките си проблеми. Общувайте свободно и открийте безброй нови приятели.

    Моля, регистрирайте се за да публикувате тема и да получите пълен достъп до всички функции.

     

Всичко за Ubuntu - проблеми,мнения,въпроси


Препоръчан отговор


Имам проблем с флашплъгина за Опера под Убунту 8.04.Не ми върви флаш видеото от Vbox и не се визуализират флаш анимацийте.Даите съвет.

Линк към този отговор
Сподели в други сайтове
  • Отговори 1,4k
  • Създадено
  • Последен отговор

Потребители с най-много отговори

Потребители с най-много отговори

Публикувани изображения

Имам проблем с флашплъгина за Опера под Убунту 8.04.Не ми върви флаш видеото от Vbox и не се визуализират флаш анимацийте.Даите съвет.

Ако си инсталирал плъгина от repos на убунту няма да стане, защото от adobe са сменили md5 сумите. Отиди на траницата на Adobe и от там си свали и инсталирай плъгина.

Линк към този отговор
Сподели в други сайтове

А как става инсталацията?Аз просто копирам libflashplayer.so в /usr/lib/flashplugin-nonfree/libflashplayer.so ,естествено,след смяна на правата за достъп.Така ставаше в ЛинуксМинт4.0,която е Убунту7.10 клонинг.При Убунту8.04 нещо не става.

Линк към този отговор
Сподели в други сайтове
А как става инсталацията?Аз просто копирам libflashplayer.so в /usr/lib/flashplugin-nonfree/libflashplayer.so ,естествено,след смяна на правата за достъп.Така ставаше в ЛинуксМинт4.0,която е Убунту7.10 клонинг.При Убунту8.04 нещо не става.

пробвай да стартираш

sudo ldconfig

Линк към този отговор
Сподели в други сайтове

Новите версии на Adobe flash player за линукс, не работят нито под Firefox 3 beta 5, нито под Opera 9.27. Решението за Firefox е да се използва Gnash но преди това трябва да се деинсталира Pulseaudio. В момента съм в това състояние и дори YouTube зарежда нормално; Нищо че Gnash е още в бета етап, ама то и файърфокса е същия. Най-добрия вариант в случая е downgrade къмто Firefox 2, мернах го нейде из хранилищата. При Опера обаче Gnash не може да се ползва и трябва да си намериш стара версия на Adobe flash, отпреди да сменят скелета му с новия. Специално за Opera 9.27 ти препоръчвам да намериш flash-plugin_9.0.48.0-1_i386 , дава отлични резултати като съвместимост (доколкото може да се очаква след трагичната кончина на Macromedia. Докато беше жива, сякаш проблеми с flash-a нямаше толкова ?) Но нищо, да живее Adobe - The Greatest Linux Supporter and Software Developer !

П.С: С новите бета версии на Opera 9.5X (изключително нестабилни) може да се ползва и най-новият Adobe-flash, ако ви се рискува с нестабилен браузър опитайте, но поне мен много ме изнервя като се самозатваря спонтанно и без предупреждение ! Ако пък не ви се даунгрейдва Файърфокс до двойката, без проблем можете да си инсталнете и Epiphany (The Gnome WEB browser; Gecko based), Gnash се разбира съвършенно с него cool.gif

Редактирано от Phoenix.bg (преглед на промените)

Линк към този отговор
Сподели в други сайтове

Plug-ins

Shockwave Flashapplication/futuresplash spl

application/x-shockwave-flash swf

/usr/lib/mozilla/plugins/flashplugin-alternative.so

NS4PluginProxyapplication/x-opera-nsplugin -

/usr/lib/opera/plugins/libnpp.so

Shockwave Flashapplication/futuresplash spl

application/x-shockwave-flash swf

/usr/lib/flashplugin-nonfree/libflashplayer.so

Няма промяна-изобразяват се само част от флаш анимацийте.При минта стана с по-стара версия на libflashplayer.so na Adobe ,тук не се получава.

Линк към този отговор
Сподели в други сайтове
А как става инсталацията?Аз просто копирам libflashplayer.so в /usr/lib/flashplugin-nonfree/libflashplayer.so ,естествено,след смяна на правата за достъп.Така ставаше в ЛинуксМинт4.0,която е Убунту7.10 клонинг.При Убунту8.04 нещо не става.

Бета версията работи с флаша - тегли ТУК

Линк към този отговор
Сподели в други сайтове

Оказа се че съм омазал работата като при първият старт на Мозила съм посочил за флаш плеър Swfdec-някакъв алтернативен плеър.Това чудо явно влиза в конфликт с Адобе плеъра и става мазало.След деинстала на Swfdec флаша на Операта заработи нормално.Новата бета2 на Опера засега се държи стабилно,ще я оставя за тестове.Благодаря на всички за помоща.

Линк към този отговор
Сподели в други сайтове

Може би въпроса не е за тук но:

Някой може ли да даде линк към инсталационен диск на Ubuntu, при който след инсталацията на самата система в мениджъра на пакети (Synaptic) да намирам пакетите на compiz ( http://compiz.org/Home/Start ) и следователно от там да ги инсталирам.

П.П Този въпрос е защото на компютъра на село нямам нет и незнам как да го инсталирам. Все пак съм новак с Linux!

Линк към този отговор
Сподели в други сайтове
Може би въпроса не е за тук но:

Някой може ли да даде линк към инсталационен диск на Ubuntu, при който след инсталацията на самата система в мениджъра на пакети (Synaptic) да намирам пакетите на compiz ( http://compiz.org/Home/Start ) и следователно от там да ги инсталирам.

П.П Този въпрос е защото на компютъра на село нямам нет и незнам как да го инсталирам. Все пак съм новак с Linux!

нямаш ли интернет? пакетите са достъпни от universe repository

Линк към този отговор
Сподели в други сайтове

Инсталирам пруз вуби. Дава ми инвалид партишън или нещо такова, търках го и инсталирах наново и пак същото... Първия път зарежда - прави чекинг инсталейшън и после след ресета - край...

Иначе преди ставаше с 7 версия на Убунто ама сега не може.

С Вуби инстлаирам като първия път той сам си изтегли нужното а втория път му сложих това исо тука от тракера от торента и нестава. След първото зареждане ми дава Invalid Partition ог Grub менаджера и нестава...

Някой знае ли как се оправя това?

Значи за по ясно ето пак какво правя:

- Пуска най-новото вуби от http://wubi-installer.org/.

- Инсталирам с 10GB дял и всичко друго по дофолт.

- Приключва и ми дава да рестартирам

- Рестартирам и тръгва Убунтото и почва да прави Checking Installation - около 5 минути и после рестартира

- Пуска се Grub менаджера и до там. Като избера някой от убунто редовете дали нормален и ли сейф мод нестава щото Invalid Partition или нещо такова.

Уиндоуса ми е XP Pro SP3, NTFS на всичките 3 харда х250GB.

Линк към този отговор
Сподели в други сайтове

Здравей. Прочети този пост и кажи дали е пробван този начин за инсталиране. Сваленият .iso файл (от официалната страница) естествено е проврен за грешки.

При пускането на wubi под Windows, се проверява съдържанието на .iso-то, прави си директория ?:\ubuntu и я пълни с неща, които са му необходими. Трябва му образ installation.iso в ?:\ubuntu\install и при мен грешката се получава точно в тази стъпка. Опитай през виртуално CD да видим дали тук е проблема.

Възможно е проблемът да е в някоя от следващите стъпки. Виждам, че имаш 3 хард диска, на кой от трите го инсталираш? Ако не е на първият - може да се дължи на това?

Линк към този отговор
Сподели в други сайтове

При мен се инсталира без проблеми, после дори се стартира без проблеми първия път но нали първото стартиране прави някакви допълнителни нeща и после иска рестарт - е там вече след ресета неще да зареди.

Ето къде е инталирано:

26687731ok0.th.jpg

Редактирано от Dave (преглед на промените)
Линк към този отговор
Сподели в други сайтове

Какви допълнителни неща?Защо да се рестартира?Какво значи да не ти се зарежда?Да не би да ти гаси монитора?Опиши точно проблема.

Линк към този отговор
Сподели в други сайтове

След като се инсталира нормално, но не иска да се зареди, си мисля, че е нещо свързано с настройките на GRUB.

С толково много дискове и дялове, аз леко се обърквам. Не мога да схвана къде е инсталиран Windows (вероятно на C?, но пък той не е Active?), първият Disk 0, пък има дял Е: и е Active? Не съм работил с повече от 1 диск и ми е трудно да схвана начина на стартиране в твоят случай.

При мен положениято е това.

Имам инсталиран Windows - дяловете са C:, D:. Имам инсталирано Ubuntu 7.10 - 10.01GB-вият дял е /home, 6.14GB-вият е "/" и 1.50GB-вият е swap. Wubi install-а е на D:. При мен е различно поради инсталираното Ubuntu. Ако се абстрахираме от това, се получи следното:

При инсталирането, освен нещата в ?:\ubuntu\, wubi ми направи в C:\ и D:\ по два файла - wubildr.mbr, wubildr. Също така добави в boot.ini на Windows-а това:

[boot loader]

timeout=15

default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS

[operating systems]

multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect

c:\wubildr.mbr="Ubuntu"
Това ти добавя възможност да избереш Windows или Ubuntu (при мен този екран идва като втори, след първоначалният избор на Windows от възможните Windows XP/Ubuntu 7.10). Като избереш Ubuntu 8.04, се зарежда GRUB, който може би е този в директория ?:\ubuntu\disks\boot\ (възможно е това да се явява нещо като boot дял(директория??). Там в директория \grub има файл menu.lst, в който е описано къде GRUB да търси и как да зареди Linux-а. Ето част от съдържанието му:
.....

## ## End Default Options ##


title		Ubuntu 8.04, kernel 2.6.24-16-generic

root		(hd0,4)/ubuntu/disks

kernel		/boot/vmlinuz-2.6.24-16-generic root=UUID=FC0C11DE0C11952C loop=/ubuntu/disks/root.disk ro quiet splash

initrd		/boot/initrd.img-2.6.24-16-generic


title		Ubuntu 8.04, kernel 2.6.24-16-generic (recovery mode)

root		(hd0,4)/ubuntu/disks

kernel		/boot/vmlinuz-2.6.24-16-generic root=UUID=FC0C11DE0C11952C loop=/ubuntu/disks/root.disk ro single

initrd		/boot/initrd.img-2.6.24-16-generic


title		Ubuntu 8.04, memtest86+

root		(hd0,4)/ubuntu/disks

kernel		/boot/memtest86+.bin


### END DEBIAN AUTOMAGIC KERNELS LIST


# This is a divider, added to separate the menu items below from the Debian

# ones.

title		Other operating systems:

root



# This entry automatically added by the Debian installer for a non-linux OS

# on /dev/sda1

title		Microsoft Windows XP Professional

root		(hd0,0)

savedefault

chainloader	+1



# This entry automatically added by the Debian installer for an existing

# linux installation on /dev/sda3.

title		Ubuntu 7.10, kernel 2.6.22-14-generic (on /dev/sda3)

root		(hd0,2)

kernel		/boot/vmlinuz-2.6.22-14-generic root=UUID=5a2c8aba-e692-4d3a-8e1c-474067e54a5b ro vga=792 splash quiet 

initrd		/boot/initrd.img-2.6.22-14-generic

savedefault

boot

.....

За сатртиране на Windows се тъси тук - (hd0,0), първият диск "hd0", първият дял "0". В моят случай това е C:.

За Ubuntu 8.04 се търси в (hd0,4) - първи диск "hd0", петти дял "4" (забелязваш, че GRUB брои от нула). При ме това се пада D:, в чиято основна директория ги има онези wubildr.mbr и wubildr.

Различното при мен е добавеното Ubuntu 7.10 в края - (hd0,2) в случая е 6.14GB-вият дял.

Накрая да кажа, че според мен е възможно да е объркано нещо точно в указването къде да се търси "wubi" инсталацията на Ubuntu 8.04 . Огледай тези неща как са при теб. Може да покажеш частта от твоят menu.list файл, за да може спецовете да погледнат и да предложат съвет.

===

Ако правилно се ориентирам в твоят случай, за стартиране на Ubuntu 8.04 срещу root трябва да пише (hd0,1) - Disk 0, дял 2 (F:). В F:\ ти трябват wubildr.mbr и wubildr, а в F:\ubuntu\disks\ - root.disk и swap.disk (файловете, играещи роля на виртуални дискове при този начин да инсталация). Провери дали е така.

Редактирано от trosho (преглед на промените)
Линк към този отговор
Сподели в други сайтове

Значи точно от груба е според мене. Спира с грешка Cant Find Boot Partition или нещо такова, още преди да стартира.

Ето го инито:

[boot loader]

timeout=15

default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS

[operating systems]

multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect /sos

c:\wubildr.mbr="Ubuntu"

F:\ubuntu\disks\ - root.disk и swap.disk

ИМА ГИ И ДВЕТЕ

Ето го ГРУБ:

Май наистина търси на грешния партишън защото никъде нямам hd0,4

# menu.lst - See: grub(8), info grub, update-grub(8)

# grub-install(8), grub-floppy(8),

# grub-md5-crypt, /usr/share/doc/grub

# and /usr/share/doc/grub-doc/.

## default num

# Set the default entry to the entry number NUM. Numbering starts from 0, and

# the entry number 0 is the default if the command is not used.

#

# You can specify 'saved' instead of a number. In this case, the default entry

# is the entry saved with the command 'savedefault'.

# WARNING: If you are using dmraid do not use 'savedefault' or your

# array will desync and will not let you boot your system.

default 0

## timeout sec

# Set a timeout, in SEC seconds, before automatically booting the default entry

# (normally the first entry defined).

timeout 10

## hiddenmenu

# Hides the menu by default (press ESC to see the menu)

#hiddenmenu

# Pretty colours

#color cyan/blue white/blue

## password ['--md5'] passwd

# If used in the first section of a menu file, disable all interactive editing

# control (menu entry editor and command-line) and entries protected by the

# command 'lock'

# e.g. password topsecret

# password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/

# password topsecret

#

# examples

#

# title Windows 95/98/NT/2000

# root (hd0,0)

# makeactive

# chainloader +1

#

# title Linux

# root (hd0,1)

# kernel /vmlinuz root=/dev/hda2 ro

#

#

# Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST

### BEGIN AUTOMAGIC KERNELS LIST

## lines between the AUTOMAGIC KERNELS LIST markers will be modified

## by the debian update-grub script except for the default options below

## DO NOT UNCOMMENT THEM, Just edit them to your needs

## ## Start Default Options ##

## default kernel options

## default kernel options for automagic boot options

## If you want special options for specific kernels use kopt_x_y_z

## where x.y.z is kernel version. Minor versions can be omitted.

## e.g. kopt=root=/dev/hda1 ro

## kopt_2_6_8=root=/dev/hdc1 ro

## kopt_2_6_8_2_686=root=/dev/hdc2 ro

# kopt=root=UUID=D4A914212AD68FC3 loop=/ubuntu/disks/root.disk ro

## Setup crashdump menu entries

## e.g. crashdump=1

# crashdump=0

## default grub root device

## e.g. groot=(hd0,0)

# groot=(hd0,4)/ubuntu/disks

## should update-grub create alternative automagic boot options

## e.g. alternative=true

## alternative=false

# alternative=true

## should update-grub lock alternative automagic boot options

## e.g. lockalternative=true

## lockalternative=false

# lockalternative=false

## additional options to use with the default boot option, but not with the

## alternatives

## e.g. defoptions=vga=791 resume=/dev/hda5

# defoptions=quiet splash

## should update-grub lock old automagic boot options

## e.g. lockold=false

## lockold=true

# lockold=false

## Xen hypervisor options to use with the default Xen boot option

# xenhopt=

## Xen Linux kernel options to use with the default Xen boot option

# xenkopt=console=tty0

## altoption boot targets option

## multiple altoptions lines are allowed

## e.g. altoptions=(extra menu suffix) extra boot options

## altoptions=(recovery) single

# altoptions=(recovery mode) single

## controls how many kernels should be put into the menu.lst

## only counts the first occurence of a kernel, not the

## alternative kernel options

## e.g. howmany=all

## howmany=7

# howmany=all

## should update-grub create memtest86 boot option

## e.g. memtest86=true

## memtest86=false

# memtest86=true

## should update-grub adjust the value of the default booted system

## can be true or false

# updatedefaultentry=false

## should update-grub add savedefault to the default options

## can be true or false

# savedefault=false

## ## End Default Options ##

title Ubuntu 8.04, kernel 2.6.24-16-generic

root (hd0,4)/ubuntu/disks

kernel /boot/vmlinuz-2.6.24-16-generic root=UUID=D4A914212AD68FC3 loop=/ubuntu/disks/root.disk ro quiet splash

initrd /boot/initrd.img-2.6.24-16-generic

title Ubuntu 8.04, kernel 2.6.24-16-generic (recovery mode)

root (hd0,4)/ubuntu/disks

kernel /boot/vmlinuz-2.6.24-16-generic root=UUID=D4A914212AD68FC3 loop=/ubuntu/disks/root.disk ro single

initrd /boot/initrd.img-2.6.24-16-generic

title Ubuntu 8.04, memtest86+

root (hd0,4)/ubuntu/disks

kernel /boot/memtest86+.bin

### END DEBIAN AUTOMAGIC KERNELS LIST

# This is a divider, added to separate the menu items below from the Debian

# ones.

title Other operating systems:

root

# This entry automatically added by the Debian installer for a non-linux OS

# on /dev/sda1

title Windows Vista/Longhorn (loader)

root (hd0,0)

savedefault

chainloader +1

# This entry automatically added by the Debian installer for a non-linux OS

# on /dev/sdb1

title Microsoft Windows XP Professional

root (hd1,0)

savedefault

map (hd0) (hd1)

map (hd1) (hd0)

chainloader +1

Сега отивам на работа, утре ще го едитна да видим дали ще зареди.

Линк към този отговор
Сподели в други сайтове
Значи точно от груба е според мене. Спира с грешка Cant Find Boot Partition или нещо такова, още преди да стартира.

От ## ## End Default Options ## нагоре можеш да изрежеш цитата. В края на предишният си пост аз съм се объркал. Не обърнах внимание, че твоят дял F: е logical, а не primary (аналогичен е на моят дял D: ). Така че според мен (hd0,4) е правилното - първи хард диск, първи логически дял.

Забелязвам обаче, че имаш инсталирани XP и Vista. Под XP или под Vista го инсталира, коя се зарежда по default?

Защото при такъв dual boot, май се прави някакъв номер да се излъже Windows-а, че е инсталиран на първият дял, на първият хард диск. Прави се нещо като размяна на местата на дисковете (виж допълнителните редове за стартиране на XP в твоят цитат). При Windows това май се прави от ntloader и лошото е, че това се случва преди да се стартира GRUB4DOS. Така GRUB търси на грешно място.

Редактирано от trosho (преглед на промените)
Линк към този отговор
Сподели в други сайтове
Забелязвам обаче, че имаш инсталирани XP и Vista. Под XP или под Vista го инсталира, коя се зарежда по default?

Значи при мене работата е малко дебела. Преди като съм инсталирал вистата тя си слагаше бубт лодера на партишъна при XP то и от там ставаше дуал буут. Последният път обаче нещата не станаха така, и сега вистата си е на отделен хардиск с отделен буут партишън. За да я пусна трябва от BIOS да сменя като първи хард този на който е тя.

Иначе винаги ми зарежда XP и ме пита и за убентото сега.

Линк към този отговор
Сподели в други сайтове

Хмм 8.04 ме кефи много. Инсталирах го през Wubi, че е най-лесно. Досега не срещам сериозни проблеми.

Линк към този отговор
Сподели в други сайтове

Мерси човече много за помоща, беше прав точно там е проблема.

Все пак аз питах в форума на Убунто и някакъв гуру ми каза следното:

In the grub menu replace all

root (hd0,4)/ubuntu/disks

with

root ()/ubuntu/disks

and also replace groot=(hd0,4)/ubuntu/disks with groot=()/ubuntu/disks

Ето това оправи положението!

Сега иам проблеми с интернета щото нещо не ми детектва уайрлеса а и мишката (безжична) ми спря да работи след 5 минути (добре че имам друга вързана) но ще ги оправям.

Линк към този отговор
Сподели в други сайтове

Важното е, че стана cool.gif .

Ще поизрия глупостите дето съм писал по-горе, за да остане това решение на проблема. Може да помогне на някой друг.

---

За wireless има нещичко тук, a мишока може би "заспива".

---

Предлагам на всички, които като мен се чудят каква беше тази или онази команда, два кратки "пищова" в PDF формат - Ubuntu Reference и Unix/Linux Command Reference.

Редактирано от trosho (преглед на промените)
Линк към този отговор
Сподели в други сайтове

Ами аз пробвах разни неща и сега съвсем не работи.

Променях разни неща по /etc/X11/xorg.conf и стана лошо.

Имам бакъп обаче как да го върна след като не ми работи мишката?

Бакъпа е тука: /etc/X11/xorg.conf.backup

Трябва да изтрия стария фаил и да сложа този ама незнам как.

Освен това искам да инсталирам nVidia драйвер ама нестава.

Като го стартирам ми дава че трябва с root права, а като напиа

sudo sh NVIDIA-Linux-x86-169.12-pkg1.run

и ми дава че няма команда NVIDIA-Linux-x86-169.12-pkg1.run

Как да го инсталирам това? В убунто неможе да се логнеш като root перманентно...

Линк към този отговор
Сподели в други сайтове

Може да погледнеш тук. В друга тема е, но май се отнася за същото.

Редактирано от trosho (преглед на промените)
Линк към този отговор
Сподели в други сайтове
Ами аз пробвах разни неща и сега съвсем не работи.

Променях разни неща по /etc/X11/xorg.conf и стана лошо.

Имам бакъп обаче как да го върна след като не ми работи мишката?

Бакъпа е тука: /etc/X11/xorg.conf.backup

Трябва да изтрия стария фаил и да сложа този ама незнам как.

Освен това искам да инсталирам nVidia драйвер ама нестава.

Като го стартирам ми дава че трябва с root права, а като напиа

sudo sh NVIDIA-Linux-x86-169.12-pkg1.run

и ми дава че няма команда NVIDIA-Linux-x86-169.12-pkg1.run

Как да го инсталирам това? В убунто неможе да се логнеш като root перманентно...

1. За да си върнеш стария config излизаш от графичния режим и пишеш cp /etc/X11/xorg.conf.backup /etc/X11/xorg.conf и даваш Ентер. За да излезеш от графичния режим, мисля че беше с ALT + F1 или ALT + F2, нека друг да каже, защото аз не си спомням точно клавишната комбинация.

2. NVIDIA-Linux-x86-169.12-pkg1.run - пакетите в Убунту завършват предимно на .deb и се "инсталирват" с командата dpkg -i name_of_file.deb Това .run не знам как ще го подкараш там.....

3. За да си инсталираш някой пакет използвай приложението Synaptic - там има много хранилища и пакети.

4. За да влезеш като руут използвай същите име и парола, които си задал на потребителя.

Накратко това от мен, ако искаш повече няма да е лошо да видиш: www.ubuntuguide.org

и пак повтарям: Преди да започнете да се занимавате с Линукс не е лошо да прочетете това-онова предварително, за да ви се прояснят някой работи. А в нета има изобилие от информация за него. Успех!

Предлагам на всички, които като мен се чудят каква беше тази или онази команда, два кратки "пищова" в PDF формат - Ubuntu Reference и Unix/Linux Command Reference.

Тези "пищови" са супер, мерси много ;)

Линк към този отговор
Сподели в други сайтове
Гост
Тази тема е заключена за нови отговори.
×
×
  • Добави ново...

Информация

Поставихме бисквитки на устройството ви за най-добро потребителско изживяване. Можете да промените настройките си за бисквитки, или в противен случай приемаме, че сте съгласни с нашите Условия за ползване