Премини към съдържанието

    Препоръчан отговор


    Здравейте,

    От известно време Windows 7x64 неще да ми разпознае dvd rom-a.

    Не се показва в Device Manager изобщо като устройство - все едно такова изобщо не е закачено.

    Странното, обаче, е че се показва в Explorer. Когато цъкнеш на него казва, че няма диск.

    Устройството работи абсолютно нормално и не е изгоряло:

    1) Без проблеми работя с него под Linux

    2) Мога да boot-вам cd-та от него

    Чудя се какъв му е проблема на Windows-a?

    Пробвах някакви "windows fix it" глупости, пробвах да махна от regedit HKEY_LOCAL_MACHINE SYSTEMCurrentControlSetControlClass{4D36E965-E325-11CE-BFC1-08002BE10318}UpperFilter и LowerFilter.

    Някакви идеи, че вече почнах да се изчерпвам? Кой знае каква "брилянтна" глупост е причината за това..

    @PC Doctor

    Устройството работеше преди и след това мистериозно спря да работи.

    Хем го вижда (седи в exporer), хем не го вижда (няма го в Device manager).

    Ползвам Nero portable, която е работеща (пробвал съм я на други компютри), но самото устройство го няма и не можеш да го избереш за да записваш с него.

    Работи под линукс е буквално - работи под линукс, мога да чета и записвам. :D

    Имам няколко OS-та качени на компютъра и ползвам lilo за да избера, коя да се пусне. Не ползвам Dual boot.

    Когато си пусна линукса dvd rom-a работи без проблеми.

    @krassleto

    Да имам качен daemon tools.

    Редактирано от tftd (преглед на промените)

    Сподели този отговор


    Линк към този отговор
    Сподели в други сайтове

    Здравей ! Как да разбирам това "От известно време .... " .Устройството е работело под Уиндоус 7 до един момент и след това край ? Разбирам че си изчерпил знанията ,но ако нещо си спомниш как се е случило да не го разпознава ще е добре за да се ориентираме за какво точно става въпрос. Това с разпознаването дай малко повече обяснение ,не го виждаш като устройство или не реагира като пуснеш дискове ? Като пробваш да запишеш диск програмата която използваш намира ли го като устройство ? Две ОС ли използваш едновременно ? Какво значи работи под Линукс ?

    Редактирано от PC doctor (преглед на промените)

    Сподели този отговор


    Линк към този отговор
    Сподели в други сайтове

    инсталирана програма за емулация на cd/dvd у-ва от типа на Daemoon tools?

    Сподели този отговор


    Линк към този отговор
    Сподели в други сайтове

    Проблема ти е точно от това използване на няколко ОС едновременно . При избирането на Уиндоус явно не ти зарежда всички устройства . Пипал си и по регистрите . Ако имаш диск с Уиндоус-а пускай го и лекувай .

    Редактирано от PC doctor (преглед на промените)

    Сподели този отговор


    Линк към този отговор
    Сподели в други сайтове

    Проблема ти е точно от това използване на няколко ОС едновременно . При избирането на Уиндоус явно не ти зарежда всички устройства . Пипал си и по регистрите . Ако имаш диск с Уиндоус-а пускай го и лекувай .

    Ще се опитам пак да ти обясня - не ползвам dual boot.

    Това с пипането по регистрите е "known hack" и го пише на support.microsoft.com.

    Пробвал съм windows 7 repair-a - не върши работа.


    Сподели този отговор


    Линк към този отговор
    Сподели в други сайтове

    Пробвай това: Device Manager => CD/DVD-ROM Drivers => Scan for hardware changes

    Редактирано от gothicrock (преглед на промените)

    Сподели този отговор


    Линк към този отговор
    Сподели в други сайтове

    Също така може да пробваш с друго или някое старо работещо оптично устройство.Деинсталирай и Daemon Tools и виж дали ще има някаква промяна.

    Сподели този отговор


    Линк към този отговор
    Сподели в други сайтове

    Пробвай това:

    Device Manager => CD/DVD-ROM Drivers => Scan for hardware changes

    Да пробвах го това доста пъти... Не го разпознава изобщо :/

    Също така може да пробваш с друго или някое старо работещо оптично устройство.Деинсталирай и Daemon Tools и виж дали ще има някаква промяна.

    Нямам в наличност други устройства. Махнах daemon tools-a, но за съжаление и това не оправи работата.

    На самото устройство нищо му няма - като го пробвам под друга OS или boot-вам диск си работи без проблеми.

    Преди много време ми се беше случвало подобно нещо и го оправих с преименуването на UpperFilter/LowerFilter регистрите.

    Сега поради някаква причина не става.

    Сподели този отговор


    Линк към този отговор
    Сподели в други сайтове

    Да пробвах го това доста пъти... Не го разпознава изобщо :/

    А с Control Panel => Add Hardware?

    На самото устройство нищо му няма - като го пробвам под друга OS или boot-вам диск си работи без проблеми.

    Преди много време ми се беше случвало подобно нещо и го оправих с преименуването на UpperFilter/LowerFilter регистрите.

    Сега поради някаква причина не става.

    Явно регистрите са се омазали.

    Сподели този отговор


    Линк към този отговор
    Сподели в други сайтове

    Здравейте отново ! Уважаеми колеги ,автора на темата пише че устройството е видимо във експлоръра ,но не е видимо в диспечера на устройствата . Не може да бъде използвано защото има грешка в регистрите на файловата система и устройството не е разпознато като хардуерно такова именно от диспечера на устройствата . Продължавам да твърдя че проблема идва от това че при използването му посредством другата ОС,посредством програмата която автора използва за избор между ОС-ми се пренася от едната към другата начина на управление на това устройство и поради тази причина устройството в видно в експлоръра ,но това е просто това което е виждал използвайки Линукс-а. От тук на там за Уиндоус това устройство не може да се използва защото това устройство все едно е разкачено. Това се случва не рядко когато се използват наистина различни по структура ОС .Дори да бъде физически премахвано и отново поставяно няма как да се получат нещата . Автора може да опита едно нещо . Разкачване на устройството . Нека разкара lilo ,да настрой предварително да се стартира Уиндоус като ОС ,след като стартира и зареди всичко да закачи обратно и да се убеди сам дали Уиндоус ще да го разпознае и конфигурира или не .Ако не се получи това ще е и края на въпросите дали ще проработи нормално или не на този компютър при наличието на двете ОС ,поне в сегашното им състояние или ще се наложи да ги преинсталира отново .

    Сподели този отговор


    Линк към този отговор
    Сподели в други сайтове

    И къде видя хардуерен дефект???????? Сам казваш, че под Убунту работи, значи е от Windows-а, а това е софтуер...

    • Харесва ми 1

    Сподели този отговор


    Линк към този отговор
    Сподели в други сайтове

    Здравейте отново ! Уважаеми колеги ,автора на темата пише че устройството е видимо във експлоръра ,но не е видимо в диспечера на устройствата . Не може да бъде използвано защото има грешка в регистрите на файловата система и устройството не е разпознато като хардуерно такова именно от диспечера на устройствата . Продължавам да твърдя че проблема идва от това че при използването му посредством другата ОС,посредством програмата която автора използва за избор между ОС-ми се пренася от едната към другата начина на управление на това устройство и поради тази причина устройството в видно в експлоръра ,но това е просто това което е виждал използвайки Линукс-а. От тук на там за Уиндоус това устройство не може да се използва защото това устройство все едно е разкачено. Това се случва не рядко когато се използват наистина различни по структура ОС .Дори да бъде физически премахвано и отново поставяно няма как да се получат нещата . Автора може да опита едно нещо . Разкачване на устройството . Нека разкара lilo ,да настрой предварително да се стартира Уиндоус като ОС ,след като стартира и зареди всичко да закачи обратно и да се убеди сам дали Уиндоус ще да го разпознае и конфигурира или не .Ако не се получи това ще е и края на въпросите дали ще проработи нормално или не на този компютър при наличието на двете ОС ,поне в сегашното им състояние или ще се наложи да ги преинсталира отново .

    Мисля, че или нещо май не ме разбираш или не знаеш за какво говоря.

    Lilo е bootloader. Bootloader-a се ползва за да можеш да избереш коя операционна система да пуснеш, когато имаш повече от една.

    От там нататък всичко е в ръцете на самата ОС. Lilo-то няма абсолютно нищо общо с проблема.

    А с Control Panel => Add Hardware?

    Явно регистрите са се омазали.

    Не може да се добави от там.. Нещо Daemon tools-a е омазал работата.

    Решението на проблема всъщност се оказа следното нещо:

    1) Следвате стъпките за "manual fix" (http://support.microsoft.com/kb/982116)

    2) Рестартирате компютъра

    3) Намирате драйверите за dvdrom-a и ги инсталирате

    4) Рестартирате компютъра

    5) Радвате се на dvd rom-a си.

    Благодаря на всички, които помогнаха! :)

    Редактирано от tftd (преглед на промените)

    Сподели този отговор


    Линк към този отговор
    Сподели в други сайтове

    Мисля, че или нещо май не ме разбираш или не знаеш за какво говоря.

    Lilo е bootloader. Bootloader-a се ползва за да можеш да избереш коя операционна система да пуснеш, когато имаш повече от една.

    От там нататък всичко е в ръцете на самата ОС. Lilo-то няма абсолютно нищо общо с проблема.

    Не може да се добави от там.. Нещо Daemon tools-a е омазал работата.

    Решението на проблема всъщност се оказа следното нещо:

    1) Следвате стъпките за "manual fix" (http://support.microsoft.com/kb/982116)

    2) Рестартирате компютъра

    3) Намирате драйверите за dvdrom-a и ги инсталирате

    4) Рестартирате компютъра

    5) Радвате се на dvd rom-a си.

    Благодаря на всички, които помогнаха! :)

    Драги приятелю ,ти въобще прочете ли какво ти написах в поста който си цитирал ? Казах ти ма махнеш лоудъра за да не избираш въобще коя ОС да ти стартира а да настроиш да ти стартира Уиндоус директно ,да разкачиш устройството и след като стартира ОС да го закачиш обратно за да го разпознае самата ОС от начало и да го конфигурира със драйвер със всичко ,и едва тогава да правиш нещо друго ако не се получи . Нали си със 7 ,ако не ти разпознае основно устройство като dvd rom-a и не може да го конфигурира самата ОС след монтирането му значи нещо не е наред . Ако беше наред нямаше да има нужда от допълнителни драйвери за това .Това е ,и дано нямаш повече проблеми ,въпреки че си мисля че въпреки че си сложил драйвер ръчно проблема ще се появи отново в даден момент ,както се е появил и преди .

    И къде видя хардуерен дефект???????? Сам казваш, че под Убунту работи, значи е от Windows-а, а това е софтуер...

    Къде се споменава за хардуерен дефект ?

    Редактирано от PC doctor (преглед на промените)

    Сподели този отговор


    Линк към този отговор
    Сподели в други сайтове

    Решението на проблема всъщност се оказа следното нещо:

    1) Следвате стъпките за "manual fix" (http://support.microsoft.com/kb/982116)

    2) Рестартирате компютъра

    3) Намирате драйверите за dvdrom-a и ги инсталирате

    4) Рестартирате компютъра

    5) Радвате се на dvd rom-a си.

    Доста е озадачаващо да трябва да се слагат някакви специални драйвери за DVD-то. Но щом това е решило проблема, хубаво. :)

    Сподели този отговор


    Линк към този отговор
    Сподели в други сайтове

    Регистрирайте се или влезете в профила си за да коментирате

    Трябва да имате регистрация за да може да коментирате това

    Регистрирайте се

    Създайте нова регистрация в нашия форум. Лесно е!

    Нова регистрация

    Вход

    Имате регистрация? Влезте от тук.

    Вход


    ×

    Информация

    Този сайт използва бисквитки (cookies), за най-доброто потребителско изживяване. С използването му, вие приемате нашите Условия за ползване.