Премини към съдържанието

    Препоръчан отговор


    С Ubuntu Linux 10.10 съм и съм инсталирал LAMPP.

    Всичко работеше перфертно, докато не почнах да бърникам по конфигурационните файлове, за да направя page forwarding.

    В един момент, когато се опитах да отворя страницата 127.0.0.1/xampp/phpmyadmin/index.php получих лседното съобщение за грешка:

    Access forbidden!

    New XAMPP security concept:

    Access to the requested directory is only available from the local network.

    This setting can be configured in the file "httpd-xampp.conf".

    If you think this is a server error, please contact the webmaster.

    Error 403

    127.0.0.1

    Apache/2.4.2 (Unix) OpenSSL/1.0.1c PHP/5.4.4

    Разбирам, че проблемът е някъде еъе файла httpd-xampp.conf, но нищо не се променя, каквото и да правя.

    Ще съм много благодарен, ако няккой ми каже как да го оправя.

    Благодаря!

    Сподели този отговор


    Линк към този отговор
    Сподели в други сайтове

    С Ubuntu Linux 10.10 съм и съм инсталирал LAMPP.

    Всичко работеше перфертно, докато не почнах да бърникам по конфигурационните файлове, за да направя page forwarding.

    В един момент, когато се опитах да отворя страницата 127.0.0.1/xampp/phpmyadmin/index.php получих лседното съобщение за грешка:

    Разбирам, че проблемът е някъде еъе файла httpd-xampp.conf, но нищо не се променя, каквото и да правя.

    Ще съм много благодарен, ако няккой ми каже как да го оправя.

    Благодаря!

    Търсете Allow, Deny ключови думи в блок, свързан с phpmyadmin

    Сподели този отговор


    Линк към този отговор
    Сподели в други сайтове

    Знам. Казх Ви, че пробвах всичко. Два дни се ровя в нета и пробвах всякакви комбинации. Дори му дадох Allow all и пак не ще.

    Сподели този отговор


    Линк към този отговор
    Сподели в други сайтове

    Знам.

    Казх Ви, че пробвах всичко.

    Два дни се ровя в нета и пробвах всякакви комбинации.

    Дори му дадох Allow all и пак не ще.

    Погледнете дали няма някоя Include команда и съответно външни конфигурационни файлове в които да има други дефиниции

    Сподели този отговор


    Линк към този отговор
    Сподели в други сайтове

    Инклуднати файлове няма, само директории за phpmyadmin.

    Ето го направо файла httpd-xampp.conf, но не виждам нищо нередно:

    <IfDefine PHP4>
    LoadModule php4_module	    modules/libphp4.so
    </IfDefine>
    <IfDefine PHP5>
    LoadModule php5_module	    modules/libphp5.so
    </IfDefine>
    # Disabled in XAMPP 1.8.0-beta2 because of current incompatibilities with Apache 2.4
    # LoadModule perl_module	    modules/mod_perl.so
    
    Alias /phpmyadmin "/opt/lampp/phpmyadmin"
    Alias /phpsqliteadmin "/opt/lampp/phpsqliteadmin"
    # since XAMPP 1.4.3
    <Directory "/opt/lampp/phpmyadmin">
        AllowOverride AuthConfig Limit
        Order allow,deny
        Allow from all
    </Directory>
    <Directory "/opt/lampp/phpsqliteadmin">
        AllowOverride AuthConfig Limit
        Order allow,deny
        Allow from all
    </Directory>
    # since LAMPP 1.0RC1
    AddType application/x-httpd-php .php .php3 .php4
    XBitHack on
    # since 0.9.8 we've mod_perl
    <IfModule mod_perl.c>
    	    AddHandler perl-script .pl
    PerlHandler ModPerl::PerlRunPrefork
    PerlOptions +ParseHeaders
    	    PerlSendHeader On
    </IfModule>
    # demo for mod_perl responsehandler
    #PerlModule Apache::CurrentTime
    #<Location /time>
    #	  SetHandler modperl
    #	  PerlResponseHandler Apache::CurrentTime
    #</Location>
    # AcceptMutex sysvsem is default but on some systems we need this
    # thanks to jeff ort for this hint
    #AcceptMutex flock
    #LockFile /opt/lampp/logs/accept.lock
    # this makes mod_dbd happy - oswald, 02aug06
    # mod_dbd doesn't work in Apache 2.2.3: getting always heaps of "glibc detected *** corrupted double-linked list" on shutdown - oswald, 10sep06
    #DBDriver sqlite3
    #
    # New XAMPP security concept
    #
    <LocationMatch "^/(?i:(?:xampp|security|licenses|phpmyadmin|webalizer|server-status|server-info))">
    Order deny,allow
    Deny from all
    Allow from ::1 127.0.0.0/8 
      fc00::/7 10.0.0.0/8 172.16.0.0/12 192.168.0.0/16 
      fe80::/10 169.254.0.0/16
    ErrorDocument 403 /error/XAMPP_FORBIDDEN.html.var
    </LocationMatch>
    

    Сподели този отговор


    Линк към този отговор
    Сподели в други сайтове

    А какъв е адреса на локалната машина, какво има в error лога?

    Последното ALLoW from... не трябва ли да е 127.0.0.1

    То Е такова (плюс още малко други мрежи)

    Сподели този отговор


    Линк към този отговор
    Сподели в други сайтове

    Оправих го. Просто инсталирах 1.7.1 вместо 1.8.0, с която бях. Тряваше да по1на с версията

    Сподели този отговор


    Линк към този отговор
    Сподели в други сайтове

    Или аз се бъркам със изписването или трябваше да е изписана единицата :

    Поне така е дадена във ALLOW DENY RULES:

    http://wiki.phpmyadmin.net/pma/Config#AllowDeny_.28order.29

    Сподели този отговор


    Линк към този отговор
    Сподели в други сайтове

    Регистрирайте се или влезете в профила си за да коментирате

    Трябва да имате регистрация за да може да коментирате това

    Регистрирайте се

    Създайте нова регистрация в нашия форум. Лесно е!

    Нова регистрация

    Вход

    Имате регистрация? Влезте от тук.

    Вход


    ×

    Информация

    Този сайт използва бисквитки (cookies), за най-доброто потребителско изживяване. С използването му, вие приемате нашите Условия за ползване.