Премини към съдържанието
edhunter

Проблем с Login в FreeBSD

Препоръчан отговор


Здравейте

ситуацията е следната:

имам freebsd 6 машина с две мрежови карти

едната е с адрес 192.168.0.1 другата 192.168.1.2 (адсл както се досещате :down:

ползвам го за рутер, и работи като такав

проблема е следния:

когато от интернет се опитам да се логна чрез ssh към bsd машината успявам безпроблемно, но когато от локалната мрежа опитвам да се логна към 192.168.0.1 не мога. излиза ми промпта в който си пиша логин user-a, и след това не иска да се появи промпта за паролата....

имате ли идея какво мога да направя по въпроса?? ;)

п.с. по принцип firewall-a e default to accept, така че не може да е от него

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

A какво казват логовете по този въпрос? Постни участъка където се опитваш да се логнеш и не успяваш.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
A какво казват логовете по този въпрос? Постни участъка където се опитваш да се логнеш и не успяваш.

<{POST_SNAPBACK}>

Apr 3 21:53:25 geo sshd[72834]: fatal: Timeout before authentication for 192.168.0.2

незнам кой точно лог трябва да видя... това дето съм го пастнал е от /var/log/auth.log

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
Apr  3 21:53:25 geo sshd[72834]: fatal: Timeout before authentication for 192.168.0.2

незнам кой точно лог трябва да видя... това дето съм го пастнал е от /var/log/auth.log

<{POST_SNAPBACK}>

Сега се сещам само за две причини които могат да го предизвикат.

1. Едната е неправилно въведен DNS.

2. Или трябва да едитираш /etc/hosts.allow ТУК има примерни команди които можеш да използваш във hosts.allow. Опитай най-напред с "ALL : ALL : allow" за да разрешиш всякакъв достъп и да видиш дали въобще е от това.

Ако и това не е, постни съдържанието на sshd_config. Също можеш да погледнеш и във /var/log/messages (не знам как е точно при freebsd ) и други логове за authentication, faillog или тем подобни.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Виж каква е стойността на директивата ListenAddress в sshd_config.

Ако там специално не е зададен другият адрес, то вероятността проблема да е в DNS-а е много голяма.

Когато се опитваш да се вържеш FreeBSD пък пробва да върже IP-то име, което няма как да стане.

Пробвай да добавиш това IP в /etc/hosts с някакво фиктивно име.


Сподели този отговор


Линк към този отговор
Сподели в други сайтове

това е /etc/ssh/sshd_config

всички редове без последния са закоментарени включително и (ListenAddress 0.0.0.0)

#	$OpenBSD: sshd_config,v 1.72 2005/07/25 11:59:40 markus Exp $

#	$FreeBSD: src/crypto/openssh/sshd_config,v 1.42.2.1 2005/09/11 16:50:35 des Exp $


# This is the sshd server system-wide configuration file.  See

# sshd_config(5) for more information.


# This sshd was compiled with PATH=/usr/bin:/bin:/usr/sbin:/sbin


# The strategy used for options in the default sshd_config shipped with

# OpenSSH is to specify options with their default value where

# possible, but leave them commented.  Uncommented options change a

# default value.


# Note that some of FreeBSD's defaults differ from OpenBSD's, and

# FreeBSD has a few additional options.


#VersionAddendum FreeBSD-20050903


#Port 22

#Protocol 2

#AddressFamily any

#ListenAddress 0.0.0.0

#ListenAddress ::


# HostKey for protocol version 1

#HostKey /etc/ssh/ssh_host_key

# HostKeys for protocol version 2

#HostKey /etc/ssh/ssh_host_dsa_key


# Lifetime and size of ephemeral version 1 server key

#KeyRegenerationInterval 1h

#ServerKeyBits 768


# Logging

# obsoletes QuietMode and FascistLogging

#SyslogFacility AUTH

#LogLevel INFO


# Authentication:


#LoginGraceTime 2m

#PermitRootLogin no

#StrictModes yes

#MaxAuthTries 6


#RSAAuthentication yes

#PubkeyAuthentication yes

#AuthorizedKeysFile	.ssh/authorized_keys


# For this to work you will also need host keys in /etc/ssh/ssh_known_hosts

#RhostsRSAAuthentication no

# similar for protocol version 2

#HostbasedAuthentication no

# Change to yes if you don't trust ~/.ssh/known_hosts for

# RhostsRSAAuthentication and HostbasedAuthentication

#IgnoreUserKnownHosts no

# Don't read the user's ~/.rhosts and ~/.shosts files

#IgnoreRhosts yes


# Change to yes to enable built-in password authentication.

#PasswordAuthentication no

#PermitEmptyPasswords no


# Change to no to disable PAM authentication

#ChallengeResponseAuthentication yes


# Kerberos options

#KerberosAuthentication no

#KerberosOrLocalPasswd yes

#KerberosTicketCleanup yes

#KerberosGetAFSToken no


# GSSAPI options

#GSSAPIAuthentication no

#GSSAPICleanupCredentials yes


# Set this to 'no' to disable PAM authentication, account processing, 

# and session processing. If this is enabled, PAM authentication will 

# be allowed through the ChallengeResponseAuthentication mechanism. 

# Depending on your PAM configuration, this may bypass the setting of 

# PasswordAuthentication, PermitEmptyPasswords, and 

# "PermitRootLogin without-password". If you just want the PAM account and 

# session checks to run without PAM authentication, then enable this but set 

# ChallengeResponseAuthentication=no

#UsePAM yes


#AllowTcpForwarding yes

#GatewayPorts no

#X11Forwarding yes

#X11DisplayOffset 10

#X11UseLocalhost yes

#PrintMotd yes

#PrintLastLog yes

#TCPKeepAlive yes

#UseLogin no

#UsePrivilegeSeparation yes

#PermitUserEnvironment no

#Compression delayed

#ClientAliveInterval 0

#ClientAliveCountMax 3

#UseDNS yes

#PidFile /var/run/sshd.pid

#MaxStartups 10


# no default banner path

#Banner /some/path


# override default of no subsystems

Subsystem	sftp	/usr/libexec/sftp-server

в hosts.allow е разрешено всичко (ALL : ALL : allow)

ще добавя в host име за 192.168.0.2 и ще пробвам

наиситна имам пуснат dns (named) на машината, може нещо да не съм го конфигурирал както трябва

благодарско за съветите :)

Редактирано от edhunter (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Регистрирайте се или влезете в профила си за да коментирате

Трябва да имате регистрация за да може да коментирате това

Регистрирайте се

Създайте нова регистрация в нашия форум. Лесно е!

Нова регистрация

Вход

Имате регистрация? Влезте от тук.

Вход

×

Информация

Поставихме бисквитки на устройството ви за най-добро потребителско изживяване. Можете да промените настройките си за бисквитки, или в противен случай приемаме, че сте съгласни с нашите условия за ползване.