Премини към съдържанието
_D5

Knoppix live cd не ми открива нета

Препоръчан отговор


Стартирам Кнопикс лайв си ди, но не ми открива нета, същият проблем имах и със Сусе, бях го инсталирал на харда, но и то не ми откри нета.

Ако някой може да помогне......

Аааа и да питам, като стартирам линукс от лайв си ди, променя ли ми това нещо по системата, говоря за трайни промени?

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Живото СиДи се зарежда в рамта и не пипа нищо по харда ако ти не му кажеш изрично да записва.

От гледна точка на сигурността няма никакви проблеми ... т.е. няма да ти съсипе бърлогата на Виндовса.

За конфигурирането на интернета трябва да бъдеш по-точен, защото ако си използвал автоматичният режим е възможно да нямаш нет ...

(то и с Виндовса е така ... в повечето случай трябва ръчно да се въвеждат IP, Gateway, DNS и т.н.)

Бъди по-точен при задаването на въпроса за да получиш още по-точен отговор :)

ENJOY !

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Значи, пускам лайв си ди.то, то почва да зарежда, някъде по време на зареждането пише dhcp /което ми е познато от ходенето по мъките със сусе, и знам че в него е цеееелият проблем/, но след дхкп ми пише и background /което пък ме навява на мисълта, че и този път нет няма да има/, след това хайвана си зарежда нормално, отваря се и тръгва на немски, сменям езика и пробвам с моцила да вялза в нета, но уви не ставаааа, след това рестарт и обратно към добрият стар уин, където явно нещата стават лесно.

Това беше преразказ на всичките ми преживявания с Кнопикс.

Лошото е че толкоз по комфортно е в линукс и мисълта че е без пари е толкоз яка, но е пъти по трудно за инсталация.

ПС иначе ползувам нет от ГГбит /ако случайно някой ползува техните "услуги" и е подкарал нет с лайв кнопикс да пише/

Значи, пускам лайв си ди.то, то почва да зарежда, някъде по време на зареждането пише dhcp /което ми е познато от ходенето по мъките със сусе, и знам че в него е цеееелият проблем/, но след дхкп ми пише и background /което пък ме навява на мисълта, че и този път нет няма да има/, след това хайвана си зарежда нормално, отваря се и тръгва на немски, сменям езика и пробвам с моцила да вялза в нета, но уви не ставаааа, след това рестарт и обратно към добрият стар уин, където явно нещата стават лесно.

Това беше преразказ на всичките ми преживявания с Кнопикс.

Лошото е че толкоз по комфортно е в линукс и мисълта че е без пари е толкоз яка, но е пъти по трудно за инсталация.

ПС иначе ползувам нет от ГГбит /ако случайно някой ползува техните "услуги" и е подкарал нет с лайв кнопикс да пише/

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Каква ти е ЛАН-картата? Да не е някоя уникална която не се поддържа от кнопикса(в което се съмнявам), но все пак.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

ми на дъното е

sis

мисля че емарката


Сподели този отговор


Линк към този отговор
Сподели в други сайтове
ми на дъното е

sis

мисля че емарката

<{POST_SNAPBACK}>

Хмм, трябва да я поддържа.Коя верия на Кнопикс ползваш?

Как си получаваш ИП-то, с DHCP ли или трябва да правиш ръчни настройки? Обясни малко по-подробно как конфигурираш картата под уиндоус. От къде получаваш интернет? Така както си го обяснил ми изглежда, че се опитваш да вземеш ИП чрез DHCP, а трябва да въведеш параметрите ръчно. По принцип ползвам Сусе от доста време като една от най-юзер-френдли ОС и никога не съм имал проблеми с нета. Стъпka по стъпка изглежда така:

1. Компилираш драйвера за картата, ако го нямаш. После го зареждаш. (modprobe driver)

2. Конфигурираш картата в зависимост от това как трябва да получиш ИП-то. Чрез DHCP или чрез ръчна настройка.

3. Проверяваш дали картата е стартирана. Трябва да ти показва правилното ИП и да няма загубени пакети. (/sbin/ifconfig)

4. Пингваш някой хост който трябва да можеш да го достигнеш ако имаш интернет. (ping yahoo.com) и ако ти изкара цифри значи е добре, имаш нет. Ако ти изпише Destination Host Unreachable или нещо такова което не ти харесва значи има проблем.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

ами ползувам кнопикс 3,9

а в уин нета си тръгва автоматично, нищо ама нищо не пипам

а за др неща ми звучакт като на някакъв неразбирам език, а и със сусе 9,3 имах същият проблем нямах нет

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
а за др неща ми звучакт като на някакъв неразбирам език, а и със сусе 9,3 имах същият проблем нямах нет

<{POST_SNAPBACK}>

Хехе, и аз бях като теб в началото. Ако искаш наистина да го подкараш ще трябва да почетеш малко. Ако нямаш желание другата алтернатива е да си ползваш уиндоуса. Доста време и аз ползвах двете системи заради многото проблеми които имах заради това, че не знаех как да ги отстраня. Ето ти User Guide за Сусе и нещо за Кнопикс. Надявам се да ти помогнат.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
Хехе,  и аз бях като теб в началото. Ако искаш наистина да го подкараш ще трябва да почетеш малко. Ако нямаш желание другата алтернатива е да си ползваш уиндоуса. Доста време и аз ползвах двете системи заради многото проблеми които имах заради това, че не знаех как да ги отстраня. Ето ти User Guide за Сусе и нещо за Кнопикс. Надявам се да ти помогнат.

<{POST_SNAPBACK}>

никаква инфо за моя проблем не намирам

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
никаква инфо за моя проблем не намирам

<{POST_SNAPBACK}>

Няма и да намериш. Това са упътвания за употреба и настройки.Дадох ти ги да прочетеш нещо и да се опиташ да си настроиш и активираш LAN картата.Виждам, че не си от хората с много опит с линукс, мога да се опитам да ти помогна едва след като ми обясниш точно какво правиш, как го правиш и какви грешки ти излизат. Колкото е по-подробно толкова по-добре ще мога(и не само аз, а всички които искат да ти помогнат) да анализирам проблема и да ти кажа как да го отстраниш. Защото "Не ми открива нета" ... може да има 100000 причини. А от линукса можеш да получиш наистина подробна информация за това какъв ти е проблема.

Като за начало можеш да кажеш как са направени настройките ти под уиндоус. Ще ги намериш в Start -> SystemSettings -> Network Connections -> NetworkCard -> Properties -> Internetprotocoll(TCP/IP) -> Properties (пиша ги по памет, не си спомням точно как бяха, защото отдавна не ползвам уиндоус)

После опиши подробно как се опитваш да "пуснеш нета" и всичко което ти се изписва при този процес.

След това можеш да отвориш една конзола и да напишеш командата /sbin/ifconfig , и да кажеш какво ти изписва. Също така и командата "ping yahoo.com" (без кавички разбира се) какви резултати ти дава. Иии ... може би с този въпрос трябваше да започна, какъв интернет ползваш?

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
Няма и да намериш. Това са упътвания за употреба и настройки.Дадох ти ги да прочетеш нещо и да се опиташ да си настроиш и активираш LAN картата.Виждам, че не си от хората с много опит с линукс, мога да се опитам да ти помогна едва след като ми обясниш точно какво правиш, как го правиш и какви грешки ти излизат. Колкото е по-подробно толкова по-добре ще мога(и не само аз, а всички които искат да ти помогнат) да анализирам проблема и да ти кажа как да го отстраниш. Защото "Не ми открива нета" ... може да има 100000 причини. А от линукса можеш да получиш наистина подробна информация за това какъв ти е проблема.

Като за начало можеш да кажеш как са направени настройките ти под уиндоус. Ще ги намериш в Start -> SystemSettings -> Network Connections -> NetworkCard -> Properties -> Internetprotocoll(TCP/IP) -> Properties (пиша ги по памет, не си спомням точно как бяха, защото отдавна не ползвам уиндоус)

После опиши подробно как се опитваш да "пуснеш нета" и всичко което ти се изписва при този процес.

След това можеш да отвориш една конзола и да напишеш командата /sbin/ifconfig , и да кажеш какво ти изписва. Също така и командата "ping yahoo.com" (без кавички разбира се) какви резултати ти дава. Иии ... може би с този въпрос трябваше да започна, какъв интернет ползваш?

<{POST_SNAPBACK}>

много добре го описа ... айде и аз ше дам един вариант ...

значи много зависи какви са ти настойките на мрежата ... щом ти излиза DHCP значи че лан картата ше чака сама да си получуи ИП от ДХСП сървъра (към който евентуално трябва да си вързан..) ... тука обаче идва едно НО...

за да решиш проблема ..... в ХР цъкваш на Start>run пишеш "cmd" и като ти излезе ДОС Промпта или "онуй черното с Цто" както му викаше един колега преди време ... в промпта пишеш "ipconfig -all" и ти излиза нещо подобно:

"Ethernet adapter Local Area Connection 2:

Connection-specific DNS Suffix . :

Description . . . . . . . . . . . : NVIDIA nForce MCP Networking Controller

Physical Address. . . . . . . . . : 00-E0-98-3A-19-31

DHCP Enabled. . . . . . . . . . . : No

IP Address. . . . . . . . . . . . : 85.187.xxx.xx

Subnet Mask . . . . . . . . . . . : 255.255.255.0

Default Gateway . . . . . . . . . : 85.187.xxx.x

DNS Servers . . . . . . . . . . . : 80.72.xx.x

192.168.12.3

"

xxx при теб няма да излизат ... аз съм ги добавил .. полето което те интересува тебе е ... DHCP дали е YES или е NO ...

ако е No тогава преписваш всичко под него .... т.е. IP Add.., Subnet Mask, Def Gateway, DNS Server (може и да са 2 гледай да спазваш при въвеждане кой е първи кой е втори ...няма да обяснявам защо)

предполагам че при тебе ще е вариант 2 така, че ше трябва да си ги препишеш на едно лисче ..

след това пускаш си Кнопикса .... не прочетох коя версия ползваш а и в момента не помя как се казваше опцията за настроки на мрежата... отдавна не съм ползвал Кнопикса sad.gif ... тука да помагат колегите :) с по-голям линукс опит от мене .... ше потърся СДто с Кнопа и ше го допиша :)

друго важно е ако имаш 2 ланки една вградена в дъното и друга отделно е хубаво да изключиш от БИОСа вградената за да не се бъркаш (пък и спестяваш пари за ново дъно, евентуално процесор и тн .. ако те сгащи неподготвен някоя гръмотевица)

това е със саветите за момента ... :nono: успех

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

дава ми че ДХКП е вкл

и сега ще препиша данните и ще ги въведа в лин

ще пиша кво е станало

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
дава ми че  ДХКП е вкл

и сега ще препиша данните и ще ги въведа в лин

ще пиша кво е станало

<{POST_SNAPBACK}>

Ako под уиндоус e:

DHCP Enabled. . . . . . . . . . . : Yes

тогава няма нужда да въвеждаш данните в линукса, а да стартираш картата с DHCP.

Можеш да постнеш какво ти излиза като напишеш в конзолата:

/sbin/ifconfig

и

ping yahoo.com

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

На пинг яху ком ми дава

ънноун сървър

а на другата команда ми дава няколко реда ама са на немски

и след това пак няма нет

даже след това

пак няма нет въвеждам пак нещата от на уин ай пи конфига

и няма и няам

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Уау, не съм се сблъсквал с чак такъв проблем. Остава да те питаме-да нямаш случайно 2 LAN карти-отделна на PCI и вградена и Кнопикса да се бърка? Провери тази възможност! В крайна сметка на мен доставчиците са ми обяснявали параметрите за връзка, ако искам да пускам Линукс-обади им се и ти!

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
На пинг яху ком ми дава

ънноун сървър

а на другата команда ми дава няколко реда ама са на немски

и след това пак няма нет

даже след това

пак няма нет въвеждам пак нещата от на уин ай пи конфига

и няма и няам

<{POST_SNAPBACK}>

А как и къде ги въвеждаш защо не описа.

да нямаш случайно 2 LAN карти-отделна на PCI и вградена и Кнопикса да се бърка?

Дори и да има, ако стартира и двете с DHCP няма да има проблеми.Едната ще получи IP а другата не, аз си мисля, че той не стига въобще до там.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

ами въвеждам данните от айпи конфига на уин

в настройките на мрежовата карта

това меню ми излиза като натисна пингвинчето от таскбара на лин

и там има мрежови настройки и някви исдн работи

и там намерих настройки на мрежовата карта

та там ги пиша

първо ме пита искаш ли дхкп да се настрои автоматично

давам му да и след чакане ми дава failed

и след това пак стартирам същата програма

само че без дхкп

и там ме пита за айпи маска гейтуей

броудкаст и тн

и въвеждам настройките от уина и накарая

пак к***ц

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
ами въвеждам данните от айпи конфига на уин

в настройките на мрежовата карта

това меню ми излиза като натисна пингвинчето от таскбара на лин

и там има мрежови настройки и някви исдн работи

и там намерих настройки на мрежовата карта

та там ги пиша

първо ме пита искаш ли дхкп да се настрои автоматично

давам му да и след чакане ми дава failed

и след това пак стартирам същата програма

само че без дхкп

и там ме пита за айпи маска гейтуей

броудкаст и тн

и въвеждам настройките от уина и накарая

пак к***ц

<{POST_SNAPBACK}>

Добре, до тука видяхме, че картата ти не може да получи IP чрез DHCP. Явно проблема не е в грешно въвеждане на данни а е с ЛАН-картата. Сега трябва да открием какъв е проблема.Отваряш една конзола и пишеш следното:

# su -

# tail -f /var/log/messages

(след всеки ред натискаш ентер)

Първия ред те прави root(администратор), а втория отваря файла със съобщенията за грешки като ти изписва последните няколко реда и продължава да изписва тепърва постъпващите.

От теб се иска, след като напишеш втората команда да се опиташ да стартираш по същия начин ЛАН-картата както си описал по-горе с DHCP докато ти покаже "failed".

След това всичко исписано на екрана в конзолата го постни тука, за да може да се анализира проблема който имаш.

EDIT:

Между другото всички които имат проблеми с линукс, моля описвайте си проблема подробно и поствайте информация от логовете за времето когато с е появил проблема. Така откриването на грешките става много бързо и точно.

Редактирано от spica (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Значи въвеждам:

# su -

# tail -f /var/log/messages

(с ентър на всеки ред) и нищо не става в конзолата, никакъв надпис, нищо.

След това пак от менюто с пингвинчето, с което се настройваше мрежовата карта, въвеждам му да търси с dhcp, и ми излиза следният надпис:

Sende DHCP von Netzwerkkarte eth0Operation failed

Fehlgeschlagen

Eingabetaste zum Beden.

Това е всичко, след това интернет отново няма sad.gif .

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
Значи въвеждам:

# su -

# tail -f /var/log/messages

(с ентър на всеки ред) и нищо не става в конзолата, никакъв надпис, нищо.

След това пак от менюто с пингвинчето, с което се настройваше мрежовата карта, въвеждам му да търси с dhcp, и ми излиза следният надпис:

Sende DHCP von Netzwerkkarte eth0Operation failed

Fehlgeschlagen

Eingabetaste zum Beden.

Това е всичко, след това интернет отново няма sad.gif .

Да, малко съм те подвел с командите, извинявай. Всъщност трябва да се напише:

# su -

# /etc/init.d/sysklogd start

# tail -f /var/log/syslog

но след като опитах да видя какво ще ми покаже моя комп, видях че всъщност не показва никаква съществена информация няма да помогне много. Поразтърсих се за подобни проблеми и повечето са на конфигурации с по две ЛАН карти и се получава поради конфигуриране на грешната карта. Ако имаш втора карта опитай се да конфигурираш и нея с DHCP. Ако все пак имаш само една ЛАН карта напиши в конзолата (като root)

# ifup -a

или се опитай да я стартираш ръчно с командата

# ifconfig eth0 (или eth1 ако имаш втора карта) <IP Adress> netmask <netmask> up

(<IP Adress> и <netmask> са стойностите които си преписал от уиндоус)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
Да, малко съм те подвел с командите, извинявай. Всъщност трябва да се напише:

# su -

# /etc/init.d/sysklogd start

# tail -f /var/log/syslog

но след като опитах да видя какво ще ми покаже моя комп, видях че всъщност не показва никаква съществена информация няма да помогне много. Поразтърсих се за подобни проблеми и повечето са на конфигурации с по две ЛАН карти и се получава поради конфигуриране на грешната карта. Ако имаш втора карта опитай се да конфигурираш и нея с DHCP. Ако все пак имаш само една ЛАН карта напиши в конзолата (като root)

# ifup -a

или се опитай да я стартираш ръчно с командата

# ifconfig eth0 (или eth1 ако имаш втора карта) <IP Adress> netmask <netmask> up

(<IP Adress> и <netmask> са стойностите които си преписал от уиндоус)

Нестава и нестава. Пробвах първата команда и ми написа че вече ми е настроено, а при втората не става нищо, пак клик на моцила и пак нищо, вече не знам...

Май няма да мога да пусна линукс на тоя комп и това си му е. sad.gif

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Приятелю,ти можеш ли сам да си настроиш нета на уиндоса?Както обясняваш

си мисля че някой друг ти е правил настройките.Аз моите ги знам наизуст/в

началото гледах от листчето,де/и съм 100 процента че настройките се правят

по един и същи начин както на уина така и на линукса.Просто трябва да разбереш точно как се настройва нета по принцип и това е.Разлика няма.Дали ти е статичен адреса и други такива.Тая информация трябва да получиш от доставчика ти на интернет.Явно само той може да ти помогне.Другия вариант е да пробваш с нещо друго.Примерно ако знаеш английски ти препоръчвам

Мепис,ако искаш български Тилих.Те са като Кнопих с малки разлики.Това е от мен.Успех.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Регистрирайте се или влезете в профила си за да коментирате

Трябва да имате регистрация за да може да коментирате това

Регистрирайте се

Създайте нова регистрация в нашия форум. Лесно е!

Нова регистрация

Вход

Имате регистрация? Влезте от тук.

Вход

×

Информация

Поставихме бисквитки на устройството ви за най-добро потребителско изживяване. Можете да промените настройките си за бисквитки, или в противен случай приемаме, че сте съгласни с нашите условия за ползване.