Премини към съдържанието
asfr

Проблем с резолюцията на монитора

Препоръчан отговор


Здравеите. Нов съм в линукс и попаднах на следния проблем. С оптимус видеокарта съм. След като си инсталирах Убунту  13.04 и инсталирах  Bumblebee, реших да свърйа лаптопа чрез VGA с TV екран но наи голямата резолюцията която ми предложи беше 1024х768. Отворих 1 терминал и написах следните редове: xrandr --newmode "1366x768_60.00" 84.75  1360 1432 1568 1776  768 771 781 798 -hsync +vsync

xrandr --addmode VGA1 1366x768_60.00 xrandr --output VGA1 --mode 1366x768_60.00 Резолюцията почти се оправи но има 2 вертикални черни ленти от ляво и от дясно на екрана на телевизора които изрязват по 2 см. Как да си реша проблема с лентите ? И още един въпрос. След рестартиране ми дава грешка с резолюцията, екрана е отново на 1024х768 и отново трябва да напиша командите. Как да направя настроиките перманентни ?

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

...

Резолюцията почти се оправи но има 2 вертикални черни ленти от ляво и от дясно на екрана на телевизора които изрязват по 2 см. Как да си реша проблема с лентите ? И още един въпрос. След рестартиране ми дава грешка с резолюцията, екрана е отново на 1024х768 и отново трябва да напиша командите. Как да направя настроиките перманентни ?

1 - Не си оцелил резолюцията.

2 - В стартиращите скриптове на Убунту.

 

еdit

Може и във xorg.conf

Редактирано от tux (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

И още един въпрос. След рестартиране ми дава грешка с резолюцията, екрана е отново на 1024х768 и отново трябва да напиша командите. Как да направя настроиките перманентни ?

Каква грешка с резолуцията ти дава?

 

Копира ли от някаде този параметър на монитора?

 

xrandr --newmode "1366x768_60.00" 84.75  1360 1432 1568 1776  768 771 781 798 -hsync +vsync

Ако си го копирал може за това да не съвпада точно.

 

Ако не си със "ctv" ли намери параметрите?

 

Ето как. 

(Пример 1024x768 мОйта резолуция)

(~)% cvt 1024 768                                                                                                         # 1024x768 59.92 Hz (CVT 0.79M3) hsync: 47.82 kHz; pclk: 63.50 MHzModeline "1024x768_60.00"   63.50  1024 1072 1176 1328  768 771 775 798 -hsync +vsync

За LCD екрани може да трябва да използваш [ -r ] опцията.

 

 

-r|--reduced : Create a mode with reduced blanking (default: normal blanking).   X : Desired horizontal resolution (multiple of 8, required).   Y : Desired vertical resolution (required).   refresh : Desired refresh rate (default: 60.0Hz).  

 

Пример $> cvt -r 1024 768

 

Прочети https://wiki.archlinux.org/index.php/Xrandr

Редактирано от ivoarch (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Направих следното:

 

xnaf@xnaf:~$ xrandrScreen 0: minimum 320 x 200, current 1024 x 768, maximum 32767 x 32767LVDS1 connected 1024x768+0+0 (normal left inverted right x axis y axis) 309mm x 174mm   1366x768       60.0 +   1360x768       59.8     60.0     1024x768       60.0*    800x600        60.3     56.2     640x480        59.9  VGA1 connected 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm   1024x768       60.0*    800x600        60.3     56.2     848x480        60.0     640x480        59.9  HDMI1 disconnected (normal left inverted right x axis y axis)DP1 disconnected (normal left inverted right x axis y axis)xnaf@xnaf:~$ cvt 1360 768# 1360x768 59.80 Hz (CVT) hsync: 47.72 kHz; pclk: 84.75 MHzModeline "1360x768_60.00"   84.75  1360 1432 1568 1776  768 771 781 798 -hsync +vsyncxnaf@xnaf:~$ xrandr --newmode "1360x768_60.00"   84.75  1360 1432 1568 1776  768 771 781 798 -hsync +vsyncxnaf@xnaf:~$ xrandr --addmode VGA1 1360x768_60.00xnaf@xnaf:~$ xrandr --output VGA1 --mode 1360x768_60.00xnaf@xnaf:~$ 

Проблема не се реши. Малко се видоизмени.  Отново имам по 2 см черна вертикала от ляво и дясно. Освен това част от екрана се удвои. Ето и снимка на която в прочем не се виждат черните вертикали по обясними причини:

Публикувано изображение


След рестарт или релогване минава на 1024х768. С cvt -r 1360x768 работата е същата. Пробвах и с 1366х768 , 1360х768 , 1368х768. Няма видима разлика. Отново има по 2 санта от ляво и дясно черна вертикала.

Редактирано от xnafets (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

МОже да проваш с xrandr --pos x y

 

например

$>  xrandr --output VGA1 --mode 1366x768_60.00 --pos 0x0  или  $>  xrandr --output VGA1 --mode 1366x768_60.00 --pos 0x998   

Също провай със gtf да намериш на нова параметрите, знае ли човек , може пък да ги изкара по различни от cvt.

 

ето така.

$> gtf 1366 768 60 

Може да пробваш с нмекой графичен Xrandr 

Например http://christian.amsuess.com/tools/arandr/

$> aptitude install arandr
Редактирано от ivoarch (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Не аrandr не предлага над 1024 за тв екрана. Свързах се с HDMI: xrandr --newmode "1360x768_60.00"   84.75  1360 1432 1568 1776  768 771 781 798 -hsync +vsync

xrandr --addmode HDMI1 1360x768_60.00 xrandr --output HDMI1 --mode 1360x768_60.00 Всичко е ок :) . Как да го добавя в кода за стартиране на Убунту та да не го пиша след всяко пускане ? Как да направя така че монитора на лаптопа да не работи докато съм на тв ? Ще се отрази ли това на видео кратата ? Преди време си играх пак и открих код с който спирах екрана на лаптопа но след това не можеше да се гледат филми през тв екрана. 

Редактирано от xnafets (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
1. Как да го добавя в кода за стартиране на Убунту та да не го пиша след всяко пускане ?

Първи начин: с едитора отвараш /etc/X11/xorg.conf

 

И вътре би трябвало да има нещо такова

/etc/X11/xorg.confSection "Monitor"    Identifier      "External DVI"    Modeline        "1280x1024_60.00"  108.88  1280 1360 1496 1712  1024 1025 1028 1060  -HSync +Vsync    Option          "PreferredMode" "1280x1024_60.00"EndSectionSection "Device"    Identifier      "ATI Technologies, Inc. M22 [Radeon Mobility M300]"    Driver          "ati"    Option          "Monitor-DVI-0" "External DVI"EndSectionSection "Screen"    Identifier      "Primary Screen"    Device          "ATI Technologies, Inc. M22 [Radeon Mobility M300]"    DefaultDepth    24    SubSection "Display"        Depth           24        Modes   "1280x1024" "1024x768" "640x480"    EndSubSectionEndSectionSection "ServerLayout"        Identifier      "Default Layout"        Screen          "Primary Screen"EndSection

Но, внимавай да не объркаш нещо, после няма да стартира сесиа.

Направи си BAKCUP на този файл.

 

Втори начин: Някаде в настройките на убунту трябва да имаш  опция за стариране на сесия http://askubuntu.com/questions/186865/how-do-i-start-a-program-automatically-when-i-boot и от там да се избират програми които да стартират при пускане, направи си един скрипт с име connect-tv.sh, и си го старирай от там, като го дабавиш.Или просто го запази на десктопа и от там.

#!/bin/shxrandr --newmode "1360x768_60.00"   84.75  1360 1432 1568 1776  768 771 781 798 -hsync +vsyncxrandr --addmode HDMI1 1360x768_60.00xrandr --output HDMI1 --mode 1360x768_60.00
Редактирано от ivoarch (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

A може ли черните черти вляво и дясно да са от настройките на ТВ-то? Случва се....

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

 По принцип не играя игри и карам с оригиналния драйвер nouveau и arandr  и много лесно става настройката за монитор и тв

Редактирано от yogle (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Регистрирайте се или влезете в профила си за да коментирате

Трябва да имате регистрация за да може да коментирате това

Регистрирайте се

Създайте нова регистрация в нашия форум. Лесно е!

Нова регистрация

Вход

Имате регистрация? Влезте от тук.

Вход

×

Информация

Поставихме бисквитки на устройството ви за най-добро потребителско изживяване. Можете да промените настройките си за бисквитки, или в противен случай приемаме, че сте съгласни с нашите условия за ползване.