Премини към съдържанието
15 години Kaldata.com – време е да почерпим! Прочети още... ×
plamen74

Проблем с KDE Plasma под УСУ 8.3

Препоръчан отговор


След ъпдейт на системата се получи някакъв гаф с работната среда под УСУ 8.3

Значи тапета, видео през плеър, както и клипчета от YouTube, Vbox7 си вървят гладко, а лентите, и рамките на прозорците, както и ефектите не бачкат (даже и браузър като отворя си показва всичко супер с изключение на рамката)?! Също така имам инсталиран и Минт 14 КДЕ, който е със същата версия на КДЕ и същото ядро (инсталирах ги и на двете да са с последните версии на КДЕ и последното LTS ядро заради DVB-T USB тунерчето), но под Минт нямам абсолютно никакво проблеми! Даже под УСУ не виждам и другите дялова, които имам с филми, музика и т.н. които са в NTFS файлова система?! Прилагам снимки:

Публикувано изображение   Публикувано изображение   Публикувано изображение
Даже пробвах и с LiveCD/DVD на УСУ 8.3 (и 32 битово и 64), но проблема го има и там:

Публикувано изображение

Като тук даже и изображения и видео файловете са зле?!
Пробвах с няколко дистрибуции от LiveCD/DVD (Минт 14 канела, Убунту 13.04 и 12.04, Лубунту 13.04, Кубунту 12.04) и проблеми при тях няма?!

Също така при всяко стартиране на УСУ-то излиза това съобщение:

Публикувано изображение

 

И преди се е получавал този проблем, но тогава беше заради счупени пакети, заради малкото останало дисково пространство, но сега са инсталирани всички ъпдейти и няма счупени пакети?!

Има ли начин да се разбере от какво идва проблема под УСУ 8.3 и как да се оправи?

 

п.с.В момента пиша от Минт-а, че под УСУ всичко става с голямо закъснение!

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Виждам ,че си избрал Native ,избери Raster.Провери ли в kinfocenter дали всичко е наред.

Коя версия на KDE ? Обнови ли до последна версия на KDE 4.11 ?Аз винаги си инсталирам наново видео драйверите при актуализация на графичната среда и ядро.

Това добавено ли ти е в хранилищата ?

 

sudo add-apt-repository ppa:kubuntu-ppa/backports

Редактирано от acnekt (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Може би няма да е зле да питаш във форумите на Усу? (Ако имат де, не съм запознат)

Може някой от тези който подържат дистрибуцията или Кде, да ти помогнат по добре.

 

Или както каза колегата, дай повече инфо за кде-то което ползваш?

Mисля, че сигорно имаш проблем с Кwin.

 

Едит:

 

Пробвай изклучи всички ефекти и рестартирай, да видиш как е?

Ако може спри Kwin.

Редактирано от ivoarch (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Може би няма да е зле да питаш във форумите на Усу? (Ако имат де, не съм запознат)

Може някой от тези който подържат дистрибуцията или Кде, да ти помогнат по добре.

 

Или както каза колегата, дай повече инфо за кде-то което ползваш?

Mисля, че сигорно имаш проблем с Кwin.

 

Едит:

 

Пробвай изклучи всички ефекти и рестартирай, да видиш как е?

Ако може спри Kwin.

Първо там пуснах тема, но резултат никакъв?!

 

Виждам ,че си избрал Native ,избери Raster.Провери ли в kinfocenter дали всичко е наред.

Коя версия на KDE ? Обнови ли до последна версия на KDE 4.11 ?Аз винаги си инсталирам наново видео драйверите при актуализация на графичната среда и ядро.

Това добавено ли ти е в хранилищата ?

 

sudo add-apt-repository ppa:kubuntu-ppa/backports

В kinfocenter всичко е ОК! Версията е 4.10 (но трябва ръчно да инсталирам 4.11 ако обясниш как, че до сега не съм го правил - 4.10 се инсталира с ъпдейтите когато излезе)?! Видео драйверите си ги има в ядрото (ползвам последното LTS) - в синаптик xserver-xorg-video-intel си е инсталирано, но пробвах и с преинсталирането му - без резултат!

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

A със Kwin какво стана?

 

На 2-рата снимка от горният ред, се вижда ясно, че има проблем със всички ефекти.

 

Дай ми тази команда 

 

от терминал.

$> kwin --replace

после  копирай от терминал и постави тука, какво ти излиза.

Редактирано от ivoarch (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

A със Kwin какво стана?

 

На 2-рата снимка от горният ред, се вижда ясно, че има проблем със всички ефекти.

 

Дай ми тази команда 

 

от терминал.

$> kwin --replace

после  копирай от терминал и постави тука, какво ти излиза.

След малко ще ти я дам, че сега се инсталират 8 актуализации!

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Аз не мога да разбера защо е избрал Xrender   и Native?

Редактирано от acnekt (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Аз не мога да разбера защо е избрал Xrender  ?

Без значение коя от версиите на OpenGL (3.1; 2.0 или 1.2) избера си връща автоматично на XRender?!

Кажи поне как се инсталира КДЕ 4.11 за да видя дали ще се подобри положението?!  

@ivoarch ето изхода от командата:

plamen74@plamen74-desktop:~$  kwin --replaceQDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.QCoreApplication::sendPostedEvents: Cannot send posted events for objects in another threadQCoreApplication::sendPostedEvents: Cannot send posted events for objects in another threadQCoreApplication::sendPostedEvents: Cannot send posted events for objects in another threadQCoreApplication::sendPostedEvents: Cannot send posted events for objects in another thread
Редактирано от plamen74 (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

То нищо не ти излиза с тая команда kwin --replace ,има и грешки 

Прибавяш си това хранилище

sudo add-apt-repository ppa:kubuntu-ppa/backports

После обновяваш sudo  apt-get update

После надстройваш sudo apt-get upgrade 

Редактирано от acnekt (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Това хранилище го има и командите са изпълнени, но промяна няма (даже и dist-upgrade изпълних)?!

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

едит

 

Освен ako можеш да изклучиш ефектите на Кwin, и да пробваш така.

 

Или чакай некой да ти отговори от Усу линукс. (Ако можеш дай репорт за бъг на Кде там)

Редактирано от ivoarch (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

kded --version или kde-open -v

Добре ,де при мен я има  тая грешка ,но когато напиша тая команда,ми излиза инфо за видеокартата ми .

Редактирано от acnekt (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

от последната картинка се вижда, че проблемът е в драйверите, сложи по стари...

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

от последната картинка се вижда, че проблемът е в драйверите, сложи по стари...

По-стари или по-нови? В Минт-а са версия 2:2.20 а в УСУ са 2:2.19 но в УСУ има само LTS версия 2:2.20

А и ако беше проблем с драйверите то защо клипчета в нета и филми през плеър вървят без проблеми - има проблем само с плазмата?!

Редактирано от plamen74 (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Добре ,де при мен защо я няма да тая грешка ,когато напиша тая команда,ми излиза инфо за видеокартата ми   и че не може някакъв процес да извърши.

Да при него има грешка някаде.

Забелязох и аз, по принцип трябва да ти излезне инфото за картата.

 

Но аз съм толкоз зле с това Кде, че съм до тук, с нищо друго не мога да помогна :)

Редактирано от ivoarch (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

kded --version или kde-open -v

Добре ,де при мен я има  тая грешка ,но когато напиша тая команда,ми излиза инфо за видеокартата ми .

4.11 е версията:

plamen74@plamen74-desktop:~$ kde-open -vQt: 4.8.2KDE Development Platform: 4.11.00Клиент KIO: 2.0plamen74@plamen74-desktop:~$ 

Това е което знам за видео картата (вградена в процесора Intel G2120):

ChipsetIntel® B75GraphicIntegrated Graphics Processor Multi-VGA output support : HDMI/DVI/RGB ports  - Supports HDMI with max. resolution 1920 x 1200 @ 60 Hz - Supports DVI with max. resolution 1920 x 1200 @ 60 Hz - Supports RGB with max. resolution 2048 x 1536 @ 75 HzMaximum shared memory of 1696 MB

Това е версията на драйвера за Уиндоус: Version 9.17.10.2884

Но нали в Линукс си го има драйвера в ядрото?! Пък и защо ще прави проблем само с ефектите и плазмата на КДЕ, е видео от нета и от плеър ще върви без проблеми?!

Редактирано от plamen74 (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

По-стари или по-нови? В Минт-а са версия 2:2.20 а в УСУ са 2:2.19 но в УСУ има само LTS версия 2:2.20

А и ако беше проблем с драйверите то защо клипчета в нета и филми през плеър вървят без проблеми - има проблем само с плазмата?!

щото едното се рендва по един начин, другото по друг (плазмата е на opengl)... според мен проблемът е в opengl драйвера... пробвай да пуснеш клип през mplayer/smplayer ама му настрой vo=opengl или vo=opengl2 и виж ще вземе ли да маже и там...

п.с. може да пробваш да затриеш настройките на kde... да си ги създаде наново...

Редактирано от the professor (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

И аз съм с чипсет B75 .

Qt е стара версия ,а пробва ли sudo apt-get install --reinstall libgl1-mesa-dri libgl1-mesa-glx ?

Редактирано от acnekt (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

И аз съм с чипсет B75 .

Qt е стара версия ,а пробва ли sudo apt-get install --reinstall libgl1-mesa-dri libgl1-mesa-glx ?

 

Това се получи след командата:

plamen74@plamen74-desktop:~$ sudo apt-get install --reinstall libgl1-mesa-dri libgl1-mesa-glx[sudo] password for plamen74: Четене на списъците с пакети... ГотовоИзграждане на дървото със зависимости       Четене на информацията за състоянието... Готово0 актуализирани, 0 нови инсталирани, 2 преинсталирани, 0 за премахване и 0 без промяна.Необходимо е да се изтеглят 4088 kB архиви.След тази операция ще бъде използвано 0 B допълнително дисково пространство.Изт:1 http://ppa.launchpad.net/ubuntu-x-swat/x-updates/ubuntu/ precise/main libgl1-mesa-dri i386 9.0-0ubuntu1 [3952 kB]Изт:2 http://ppa.launchpad.net/ubuntu-x-swat/x-updates/ubuntu/ precise/main libgl1-mesa-glx i386 9.0-0ubuntu1 [137 kB]Изтеглени 4088 kB за 11с (354 kB/сек)                                      (Четене на базата данни ... 863732 files and directories currently installed.)Подготовка за замяна на libgl1-mesa-dri 9.0-0ubuntu1 (използва се .../libgl1-mesa-dri_9.0-0ubuntu1_i386.deb) ...Извличане на заместител на libgl1-mesa-dri ...Подготовка за замяна на libgl1-mesa-glx 9.0-0ubuntu1 (използва се .../libgl1-mesa-glx_9.0-0ubuntu1_i386.deb) ...Извличане на заместител на libgl1-mesa-glx ...Инсталиране на libgl1-mesa-dri (9.0-0ubuntu1) ...Инсталиране на libgl1-mesa-glx (9.0-0ubuntu1) ...Обработка на превключватели за libc-bin ...ldconfig deferred processing now taking placeplamen74@plamen74-desktop:~$ 

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Сега как е ? Можеш ли да избираш ? Имаш ли някакви грешки  .xsession-errors ?

kdebugdialog ?

Редактирано от acnekt (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Сега е още по-зле т.е. вече и в графична среда не влиза?! След като зареди стига до черен екран все едно съм натиснал Ctrl+Alt+F1 за влизане в конзолен режим (без да съм натискал клавишната комбинация), а като напиша startx и ми пише, че няма такъв файл или директория?! Също и Ctrl+Alt+F8 не действа?! Жалко, че не стартира от LiveCD/DVD иначе до сега да съм преинсталирал (нямам какво да губя)!

 

Edit: Реших да преинсталирам на чисто, но този път сложих 64 битовата версия на УСУ 8.3

Инсталацията мина като по ноти, след рестарта ефектите си бачкаха, и тъкмо си рекох, че всичко вече е ОК се появи отново проблема с OpenGL след инсталиране на ъпдейтите?! Преди да ъпдейтна в настройките имаше само OpenGL и XRender, а след ъпдейта станали пак три OpenGL т.е. OpenGL-1,2 ; OpenGL-2.0  и OpenGL-3,1

Сега отново си се връща автоматично на XRender / Native, а като избера някоя от версиите на OpenGL и всичко почва да маже, бави и дори само черен екран стана по едно време (само курсора на мишката остана)! С клавишна комбинация Ctrl+Alt+F1 влязох в конзолен режим, но нямаше нови ъпдейти, след което с Ctrl+Alt+F8 стартирах логин екрана, и влязох в графичен режим! Сега пак си е на XRender / Native но ми прави впечатление, че има ефекти, но не са всичките?!

Сега поне няма да оправяме старото инсталирано УСУ (което се беше омазало тотално), а новоинсталироното!
Много ми е странно, че само с УСУ го прави и то сасо с версия 8.3?!

 

Edit 2: Днес пробвах Kubuntu 13.04 x64 и няма абсолютно никакви проблеми! Явно ще се чака излизането на УСУ базирано на него, защото сегашното 12.04 има доста голям проблем, който разбираемо го има и в УСУ 8.3!

Ето шотове от Kubuntu 13.04 x64:

Публикувано изображение Публикувано изображение

Редактирано от plamen74 (преглед на промените)
  • Харесва ми 1

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Регистрирайте се или влезете в профила си за да коментирате

Трябва да имате регистрация за да може да коментирате това

Регистрирайте се

Създайте нова регистрация в нашия форум. Лесно е!

Нова регистрация

Вход

Имате регистрация? Влезте от тук.

Вход

×

Информация

Поставихме бисквитки на устройството ви за най-добро потребителско изживяване. Можете да промените настройките си за бисквитки, или в противен случай приемаме, че сте съгласни с нашите условия за ползване.