Премини към съдържанието

Архивирана тема

Темата е твърде стара и е архивирана. Не можете да добавяте нови отговори в нея, но винаги можете да публикувате нова тема, в която да продължи дискусията. Регистрирайте се или влезте във вашия профил за да публикувате нова тема.

SuperLuigi

Грозни шрифтове в Chrome под Xubuntu 12.04

Препоръчан отговор


Здравейте!

Проблемът ми е, че след последните 2 ъпдейта на Хрома в последните 2 седмици, шрифтовете стана незагладени. Смених ги от настройките на браузера, но никакъв ефект, освен ако размера не е 20+. В някои сайтове изглеждат добре, но са малко на брой. Иначе в системата шрифтовете са ми наред.

Същия проблем имам и с Лисицата от няколко месеца, но нея не я ползвам по дефолт.

Някой друг да е имал подобен проблем наскоро? Как е решен? Незнам дали ще е от значение шота, но ето го:

post-241463-0-74181000-1378003607_thumb.

 

Благодаря!

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

А да не би случайно да имате ~/.fonts.conf с някакви ваши настройки там? Защото от известно време fontconfig го игнорира и плюе нещо като:

 

reading configurations from ~/.fonts.conf is deprecated.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Нямам такъв файл. Иначе забравих да спомена за този причинител. Проблема е някъде другаде.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Здравейте!

Проблемът ми е, че след последните 2 ъпдейта на Хрома в последните 2 седмици, шрифтовете стана незагладени. Смених ги от настройките на браузера, но никакъв ефект, освен ако размера не е 20+. В някои сайтове изглеждат добре, но са малко на брой. Иначе в системата шрифтовете са ми наред.

Същия проблем имам и с Лисицата от няколко месеца, но нея не я ползвам по дефолт.

Някой друг да е имал подобен проблем наскоро? Как е решен? Незнам дали ще е от значение шота, но ето го:

Публикувано изображениеСнимка на екрана - 1.09.2013 - 5,49,10.png

 

Благодаря!

Отвори "Настройки">>"Външен вид" и покажи, кой шрифт и размер си задал http://s19.postimg.org/ysrodbws3/fonts.png

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Отвори "Настройки">>"Външен вид" и покажи, кой шрифт и размер си задал http://s19.postimg.org/ysrodbws3/fonts.png

 

Иначе в системата шрифтовете са ми наред.

 

 

Проблемът е само в браузера. С други програми нямам проблем. Kelly Slab ми е шрифта на Xubuntu-то от близо 9 месеца.


Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Смени го със sans или droid sans и отвори браузъра отново. Изобщо не знам този шрифт какъв е и дали се изчертава по един и същи начин във всички приложения.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

@cybercop, никакъв ефект. Това е шрифта:

 

Публикувано изображение

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

проблемът го има и при файерфокс и се дължи на забранен антиалиазинг ефект... ме ме дразнят замазаните шрифтове и преглъщам разкривените букви в интернет... интересното е че проблема го има само в някои страници и не на всички размери текст.... за пример http://hardwarebg.com/forum/showthread.php/128850-%D0%A1%D0%BA%D0%B0%D0%BF%D0%B0%D0%BD-%D1%88%D1%80%D0%B8%D1%84%D1%82-%D0%BD%D0%B0-Firefox-%28?s=6ff0a368debfb3295299338e91035b3b

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

@SuperLuigi: Шрифтовете се заглаждат нормално във всички браузъри http://s19.postimg.org/7kq8s8xir/fonts2.png

Извинявай, но не ми показа, как си настроил шрифтовете от Външен вид и ми се струва, че бягаш от темата.

Ако е необходимо, след промяната на шрифтовете, растартирай машината.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Така като гледам от първата снимка, вашият фаил манеджър не използва ли същият грозен шрифт?

Проблема едвали ще е от некой от вашите броузъри, пробвай да създадете ~/.config/fontconfig/fonts.conf в интернет може да разгледате примери. И после актуализирайте шрифтовете със $> fc-cache -vf

 

Да не говорим и за едитора, нещо сте оплескали с тези шрифтове, много зле..(тези искривени шрифтове стават само за conky но не и за четене и работа.)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

post-241463-0-04014200-1378023846_thumb.

 

@cybercop, заповядай скрийншота.

 

@ivoarch, за трети път ще кажа, че в с-мата нямам "грозни" шрифтове. Проблема се появи след актуализацията на Хрома.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Ок тогава, пробвахте ли да смените този грозен шрифт, който ползвате за системата (това чудо ще ви направи къорав)?

Защо не пробвате със стандартен шрифт (Sans, Dejavu, Droid . ..) а не тези тунинг линии, които сега сте сложили за шрифт.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Отново и за последен път ти пиша.

Какво става с тези шрифтове, когато ги промениш на sans или droid sans от Външен вид, както е при мен на първата снимка ? Този шрифт, които така упорито отказваш да промениш, може да не е приложим за Firefox, а евентуално и за доста други приложения.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Отново и за последен път ти пиша.

Какво става с тези шрифтове, когато ги промениш на sans или droid sans от Външен вид, както е при мен на първата снимка ? Този шрифт, които така упорито отказваш да промениш, може да не е приложим за Firefox, а евентуално и за доста други приложения.

 

Отново казвам: никакъв ефект

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Хмм, смисъл покажете да видим, след като сменихте шрифта как е?

 

Edit

 

МОже да пробваш да създадеш файла ~/.Xresources

 

после сложи там

! Xft settings ---------------------------------------------------------------Xft.dpi:        96Xft.antialias:  trueXft.rgba:       rgbXft.hinting:    trueXft.hintstyle:  hintslight

и после актуализирай

$> xrdb -merge ~/.Xresources

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Според мен колкото и да сменяте шрифта това няма как да окаже влияние на шрифтовете на самите страници (освен ако не сте задали самият browser да игнорира шрифтовете от страниците), така че опити в тази насока едва ли ще доведат до някакъв успех.

 

Ако наистина рендирането на шрифтовете се е променило след update на browser-a защо първо не пробвате да се върнете няколко версии назад на самият browser? Ако проблема изчезне, то ще бъдете сигурен, че именно browser-а прави проблема.

 

Между другото пробвахте ли да изключите/включите GPU рендирането в Chrome? Виждал съм големи разлики в качеството на рендиране. Пробвайте - about:flags

Disable accelerated 2D canvas

GPU compositing on all pages

Override software rendering list

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

post-241463-0-32997500-1378025530_thumb.

 

Ето и след смяната им.

 

@mail123456, никакъв ефект.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Публикувано изображениеsan.png

 

Ето и след смяната им.

 

@mail123456, никакъв ефект.

Напротив - сменили са се. Смени прочутият шрифт и от мениджъра на прозорците http://s19.postimg.org/mhypt9ar7/fonts3.png

Ако е необходимо рестартирай или изтрий потребителската конфигурация на браузъра, ако си пипал по шрифтовете и там.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Отиди в 

$HOME/.config/google-chrome/Default/User StyleSheet/

и редактирай файла Custom.css

добави този ред вътре

 *{font-family:твоите шрифтове}

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

@tux, файла е празен и след като запаметя промените, пак никакъв ефект, какъвто и шрифт да сложа.

 

@cybercop, нищо не съм барал там до днес.

 

Ето и един шот за размисъл:

 

Публикувано изображение

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Това какви шрифтове си избрал за системата няма нищо общо със един глупав браузер.Отваряш хрома.Избираш настройки - после да се покажат допълнителните настройки - "Show advanced settings" и там има секция web content  айде пробвай от customize fonts  там да смениш тоя шрифт

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Това какви шрифтове си избрал за системата няма нищо общо със един глупав браузер.Отваряш хрома.Избираш настройки - после да се покажат допълнителните настройки - "Show advanced settings" и там има секция web content  айде пробвай от customize fonts  там да смениш тоя шрифт

 

Пробвано е с всички типове шрифтове и ефекта е нулев!

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Пробвай, запази това във ~/.config/fontconfig/font.conf

<?xml version='1.0'?><!DOCTYPE fontconfig SYSTEM 'fonts.dtd'><fontconfig>  <match target="font">    <edit mode="assign" name="autohint">      <bool>true</bool>    </edit>  </match>  <!-- Enable sub-pixel rendering -->  <match target="font">    <edit name="rgba" mode="assign">      <const>rgb</const>    </edit>  </match>  <!-- Enable hintstyle as hintslight -->  <match target="font">    <edit name="hintstyle" mode="assign">      <const>hintslight</const>    </edit>  </match></fontconfig>

После от темринал.

 

$> fc-cache -vf

 

Рестартирай Хрома и виж как е.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

@ivoarch, поиграх си с кода, но никакъв ефект.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Коя е версията на хрома.МОята е последната 29.0.1547.62.Ако трябва чакай нова версия или върни назад една с която е работило като хората.Може да изтриеш $HOME/.config/google-chrome и да видиш дали има ефект

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

×

Информация

Поставихме бисквитки на устройството ви за най-добро потребителско изживяване. Можете да промените настройките си за бисквитки, или в противен случай приемаме, че сте съгласни с нашите условия за ползване.