Премини към съдържанието

    Препоръчан отговор


    Дългата история накратко: наскоро почнах да експериментирам с уеб сървъри, инсталирах си апачи, но не работи както трябва.

     

    Отваряйки localhost получавам само бял екран и дотам. Когато се опитам да го стартирам през xampp control panel казва Error: Apache shutdown unexpectedly и се спира. MySQL работи нормално.

     

    Някакви насоки?

     

    Благодаря предварително.

    Редактирано от Crimsader (преглед на промените)

    Сподели този отговор


    Линк към този отговор
    Сподели в други сайтове

    Дългата история накратко: наскоро почнах да експериментирам с уеб сървъри, инсталирах си апачи, но не работи както трябва.

     

    Отваряйки localhost получавам само бял екран и дотам. Когато се опитам да го стартирам през xampp control panel казва Error: Apache shutdown unexpectedly и се спира. MySQL работи нормално.

     

    Някакви насоки?

     

    Благодаря предварително.

    Логовете на апаш. И белия екран е защото вероятно няма информация, която да покаже

    • Харесва ми 1

    Сподели този отговор


    Линк към този отговор
    Сподели в други сайтове

    Логовете на апаш. И белия екран е защото вероятно няма информация, която да покаже

    21:22:37  [Apache]  Error: Apache shutdown unexpectedly. 21:22:37  [Apache]  This may be due to a blocked port, missing dependencies, 21:22:37  [Apache]  improper privileges, a crash, or a shutdown by another method. 21:22:37  [Apache]  Press the Logs button to view error logs and check 21:22:37  [Apache]  the Windows Event Viewer for more clues 21:22:37  [Apache]  If you need more help, copy and post this 21:22:37  [Apache]  entire log window on the forums  

     

    Това е от самия контролен панел. Лог файлове не ми сейфа, не ме питайте защо.

     

    Информация за показване има. Но дори и да нямаше би трябвало дами покаже съдържанието на индекса, като го отворя ръчно.

     

    Проверил съм портовете и правата, но не откривам нещо нередно...

    Редактирано от Crimsader (преглед на промените)

    Сподели този отговор


    Линк към този отговор
    Сподели в други сайтове

    21:22:37  [Apache]  Error: Apache shutdown unexpectedly. 21:22:37  [Apache]  This may be due to a blocked port, missing dependencies, 21:22:37  [Apache]  improper privileges, a crash, or a shutdown by another method. 21:22:37  [Apache]  Press the Logs button to view error logs and check 21:22:37  [Apache]  the Windows Event Viewer for more clues 21:22:37  [Apache]  If you need more help, copy and post this 21:22:37  [Apache]  entire log window on the forums  

     

    Това е от самия контролен панел. Лог файлове не ми сейфа, не ме питайте защо.

     

    Информация за показване има. Но дори и да нямаше би трябвало дами покаже съдържанието на индекса, като го отворя ръчно.

    Добре. какво връща командата:

    netstat -an|findstr 80|findstr LIST

    Сподели този отговор


    Линк към този отговор
    Сподели в други сайтове

     

    Добре. какво връща командата:

    netstat -an|findstr 80|findstr LIST

    Setting environment for using XAMPP for Windows. # netstat -an|findstr 80|findstr LIST   TCP   0.0.0.0:80 0.0.0.0:0   LISTENING   TCP   0.0.0.0:44080   0.0.0.0:0   LISTENING   TCP   [::]:44080 [::]:0 LISTENING #


    Сподели този отговор


    Линк към този отговор
    Сподели в други сайтове

    Setting environment for using XAMPP for Windows. # netstat -an|findstr 80|findstr LIST   TCP   0.0.0.0:80 0.0.0.0:0   LISTENING   TCP   0.0.0.0:44080   0.0.0.0:0   LISTENING   TCP   [::]:44080 [::]:0 LISTENING #

    Добре. ВИждам че има пуснато нещо на порт 80. Изпълнете тази команда (като администратор) Листа ще е дълъг но трябва да търсите две линии, първата ще е тази (може да има още едно число накрая):

      TCP   0.0.0.0:80 0.0.0.0:0   LISTENING

    На втората ще има име на програма

    Запомнете числото и ми кажете какво е името на програмата

    Сподели този отговор


    Линк към този отговор
    Сподели в други сайтове

    Добре. ВИждам че има пуснато нещо на порт 80. Изпълнете тази команда (като администратор) Листа ще е дълъг но трябва да търсите две линии, първата ще е тази (може да има още едно число накрая):

      TCP   0.0.0.0:80 0.0.0.0:0   LISTENING

    На втората ще има име на програма

    Запомнете числото и ми кажете какво е името на програмата

    Поради незнайни причини сега тази команда ми дава грешка. Забелязах Netstat меню в Apache, според което порт 80 се използва от Skype.

    Сподели този отговор


    Линк към този отговор
    Сподели в други сайтове

    Поради незнайни причини сега тази команда ми дава грешка. Забелязах Netstat меню в Apache, според което порт 80 се използва от Skype.

    ОК, спирате скайп и тогава пускате апаш. СЛед като стартира пускате скайп и му забранявате да ползва порт 80 и 443

    Сподели този отговор


    Линк към този отговор
    Сподели в други сайтове

    ОК, спирате скайп и тогава пускате апаш. СЛед като стартира пускате скайп и му забранявате да ползва порт 80 и 443

    Добре, това проработи за да пусна модула, но сега при викане на localhost получавам това:

     

    Firefox can't establish a connection to the server at localhost.

     

    :eek:

     

    Мисля че имам някакъв проблем с портовете като цяло.

    Редактирано от Crimsader (преглед на промените)

    Сподели този отговор


    Линк към този отговор
    Сподели в други сайтове

    Добре, това проработи за да пусна модула, но сега при викане на localhost получавам това:

     

    Firefox can't establish a connection to the server at localhost.

     

    :eek:

     

    Мисля че имам някакъв проблем с портовете като цяло.

    Сега изпълнете отново командата:

    netstat -an|findstr 80|findstr LIST

    Сподели този отговор


    Линк към този отговор
    Сподели в други сайтове

     

    Сега изпълнете отново командата:

    netstat -an|findstr 80|findstr LIST

    Setting environment for using XAMPP for Windows. # netstat -an|findstr 80|findstr LIST   TCP   0.0.0.0:44080   0.0.0.0:0   LISTENING   TCP   192.168.0.100:80 0.0.0.0:0   LISTENING   TCP   [::]:44080 [::]:0 LISTENING #

     

    Това което забелязах е, че сървърът фактически работи, когато си напиша IPv4-то. Ноо не и с localhost хм.

    Сподели този отговор


    Линк към този отговор
    Сподели в други сайтове

    Setting environment for using XAMPP for Windows. # netstat -an|findstr 80|findstr LIST   TCP   0.0.0.0:44080   0.0.0.0:0   LISTENING   TCP   192.168.0.100:80 0.0.0.0:0   LISTENING   TCP   [::]:44080 [::]:0 LISTENING #

     

    Това което забелязах е, че сървърът фактически работи, когато си напиша IPv4-то. Ноо не и с localhost хм.

    това се коригира като в конфига на апаш намерите ред от вида:

    Listen 192.168.0.100:80

    и я замените с

    Listen 80

    (ако мислите че имате нужда от това :)

    Сподели този отговор


    Линк към този отговор
    Сподели в други сайтове

    това се коригира като в конфига на апаш намерите ред от вида:

    Listen 192.168.0.100:80

    и я замените с

    Listen 80

    (ако мислите че имате нужда от това :)

    Уви май имам, тъй като все още localhost-а ми връща грешка :(

    Сподели този отговор


    Линк към този отговор
    Сподели в други сайтове

    Уви май имам, тъй като все още localhost-а ми връща грешка :(

    А рестартирахте ли апаш след като редактирахте конфиг файла?

    Сподели този отговор


    Линк към този отговор
    Сподели в други сайтове

    А рестартирахте ли апаш след като редактирахте конфиг файла?

     

    Естествено. Отностно постнатите по-горе портове, откривате ли нещо нередно?

    Сподели този отговор


    Линк към този отговор
    Сподели в други сайтове

    Естествено. Отностно постнатите по-горе портове, откривате ли нещо нередно?

    тогава в конфига има забрана за достъп до локалния хост (което ми е странно). Проверете дали има нещо такова:

    Deny from 127.0.0.1

    или

    Deny from localhost

    П.П. Макар че виждам че апаша слуша само на вашето ИП. Ако това не е особен проблем работете така

    Сподели този отговор


    Линк към този отговор
    Сподели в други сайтове

    тогава в конфига има забрана за достъп до локалния хост (което ми е странно). Проверете дали има нещо такова:

    Deny from 127.0.0.1

    или

    Deny from localhost

    П.П. Макар че виждам че апаша слуша само на вашето ИП. Ако това не е особен проблем работете така

     

    Нямам denies.

     

    Благодаря Ви, помогнахте ми изключително много тази вечер.

     

    А аз ще продължа да търся какво не му харесва на localhost-a.

    Сподели този отговор


    Линк към този отговор
    Сподели в други сайтове

    Нямам denies.

     

    Благодаря Ви, помогнахте ми изключително много тази вечер.

     

    А аз ще продължа да търся какво не му харесва на localhost-a.

    Няма защо. А случайно да сте пипал нещо по hosts файла?

    Сподели този отговор


    Линк към този отговор
    Сподели в други сайтове

    Няма защо. А случайно да сте пипал нещо по hosts файла?

    Имам

     

    #  127.0.0.1 localhost #  ::1 localhost

    Сподели този отговор


    Линк към този отговор
    Сподели в други сайтове

    Имам

     

    #  127.0.0.1 localhost #  ::1 localhost

    махнете коментара на първото

    Сподели този отговор


    Линк към този отговор
    Сподели в други сайтове

    След многобройни опити и провали открих по-простото решение, а именно - пробвам с друг софтуер. И стана. С Wamp.

     

    Също така осъзнах, че съм постнал темата в грешния раздел, за което се извинявам.

    • Харесва ми 1

    Сподели този отговор


    Линк към този отговор
    Сподели в други сайтове

    Регистрирайте се или влезете в профила си за да коментирате

    Трябва да имате регистрация за да може да коментирате това

    Регистрирайте се

    Създайте нова регистрация в нашия форум. Лесно е!

    Нова регистрация

    Вход

    Имате регистрация? Влезте от тук.

    Вход


    ×

    Информация

    Този сайт използва бисквитки (cookies), за най-доброто потребителско изживяване. С използването му, вие приемате нашите Условия за ползване.