Премини към съдържанието

Препоръчан отговор


Здравейте, Имам проблем със свързването на CSS файл към HTML. Пробвам по всякакъв начин, но нещо не се получава. Отварям го през различни браузъри и пак...  Ако има човек, който може да ми каже къде греша, ще бъда супер благодарен!

Имам грешка със качването на CSS файла. Ето как съм го написал:

 
<html>
<body>
    <style type="text/css">
        body {
            color:black;padding: 1em;
        }
        .lsec {
            type ="italic";
        }
        h1 { 
            font-family: verdana,sans-serif;
            color ="red";
        }
        .rsec {
            color ="yellow";
        }
        .rsec2 {
            color ="red";
        }
        .rsec3 {
            color ="grey";
        }
        .rsec4 {
            color ="orange";
        }
    </style>
</body>
</html>
 
Благодаря за отделеното време :)

HTML-CSS.html

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Използвайте таговете за код! А ако наистина показаното съдържание е на .css файла, то грубата грешка е, че са включени HTML тагове в него!

  • Харесва ми 1

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

<!DOCTYPE html> <html> <head> <style type="text/css"> h1 {color:red;} p {color:blue;} </style> </head> <body> <h1>This is a heading</h1> <p>This is a paragraph.</p> </body> </html>

 

Разбра ли сега къде е грешката?

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Основната ти грешка е, че си ги комбинирал в един файл. Раздели кода на два файла като в хедъра на html файла сложи това: 

 

<link rel="stylesheet" type="text/css" href="името-на-файла.css">

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Ами пише, че тези с . отпреди са за клас и реших да правя с тях, че ми изглежда по- лесно. Пробвах без <html> в css файла и пак не се получава. 

alphа в два отделни файла са ми и в една и съща папка. 

Invisible грешката продължавам да не я виждам. Единственото което видях е, че липсват кавички при цветовете. 


Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Стилизирането се прави във HEAD или отделен файл или инлайн със !important

Стилизира се нещо което присъства във Body

???

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Във заданието е казано да е в два отделни файла. Промених css файла нещата да са в <head></head> и пак... все едно този файл не е свързан към другия...

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Момче, от това което чета, виждам, че ти е станала голяма каша в главата. За да ти помогна ти предлагам да изгледаш няколко от тези туториали.

Редактирано от GoodfeIlas (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

И тука идеално влиза припева на една добре позната песен "Ооо колко съм прос...." 

СТРАШНО МНОГО ВИ БЛАГОДАРЯ! Видях каква ми е грешката благодарение на тези туториали.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Регистрирайте се или влезете в профила си за да коментирате

Трябва да имате регистрация за да може да коментирате това

Регистрирайте се

Създайте нова регистрация в нашия форум. Лесно е!

Нова регистрация

Вход

Имате регистрация? Влезте от тук.

Вход

  • Разглеждащи това в момента   0 потребители

    Няма регистрирани потребители разглеждащи тази страница.

  • Горещи теми в момента

  • Подобни теми

    • от BluePower
      USB Портовете не ми работят ето и снимка

    • от Petar02
      Здравейте,           Не успях да намиря друга тема, по моя въпрос и за това отварям нова. Имам лаптоп Lenovo x61 windows 7 home premium. Когато го включа щом ми каже добре дошли става черен екрана и само мишката може да се движи. Така стои и не ми зареждат иконите. Щом дам Ctrl+Alt+Del и отворя Task Manager и изчакам ми се отварят иконите и си зарежда. След изчакване 30 минути при опит за отваряне на controll panel някой път се отваря, но почти винаги забива и се рестартира.
      Лаптопът е закупен втора употреба и е на норвежки, след като не мога да стигна до control panel, ни мога да му сменя и езика.
      Моля за помощ.
    • от Мирослав Каменов
      Здравейте, моят проблем е следният лаптопът ми е Guru M67SRU закупих си оригинален диск за Windows 7 от Microsoft с цел да вдигна битовете на моят понеже е 32 Bit а искам 64 Bit така сложих диска във лаптопът пуснах инсталацията започнах да го инсталирам и ми изписа че „Windows не може да се инсталира защото е стартиран безопасен режим натиснете Ok за да продължите натискам и вадя диска и пускам Windows normally излиза ми това натискам ok пак това пробвах да вляза във Safe Mode да го спра не става излиза ми само това на снимката и не ме пуска вътре помощ!!!!
       

    • от fresh_bones
      Добър ден от няколко дена компютъра прави проблеми . Не иска да стартира . Пускам го от кобчето тръгва да свети пък не зарежда windows . Трябва го изключа и да го включа пет пъти за да зареди . И още нещо някой път не върти перката на  захранването и също така по някой път като зареди Windows  след като влезе след 2-3 минути ми забива и излиза син екран . Не знам какво да права да го вода на ремонт или ще мога сам да го поправа .  Днес го преинсталирах ама проблема си остава .  Параметрите му са 2 рам  процесор Intel Celeron e3300  две ядра , дънна платка biostar G47-M7 ,  видеокарта Nvidia Getforce  210 1gb . хард диск ADATA sp550 (sata 3 ) . 
      Ето го синия екран http://prikachi.com/images.php?images/643/9357643t.jpg
  • Дарение

×

Информация

Поставихме бисквитки на устройството ви за най-добро потребителско изживяване. Можете да промените настройките си за бисквитки, или в противен случай приемаме, че сте съгласни с нашите условия за ползване.