Премини към съдържанието
GoodfeIlas

Проблем след премахване на slackware

Препоръчан отговор


Имах slackware на пц-то, но ми се наложи да го махна и на негово място да инсталирам Mint. В момента ми дава тази грешка:LILO - keytable read / checksum error и неможе да подкара ОС. ПЦ-то тръгва само ако има сложена флашка с линукса (ЦД няма). Погледнах и харда ми е разделен както съм го направил при инсталацията, а именно изтрих всички стари дялове като после направих дял за swap, root и още един дял, който поставих така /store. ОС явно е инсталиране, но не може да стартира от тази грешка. Силно се надявам някои да знае как да я премахна.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Нещо се е прецакал MBR. Бутни в rescue mode, и оправи партицията от която бутва, че не явно не кореспондира правилно с нея.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

А това LILO от слака ли е останало и изборите в него сочат ли правилните образи за зареждане на Mint-a? Понеже инсталатора на Минт предлага инсталиране на GRUB като мениджър за начално зареждане, вие инсталирали ли сте го и ако да къде сте му дали да се инсталира? Мисля, че би било добра идея да се пусне едно live CD (или от флашка) на Минта и да се инсталира Boot-Repair и да се преинсталира/инсталира GRUB.Ето тук можете да намерите инструкции и по-специално как да инсталирате програмата на заредения жив диск с Mint (ръководството е за Убунто, но мисля че няма да има проблеми с работата под Минт, понеже последния е създаден на база на първия). Командите са:

sudo add-apt-repository ppa:yannubuntu/boot-repair && sudo apt-get update

и след това:

sudo apt-get install -y boot-repair && (boot-repair &)

След това просто стартирате програмата и преинсталирате/инсталирате GRUB като му задавате да се помести там където е LILO (където сте задали при инсталацията на SLACKWARE-a).  Друг вариант е да заредите някакъв линукс и да видите конфигурационния файл на LILO-то къде се намира и да оправите там опциите в менюто му да зареждат правилния образ на ОС-а(ако само това се е объркало). Повече информация за LILO може да намерите тук.

  • Харесва ми 1

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Просто инсталирай grub наново.grub2-install /dev/sdX


  • Харесва ми 1

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Регистрирайте се или влезете в профила си за да коментирате

Трябва да имате регистрация за да може да коментирате това

Регистрирайте се

Създайте нова регистрация в нашия форум. Лесно е!

Нова регистрация

Вход

Имате регистрация? Влезте от тук.

Вход

×

Информация

Поставихме бисквитки на устройството ви за най-добро потребителско изживяване. Можете да промените настройките си за бисквитки, или в противен случай приемаме, че сте съгласни с нашите условия за ползване.