Премини към съдържанието

Препоръчан отговор


Здравейте,

Днес инсталирах Java х64 от инструкциите в сайта им, в директория  /usr/java/jre1.7.0_51/ но като напиша java -version не излиза нищо ......VPS

ОС: Debian 7 NOGUI

Благодаря предварително!

Редактирано от _xXTigerXx_ (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Защо не опиташ да инсталиращ JRE-7 от хранилищата на Дебиан ?

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Защо не опиташ да инсталиращ JRE-7 от хранилищата на Дебиан ?

Нямат JRE-7 упдейт 51 апък ми трябва последната версия..

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Здравейте,

Днес инсталирах Java х64 от инструкциите в сайта им, в директория  /usr/java/jre1.7.0_51/ но като напиша java -version не излиза нищо ......

ОС: Debian 7 NOGUI

Благодаря предварително!

 

Ако напишете само "java -version" определено няма да излезе нищо повече ... все пак пробвайте да натиснете ENTER и да покажете, какво съобщение ви връща :)

  • Харесва ми 1

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Нямат JRE-7 упдейт 51 апък ми трябва последната версия..

В  sid е точно тази версия.

Редактирано от cybercop (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

ОС: Debian 7 NOGUI

Нямам десктоп.

В  sid е точно тази версия.

Може ли да ми обясните как да я инсталирам от sid ?

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

ОС: Debian 7 NOGUI

Нямам десктоп.

Това си е твой проблем. Инсталацията на една лека графична среда и един мениджър на вход отнема по- малко от минута.

Изобщо, добавил (разрешил) ли си основните хранилища (main, contrib, nonfree) в etc/apt/sources.list ?

Редактирано от cybercop (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Това си е твой проблем. Инсталацията на една лека графична среда и един мениджър на вход отнема по- малко от минута.

Май не ме разбрахте .. инсталирам java-та на VPS немога да слагам десктопи и такива ...

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Тогава промени хранилищата от stable на unstable

deb http://ftp.bg.debian.org/debian unstable main contrib non-free
deb-src http://ftp.bg.debian.org/debian unstable main contrib non-free
Изпълни 
su
apt-get update
apt-get dist-upgrade
apt-get update
apt-get install -f
reboot
След което си инсталирай актуалната версия на JRE-7 направо от хранилищата. 
Тъй- като нямаш десктоп, надграждането при теб ще бъде доста лесно.
Ако не знаеш, как да отвориш etc/apt/sources.list ми кажи, какъв текстов редактор ползваш.
Не знам, виртуалните сървъри дали се конфигурират като реалните такива, защото нямам опит в това отношение.
Редактирано от cybercop (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

 

Тогава промени хранилищата от stable на unstable

deb http://ftp.bg.debian.org/debian unstable main contrib non-free
deb-src http://ftp.bg.debian.org/debian unstable main contrib non-free
Изпълни 
su
apt-get update
apt-get dist-upgrade
apt-get update
apt-get install -f
reboot
След което си инсталирай актуалната версия на JRE-7 направо от хранилищата. 
Тъй- като нямаш десктоп, надграждането при теб ще бъде доста лесно.
Ако не знаеш, как да отвориш etc/apt/sources.list ми кажи, какъв текстов редактор ползваш.

 

А как да я инсталирам от хранилищата ?

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Кажи ми, какъв текстов редактор ползваш, защото sources.list е текстов файл. Както вече ти писах, пиша ти като за реална инсталация, защото не съм изобщо в час относно виртуалните сървъри.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

 

Ако не знаеш, как да отвориш etc/apt/sources.list ми кажи, какъв текстов редактор ползваш.

 

Използвам стандартния Vi.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Използвам стандартния Vi.

Стандартно, аз ползвам nano.

Все пак, опитай с командата.

su

vi /etc/apt/sources.list

за да видиш, дали няма да ти се отвори списъка с източници.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Стандартно, аз ползвам nano.

Все пак, опитай с командата.

su

vi /etc/apt/sources.list

за да видиш, дали няма да ти се отвори списъка с източници.

Oтвори се, сега какво ?

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Чети командите за работа с текстовият редактор, изтрий съществуващата листа и копирай двата реда с хранилища, които съм ти постнал на мястото на съществуващият списък. След това запомни промените и затвори файла.

 

deb http://ftp.bg.debian.org/debian unstable main contrib non-free
deb-src http://ftp.bg.debian.org/debian unstable main contrib non-free
Редактирано от cybercop (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

 

Чети командите за работа с текстовият редактор, изтрий съществуващата листа и копирай двата реда с хранилища, които съм ти постнал на мястото на съществуващият списък. След това запомни промените и затвори файла.

deb-src http://ftp.bg.debian.org/debian wheezy main
deb http://security.debian.org/ wheezy/updates main 
deb-src http://security.debian.org/ wheezy/updates main# wheezy-updates, previously known as 'voiatile'
deb http://ftp.bg.debian.org/debian wheezy-updates main
deb-src http://ftp.bg.debian.org/debian wheezy-updates mainВсичко ли да трия ?
Редактирано от _xXTigerXx_ (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Пробвай така:

# Свали JAVA 64 update 5.1Ако речем че след изтеглянето се е свалила във Downloads# Разархивирай JAVAcd Downloads && tar xvzf ~/Downloads/jre-7u51-linux-x64.tar.gz# Създай папка където да преместиш JAVAsudo mkdir -p -v /opt/java/64# Премества JAVA в директория /opt/javasudo mv -v ~/Downloads/jre1.7.0_51 /opt/java/64# Казва на системата че, има нова версия на JAVA (ако ти даде error изпълни 2 пъти командата)sudo update-alternatives --install "/usr/bin/java" "java" "/opt/java/64/jre1.7.0_51/bin/java" 1# Казва на системата да използва по подразбиране тази версия JAVAsudo update-alternatives --set java /opt/java/64/jre1.7.0_51/bin/java

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

 

deb-src http://ftp.bg.debian.org/debian wheezy main

deb http://security.debian.org/ wheezy/updates main 
deb-src http://security.debian.org/ wheezy/updates main

# wheezy-updates, previously known as 'voiatile'

deb http://ftp.bg.debian.org/debian wheezy-updates main
deb-src http://ftp.bg.debian.org/debian wheezy-updates main

Всичко ли да трия ?

 

Засега не пипай, въпреки, че хранилищата не са добре конфигурирани.

Опитай съвета на колегата в последният пост. Само, имай предвид, че указанията са за Ubuntu.

За Debian, ще трябва да изпълниш

su

за да извършиш следващите действия с администраторски права.

 

 

Нещо подобно :

 

# Свали JAVA 64 update 5.1

Ако речем че след изтеглянето се е свалила във Downloads

# Разархивирай JAVA

cd Downloads && tar xvzf ~/Downloads/jre-7u51-linux-x64.tar.gz

 

su  (Натискаш Enter, въвеждаш паролата и отново натискаш Enter)

 

# Създай папка където да преместиш JAVA

sudo mkdir -p -v /opt/java/64

# Премества JAVA в директория /opt/java

sudo mv -v ~/Downloads/jre1.7.0_51 /opt/java/64

# Казва на системата че, има нова версия на JAVA (ако ти даде error изпълни 2 пъти командата)

sudo update-alternatives --install "/usr/bin/java" "java" "/opt/java/64/jre1.7.0_51/bin/java" 1

# Казва на системата да използва по подразбиране тази версия JAVA

sudo update-alternatives --set java /opt/java/64/jre1.7.0_51/bin/java

Редактирано от cybercop (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

 

Пробвай така:

# Свали JAVA 64 update 5.1Ако речем че след изтеглянето се е свалила във Downloads# Разархивирай JAVAcd Downloads && tar xvzf ~/Downloads/jre-7u51-linux-x64.tar.gz# Създай папка където да преместиш JAVAsudo mkdir -p -v /opt/java/64# Премества JAVA в директория /opt/javasudo mv -v ~/Downloads/jre1.7.0_51 /opt/java/64# Казва на системата че, има нова версия на JAVA (ако ти даде error изпълни 2 пъти командата)sudo update-alternatives --install "/usr/bin/java" "java" "/opt/java/64/jre1.7.0_51/bin/java" 1# Казва на системата да използва по подразбиране тази версия JAVAsudo update-alternatives --set java /opt/java/64/jre1.7.0_51/bin/java

Стана! Благодаря ти много :)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Сега си сложи само тези два реда в списъка с хранилища, ако ползваш 64 битова Debian Stable.

 
deb http://ftp.bg.debian.org/debian stable main contrib non-free
deb-src http://ftp.bg.debian.org/debian stable main contrib non-free
 
Нищо друго не ти трябва.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Аз направих друго :

 

deb http://www.duinsoft.nl/pkg/ debs all - добавих си това хранилище

 

След което :

 

su -c 'update-sun-jre install'

 

Следва : sudo aptitude update && sudo aptitude upgrade && sudo apt-get update && sudo apt-get upgrade ... autoclean, autoremove и т.н. ...  ( deborphan & gtkOrphan )

 

Резултат :

java version "1.7.0_51"Java SE Runtime Environment (build 1.7.0_51-b13)Java HotSpot Server VM (build 24.51-b03, mixed mode)

 

Засега нямам проблеми и, всичко си върви нормално.

Поздрави на всички, надявам се, че това решение би Ви помогнало ;)

Редактирано от iptables (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Регистрирайте се или влезете в профила си за да коментирате

Трябва да имате регистрация за да може да коментирате това

Регистрирайте се

Създайте нова регистрация в нашия форум. Лесно е!

Нова регистрация

Вход

Имате регистрация? Влезте от тук.

Вход

  • Разглеждащи това в момента   0 потребители

    Няма регистрирани потребители разглеждащи тази страница.

  • Горещи теми в момента

  • Подобни теми

    • от Семка
      Еййй, реших и аз най-после да се регистрирам.
      Дълга история накратко, когато си свържа безжичните слушалки по Bluetooth, скоростта на интернета ми (едиснтвено ако използвам Wifi) пада до степен в която става неизползваем. Естествено, че винаги мога да сложа един AUX кабел или да не използвам Wifi връзка но самият проблем е решим, според мен. 
      Четох не малко из интернет, оказало се, че е common problem. За жалост решение така и не намерих, даже и временно. 
      Какво го предизвиква въпросния пролем? Според интернет е едновременното използване на Bluetooth и Wifi връзка от един и същ драйвър???? Звучи ми логично, но нищо повече. 
      За добро или лошо, проблемът не е предизвикан от конкретна Linux дистибуция, даже го има и при Windows машини. 
      Такаа, имайки в предивид всичко споменато горе, предлагам да измислим някакво решение? Предварително се извинявам ако пропуснал съм да споделя информация, която е необходима за установим източника на проблема. Не се сърдете, кажете какво Ви трябва.
    • от coldrage
      Здравейте, от скоро съм с Ubuntu 18.04. Опитвам се да подкарам една игра, но ми дава следният проблем :
      Wine cannot find the FreeType font library.  To enable Wine to
      use TrueType fonts please install a version of FreeType greater than
      or equal to 2.0.5.
      http://www.freetype.org

      Търсих инфо в нета и правих какви ли не опити но не можах да го реша.
      Помагайте, моля!
    • от Alexandar89
      Здравейте, тъй като ми попадна дъно на изгодна цена, внесено от чужбина, Gigabyte GA-H81M-S2PV REV2. Сокета е 1150, обаче попаднах на интересна информация относно потдържаните процесори или по-конкретно за Intel Pentium G3260 със същият сокет, който до сега използвам. Идилията е следната, за същото дъно като модел само че ревизия 1 този процесор е съвместим в листа с потдържани процесори от сайта на гигабайт, но след ъпдейт на биоса, докато за рев 2 този процесор отсъства. Не се отказах, реших да проуча малко по-подробно и попаднах на  саита  www.cpu-upgrade.com , според който и трите възможни ревизии на това дъно потдържат процесора, като единствено ревизия 1 се нуждае от ъпдейт на биоса, както се вижда на снимката от сайта. Въпроса е на кое да вярвам ? И в този случай означава ли че този процесор няма изобщо да тръгне на това дъно. Благодаря предварително за отделеното внимание.

    • от Nicole V.
      Здравейте, от скоро имам един проблем..Вече ползвам телефона (samsung j7 2017) от половин година и наскоро изведнъж се появи следния проблем. Като си пусна например песен, първите секунди си се чува както трябва, но после изведнъж рязко се намалява сам без да го пипам, а е усилен до край и няма как да го усилиш още..така е със всичко звънене, аларми..И нямам дори идея защо е така, не съм теглила приложения и не съм си пипала настройките, някой да знае как да се справя, че нещо май не му се свири? 
    • от dipsuchos
      Хай!
      Отново аз, отново сходна спънка. 

      Много често (всеки ден) лаптопът ми настройва дата и час по негово грешно усмотрение, а там, където мога да ги сменя... не ми дава. Няма значение. За мен е по-важно да разбера откъде произлиза проблемът, за да знам как да го предотвратявам в бъдеще. 

      (Тези прозорци се отварят директно с включването ми на лаптопа?!?!?!)

      Свежи, леки предположения?

  • Дарение

×

Информация

Поставихме бисквитки на устройството ви за най-добро потребителско изживяване. Можете да промените настройките си за бисквитки, или в противен случай приемаме, че сте съгласни с нашите условия за ползване.