Премини към съдържанието

Препоръчан отговор


Здравейте. 
 
Взех си MSP430G2 и Bluetooth (JY-MCU Bluetooth Wireless Serial Port Module). Днес реших да ги пробвам и ги вързах по следният начин както е обяснено ТУК. Всичко супер изтеглих си и приложението за Android BlueTerm, пускам пускам приложението, а на MSP-то качих следната програма:
 char valor=0; void setup(){  Serial.begin(9600);} void loop()  //Bucle infinito{    if (Serial.available())//Si hay una caracter en el buffer serial    {         valor = Serial.read();// Se lee el valor numérico en el puerto serie.        Serial.print(valor);      }}
 
Връзвам се към блутута и когато започна да пиша нищо не се получава. Пуснах едно Putty, но там нищо не става, нищо не се появява. Когато обаче разменя двата кабела (TXD) и (RXD). Пускам програмата и Putty и когато пиша нещо в Putty се появяват символи. Някой ако може да помогне ще е супер.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Проблема си го оправих. А ето и какъв беше той. Моят номера на чипа е M430G2553, а аз компилирах и качвах за M430G2452. И от там идваше и този проблем. 

Ето и картинка за кой чип се отнася

 

 

Публикувано изображение

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Регистрирайте се или влезете в профила си за да коментирате

Трябва да имате регистрация за да може да коментирате това

Регистрирайте се

Създайте нова регистрация в нашия форум. Лесно е!

Нова регистрация

Вход

Имате регистрация? Влезте от тук.

Вход

×

Информация

Поставихме бисквитки на устройството ви за най-добро потребителско изживяване. Можете да промените настройките си за бисквитки, или в противен случай приемаме, че сте съгласни с нашите условия за ползване.