Премини към съдържанието
  • Добре дошли!

    Добре дошли в нашите форуми, пълни с полезна информация. Имате проблем с компютъра или телефона си? Публикувайте нова тема и ще намерите решение на всичките си проблеми. Общувайте свободно и открийте безброй нови приятели.

    Моля, регистрирайте се за да публикувате тема и да получите пълен достъп до всички функции.

     

Архивирана тема

Темата е твърде стара и е архивирана. Не можете да добавяте нови отговори в нея, но винаги можете да публикувате нова тема, в която да продължи дискусията. Регистрирайте се или влезте във вашия профил за да публикувате нова тема.

Lautrec

Puppy Linux и TP-LINK WR725N USB wireless?

Препоръчан отговор


Здравейте.

 

Опитвам се да накарам един TP-LINK WR725N usb wireless адаптор "да тръгне" под puppy linux.

 

Тъй като не се получи с автоматично разпознаване на TP-LINK WR725N  използвах ndiswrapper, за да стартирам инсталирането на *.inf файла от драйвера за windows_xp.

Драйвера беше инсталиран успешно, според puppy и устройството беше разпознато.

 

След успешното сканиране за налични безжични мрежи става ясно, че tp-link е разпознат като устройство.

Избирам си моята безжична мрежова връзка – която съм оставил отворена, следва

успешно свързване > Save > Use This Profile > Done > YES SET AS DEFAULT > OK

 

До тук би трябвало всичко да е изпълнено както трябва, но след опит да вляза в който и да е сайт се оказва, че нямам връзка с интернет. В същото време иконата в трея няма X.

 

Тествах TP-LINK WR725N със настолния компютър. Същата процедура и устройството работи.

 

Смея да твърдя, че схващам бързо, но съм нов с Linux, имате го предвид.

 

п.п.

Eдна и съща процедура за Slacko, Wary, Racy. Крайния резултат еднакъв, за това прецених, че не е от дистрибуцията.

Машината е много стар лаптоп Pentium II 336MHz, RAM PC-100 / 3 x 64MB. Единственият начин за ползване се оказва или Window_98 или някоя лека дистрибуция на Linux.

Най-лека се оказва SliTaz, но тук няма оправия с добавено мрежово устройство.

Интернета (за този лаптоп) е достъпен само чрез USB wireless (зависи от OS) или PCMCIA карта (каквато нямам).

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Продължавам да търся решение на проблема. :(

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

какъв е модела на Тп-линка?

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

какъв е модела на Тп-линка?

 

Извинете ме за това, че ви пиша два дена след вашия коментар. Устройството е TP-LINK WR725N.

 

п.п.

редактирах си поста

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Какво дава като инфо в терминал когато е закачен адаптера -

lsusb

и после

iwconfig


Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Може би, трябва да се опитате да вдигнете ръчно мрежата.

 

Пробвай те това, и после ни покажете изхода.

 

Като root или sudo потребител изпълнете следното:

 

Там където има <името на интерфейса ви>, трябва да е например wlan0 или eth0 ...,

за да проверите, кой е вашият интерфейс, изпълнете първо това ifconfig -a , също може да видите в нета

за кoмандата ifconfig.

ifconfig <името на интерфейса ви> up

След като, изпълните тази команда,  би трябало да тече интернет през компа, и да отваряте станички.

Ако ли не, покажете какво излиза в терминала след като, изпълните командата.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Какво дава като инфо в терминал когато е закачен адаптера -

lsusb

и после

iwconfig

 

Публикувано изображение

 

Не разбирам защо EESID не показва името на мрежата. След избора на мрежа, същата запазвам по подразбиране.

 

Може би, трябва да се опитате да вдигнете ръчно мрежата.

 

..........................

ifconfig <името на интерфейса ви> up

След като, изпълните тази команда,  би трябало да тече интернет през компа, и да отваряте станички.

Ако ли не, покажете какво излиза в терминала след като, изпълните командата.

 

Публикувано изображение

 

Както виждате командата ifconfig wlan0 up не връща резултат. Може би липсата на такъв означава нещо! 

Опитах с друг запис и виждате какво изведе като резултат.

_______

Така изглежда подробната информация за състоянието на интернет връзката.

Има и още нещо, което ня бях забелязал. По време на настройките след избора на мрежа, съветникът информира, че настройката на адптера не е успешна. Дори 'Auto DHCP' търпи провал. Наложи се ръчно да въведа статичен IP address за да може настройката да завърши успешно. Въпреки това връзка с www нямам.

 

Публикувано изображение  Публикувано изображение  Публикувано изображение  Публикувано изображение

 

п.п.

Започвам да се съмнявам, че ще се получи.

Машината е не просто стара...., "древна е"! Дори с Puppy Linux древният, е малко по-бърз.

Ако мислите, че DSL или SliTaz биха били по-лесни за конфигуриране, може да пробвам с някоя от тях или друга малка и лека дистрибуция.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Да, нормално е да не изкара нищо от командта ifconfig up, тя само вкючва wireless картата ви.

Taka като  гледам от снимките, устрйството ви се намира от Puppy, единсвеният проблем е, че не се е звързало към мрежата ви.

 

дай те тeзи команда, да видим :

 

sudo ifconfig wlan0 up

sudo iwconfig wlan0 essid <име на мрежата ви>

може да сложиш и ключа/паролата sudo iwconfig wlan0 key <парола>

sudo dhclient wlan0

 

и дайте пак  изхода от командата iwconfig , също пробвай те за интернет.

 

едит: Ако използвате (WPA, WPA2) за мрежата ви, то горните команди нема да ви свършат работа.

 

Погледнте за wpa_supplicant

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

не очаквах и че реалтек ще прави въртели като броадком, чипсета на тп-линка е реалтек

lspci | grep -i wireless

за да видиш кое ти трябва и после може да си свалиш от тук това, което ти отговаря на адаптера

http://puppyfiles.org/dotpupsde/dotpups/Wifi/drivers-for-Puppy-2.12-to-2.14/

 

всъщност не каза досега за кое пъпи иде реч!?

след това може да пуснеш като su

ifconfig wlan0 up

и останалите неща който ти е написал ivoarch

а преди това ако искаш може да добавиш и модула в кернела с

 

modprobe rt8.... какъвто ти даде от lspci

 

и гледай да си с root права, не с потребител!

 

sudo ти е написал ivoarch, но не видях да си su на скрииншотовете

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

и пак остава варианта тп-линка да не работи изобщо на usb 1.0/1.1...

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Най-добре, пробвай да ъпдейтваш биоса на лаптопа. 

Можe би, той не го поддържа. Не вярвам да няма съвместимост с USB 1/1.1

Пробвал съм безжични карти на такива портове и си работят. 

Пробвай с някой евтин Ralink. Те се поддържат добре в линукс.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

За да сместя писането на команди, погледнете сам, някъде в нета, Как да се конектирате в интернет през терминала, един пример може да бъде.

 

1) Относно проблемa със essid, там където ви дава грешка:

 

Пробвай те със некой от тези методи:

 

iwconfig eth0 essid any (вече го пробвах те не става!)iwconfig eth0 essid "My Network"

iwconfig eth0 essid -- "ANY"

 

Също най добре прочетете и man станицата на iwconfig, там са ви дадени промери със командите които ще видите и в интернет:

 

За да прочетете страницата ето така в теrминала:

 

man iwconfig

 

Ако мрежата ви не е WPA... , нямa нужда за wpa_supplicant

 

Успех!

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

×
×
  • Добави ново...