Премини към съдържанието
  • Добре дошли!

    Добре дошли в нашите форуми, пълни с полезна информация. Имате проблем с компютъра или телефона си? Публикувайте нова тема и ще намерите решение на всичките си проблеми. Общувайте свободно и открийте безброй нови приятели.

    Моля, регистрирайте се за да публикувате тема и да получите пълен достъп до всички функции.

     

Linux - обща дискусия 3


Препоръчан отговор

преди 1 час, cybercop написа:

Натисни Alt+F2 и напиши в полето :

gksu software-properties-gtk

след което опитай да стартираш приложението.

Пробвах да го стартирам и дава грешка,явно се е прецакало.Ами ако опитам от жив диск на Xubuntu 16.04.1 да копирам този файл който се намира в /usr/bin/software-properties-gtk и да го заменя,дали ще стане?

Линк към коментара
Сподели в други сайтове

  • Отговори 7,1k
  • Създадено
  • Последен отговор

Потребители с най-много отговори

преди 1 минута, Булет написа:

Пробвах да го стартирам и дава грешка,явно се е прецакало.Ами ако опитам от жив диск на Xubuntu 16.04.1 да копирам този файл който се намира в /usr/bin/software-properties-gtk и да го заменя,дали ще стане?

Съмнявам се. Защо ти е този мениджър ?

Линк към коментара
Сподели в други сайтове

току-що, cybercop написа:

Съмнявам се. Защо ти е този мениджър ?

Ами по принцип не ми трябва но до сега работеше а сега като пробвах да добавя това PPA се прецака и не работи,а и постоянно ми дава грешки за проблеми във системна програма и да пращам доклад.

Линк към коментара
Сподели в други сайтове

Аз не ползвам нито apport, нито software-properties, update-manager и update-notifier. Досега не съм забелязал липсата им. Не ми трябва мениджър, за да си добавя ред в sources.list. 

Редактирано от cybercop (преглед на промените)
Линк към коментара
Сподели в други сайтове

на 11/18/2016 в 12:40, Desdinova написа:

Защо пък това? Досега всичко е топ. Всички ще спечелим от това.

Трудно е да се обясни. Но комерсиалната логика диктува, че когато искаш адски много пари е по-добре да елиминираш конкуренцията. Даже е задължително.

Ако искаха просто много пари - тогава вече се отварят съвсем различни врати за развитие. Когато го използват както трябва, комерсиалния софтуер също има много големи възможности за развитие.

Линк към коментара
Сподели в други сайтове

преди 1 час, Булет написа:

Пробвах да го стартирам и дава грешка,явно се е прецакало.Ами ако опитам от жив диск на Xubuntu 16.04.1 да копирам този файл който се намира в /usr/bin/software-properties-gtk и да го заменя,дали ще стане?

Опитай първо да преинсталираш пакетите.

sudo apt-get install --reinstall software-properties-common software-properties-gtk python3-software-properties

Да не би да има инсталирано python-software-properties, я първо "гръмни" профилактично.

sudo apt-get purge python-software-properties

 

Редактирано от бат'начо (преглед на промените)
Линк към коментара
Сподели в други сайтове

преди 27 минути, бат'начо написа:

Опитай първо да преинсталираш пакетите.

sudo apt-get install --reinstall software-properties-common software-properties-gtk python3-software-properties

Да не би да има инсталирано python-software-properties, я първо "гръмни" профилактично.

sudo apt-get purge python-software-properties

 

Първо

sudo apt-get purge python-software-properties

нямам го инсталирано и не може да го махне.

sudo apt-get install --reinstall software-properties-common software-properties-gtk python3-software-properties

Изпълних го и пак не се отваря,грешка: Test

Линк към коментара
Сподели в други сайтове

Всъщност интересното е в "сесия и стартиране" в контролния център.

А чистил ли си системата някога? Я пробвай

sudo rm /var/cache/apt/archives/*.deb

 

Линк към коментара
Сподели в други сайтове

@Булет Защо ходиш до /etc/apt/ като администратор. Сигурен ли си, че не си променял нещо по sources.list или sources.list.save, с текстов редактор с неправилна кодировка (примерно), или пък допусната грешка там. Какво е точното съдържание на тези двата файла.

Линк към коментара
Сподели в други сайтове

преди 41 минути, бат'начо написа:

@Булет Защо ходиш до /etc/apt/ като администратор. Сигурен ли си, че не си променял нещо по sources.list или sources.list.save, с текстов редактор с неправилна кодировка (примерно), или пък допусната грешка там. Какво е точното съдържание на тези двата файла.

Аз го посъветвах. Но, не просто да ходи, а да изтрие едно хранилище за PPA от etc/apt/sources.list.d.

Линк към коментара
Сподели в други сайтове

преди 12 минути, Колчо написа:

Да попитам има ли начин да забраня обновяването на ядрото при dist-upgrade  в LMDE Betsy?!

Има няколко начина. Най - лесния е да актуализираш с apt-get upgrade.

Защо искаш да спреш обновленията и, кое ядро ползваш ? Ако е щатното на Jessie, то се обновява само в рамките на текущата версия.

Изпълни uname -а и публикувай изхода.

Редактирано от cybercop (преглед на промените)
Линк към коментара
Сподели в други сайтове

преди 7 минути, cybercop написа:

Има няколко начина. Най - лесния е да актуализираш с apt-get upgrade.

Защо искаш да спреш обновленията и, кое ядро ползваш ? Ако е щатното на Jessie, то се обновява само в рамките на текущата версия.

Изпълни uname -а и публикувай изхода.

Искам да забраня инсталация на ядро 4.8. Като започна цялата процеудра по ъпгрейд на виртуалната машина ще дам изхода на целият дист ъпгрейд. Реших да се върна към Бетси като го поставя на ново на лаптопа си. Последният когато трябваше да ъпгрейдне ядрото към 4,8 изписа нещо за  графичният драйвер Ati Mobility 5XXXX и след това последва сриване на XORG след рестарт и стартиране на машината с въпросното ядро. За съжаление изтрих въпросната дистрибуция и на нейно място за сега функционира MX 16 Beta 1 но не се кефя на XFCE като графична среда. Предпочитам Cinnamon.

Линк към коментара
Сподели в други сайтове

на 18.11.2016 г. в 19:20, cybercop написа:

Някой знае ли, нещо повече за този проект ? И, ще бъдат ли достъпни пакетите за останалите дистрибуции ? 

https://www.archlinux.org/groups/x86_64/lxde-gtk3/

Далече съм от разработчиците на Arch, но тези момчета, правят нещо, което трябваше да направят разработчиците на LXDE още преди две години.

Ако някой комуникира с тях, нека ги поздрави и от мое име.

 

А ми тези пакети не са нищо друго освен lxde + компонентите, компилирани със gtk3 съпорт (--enable-gtk3) , който се поддържа от опциите  . Изключение прави само пакет lxterminal за който е добавене кръпка към пакета за gtk3 [1] https://git.archlinux.org/svntogit/community.git/tree/trunk/gtk3.patch?h=packages/lxterminal

На кратко:

Ако си изтеглиш сам сорсовете на тези пакети и ти може да си ги компилираш със gtk3 , после прилагаш онази кръпка за lxterminal и си готов !  

Общо взето това е , друг е въпроса защо gtk3 не е включен по подразбиране във тези приложения.

Редактирано от ivoarch (преглед на промените)
Линк към коментара
Сподели в други сайтове

преди 1 час, Колчо написа:

Искам да забраня инсталация на ядро 4.8. Като започна цялата процеудра по ъпгрейд на виртуалната машина ще дам изхода на целият дист ъпгрейд. Реших да се върна към Бетси като го поставя на ново на лаптопа си. Последният когато трябваше да ъпгрейдне ядрото към 4,8 изписа нещо за  графичният драйвер Ati Mobility 5XXXX и след това последва сриване на XORG след рестарт и стартиране на машината с въпросното ядро. За съжаление изтрих въпросната дистрибуция и на нейно място за сега функционира MX 16 Beta 1 но не се кефя на XFCE като графична среда. Предпочитам Cinnamon.

Не го инсталирай. Инсталирай си оригиналното на Jessie и, след като се убедиш, че работи, премахни тези на LMD. 

За 32 или за 64 битова версия става въпрос ?

Държиш ли, LM да е Debian базирана, защото Ubuntu базираните се поддържат по- добре.

преди 1 час, ivoarch написа:

А ми тези пакети не са нищо друго освен lxde + компонентите, компилирани със gtk3 съпорт (--enable-gtk3) , който се поддържа от опциите  . Изключение прави само пакет lxterminal за който е добавене кръпка към пакета за gtk3 [1] https://git.archlinux.org/svntogit/community.git/tree/trunk/gtk3.patch?h=packages/lxterminal

На кратко:

Ако си изтеглиш сам сорсовете на тези пакети и ти може да си ги компилираш със gtk3 , после прилагаш онази кръпка за lxterminal и си готов !  

Общо взето това е , друг е въпроса защо gtk3 не е включен по подразбиране във тези приложения.

Това не е ли прехвърляне на GTK3 платформата ? Друг вид поддръжка не мога да разбера, какво означава. Изгледа на GTK3 приложенията се определя от GTK3 интеграцията на темите, а не от самата графична среда. 

Редактирано от cybercop (преглед на промените)
Линк към коментара
Сподели в други сайтове

преди 46 минути, cybercop написа:

Не го инсталирай. Инсталирай си оригиналното на Jessie и, след като се убедиш, че работи, премахни тези на LMD. 

За 32 или за 64 битова версия става въпрос ?

Държиш ли, LM да е Debian базирана, защото Ubuntu базираните се поддържат по- добре.

Това не е ли прехвърляне на GTK3 платформата ? Друг вид поддръжка не мога да разбера, какво означава. Изгледа на GTK3 приложенията се определя от GTK3 интеграцията на темите, а не от самата графична среда. 

1.А ми ДА , означава ,че ще ползва GTK3 за приложението вместо GTK2, като има зависимост GTK3 .  Тези приложение на LXDE , изглежда имат GTK3 интеграция и този потребител, е направил пакетите билднати със GTK3 вместо GTK2 по дефолт .

2.ДА, но графичната среда, или дадено приложение компонент от тази графична среда, първо трябва да поддържа GTK3 , и не на последно място да е компилирано със GTK3 . Както е случая със тези пакети от AUR , те са компилирани със GTK3 ,предлагащ се от опциите на самата програма , което дава възможност на този който компилира да разбера ,че има и  GTK3 интеграция на приложението .  Една тема просто украсява приложението , нищо друго .

Редактирано от ivoarch (преглед на промените)
Линк към коментара
Сподели в други сайтове

преди 12 минути, ivoarch написа:

2.ДА, но графичната среда, или дадено приложение компонент от тази графична среда, първо трябва да поддържа GTK3 , и не на последно място да е компилирано със GTK3 . Както е случая със тези пакети от AUR , те са компилирани със GTK3 ,предлагащ се от опциите на самата програма , което дава възможност на този който компилира да разбера ,че има и  GTK3 интеграция на приложението .  Една тема просто украсява приложението , нищо друго .

Факт е, че която и версия на LXDE да ползваш или само мениджър на прозорци, ако GTK темата има работеща GTK3 интеграция, всяко GTK3 приложение, стартира  с външен вид, зададен от тази интеграция. 

Линк към коментара
Сподели в други сайтове

преди 22 минути, cybercop написа:

Факт е, че която и версия на LXDE да ползваш или само мениджър на прозорци, ако GTK темата има работеща GTK3 интеграция, всяко GTK3 приложение, стартира  с външен вид, зададен от тази интеграция. 

Ако приложението е билдното със GTK2 , то тогава ще взима изгледа на GTK2 темата .

Линк към коментара
Сподели в други сайтове

преди 13 минути, ivoarch написа:

 

Ако приложението е билдното със GTK2 , то тогава ще взима изгледа на GTK2 темата .

 

За платформата няма спор. Въпросът ми беше, приложенията от този проект на GTK3 платформата ли са прехвърлени. Не мисля, че е толкова просто, щом, нуждата от тях е голяма, а, само този екип са го реализирали. Не знам до каква степен. Вече няколко пъти съм писал, че LxQt, вероятни никога няма да може да замести напълно LXDE. И, има много голяма нужда от директно прехвърляне на компонентите на LXDE на GTK3 платформата. Проекта е достигнал такова равнище, че е необходимо само малко работа по десктопа и мениджър за управление за нахранването за да стане равностоен конкурент на всяка друга DE. Но и в това си състояние, може да задоволи потребностите на повечето потребители.

Линк към коментара
Сподели в други сайтове

преди 16 часа, бат'начо написа:

Опитай първо да преинсталираш пакетите.

sudo apt-get install --reinstall software-properties-common software-properties-gtk python3-software-properties

Да не би да има инсталирано python-software-properties, я първо "гръмни" профилактично.

sudo apt-get purge python-software-properties

 

 

преди 14 часа, бат'начо написа:

Всъщност интересното е в "сесия и стартиране" в контролния център.

А чистил ли си системата някога? Я пробвай

sudo rm /var/cache/apt/archives/*.deb

 

 

преди 6 часа, бат'начо написа:

@Булет Защо ходиш до /etc/apt/ като администратор. Сигурен ли си, че не си променял нещо по sources.list или sources.list.save, с текстов редактор с неправилна кодировка (примерно), или пък допусната грешка там. Какво е точното съдържание на тези двата файла.

Не,не съм променял тези два файла.

бат'начо,след като изпълних горните команди снощи не се отваряше Програми и актуализации,но днеска като включих лаптопа и пробвах да отворя Програми и актуализации се отвори.Сега няма проблеми.

Благодаря ви много на тебе и cybercop за помощта.

Линк към коментара
Сподели в други сайтове

преди 34 минути, cybercop написа:

За платформата няма спор. Въпросът ми беше, приложенията от този проект на GTK3 платформата ли са прехвърлени. Не мисля, че е толкова просто, щом, нуждата от тях е голяма, а, само този екип са го реализирали. Не знам до каква степен. Вече няколко пъти съм писал, че LxQt, вероятни никога няма да може да замести напълно LXDE. И, има много голяма нужда от директно прехвърляне на компонентите на LXDE на GTK3 платформата. Проекта е достигнал такова равнище, че е необходимо само малко работа по десктопа и мениджър за управление за нахранването за да стане равностоен конкурент на всяка друга DE. Но и в това си състояние, може да задоволи потребностите на повечето потребители.

ДА , вече казах , използват GTK3 вместо GTK2 , компилирани са със GTK3 библиотеки и има зависимост GTK3 , вместо старата GTK2 .  А ми не виждам нищо реализирано чак толкоз , авторите на LXDE са си портнали повечето приложения във GTK3 , като са добавили съпорт и опция да се билднат със GTK3 . От Aur или по точно този отговорен за пакетите просто компилира със тази опция , нищо сложно (./configure --prefix=/usr --enable-gtk3 ; make; sudo make install ) пример https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=lxlauncher-gtk3#n25 . Малко по различно  стои при пакета lxterminal ,  този пакет не е бил портнат на GTK3 , за това е трябвало да се напише кръпка и да се приложи  в кода от пакета в AUR , това е по сложното понеже се иска да  да знаеш програмиране , ,за другото просто се иска  да  можеш да компилираш .

 

Преди месец пробвах LXQT и ми хареса доста, успях да го рацъкам дори със kwin , има направени доста компоненти , липсваше ми само плъгин clipboard . Темата KDE plasma кърти , pcmanfm-qt е много много добър ,  не срещнах никакви бъгове за два дена ползване .

 

 

Редактирано от ivoarch (преглед на промените)
Линк към коментара
Сподели в други сайтове

преди 6 минути, ivoarch написа:

Преди месец пробвах LXQT и ми хареса доста, успях да го рацъкам дори със kwin , има направени доста компоненти , липсваше ми само плъгин clipboard . Темата KDE plasma кърти , pcmanfm-qt е много много добър ,  не срещнах никакви бъгове за два дена ползване .

Никъде не съм писал, че LxQt няма да има почитатели. Но не е LXDE и, според мен никога няма да бъде неин истински заместител. Колкото до Lxterminal, xterm е достатъчно мощно приложение и при неговото наличие, повечето от останалите графични терминали са си чиста проба глезотия. Не, че е лошо да ги има.

Редактирано от cybercop (преглед на промените)
Линк към коментара
Сподели в други сайтове

Здравейте! :)

При описване на снимки, забелязах едно странно явление - файловият мениджър показва две копия на едни и същи файлове с различни размери и дати. На screenshot-а това, което е отдясно, е backup на картата памет (който се намира на харддиска) - копирана е цялата главна директория на картата, а от ляво са същите снимки, само че разпределени в съответния им албум (отново на същия харддиск). Защо се получава така?

Screenshot_20161119_025923.png

Линк към коментара
Сподели в други сайтове

току-що, бат'начо написа:

На две еднакви файлови системи ли са, ако да са на един хард?

На една и съща файлова система са (xfs), в една и съща главна директория са, просто това от ляво е сваляно от апарата след като са направени снимките, а това от дясно е второ , резервно копие на цялата карта памет, правено по друго време. И това, което е по-интересно, е че реалните данни за снимките са тези от дясно.

Линк към коментара
Сподели в други сайтове

Добавете отговор

Можете да публикувате отговор сега и да се регистрирате по-късно. Ако имате регистрация, влезте в профила си за да публикувате от него.

Гост
Напишете отговор в тази тема...

×   Вмъкнахте текст, който съдържа форматиране.   Премахни форматирането на текста

  Разрешени са само 75 емотикони.

×   Съдържанието от линка беше вградено автоматично.   Премахни съдържанието и покажи само линк

×   Съдържанието, което сте написали преди беше възстановено..   Изтрий всичко

×   You cannot paste images directly. Upload or insert images from URL.

  • Разглеждащи това в момента   0 потребители

    • Няма регистрирани потребители разглеждащи тази страница.
  • Горещи теми в момента

  • Подобни теми

    • от Недко
      Здравейте !

      Преди години в предаването "Микрофон и мишка" на Дарик Радио чух, че компютър с Linux може да се използва като антивирусен "филтър", или изобщо средство за защита на интернет трафика на компютър с Windows.
      В моя случай дори е належащо, защото имам компютър с XP, която вече не се поддържа от MS.
      Наскоро ме "светнаха", че такива машини не само са лесни за заразяване, но и били цел за някакви ботове, създадени да сканират нета и да откриват такива компютри. 
      Та, на въпроса с филтриращия Linux компютър. Дали все още е актуално такова решение, дали има ефект, 
      има ли писано някъде в нета за него и описано как се прави ?
      Моля за някаква информация, съвет, линк на български, руски, английски, немски ...
      или дори само за правилна формулировка на въпроса към Гугъл !

      Предварително ви благодаря !

      P.S. Да уточня, че имам други лаптопи с Linux Mint 20.2, но този с ХР искам да си остане така.

      Евентуално, като вариант, инсталиране на XP във виртуална машина на Linux система,
      дали е ефективно решение за защита на ХР-то ?
       
    • от vpvelev
      Здравейте!
      Отварям отделна тема за още една Linux дистрибуция - Gentoo.
      Много са чували за нея, но малко са я ползвали. Причината е, че трудно (това е относително) се инсталира и изисква много време, защото всичко се компилира от изходен код. Последното пък изисква по-мощен хардуер, а не всеки разполага с такъв.
      При мен се случи така, че първото ми запознаване с Линукс беше имено с Gentoo Linux (нямам точен спомен, но преди 2005 година беше). Но не защото знаех нещо за линукс или за Gentoo, а защото не знаех какво ме очаква.  Но се оказа, че съм имал късмет да попадна на тази дистрибуция, за да науча поне нещо за линукс.
      И от тогава, тъй като не съм имал подходящ компютър (поне така съм си мислел) до преди няколко дена не обръщах внимание на тази дистрибуция.
      Тия дни я инсталирах и засега работи нормално всичко. Затова и отварям тази тема за новини, дискусии, помощ и др.
      Инсталацията я направих от съществуваща при мен друга линукс дистрибуция - Arco Linux. По начало Gentoo може да се инсталира и от други дистрибуции. Този начин за инсталиране, поне за мен е за предпочитане, особено за тия, които не са много запознати, а и не искат да си загубят другата дистрибуция.
      При този вид на инсталация не са необходими никакви флашки и дискове, а освен това се инсталира в графична среда и се ползват и четат различни статии и разяснения. Така инсталацията става много лесно. Дори може и да се прекрати, ако някой се уплаши или му омръзне и след време може пак да я продължи.
      Ето няколко линка за това. И аз ще покажа по-нататък как протече при мен инсталацията и какви проблеми срещнах.
      https://www.wikihow.com/Install-Gentoo-Linux-from-Ubuntu
       
      Отваряте терминала и започвате
      Използвах тия два линка в началото, но след това направих нещо средно м/у тях. Но това зависи от мощността на компютъра или какъв профил ще изберете:

      Важното е да не се отказвате лесно след първите неуспехи.

       

    • от Теодор Тодоров
      За забравената парола на BIOS-а нищо не reset-на самата парола ще инсталирам Windows 8.1 На друг диск, защото не знам как се инсталира plop boot manager под linux, Гледах клипове как се инсталира plop под linux но нищо не разбрах от него
    • от Street Life
      Здравейте!
      #####
      На дамите - Честит празник!
      #####
      Въпросът ми е:
      На какъв принцип работи Microsoft Windows? Подобен ли е като в Wayland или Xorg на Linux?
       
    • от Camazotz_21
      Искам да попитам, ако си поръчам лаптоп с Ос-Linux мога ли след това да му сложа Windows? Защото ми слага триста лева отгоре с Windows. 
×
×
  • Добави ново...

Информация

Поставихме бисквитки на устройството ви за най-добро потребителско изживяване. Можете да промените настройките си за бисквитки, или в противен случай приемаме, че сте съгласни с нашите Условия за ползване