Премини към съдържанието
  • Добре дошли!

    Добре дошли в нашите форуми, пълни с полезна информация. Имате проблем с компютъра или телефона си? Публикувайте нова тема и ще намерите решение на всичките си проблеми. Общувайте свободно и открийте безброй нови приятели.

    Моля, регистрирайте се за да публикувате тема и да получите пълен достъп до всички функции.

     

Linux - обща дискусия 3


Препоръчан отговор

преди 2 часа, FR13ND написа:

Ползвай Synaptic за да инсталираш python-libtorrent ...след това преинсталирай Deluge.

Успех.

Въпросната зависимост се селектира автоматично и се инсталира. Проблема не е в инсталацията, а в пакетите. Писах им bug на openSUSE, сега само се надявам да не получа отговор от сорта на :"We are sorry but we hope it will be OK for 42.3" :D

преди 17 минути, cybercop написа:

Може би имаш предвид инсталатора на YaST ?

Какво става, когато свалиш deluge-custom (1.3.12) пакета и го инсталираш с инсталатора на YaST ?

http://download.opensuse.org/repositories/home:/Warhammer40k:/stuff/openSUSE_42.2_Update/noarch/deluge-custom.1.3.12-3.12.noarch.rpm

Виж, това не съм пробвал. Но е и по-стара версия, а не последната. Ще пробвам.
p.s. същата история. Явно, че проблема е конкретно в libtorrent, който е от хранилищата на openSUSE.

Редактирано от HotMusicFan (преглед на промените)
Линк към коментара
Сподели в други сайтове

  • Отговори 7,1k
  • Създадено
  • Последен отговор

Потребители с най-много отговори

Nouveau е reverse engineering, т.е. от нВидия не предоставят информация за това как работи хардуера им, а разработчиците го разглеждат "черна кутия" - при даден вход се получава някакъв изход, та те имплементират функционаността все едно със затворени очи :D Иначе аз съм и разработчик на КДЕ, не професионално, а като контрибутор, може да пишеш, ако нещо те дразни.

Що се отнася до OpenSuse-то под "stable as rock" се има предвид стабилна работа на ядрото и неговото обкръжение, приложенията е възможно да има някакви трески за дялане, но конкретно в този случай просто е объркана компилацията или е компилирана по-стара версия, без въпросната функция.

Линк към коментара
Сподели в други сайтове

преди 30 минути, HotMusicFan написа:

Въпросната зависимост се селектира автоматично и се инсталира. Проблема не е в инсталацията, а в пакетите. Писах им bug на openSUSE, сега само се надявам да не получа отговор от сорта на :"We are sorry but we hope it will be OK for 42.3" :D

Виж, това не съм пробвал. Но е и по-стара версия, а не последната. Ще пробвам.
p.s. същата история. Явно, че проблема е конкретно в libtorrent, който е от хранилищата на openSUSE.

Добавил ли си някакви community repositories ? Често се налага, особено Packman.

Линк към коментара
Сподели в други сайтове

преди 6 минути, cybercop написа:

Добавил ли си някакви community repositories ? Често се налага, особено Packman.

Имам само за NVIDIA драйвърите, официалната на  VLC (но не Packman) и хранилището за Google Chrome, което си идва със самия пакет.

преди 11 минути, bvbfan написа:

Nouveau е reverse engineering, т.е. от нВидия не предоставят информация за това как работи хардуера им, а разработчиците го разглеждат "черна кутия" - при даден вход се получава някакъв изход, та те имплементират функционаността все едно със затворени очи :D Иначе аз съм и разработчик на КДЕ, не професионално, а като контрибутор, може да пишеш, ако нещо те дразни.

Що се отнася до OpenSuse-то под "stable as rock" се има предвид стабилна работа на ядрото и неговото обкръжение, приложенията е възможно да има някакви трески за дялане, но конкретно в този случай просто е объркана компилацията или е компилирана по-стара версия, без въпросната функция.

Тогава нека не объркват хората с твърдения за "polished experience". Въпреки, че за Linux светът и специално за KDE е наистина една от най-добрите. За nouveau знам, че е reverse engieering, не споря за това, просто съветвам чисто практически да не се ползва, най-вече заради никаквия power management и почти неработещите вентилатори, което за лаптоп е немислимо.

Линк към коментара
Сподели в други сайтове

И с Packman е същото. Пробвах. Покрай deluge се инсталираха 32 пакета, но при стартиране на програмата дава същата грешка с Classic Mode.

Линк към коментара
Сподели в други сайтове

преди 13 минути, HotMusicFan написа:

Имам само за NVIDIA драйвърите, официалната на  VLC (но не Packman) и хранилището за Google Chrome, което си идва със самия пакет.

 

Отвори YAST >>Източници на софтуер >>Добавяне>>Community repositories. Отметни Packman хранилището и го добави, като внесеш ключ.

Като затвориш мениджъра, изпълни в терминал.

su

zypper update

Ако ти излезе списък с пакети, които не могат да се надградят, копирай целия списък от изхода на терминала, напиши :

zypper install копирания_списък

Ако не се оправят нещата - торент клиентите са доста и deluge не е незаменим.

Редактирано от cybercop (преглед на промените)
Линк към коментара
Сподели в други сайтове

преди 3 минути, дръндю написа:

понеже тук е свободна дискусия...ъ-ъ-ъ...тъй де, да ви попитам, до колко е свободен Линукса ъ

 

Ново Bitmap изображение.jpg

Свободен е точно колкото трябва. Гарет е все от нещо или някого недоволен и не е критерии за обективност. Става въпрос за манипулирани образи, издавани, като официални издания на Ubuntu.

Редактирано от cybercop (преглед на промените)
Линк към коментара
Сподели в други сайтове

преди 1 минута, cybercop написа:

Точно колкото трябва. Гарет е все от нещо или някого недоволен и не е критерии за обективност. Става въпрос за манипулирани образи, издаване, като официални издания на Ubuntu.

Линукса имаше това предимство пред всички ОС, че всеки можеше да си го модифицира какту муй кеф и ся накъде
с ултраисото си ги модифицирах, но явно, вече съм на кръстопът
ползвах пакети от различни дистрибуции, като размествах това онова, но май всичко умря

Линк към коментара
Сподели в други сайтове

Съвсем друго се има предвид, според мен, когато си модифицираш Убунту-то, то да не е вече Убунту, ако разпространяваш негови образи, а да си го наречеш Дръндюнту :D 

Редактирано от bvbfan (преглед на промените)
Линк към коментара
Сподели в други сайтове

преди 7 минути, дръндю написа:

Линукса имаше това предимство пред всички ОС, че всеки можеше да си го модифицира какту муй кеф и ся накъде
с ултраисото си ги модифицирах, но явно, вече съм на кръстопът
ползвах пакети от различни дистрибуции, като размествах това онова, но май всичко умря

Нещо, сериозно си се объркал. Никой не ти пречи да модифицираш, какъвто искаш свободен софтуер, както си пише в GPL лиценза. Не можеш да ползваш запазена марка, под която да издаваш манипулиран от теб по незнайно какъв начин код. Чиста измама на потребителите и компроментиране на Canonical. Все едно да вземеш кредит на мое име. Никой не им пречи да модифицират софтуера и да го издадат под друго име. Достатъчно е да сложат една буква пред Ubuntu или да подменят първата.

Редактирано от cybercop (преглед на промените)
Линк към коментара
Сподели в други сайтове

преди 10 минути, дръндю написа:

благодаря ви, но в статията се споменава, че не мога да ползвам техни хранилища, а всички знаете, че по същество пакетите са архиви

Можеш да ползваш всеки пакет от хранилищата им. Кой и кога те е спирал.

http://packages.ubuntu.com/bg/

Става въпрос за обикновена измама и една новина с манипулационно съдържание.

По подобен начин, Гарет напусна тенденциозно и екипа по разработка на Linux ядрото. 

Линк към коментара
Сподели в други сайтове

преди 1 минута, cybercop написа:

 

Става въпрос за обикновена измама и една новина с манипулационно съдържание.

По подобен начин, Гарет напусна тенденциозно и екипа по разработка на Linux ядрото. 

те това ми трябваше

огромно благодаря

Линк към коментара
Сподели в други сайтове

преди 7 минути, дръндю написа:

те това ми трябваше

огромно благодаря

Имай предвид, че някои пакети в хранилищата са с особен статут и, особено тези от Parners. Те са с наложени фирмени ограничения и Canonical няма право да се разпорежда с тях. Ползването им става със сключване на индивидуален договор на всеки потребител при инсталацията им. Затова, не те съветвам да пускаш образи с предварително инсталиран Skype, broadcom драйвъри, някои декодери и т.н. 

Линк към коментара
Сподели в други сайтове

Моите уважения, @cybercop, но изобщо не мога да се съглася. Matthew Garett с право е недоволен от много неща и е особено адекватно мнение по отношение на въпросите със сигурността и неглижирането на проблемите с нея. Той, както и други разработчици, напуснаха разработката на Linux ядрото заради тенденциозното отношение на Linus, който просто не иска да чуе чуждо мнение, било то и мение, предлагащо нещо полезно.
Canonical не искам и да ги обсъждам. И моля никой да не се опитва да ги изкара "светци". Те и специално Shuttleworth са просто едни готовани, които ползват наготово нещо разработено, за да правят кинти, представяйки "продукт", в който почти всеки компонент е тяхна измислица, базирана на идея или разработка на някой истински open source проект. Само че с (TM) ;) Canonical лично за мен са най-отвратителните лицемери, особено и с тяхното прословуто CLA...и смятат, че целия останал свят трябва да им играе по свирката ;) Ubuntu отдавна НЕ Е свободен софтуер в истинския смисъл на думата и всеки, който си мисли, че е такъв, само защото е без пари, греши.

Линк към коментара
Сподели в други сайтове

По точно такава причина УСУ си е просто УСУ (некво име), а не Учи Свободен с Убунту.

Шрифтовете, логото, името и сигурно още нещо, дето пропускам, са си собственост на Каноникал и е нормално да си защитават правата.

Тези, които си партнират по някъкъв начин с Каноничните, имат право да имат *бунту в името и да ползват останалото.

преди 3 минути, HotMusicFan написа:

Ubuntu отдавна НЕ Е свободен софтуер в истинския смисъл на думата и всеки, който си мисли, че е такъв, само защото е без пари, греши.

От много време даже и не го смятат и за Линукс, но какво от това, всеки трябва да се храни, нали. Дебиан тоже не е свободен софтуер в истинския смисъл на думата. В днешния свят май се броят на пръстите на едната ръка, тези които се опитват да бъдат (и полагат усилилия за това).

Линк към коментара
Сподели в други сайтове

преди 16 минути, HotMusicFan написа:

Ubuntu отдавна НЕ Е свободен софтуер в истинския смисъл на думата и всеки, който си мисли, че е такъв, само защото е без пари, греши.

Искаш ли да доведем нещата до смислено ниво. Какво имаш предвид под горното изречение. Че, софтуерът в дистрибуцията Ubuntu не е свободен ли ? Или, че наименованието Ubuntu не е свободно ? Парите, които правят от услуги (десктопът им е хоби) в никакъв случай не смятам за нещо порочно или лошо. Нито от Canonical, нито от Red Hat, нито от Novell. Това са работни места за служителите, както и доволни интернет потребители, доставчици и т.н.

Редактирано от cybercop (преглед на промените)
Линк към коментара
Сподели в други сайтове

преди 8 минути, бат'начо написа:

 

По точно такава причина УСУ си е просто УСУ (некво име), а не Учи Свободен с Убунту.

 

Шрифтовете, логото, името и сигурно още нещо, дето пропускам, са си собственост на Каноникал и е нормално да си защитават правата.

Тези, които си партнират по някъкъв начин с Каноничните, имат право да имат *бунту в името и да ползват останалото.

От много време даже и не го смятат и за Линукс, но какво от това, всеки трябва да се храни, нали. Дебиан тоже не е свободен софтуер в истинския смисъл на думата. В днешния свят май се броят на пръстите на едната ръка, тези които се опитват да бъдат (и полагат усилилия за това).

Ако трябва да сме точни, всички големи дистрибуции са полу-свободни, считайки факта, че в тях се ползва или се дава възможност за инсталация на proprietary софтуер, а понякога той просто и няма алтернатива. Но, поставяйки се на мястото на разработчик, не мога да се съглася и да приема някаква си там компания да ми казва:"пишеш код, който лицензираш като GPL, ние го дистрибутираме и ре-дистрибутираме и имаме правото да го прелицензираме под какъвто и да било друг тип лиценз, даже и proprietary license" ;) Sorry, ама изнагляват яко. 
Не щяли Wayland - OK; и след това набързо измислиха Mir, който концептуално е почти същото ;) После се сърдиха, че Intel не искали да се занимават с поддръжка на Mir. 
Като са много отворени, да вземат да си пишат сами и драйвърите, и съвсем ново ядро да си измислят. Canonical правят така, че контрибутирането към тях да е лесно, но контрибутирането от тяхна страна - невъзможно.

Линк към коментара
Сподели в други сайтове

преди 3 часа, HotMusicFan написа:

Аз даже гледах в официалния сайт на Deluge, след като го деинсталирах - имат 1-click пакет, който при отваряне дава информация, че за 42.2 изобщо няма пакети, т.е. те просто са взели source и явно не са компилирали пакета както трябва. Ще им пиша. Честно казано, лично за мен концептуално е най-добрата дистрибуция за desktop, но ме е изключително яд, като се бият в гърдите, че всичко било стабилно като камък, което за мен означава всичко да работи без абсолютно никакъв проблем. Намерих и други малки кусури по KDE, макар че 5.8 е голяма стъпка напред по отношение на работата.

Между другото, който е с nVidia, като мен, изобщо да забрави за нормална работа с nouveau. Даже и в инсталатора на системата излиза предупреждение, че дава проблеми с KDE и qt-базирани приложения. Nouveau изобщо не "познава" вентилаторите и те почти не работят, получават се крашове, яки "размазвания" и ефектите изобщо не работят нормално. Слагайте драйвъра на nVidia, който е със затворен код.

Инсталирай тези пакети libtorrent-rasterbar8 също python-libtorrent-rasterbar . Стартирай deluge отново.

Линк към коментара
Сподели в други сайтове

преди 4 минути, ivoarch написа:

Инсталирай тези пакети libtorrent-rasterbar8 също python-libtorrent-rasterbar . Стартирай deluge отново.

По-горе разбрахме какъв е проблема. Тези два пакета се инсталират автоматично и въпреки това не работи, което означава, че има неправилно компилирани. Благодаря все пак :)

Линк към коментара
Сподели в други сайтове

Ок, тогава направи donwgrade на този пакет python-libtorrent-rasterbar и пак стартирай ;)

Забележи версията да е под 1.1.1-1.1

 

edit: Най добре тази версия я инсталирай python-libtorrent-rasterbar-1.0.9-7.1.x86_64.rpm

ето от тук ftp://195.220.108.108/linux/opensuse/update/leap/42.1/oss/x86_64/python-libtorrent-rasterbar-1.0.9-7.1.x86_64.rpm

също този ftp://195.220.108.108/linux/opensuse/update/leap/42.1/oss/x86_64/libtorrent-rasterbar8-1.0.9-7.1.x86_64.rpm

По този начин ще направиш downgrade на пакета който е пречка за стартирането на deluge под 42.2 .

Редактирано от ivoarch (преглед на промените)
Линк към коментара
Сподели в други сайтове

преди 2 минути, ivoarch написа:

Ок, тогава направи donwgrade на този пакет python-libtorrent-rasterbar и пак стартирай ;)

Забележи версията да е под 1.1.1-1.1

То май няма накъде да правя downgrade, защото като гледам в хранилището на 42.2 e единствената налична версия. Варианта е или да издърпам deluge и повредените пакети от хранилището на 42.1 или да си компилирам всичко сам.
И може би, тук е момента да се замислим колко добри в такива ситуации са решения като AppImage например ;) 

Линк към коментара
Сподели в други сайтове

Няма нужда да билдваш сам  , това няма да реши проблема . Проблема е новата версия на тези два пакета libtorrent-rasterbar8, python-libtorrent-rasterbar . Виж линковете които ти дадох , инсталирай долните версии от там , те са за 42.1 къде все още deluge стартира . Успех!

Линк към коментара
Сподели в други сайтове

Добавете отговор

Можете да публикувате отговор сега и да се регистрирате по-късно. Ако имате регистрация, влезте в профила си за да публикувате от него.

Гост
Напишете отговор в тази тема...

×   Вмъкнахте текст, който съдържа форматиране.   Премахни форматирането на текста

  Разрешени са само 75 емотикони.

×   Съдържанието от линка беше вградено автоматично.   Премахни съдържанието и покажи само линк

×   Съдържанието, което сте написали преди беше възстановено..   Изтрий всичко

×   You cannot paste images directly. Upload or insert images from URL.

  • Разглеждащи това в момента   0 потребители

    • Няма регистрирани потребители разглеждащи тази страница.
  • Горещи теми в момента

  • Подобни теми

    • от Недко
      Здравейте !

      Преди години в предаването "Микрофон и мишка" на Дарик Радио чух, че компютър с Linux може да се използва като антивирусен "филтър", или изобщо средство за защита на интернет трафика на компютър с Windows.
      В моя случай дори е належащо, защото имам компютър с XP, която вече не се поддържа от MS.
      Наскоро ме "светнаха", че такива машини не само са лесни за заразяване, но и били цел за някакви ботове, създадени да сканират нета и да откриват такива компютри. 
      Та, на въпроса с филтриращия Linux компютър. Дали все още е актуално такова решение, дали има ефект, 
      има ли писано някъде в нета за него и описано как се прави ?
      Моля за някаква информация, съвет, линк на български, руски, английски, немски ...
      или дори само за правилна формулировка на въпроса към Гугъл !

      Предварително ви благодаря !

      P.S. Да уточня, че имам други лаптопи с Linux Mint 20.2, но този с ХР искам да си остане така.

      Евентуално, като вариант, инсталиране на XP във виртуална машина на Linux система,
      дали е ефективно решение за защита на ХР-то ?
       
    • от vpvelev
      Здравейте!
      Отварям отделна тема за още една Linux дистрибуция - Gentoo.
      Много са чували за нея, но малко са я ползвали. Причината е, че трудно (това е относително) се инсталира и изисква много време, защото всичко се компилира от изходен код. Последното пък изисква по-мощен хардуер, а не всеки разполага с такъв.
      При мен се случи така, че първото ми запознаване с Линукс беше имено с Gentoo Linux (нямам точен спомен, но преди 2005 година беше). Но не защото знаех нещо за линукс или за Gentoo, а защото не знаех какво ме очаква.  Но се оказа, че съм имал късмет да попадна на тази дистрибуция, за да науча поне нещо за линукс.
      И от тогава, тъй като не съм имал подходящ компютър (поне така съм си мислел) до преди няколко дена не обръщах внимание на тази дистрибуция.
      Тия дни я инсталирах и засега работи нормално всичко. Затова и отварям тази тема за новини, дискусии, помощ и др.
      Инсталацията я направих от съществуваща при мен друга линукс дистрибуция - Arco Linux. По начало Gentoo може да се инсталира и от други дистрибуции. Този начин за инсталиране, поне за мен е за предпочитане, особено за тия, които не са много запознати, а и не искат да си загубят другата дистрибуция.
      При този вид на инсталация не са необходими никакви флашки и дискове, а освен това се инсталира в графична среда и се ползват и четат различни статии и разяснения. Така инсталацията става много лесно. Дори може и да се прекрати, ако някой се уплаши или му омръзне и след време може пак да я продължи.
      Ето няколко линка за това. И аз ще покажа по-нататък как протече при мен инсталацията и какви проблеми срещнах.
      https://www.wikihow.com/Install-Gentoo-Linux-from-Ubuntu
       
      Отваряте терминала и започвате
      Използвах тия два линка в началото, но след това направих нещо средно м/у тях. Но това зависи от мощността на компютъра или какъв профил ще изберете:

      Важното е да не се отказвате лесно след първите неуспехи.

       

    • от Теодор Тодоров
      За забравената парола на BIOS-а нищо не reset-на самата парола ще инсталирам Windows 8.1 На друг диск, защото не знам как се инсталира plop boot manager под linux, Гледах клипове как се инсталира plop под linux но нищо не разбрах от него
    • от Street Life
      Здравейте!
      #####
      На дамите - Честит празник!
      #####
      Въпросът ми е:
      На какъв принцип работи Microsoft Windows? Подобен ли е като в Wayland или Xorg на Linux?
       
    • от Camazotz_21
      Искам да попитам, ако си поръчам лаптоп с Ос-Linux мога ли след това да му сложа Windows? Защото ми слага триста лева отгоре с Windows. 
×
×
  • Добави ново...

Информация

Поставихме бисквитки на устройството ви за най-добро потребителско изживяване. Можете да промените настройките си за бисквитки, или в противен случай приемаме, че сте съгласни с нашите Условия за ползване