Премини към съдържанието
  • Добре дошли!

    Добре дошли в нашите форуми, пълни с полезна информация. Имате проблем с компютъра или телефона си? Публикувайте нова тема и ще намерите решение на всичките си проблеми. Общувайте свободно и открийте безброй нови приятели.

    Моля, регистрирайте се за да публикувате тема и да получите пълен достъп до всички функции.

     

GNS 3 рутер към Ubuntu 14.04


TheSmoKeR

Препоръчан отговор

Здравейте.Вързал съм един виртуален Cisco 3700 към моя tap в Ubuntu 14.04.Общо взето последвах следния пример:

 

 

[email protected]:~$ sudo –i
[email protected] admin-desktop:~#apt-get install uml-utilities
[email protected] admin-desktop:~#modprobe tun
[email protected] admin-desktop:~#tunctl  This will create loopback interface tap0
[email protected] admin-desktop:~#ifconfig tap0 10.100.100.100 netmask 255.255.255.0 up
[email protected] admin-desktop:~#ifconfig verify that tap0 is up and given ip is assigned

Задал съм IP 192.168.100.1/24 на tap адаптера и 192.168.100.254/24 на рутера.От моята машина естествено имам пинг към тап-а и към рутера.От рутера имам пинг към тап-а също но проблемът е че нямам пинг навън към интернет или към реалния адаптер на лаптопа.Въпроса ми е как да настроя тоя tap0 адаптер да рутира пакетите?Трябва да го бриджна с моя реален адаптер(в случая wlan0) ли?Да отблежа че съм задал ip default gateway на рутера да е tap0.

Линк към коментара
Сподели в други сайтове

Какви са останалите настройки - маски, днс-и ? С каква цел е този виртуален маршрутизатор ? VPN сървър нямаше ли да е по-лесно да вдигнете ?

Линк към коментара
Сподели в други сайтове

Wlan0 на лаптопа който в случая използвам за връзка с интернет е с адрес 192.168.0.101/24 a gateway-а 192.168.0.1/24.Зададох ip-та на виртуалния рутер  и на tap адаптера да са в същата в мрежа като на реалния адаптер но резултата е същия.Има връзка между tap0 и виртуалния рутер но само дотолкова.Целта честно казано е никаква просто го видях някъде в интернет и ми стана много интересно и реших да пробвам :) Сега ще пробвам като бриджна wlan0 и tap0 да видим какво ще се получи.

Линк към коментара
Сподели в други сайтове

Защо правите:

[email protected] admin-desktop:~#ifconfig tap0 10.100.100.100 netmask 255.255.255.0 up

а след това, казвате, че сте задали 192.168.100.1?

 

Ако ползвате първата постановка т.е. tap0 и рутер-а да са ви 100 мрежата, то ви трябва един NAT за да имате нет към рутера.

iptables -t nat -A POSTROUTING -s 192.168.100.0/255.255.255.0 -j MASQUERADE

 

Не забравяйте и да пуснете forwarding-а

echo 1 >/proc/sys/net/ipv4/ip_forward

 

Ако направите bridge между wlan0 и tap0 и зададете същото IP на бриджа, каквото на wlan0, то на рутер-а ще трябва да сложите IP от нулевата мрежа и ако 0.1 NAT-ва IP-то, което сте сложили на рутер-а би трябвало да работи.

 

Ако съм разбрал правилно, какво правите де :D

Линк към коментара
Сподели в други сайтове

Защо правите:

[email protected] admin-desktop:~#ifconfig tap0 10.100.100.100 netmask 255.255.255.0 up

а след това, казвате, че сте задали 192.168.100.1?

 

Ако ползвате първата постановка т.е. tap0 и рутер-а да са ви 100 мрежата, то ви трябва един NAT за да имате нет към рутера.

iptables -t nat -A POSTROUTING -s 192.168.100.0/255.255.255.0 -j MASQUERADE

 

Не забравяйте и да пуснете forwarding-а

echo 1 >/proc/sys/net/ipv4/ip_forward

 

Ако направите bridge между wlan0 и tap0 и зададете същото IP на бриджа, каквото на wlan0, то на рутер-а ще трябва да сложите IP от нулевата мрежа и ако 0.1 NAT-ва IP-то, което сте сложили на рутер-а би трябвало да работи.

 

Ако съм разбрал правилно, какво правите де :D

Здравейте в моя случай командата беше ifconfig tap0 192.168.100.254 netmask 255.255.255.0 up.Тази команда в цитата горе просто беше за пример който видях от един сайт.Току що пробвах бриджването но не се получава.След командата : sudo brctl addif br0 wlan0 tap0 ми изписва:

 

can't add wlan0 to bridge br0: Operation not supported

 

Също така като информация в интернет намерих това :

 

This cannot be done. You cannot bridge a WiFi client connection. If you could, we wouldn't need WDS, we'd just bridge.

The problem is very simple -- an access point is prohibited by the WiFi specifaction from broadcasting traffic over the WiFi network unless something authorizes that transmission. This is largely a relic from the days when WiFi networks were very slow and had poor, if any, security.

Така че остава варианта който вие предложихте.Само ако може да ми кажете после как мога да спра forwarding-а като ми свършат експериментите ще съм ви много благодарен :))

Линк към коментара
Сподели в други сайтове

Имах някакви подозрения относно бриджа наистина. Ключа е "client". Иначе няма проблем ...

bridge name  bridge id    STP enabled  interfaces
br0    8000.0002dd30ab3c  no    eth1
             wlan0
 

Forward-инга и да не го махате не е проблем. Можете да го спрете с простичкото:

echo 0 >/proc/sys/net/ipv4/ip_forward

 

Ако имате само това правило в iptables то най-лесно:

iptables -t nat -F

или още по-грубо:

iptables -F

 

Успех!

Линк към коментара
Сподели в други сайтове

R2#ping abv.bgTranslating "abv.bg"...domain server (8.8.8.8) [OK]Type escape sequence to abort.Sending 5, 100-byte ICMP Echos to 194.153.145.104, timeout is 2 seconds:!!!!!Success rate is 100 percent (5/5), round-trip min/avg/max = 28/174/352 ms

Тъкмо си мислех че няма да тръгне понеже погрешка съм задал на рутера Gateway of Last Resort да е към интерфейса свързан към tap0.Впоследствие осъзнах че това е грешно и вместо интерфейс трябва да напиша Ip адрес.

Благодаря на колегата mail123456 и всички останали за помощта. 

Линк към коментара
Сподели в други сайтове

Архивирана тема

Темата е твърде стара и е архивирана. Не можете да добавяте нови отговори в нея, но винаги можете да публикувате нова тема, в която да продължи дискусията. Регистрирайте се или влезте във вашия профил за да публикувате нова тема.

×
×
  • Добави ново...

Информация

Поставихме бисквитки на устройството ви за най-добро потребителско изживяване. Можете да промените настройките си за бисквитки, или в противен случай приемаме, че сте съгласни с нашите Условия за ползване