Премини към съдържанието
От 1-ви септември 2021 г., вход във форумите ще е възможен само с имейл адрес вместо потребителско име. Ако не помните имейла с който сте се регистрирали, вижте го в настройките на профила си. ×
  • Добре дошли!

    Добре дошли в нашите форуми, пълни с полезна информация. Имате проблем с компютъра или телефона си? Публикувайте нова тема и ще намерите решение на всичките си проблеми. Общувайте свободно и открийте безброй нови приятели.

    Моля, регистрирайте се за да публикувате тема и да получите пълен достъп до всички функции.

     

„Омазан“ Debian 7


Славчо Хаджийски

Препоръчан отговор


perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
    LANGUAGE = (unset),
    LC_ALL = (unset),
    LANG = "en_US.utf8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
dpkg-query: package 'console-data' is not installed and no information is available
Use dpkg --info (= dpkg-deb --info) to examine archive files,
and dpkg --contents (= dpkg-deb --contents) to list their contents.
/usr/sbin/dpkg-reconfigure: console-data is not installed

Моля, какво правим, когато излезе този надпис в терминала, може ли някой да помогне с някоя и друга команда?

Линк към коментара
Сподели в други сайтове

Добавете следното във файла ~/.bashrc файла, който се намира във вашата домашна папка.

Забележка! Ако по някаква случайност този файл го няма - просто го създайте със редактора или от линията на команди.

export LANG="en_US.UTF-8"
export LC_ALL=$LANG
export LC_COLLATE=$LANG
export LC_CTYPE=$LANG
export LC_MESSAGES=$LANG
export LC_MONETARY=$LANG
export LC_NUMERIC=$LANG
export LC_TIME=$LANG
export LC_NAME=$LANG
export LC_TELEPHONE=$LANG
export LESSCHARSET="UTF-8"

след като, добавите посоченото по горе, излезте от системата и пак влезнете, или просто рестартирайте вашият терминал и пробвайте на ново командите които ви даваха грешки.

Линк към коментара
Сподели в други сайтове

Изпълних указанията на  bvbfan и мисля, че смена прав път, защото се получи следното:

 The keymap records the layout of symbols on the keyboard.                │  
  │                                                                          │  
  │  - 'Select keymap from arch list': select one of the predefined keymaps  │  
  │    specific for your architecture (recommended for non-USB keyboards);   │  
  │  - 'Don't touch keymap': don't overwrite the keymap in /etc/console,     │  
  │    which is maintained manually with install-keymap(8);                  │  
  │  - 'Keep kernel keymap': prevent any keymap from being loaded next time  │  
  │    the system boots;                                                     │  
  │  - 'Select keymap from full list': list all the predefined keymaps.      │  
  │    Recommended when using cross-architecture (often USB) keyboards.

Само да помогнете да попълня графите.


Добавете следното във файла ~/.bashrc файла, който се намира във вашата домашна папка.

Забележка! Ако по някаква случайност този файл го няма - просто го създайте със редактора или от линията на команди.

export LANG="en_US.UTF-8"
export LC_ALL=$LANG
export LC_COLLATE=$LANG
export LC_CTYPE=$LANG
export LC_MESSAGES=$LANG
export LC_MONETARY=$LANG
export LC_NUMERIC=$LANG
export LC_TIME=$LANG
export LC_NAME=$LANG
export LC_TELEPHONE=$LANG
export LESSCHARSET="UTF-8"

след като, добавите посоченото по горе, излезте от системата и пак влезнете, или просто рестартирайте вашият терминал и пробвайте на ново командите които ви даваха грешки.

Тота колега е твърде сложно за мен, ако може указанията Ви да са стъпка по стъпка. Съжалявам за неудобството.

Линк към коментара
Сподели в други сайтове

Изпълних указанията на  bvbfan и мисля, че смена прав път, защото се получи следното:

 The keymap records the layout of symbols on the keyboard.                │  

  │                                                                          │  

  │  - 'Select keymap from arch list': select one of the predefined keymaps  │  

  │    specific for your architecture (recommended for non-USB keyboards);   │  

  │  - 'Don't touch keymap': don't overwrite the keymap in /etc/console,     │  

  │    which is maintained manually with install-keymap(8);                  │  

  │  - 'Keep kernel keymap': prevent any keymap from being loaded next time  │  

  │    the system boots;                                                     │  

  │  - 'Select keymap from full list': list all the predefined keymaps.      │  

  │    Recommended when using cross-architecture (often USB) keyboards.

Само да помогнете да попълня графите.

 

Проблема е със locale настройките ви, и вече ви казах как най бързо се решава това, но явно не четете.

 

perl: warning: Setting locale failed. perl: warning:

Please check that your locale settings:

    LANGUAGE = (unset),

    LC_ALL = (unset),

    LANG = "en_US.UTF-8"

are supported and installed on your system.

perl: warning: Falling back to the standard locale ("C").

 

edit: От терминала изпълнете.

gedit ~/.bashrc

и сложете най долу следното

export LANG="en_US.UTF-8"
export LC_ALL=$LANG
export LC_COLLATE=$LANG
export LC_CTYPE=$LANG
export LC_MESSAGES=$LANG
export LC_MONETARY=$LANG
export LC_NUMERIC=$LANG
export LC_TIME=$LANG
export LC_NAME=$LANG
export LC_TELEPHONE=$LANG
export LESSCHARSET="UTF-8"

запазете, излезте от сесия и пак влезте, пробвайте дали има ефект.

Това Е.


Линк към коментара
Сподели в други сайтове

Ето резултата:

[email protected]:~$ sudo gedit ~/.bashrc
[sudo] password for slavcho:
sudo: gedit: command not found
[email protected]:~$
 

Линк към коментара
Сподели в други сайтове

Ето резултата:

[email protected]:~$ sudo gedit ~/.bashrc

[sudo] password for slavcho:

sudo: gedit: command not found

[email protected]:~$

 

тогава заменете gedit  със името на вашият редактор, или просто отворете редактора от менюто и после потърсете файла и го отворете.

Линк към коментара
Сподели в други сайтове

Ето резултата:

[email protected]:~$ sudo gedit ~/.bashrc

[sudo] password for slavcho:

sudo: gedit: command not found

[email protected]:~$

 

 

тогава заменете gedit  със името на вашият редактор, или просто отворете редактора от менюто и после потърсете файла и го отворете.

[email protected]:~$ sudo dpkg-reconfigure lovales

perl: warning: Setting locale failed.

perl: warning: Please check that your locale settings:

    LANGUAGE = (unset),

    LC_ALL = (unset),

    LANG = "en_GB.utf8"

    are supported and installed on your system.

perl: warning: Falling back to the standard locale ("C").

locale: Cannot set LC_CTYPE to default locale: No such file or directory

locale: Cannot set LC_MESSAGES to default locale: No such file or directory

locale: Cannot set LC_ALL to default locale: No such file or directory

dpkg-query: package 'lovales' is not installed and no information is available

Use dpkg --info (= dpkg-deb --info) to examine archive files,

and dpkg --contents (= dpkg-deb --contents) to list their contents.

/usr/sbin/dpkg-reconfigure: lovales is not installed

[email protected]:~$

 

Линк към коментара
Сподели в други сайтове

[email protected]:~$ sudo dpkg-reconfigure lovales

 

 

Имате грешка при изписването на програмата, трябва да е locales.

edit: Не бързайте, четете и най важното мислете, това което ви връща терминала, като грешка го четете.

Линк към коментара
Сподели в други сайтове

Това „заменете gedit  със името на вашият редактор, или просто отворете редактора от менюто и после потърсете файла и го отворете.“ не съм в състояние да го изпълня. Ако бях толкова навътре в нещата, едва ли щях да търся помоща ви.

Ако ми напишете:

1.

2.

3.

може би ще мипомогнете. Съжалявам.

Линк към коментара
Сподели в други сайтове

Ок, пробвайте с една команда тогава.

sudo dpkg-reconfigure locales

ediT: Ако така не стане, пробвайте тази команда.

 

копирайте и изпълнете в терминала.

cat << 'EOF' >> ~/.bashrc
export LANG="en_US.UTF-8"
export LC_ALL=$LANG
export LC_COLLATE=$LANG
export LC_CTYPE=$LANG
export LC_MESSAGES=$LANG
export LC_MONETARY=$LANG
export LC_NUMERIC=$LANG
export LC_TIME=$LANG
export LC_NAME=$LANG
export LC_TELEPHONE=$LANG
export LESSCHARSET="UTF-8"
EOF
Линк към коментара
Сподели в други сайтове

Имате грешка при изписването на програмата, трябва да е locales.

edit: Не бързайте, четете и най важното мислете, това което ви връща терминала, като грешка го четете.

не съм ги объркал ето какво съм получил:

[email protected]:~$ sudo gedit ~/.bashrc

[sudo] password for slavcho:

sudo: gedit: command not found

[email protected]:~$ dpkg-reconfigure locales

bash: dpkg-reconfigure: command not found

[email protected]:~$ sudo dpkg-reconfigure lovales

perl: warning: Setting locale failed.

perl: warning: Please check that your locale settings:

    LANGUAGE = (unset),

    LC_ALL = (unset),

    LANG = "en_GB.utf8"

    are supported and installed on your system.

perl: warning: Falling back to the standard locale ("C").

locale: Cannot set LC_CTYPE to default locale: No such file or directory

locale: Cannot set LC_MESSAGES to default locale: No such file or directory

locale: Cannot set LC_ALL to default locale: No such file or directory

dpkg-query: package 'lovales' is not installed and no information is available

Use dpkg --info (= dpkg-deb --info) to examine archive files,

and dpkg --contents (= dpkg-deb --contents) to list their contents.

/usr/sbin/dpkg-reconfigure: lovales is not installed

[email protected]:~$

 

Линк към коментара
Сподели в други сайтове

Ok, явно нямате тази програма dpkg-reconfigure.

 

Пробвайте да я инсталирате, или изпълнете втората команда която ви дадох.

Линк към коментара
Сподели в други сайтове

Ok, явно нямате тази програма dpkg-reconfigure.

 

Пробвайте да я инсталирате, или изпълнете втората команда която ви дадох.

 

Има я но за пореден път е написал lovales

Линк към коментара
Сподели в други сайтове

Преинсталирай locales, изпълни

su

dpkg-reconfigure locales

и си направи конфигурацията. 

Операцията изисква рестарт. 

Линк към коментара
Сподели в други сайтове

Преинсталирай locales, изпълни

su

dpkg-reconfigure locales

и си направи конфигурацията. 

Операцията изисква рестарт. 

Много благодаря. Оправих локалите-получи се точно както ме посъвевахте, но липсва още нещо дявол да го вземе, защото:

1.Папките не се отварят и изглеждат така  ?????????????????????????????????????.odt doest not exist.

2.Всичко е на английски, а повечето неща бяха на български език, пр. командния ред на браузъра в случая Firefox.

3.Не мога да си пусна клип и радио, излиза надпис: Firefox has prevendet the outdated plugin „Adobe Flash “ from running on WWW.raditunes.com.

Моля, кажете какво да правя по-нататък, борбата трябва да продължи!

Много благодаря. Оправих локалите-получи се точно както ме посъвевахте, но липсва още нещо дявол да го вземе, защото:

1.Папките не се отварят и изглеждат така  ?????????????????????????????????????.odt doest not exist.

2.Всичко е на английски, а повечето неща бяха на български език, пр. командния ред на браузъра в случая Firefox.

3.Не мога да си пусна клип и радио, излиза надпис: Firefox has prevendet the outdated plugin „Adobe Flash “ from running on WWW.raditunes.com.

Моля, кажете какво да правя по-нататък, борбата трябва да продължи!

Поисках от терминала инфо за   modprobe. Той изписа много неща, повечето не ясни за мен, но след като натиснах q, пак изписа това, което се появяваше и по-рано:

[email protected]:~$ man modprobe

man: can't set the locale; make sure $LC_* and $LANG are correct

[email protected]:~$

Добавям го, надявайки се по-лесно да поставите диагнозата на моя болен лаптоп.

Много благодаря. Оправих локалите-получи се точно както ме посъвевахте, но липсва още нещо дявол да го вземе, защото:

1.Папките не се отварят и изглеждат така  ?????????????????????????????????????.odt doest not exist.

2.Всичко е на английски, а повечето неща бяха на български език, пр. командния ред на браузъра в случая Firefox.

3.Не мога да си пусна клип и радио, излиза надпис: Firefox has prevendet the outdated plugin „Adobe Flash “ from running on WWW.raditunes.com.

Моля, кажете какво да правя по-нататък, борбата трябва да продължи!

Поисках от терминала инфо за   modprobe. Той изписа много неща, повечето не ясни за мен, но след като натиснах q, пак изписа това, което се появяваше и по-рано:

[email protected]:~$ man modprobe

man: can't set the locale; make sure $LC_* and $LANG are correct

[email protected]:~$

Добавям го, надявайки се по-лесно да поставите диагнозата на моя болен лаптоп.

Още:

 man $LANG

man: can't set the locale; make sure $LC_* and $LANG are correct

No manual entry for en_GB.utf8

[email protected]:~$

Как да го въведа този en_GB?

Линк към коментара
Сподели в други сайтове

.odt e файл не директория. man връща проблем с locale т.е. не е оправен. В момента може да има борба, но с вятърни мелници. Някой колега, който се занимава с Дебиан, може да ви го оправи по ssh.

Линк към коментара
Сподели в други сайтове

Много благодаря. Оправих локалите-получи се точно както ме посъвевахте, но липсва още нещо дявол да го вземе, защото:

1.Папките не се отварят и изглеждат така  ?????????????????????????????????????.odt doest not exist.

2.Всичко е на английски, а повечето неща бяха на български език, пр. командния ред на браузъра в случая Firefox.

3.Не мога да си пусна клип и радио, излиза надпис: Firefox has prevendet the outdated plugin „Adobe Flash “ from running on WWW.raditunes.com.

Моля, кажете какво да правя по-нататък, борбата трябва да продължи!

Поисках от терминала инфо за   modprobe. Той изписа много неща, повечето не ясни за мен, но след като натиснах q, пак изписа това, което се появяваше и по-рано:

[email protected]:~$ man modprobe

man: can't set the locale; make sure $LC_* and $LANG are correct

[email protected]:~$

Добавям го, надявайки се по-лесно да поставите диагнозата на моя болен лаптоп.

Още:

 man $LANG

man: can't set the locale; make sure $LC_* and $LANG are correct

No manual entry for en_GB.utf8

[email protected]:~$

Как да го въведа този en_GB?

Имам инсталиран Adobe Flash plugin 11. Какво иска?

.odt e файл не директория. man връща проблем с locale т.е. не е оправен. В момента може да има борба, но с вятърни мелници. Някой колега, който се занимава с Дебиан, може да ви го оправи по ssh.

Благодаря колега! Желая много здраве и успех във всяко начинание!

Линк към коментара
Сподели в други сайтове

Днес изпълних sudo gedit ~/.bashrc и за разлика от вчера, сега терминала отвори gedit с много неща вътре, които не изглеждат като тези, по-долу, които ми препоръчвате да копирам:

cat
<< 'EOF' >> ~/.bashrc
export LANG="en_US.UTF-8"
export LC_ALL=$LANG
export LC_COLLATE=$LANG
export LC_CTYPE=$LANG
export LC_MESSAGES=$LANG
export LC_MONETARY=$LANG
export LC_NUMERIC=$LANG
export LC_TIME=$LANG
export LC_NAME=$LANG
export LC_TELEPHONE=$LANG
export LESSCHARSET="UTF-8"
EOF

 

Какво да правя?

Линк към коментара
Сподели в други сайтове

 

 

При update излиза:E: Some index files failed to download. They have been ignored, or old ones used instead.

 

Линк към коментара
Сподели в други сайтове

Днес изпълних sudo gedit ~/.bashrc и за разлика от вчера, сега терминала отвори gedit с много неща вътре, които не изглеждат като тези, по-долу, които ми препоръчвате да копирам:

 

 

Какво да правя?

На последните редове от файла (след всичко писано), копирайте само това

 

export LANG="en_US.UTF-8"

export LC_ALL=$LANG

export LC_COLLATE=$LANG

export LC_CTYPE=$LANG

export LC_MESSAGES=$LANG

export LC_MONETARY=$LANG

export LC_NUMERIC=$LANG

export LC_TIME=$LANG

export LC_NAME=$LANG

export LC_TELEPHONE=$LANG

export LESSCHARSET="UTF-8"

Линк към коментара
Сподели в други сайтове

На последните редове от файла (след всичко писано), копирайте само това

 

export LANG="en_US.UTF-8"

export LC_ALL=$LANG

export LC_COLLATE=$LANG

export LC_CTYPE=$LANG

export LC_MESSAGES=$LANG

export LC_MONETARY=$LANG

export LC_NUMERIC=$LANG

export LC_TIME=$LANG

export LC_NAME=$LANG

export LC_TELEPHONE=$LANG

export LESSCHARSET="UTF-8"

Получи се това:(process:6010): Gtk-WARNING **: Locale not supported by C library.

    Using the fallback 'C' locale.

 

Линк към коментара
Сподели в други сайтове

Архивирана тема

Темата е твърде стара и е архивирана. Не можете да добавяте нови отговори в нея, но винаги можете да публикувате нова тема, в която да продължи дискусията. Регистрирайте се или влезте във вашия профил за да публикувате нова тема.

×
×
  • Добави ново...

Информация

Поставихме бисквитки на устройството ви за най-добро потребителско изживяване. Можете да промените настройките си за бисквитки, или в противен случай приемаме, че сте съгласни с нашите Условия за ползване