Премини към съдържанието
Пуканчо0

FlashPlayer в АrchLinux крашва постоянно

Препоръчан отговор


Здравейте колеги, 

 

Имам проблем с flashplayer-a и Лисицата в ArchLinux. Получава се едно постоянно крашване при опит за гледане на клипчета, дори и като отворя няколко таба със сайтове който изискват flash пак крашва. 

 

Не ме устройва да ползвам хрома, защото работя с web базирана програма и бързите клавиши за тази програма работят само с лисицата.

 

С GeForce GT 620 видео съм, инсталирал съм драйвъра от официалните хранилища. Ядрото в момента е 3.17.6-1. Графичната среда в момента която ползвам е MATE  1.8.1

Редактирано от Пуканчо0 (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

А кой флаш ползвате?

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

А кой флаш ползвате?

 

 

адобския. Забравих да спомена че Арча е с 64 битова архитектура.

Редактирано от Пуканчо0 (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

ДОбре де, то ясно, но дайте версия на флаша, също версия на лисицата, иначе няма как да се помогне.

 

edit 2  Уверете се че имате последната версия на флаш, също пробвайте да го премахнете от лисицата, рестарт, после инсталирайте/преинсталирайте пак флаш.

Редактирано от ivoarch (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Нещо става доста зле работата с лисицата и този флаш 11 .В много сайтове не мога да гледам стриймовете, защото иска последна версия. И аз се бях привързал към този браузър, но съветвам Пуканчо да мине на Chromium с pepperflash. Така поне си сигурен че си в час, защото последния флаш е 16, а лисицата цикли на 11.


Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Много пъти съм коментирал, че това е едно от най- слабите места на Mozilla. Отдавна трябваше да разработят собствен флаш плеър.

А, колегата може да инсталира Maxthon, където може да превключва между двата плеъра - adobe flash player и pepperflash.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Те от Мозила нещо друго кроят..

36 мисля че беше ще го правят на HTML5 и ще разкарат xulrunner.

И тогава вероятно ще е завършен и shumway (техния html5 флаш плейър)


Но по-добре да не ползвам флаш от колкото да ползвам Хром и неговите базирани (включително и Опера която я одрискаха като хром базирана)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
vainfo
исталирай, ако я няма и постави изхода да го видя. Редактирано от bvbfan (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Те от Мозила нещо друго кроят..

36 мисля че беше ще го правят на HTML5 и ще разкарат xulrunner.

И тогава вероятно ще е завършен и shumway (техния html5 флаш плейър)

Те и сега имат приемлива поддръжка на html5. Но, все още доста сайтове изискват flash player. Колкото до Shumway - не знам, доколко е техен този проект. Добавката се развива със скоростта на охльов, а Firefox вече поддържа html5 без да е необходима. Даже не забелязвам да я препоръчват.

Редактирано от cybercop (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Инак ето..

 

a423a0f20273a43fa1eaba3eb50ad3a0.png

0f8ca04c5e58011568aa1d16927d2c84.png


Но работи по-смотано от 11.2 под линукс тъй като няма грам хардуерно ускорение.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

https://github.com/sandikata/ROKO__/blob/master/www-plugins/freshplayerplugin/freshplayerplugin-9999.ebuild

 

Ето и от моя страна. Мисля че и в Арчлайното го има пакета.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
vainfo

исталирай, ако я няма и постави изхода да го видя.

 

libva info: VA-API version 0.36.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/dri/nvidia_drv_video.so
libva info: Found init function __vaDriverInit_0_35
libva info: va_openDriver() returns 0
vainfo: VA-API version: 0.36 (libva 1.4.1)
vainfo: Driver version: Splitted-Desktop Systems VDPAU backend for VA-API - 0.7.4
vainfo: Supported profile and entrypoints
      VAProfileMPEG2Simple            :	VAEntrypointVLD
      VAProfileMPEG2Main              :	VAEntrypointVLD
      VAProfileMPEG4Simple            :	VAEntrypointVLD
      VAProfileMPEG4AdvancedSimple    :	VAEntrypointVLD
      VAProfileH264Main               :	VAEntrypointVLD
      VAProfileH264High               :	VAEntrypointVLD
      VAProfileVC1Simple              :	VAEntrypointVLD
      VAProfileVC1Main                :	VAEntrypointVLD
      VAProfileVC1Advanced            :	VAEntrypointVLD

ДОбре де, то ясно, но дайте версия на флаша, също версия на лисицата, иначе няма как да се помогне.

 

edit 2  Уверете се че имате последната версия на флаш, също пробвайте да го премахнете от лисицата, рестарт, после инсталирайте/преинсталирайте пак флаш.

 

Версията на флаш е 11.2.202.425  а на браузъра 34.0.5

 

Доста теми поизчетох в официалния форум на арч но до момента не открих работещо решение. Само някъкви фиксове се подмятат от време на време, който при някои уж работят а при други не.

Нещо става доста зле работата с лисицата и този флаш 11 .В много сайтове не мога да гледам стриймовете, защото иска последна версия. И аз се бях привързал към този браузър, но съветвам Пуканчо да мине на Chromium с pepperflash. Така поне си сигурен че си в час, защото последния флаш е 16, а лисицата цикли на 11.

 

Не ме устройва да работя със Хрома, тъй както вече споменах програмата, с която ми е свързана работата е WEB базирана и имам доста бързи клавиши за улеснение, които не работят под други браузъри а само под лисицата.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Не ме устройва да работя със Хрома, тъй както вече споменах програмата, с която ми е свързана работата е WEB базирана и имам доста бързи клавиши за улеснение, които не работят под други браузъри а само под лисицата.

 

Ами, инсталирай и някаква Ubuntu базирана дистрибуция (Lubuntu, Xubuntu...) и ползвай Firefox върху нея. Пакета с плеъра се нарича flashplugin-installer. Въпреки, че не мога да понасям това недоразумение Adobe Flash Player, досега не съм забелязал някакви пречки да се работи с него.

Редактирано от cybercop (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Убунту не може да му помогне в случая.

sudo mkdir -p /etc/adobe
echo "EnableLinuxHWVideoDecode=1" | sudo tee /etc/adobe/mms.cfg
echo "OverrideGPUValidation=1" | sudo tee -a /etc/adobe/mms.cfg
Стартираш пак браузъра, флаша работи кошмарно на 64 битов Линукс.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Ами, инсталирай и някаква Ubuntu базирана дистрибуция (Lubuntu, Xubuntu...) и ползвай Firefox върху нея. Пакета с плеъра се нарича flashplugin-installer. Въпреки, че не мога да понасям това недоразумение Adobe Flash Player, досега не съм забелязал някакви пречки да се работи с него.

 

Да ти кажа чeсно не съм фен на *buntu и неговите базирани дистрота, пък с арча вече доста съм свикнал. По съм склонен да направя преинсталация и да инсталирам Арч с 32 битова архитектура.

Убунту не може да му помогне в случая.

sudo mkdir -p /etc/adobe
echo "EnableLinuxHWVideoDecode=1" | sudo tee /etc/adobe/mms.cfg
echo "OverrideGPUValidation=1" | sudo tee -a /etc/adobe/mms.cfg
Стартираш пак браузъра, флаша работи кошмарно на 64 битов Линукс.

 

След като добавих и OverrideGPUValidation за момента има някакъв ефект, но се получава един гаден лаг на моменти, който за момента не ме притеснява. През почивните дни ще инсталирам и един 32 битов арч на домашното PC и ще видя дали работи по-добре. Ако работи ще се преинсталира и в офиса компа.

Редактирано от Пуканчо0 (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Свали си и най-новата версия на флаша, от сайта, слагаш я в ~/.mozilla/plugins и пак пробвай, в последните няколко актуализации има сериозен bug-fix. Освен това, ако си ги имал въпросноте опции в /etc/adobe/mms.cfg и е крашвало много, по-добре ги махни и пробвай без тях.

Редактирано от bvbfan (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Флаша крашва яко с лайняните драйвери на Nvidia ако е добавен реда HWAccel в mms.cfg


yaourt -S freshplayerplugin-git

По този начин ще имаш флаш 16 на лисицата както съм показал и от моята снимка.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

То па тоя пиперен флаш е баси говното, той е по-зле и от старият.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

За флаша псувайте тия от Адобе  ,че  му спряха съпорта.Сега  ше се задоволите с  правени в голямото междучасие алфа проекти на  няколко групички ентусиасти. Ако не ви се експериментира си инсталирате Chrome  и карате с него колкото може и каквото може.

Редактирано от AlkatrazBG (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Мне, няма да плюя никой. http://pipelight.net/cms/install/installation-ubuntu.htmlможе да ползваш, който си искаш плъгин, аз не ги ща, като цяло и флаша пълен боклук на мен не ми трябва.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

То па тоя пиперен флаш е баси говното, той е по-зле и от старият.

 

Аз казах че е ла**ария. Няма грам хардуерно ускорение.

 

А това с pipelight е същата история както в BSD с nspluginwrapper да подкарваш линукс приставки.

Редактирано от Росен Р. Александров (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

За флаша псувайте тия от Адобе  ,че  му спряха съпорта.Сега  ше се задоволите с  правени в голямото междучасие алфа проекти на  няколко групички ентусиасти. Ако не ви се експериментира си инсталирате Chrome  и карате с него колкото може и каквото може.

Аз по скоро бих псувал тия от Mozilla, за това, че не видяха очеваден проблем и не разработиха собствен флаш плеър. Можеше, дори да го вградят по подразбиране в браузъра. Глупост е да изпадаш в зависимост от компания, която винаги може да ти извива ръцете. Издигаха призиви за свобода, докато се поставяха сами в зависимост от корпорациите.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Мне, няма да плюя никой. http://pipelight.net/cms/install/installation-ubuntu.htmlможе да ползваш, който си искаш плъгин, аз не ги ща, като цяло и флаша пълен боклук на мен не ми трябва.

 

 

За теб да, но решия моя с крашването и лага. Не бях чувал изобщо за pipelight

 

Благодаря на всички за помощта.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Регистрирайте се или влезете в профила си за да коментирате

Трябва да имате регистрация за да може да коментирате това

Регистрирайте се

Създайте нова регистрация в нашия форум. Лесно е!

Нова регистрация

Вход

Имате регистрация? Влезте от тук.

Вход

×

Информация

Поставихме бисквитки на устройството ви за най-добро потребителско изживяване. Можете да промените настройките си за бисквитки, или в противен случай приемаме, че сте съгласни с нашите условия за ползване.