Премини към съдържанието
iBonev

Ръчно изтриване на инсталиран мод за GTA IV вместо Uninstall

Препоръчан отговор


Здравейте!

 

Появи се следния проблем – имам инсталирана GTA 4 (закупена от Steam), като към нея съм добавил няколко коли от този сайт (http://www.gtaall.com/). Всеки мод е със собствен инсталатор (а от скоро има възможност и за "ръчно" инсталиране), но аз ползвах първия метод като посочих директорията на играта и съответната кола се инсталира, и появи в играта. Но с това, се появи и иконка за деинсталиране на същата, както в Контролен панел, така и в Всички програми (старт меню).

По стечение на обстоятелствата изтрих папката с играта, съответно заминаха и въпросните коли, които инсталирах по-рано. Сега върнах бекап на оригиналната игра без модификации и искам да добавя същите коли. Но инсталатора изписва, че те вече са инсталирани, и за да се сложат на ново, трябва първо да се премахнат с деинсталиране. Само, че както казах, те бяха премахнати ръчно и вече не фигурира иконка за деинсталиране. Предполагам, че някъде в регистъра или на друго място е останал запис, който "казва" на системата (Windows 7), че инсталацията я има. Само, че не знам какво и къде да търся. Между другото, пуснах CCleaner да почисти ненужни файлове, но резулат по проблема ми няма и за това се обръщам към вас за помощ.

 

Благодаря на всички отзовали се и Весели празници!

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Здравейте!

 

Появи се следния проблем – имам инсталирана GTA 4 (закупена от Steam), като към нея съм добавил няколко коли от този сайт (http://www.gtaall.com/). Всеки мод е със собствен инсталатор (а от скоро има възможност и за "ръчно" инсталиране), но аз ползвах първия метод като посочих директорията на играта и съответната кола се инсталира, и появи в играта. Но с това, се появи и иконка за деинсталиране на същата, както в Контролен панел, така и в Всички програми (старт меню).

По стечение на обстоятелствата изтрих папката с играта, съответно заминаха и въпросните коли, които инсталирах по-рано. Сега върнах бекап на оригиналната игра без модификации и искам да добавя същите коли. Но инсталатора изписва, че те вече са инсталирани, и за да се сложат на ново, трябва първо да се премахнат с деинсталиране. Само, че както казах, те бяха премахнати ръчно и вече не фигурира иконка за деинсталиране. Предполагам, че някъде в регистъра или на друго място е останал запис, който "казва" на системата (Windows 7), че инсталацията я има. Само, че не знам какво и къде да търся. Между другото, пуснах CCleaner да почисти ненужни файлове, но резулат по проблема ми няма и за това се обръщам към вас за помощ.

 

Благодаря на всички отзовали се и Весели празници!

А на CCleaner посочи ли да почисти и регистрите ?

Съответно влез в регистрите и търси папка с името на модовете.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

А на CCleaner посочи ли да почисти и регистрите ?

Съответно влез в регистрите и търси папка с името на модовете.

Здравейте и Честита Коледа!

 

Снощи, както казах използвах CCleaner, втората опция в ляво Registry -> Scan for Issues и на показалите се резултати - поправи, но резултат нямаше. Стартирах regedit, в HKEY_CURRENT_USER намерих въпросната папка на инсталаторите и я изтрих, рестартирах и пробвах отново да инсталирам същите модове, но резултат няма. Отново изписва, че съществуват - http://prikachi.com/images/206/7804206D.png. :shock11:

 

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Здравейте и Честита Коледа!

 

Снощи, както казах използвах CCleaner, втората опция в ляво Registry -> Scan for Issues и на показалите се резултати - поправи, но резултат нямаше. Стартирах regedit, в HKEY_CURRENT_USER намерих въпросната папка на инсталаторите и я изтрих, рестартирах и пробвах отново да инсталирам същите модове, но резултат няма. Отново изписва, че съществуват - http://prikachi.com/images/206/7804206D.png. :shock11:

 

Честита Коледа!

Значи вие затрихте папката или изтрихте локалните файлове през steam ?

Също GTAIV трябва да има една папка в Documents, изтрийте и нея.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Честита Коледа!

Значи вие затрихте папката или изтрихте локалните файлове през steam ?

Също GTAIV трябва да има една папка в Documents, изтрийте и нея.

GTA IV ми е инсталирана в следната директория през Steam, D:\Games\SteamLibrary\steamapps\common\Grand Theft Auto IV. В същата тази директория инсталирах няколко мода с инсталатор, като за съответните инсталации на модовете се появиха и иконки за деинсталиране в Контролен панел и старт меню -> всички програми. Изтрих ръчно цялата папка с GTA 4 от горепосочената директория, като се изтриха и пътицата на деинсталация на модовете. След това върнах бекап на оригиналната GTA IV, който си направих по рано и играта работи, но модовете не мога отново да ги инсталирам, защото изписва, че вече са били инсталирани. Явно някъде в системата са останали записи с пътищата, които показват, че в горепосочената директория има техни инсталации и аз съм ги прекъснал някъде изтривайки всичко ръчно, а не от Контролен панел. Сега търся начин да затрия тотално тези пътица на минали инсталации, Надявам се, че съм обяснил ситуацията ясно. Ако имате нужда от друга информация, моля кажете, за да я напиша.


Сподели този отговор


Линк към този отговор
Сподели в други сайтове

GTA IV ми е инсталирана в следната директория през Steam, D:\Games\SteamLibrary\steamapps\common\Grand Theft Auto IV. В същата тази директория инсталирах няколко мода с инсталатор, като за съответните инсталации на модовете се появиха и иконки за деинсталиране в Контролен панел и старт меню -> всички програми. Изтрих ръчно цялата папка с GTA 4 от горепосочената директория, като се изтриха и пътицата на деинсталация на модовете. След това върнах бекап на оригиналната GTA IV, който си направих по рано и играта работи, но модовете не мога отново да ги инсталирам, защото изписва, че вече са били инсталирани. Явно някъде в системата са останали записи с пътищата, които показват, че в горепосочената директория има техни инсталации и аз съм ги прекъснал някъде изтривайки всичко ръчно, а не от Контролен панел. Сега търся начин да затрия тотално тези пътица на минали инсталации, Надявам се, че съм обяснил ситуацията ясно. Ако имате нужда от друга информация, моля кажете, за да я напиша.

Ако имате System Restore, го използвайте.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Ако имате System Restore, го използвайте.

Май натам вървят нещата.... Благодаря, че се отзовахте и весели празници! :)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Регистрирайте се или влезете в профила си за да коментирате

Трябва да имате регистрация за да може да коментирате това

Регистрирайте се

Създайте нова регистрация в нашия форум. Лесно е!

Нова регистрация

Вход

Имате регистрация? Влезте от тук.

Вход

×

Информация

Поставихме бисквитки на устройството ви за най-добро потребителско изживяване. Можете да промените настройките си за бисквитки, или в противен случай приемаме, че сте съгласни с нашите условия за ползване.