Премини към съдържанието
Vask0

Server error update apache ,php7, phpmyadmin. MySQL

Препоръчан отговор


Здравейте  имам нужда  от  помощж  за  Ubuntu server.

Проблема е следният,  имах   малко   грешки по конфигурационният файл  на in.php  и можеби  апачито.   когато  упдейтнах на  php7  всичко  умря,  сега на phpmyadmin  ми  излиза

Not Found

The requested URL /phpmyadmin/ was not found on this server.
(Въвел съм си ip адреса във /phpmyadmin/.htaccess , на usr/share/phpmyadmin/.htaccess  като го отворя  нямам нищо  )

Също когато се опитам да заредя сайта в определена папка ми изписва:  Server error 500

На трета  бяла страница!!!!

Някои биха  казали  на ново да се инсталира  целият сървър, но искам да видя  дали това може да се оправи  и дали има някакъв шанс.. (инсталацията е  лесна )

Въпроса е дали  ще може  да се оправят тези неща

(Дори бих дал shh достъп някой който е по запознат да види дали  ще може да се оправи проблема)

Благодаря предварително

  • Харесва ми 1

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Опитайте с това:

Добавете в края на файл:
/etc/apache2/apache2.conf

следния запис
Include /etc/phpmyadmin/apache.conf

рестарт на Apache 2.4:
sudo /etc/init.d/apache2 restart

Източник: http://profruit.blogspot.bg/2013/10/php-55-apache-24-ubuntu.html

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

 тоест  като отворя apache2.conf    и накрая  на файла да  запиша  Include /etc/phpmyadmin/apache.conf

 

тоест да  изглежда  по следния начин


# Include the virtual host configurations:
IncludeOptional sites-enabled/*.conf

# vim: syntax=apache ts=4 sw=4 sts=4 sr noet

Include /etc/phpmyadmin/apache.conf
 

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Да,

отваряте файла apache2.conf с текстов редактор

в края на файла добавяте реда

Include /etc/phpmyadmin/apache.conf

съхранявате файла

рестартирате сървъра, като за целта в командния ред въвеждате

sudo /etc/init.d/apache2 restart

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

[....] Restarting apache2 (via systemctl): apache2.serviceJob for apache2.service failed because the control process exited with error code. See "systemctl status apache2.service" and "journalctl -xe" for details.
 failed!

това  върна при

sudo /etc/init.d/apache2 restart


Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Сървъра не може да рестартира.

Не зная дали е най-правилния начин, но аз бих постъпил/а така:

Отварям отново файл

/etc/apache2/apache2.conf

Премахам последния ред

Include /etc/phpmyadmin/apache.conf

Съхранявам файла. Рестартирам сървъра

sudo /etc/init.d/apache2 restart

Ако отново не иска да рестартира, преинсталирам.

Ако ли пък рестартира нормално, търся друго решение.

Лека вечер.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Като  го премахнах

root@Flubber:~# nano /etc/apache2/apache2.conf
root@Flubber:~# sudo /etc/init.d/apache2 restart
[ ok ] Restarting apache2 (via systemctl): apache2.service.

 

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

тоест да инсталирвам  на ново

 със

sudo apt-get install apache2 ?

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Регистрирайте се или влезете в профила си за да коментирате

Трябва да имате регистрация за да може да коментирате това

Регистрирайте се

Създайте нова регистрация в нашия форум. Лесно е!

Нова регистрация

Вход

Имате регистрация? Влезте от тук.

Вход


×

Информация

Този сайт използва бисквитки (cookies), за най-доброто потребителско изживяване. С използването му, вие приемате нашите Условия за ползване.