Премини към съдържанието
Bel1al

Постоянно ми се разместват иконите на десктопа.

Препоръчан отговор


 Извинявам се ако не съм уцелил правилния раздел. Та преди някой друг ден смених стария монитор с MG279Q, и още след първото "заспиване" иконите от лявата страна се разместиха, в смисъл отиват на долу не знам как да го обясня по-точно. Освен това разни др. програми като Skype, uTorrent и Foobar са как да кажа все едно съм ги "свил" не се сещам точната дума. Естествено Auto arrange icons е с махната отметка, другото  което пробвах е на по-рано споменатите програми в Properties--Compatibility сложих отметката на Disable display scaling on high DPI settings, обаче не помогна пак там (Compatibility) зададох run a program in compatibility mode in Windows 7 и пак нищо. Четох тук в форума за някаква програма ERUNT обаче не схванах връзката с разместването на иконите? Другото решение което намерих в този сайт не съм сигурен дали се отнася за моя проблем. Та понеже нямам идея какво да правя, ще бъда благодарен ако помогнете :)

Забравих да напиша ОС e Windows 7 Home Edition. Ъпдейтнал съм драйверите на видеото с последните налични щото някъде пишеше, че може  би проблема е в тях.

Добавка:

GTX970 Gigabyte G1, драйвера е от сайта на Techpowerup от немския server версия 368,81.

 p.s. А има ли значение, че монитора е вързан за видеото с miniDisplayPort кабела ?

Ще бъда благодарен ако някой помогне :)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

http://www.softwareok.com/?seite=Freeware/DesktopOK пробвай този инструмент. Нагласи си позиционирането на всяка икона, стартирай DesktopOK  и запиши. Кликни на Exit и Всичко трябва да е ок. Ако след рестарт са разместени стартирай DesktopOK, кликни на реда със записаната позиция и кликни на Restore. И кликни Exit.

  • Харесва ми 4

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Може да е от много неща:

1. Омазани настройки и повредени регистри

HKEY_CURRENT_USER\Control Panel\Desktop
HKEY_CURRENT_USER\Control Panel\Desktop\WindowMetrics
HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell
HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell\BagMRU
HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell\Bags
HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell\Bags\1
HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell\Bags\1\Desktop

+ грешни настройки на ключа NoSaveSrttings. Може да се опита този FIXIT:

https://support.microsoft.com/en-us/kb/813711

2. Премахване на Auto-Arrange отметката:

iUtMz.png

3. Зараза с рууткит ZeroAccess, който променя настройките на ключа => HKEY_CURRENT_USER\Software\Classes\clsid\{42aedc87-2188-41fd-b9a3-0c966feabec1}

Добре е да се направи една проверка с Malwarebytes Anti-Rootkit

  • Харесва ми 4

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

 @ExaFlopМного ти благодаря :) Ама ми се иска да намеря решение на проблема, обаче ако няма такова ще пробвам програмата.

@B-boy/StyLe/ ще прочета за fix-a, и сканирам с програмата, благодаря за помощта.

Редактирано от Bel1al (преглед на промените)
  • Харесва ми 1

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Можете да погледнете и тази тема:

Поздрави и успех! :)


  • Харесва ми 2

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
преди 5 минути, ExaFlop написа:

Това е точно за ZeroAccess, за проблема с CLSID {42aedc87-2188-41fd-b9a3-0c966feabec1} . ;)

Но като  ти видях линковете, се сетих, че и NOD32 е причината за проблема, защото човърка същия CLSID...Имаше бум навремето по този въпрос при излизането на Windows 10, но би трябвало в новите версии на NOD32, отдавна да е отстранен. Все пак не пречи да се премахне временно NOD32, ако е инсталирана на системата и да се провери после как е положението.

  • Харесва ми 3

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
Цитат

taskkill /f /im explorer.exe
reg delete "HKCU\SOFTWARE\Microsoft\Windows\Shell\Bags\1\Desktop" /f
explorer

Стартирай cmd като админ, копирай и постави горното и натисни Enter.

Рестартирай (или се отпиши) да видиш има ли ефект.

  • Харесва ми 1

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

 Значи след като натиснах enter, всички икони отидоха на лявата страна на десктопа. След като рестартирах, нямаше размествания, ама ще изчакам да "заспи" и тогава ще си проличи :)

@ExaFlopне стана пак се разместиха иконите, пробвах и fix-а на @B-boy/StyLe/ обаче и там нямах успех. Ще чета за решение от другите линкове :)

Забравих да спомена, че сканирах с Malwarebytes Anti-Rootkit, намери един вредител, ама явно не беше свързан с проблема. М/у другото нямам NOD32.

Редактирано от Bel1al (преглед на промените)
  • Харесва ми 1

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Въпроса ми е с една видеокарта ли си или две при мен са две AMD и INTEL. Изтегли си тази програма Sweeper Driver тя изчиства остатъците от драивъра  Пробвай да деинсталираш драивера   в диспечер на устроиствата след  това рестартираш и влизаш под SAFE MODE и  чистиш с програмата рестартираш и инсталираш  драивера пробваи с по стара версия на драивъра 

Редактирано от bobi iordanov (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Картата е една (GTX970 G1) аз по-принцип ползвам DDU има ли значение с каква програма почиствам драйверите ? Въпреки, че съм с последния драйвер ей сега ще пробвам с друг по-стар.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Това 

преди 24 минути, Bel1al написа:

(GTX970 G1

.Да има по добри програми.Инсталирането на драивера в нормален режим.Изтегли си драивера от официалния саит

Редактирано от bobi iordanov (преглед на промените)
  • Харесва ми 1

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Да GTX970 е NVIDIA. Така изтрих драйверите с DDU (Safe Mode) и сложих по-стара версия - 368,22, но проблема си остана.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Според мен след всичко това визирам и горните постове и няма резултат е добре да си направиш преинсталация явно се е омазала ос ти си решаваш.      Успех:)  Преди около 2 месеца имах проблем с safe mode Windows 10 тук в форума пробвахме какво ли не нестава и нестава накрая нулирах и всичко се оправи. Та понякога това е единствения вариант

Редактирано от bobi iordanov (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

А коя беше намерената гадина от MBAR? Може ли да видя лог файловете от папката на програмата? В папката Plugins има модул - fixdamage.exe. Ако е намерен ZeroAccess или друг опасен троянец е добре да стартирате и него за да възстанови засегнатите настройки.

Пробвайте и да създадете нов тестови акаунт и вижте дали проблема се появява в него.

Стартирайте и команда sfc /scannow от CMD.exe (Command Prompt) стартиран като администратор.

  • Харесва ми 3

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Първо пробвах този fix и нещо не ми се получи :) Малко ми е неясна материята...уж бях направил бекъп на регистрите обаче ми даде грешка, че не можело да да възстанови всички файлове и в крайна сметка ми отказаха задните USB-та. Добре, че преди бях имал такъв проблем (Code10), та пак след лека намеса в регистрите всичко се оправи :) Пробвах единия fix  предложен от @ExaFlop там уж се справих по-добре но не помогна. Та сега ще разгледам другите решения и ще пробвам :)

@B-boy/StyLe/ мисля, че гадината която намерих беше нещо свързано с RemoveWAT, прикачам и log-а от програмата.

Пробвах с командата sfc /scannow и ето резултата:

844807.png

Ще пробвам с нов тестови акаунт по-късно.

 

 

 

 

system-log.txt

Редактирано от Bel1al (преглед на промените)
  • Харесва ми 1

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Не би трябвало след fix-a на Microsoft да спрат да работят USB-тата. Но така или иначе можете да ги деинсталирате през Device Manager-a и да оставите Windows да ги инсталира наново с бутона Scan for hardware changes или с изтриването на UpperFilters и LowerFilters и MountPoints2 ключовете в регистрите.

Как направихте бекъпа на регистрите? Надявам се не с export на регистрите през Registry Editor-a? Нормално е после да не можете да merge-нете файла, заради липса на права. Бекъп се прави със специализирана програма като ERUNT, която макар вече да не се поддържа си работи ли с новата Tweaking Registry Backup, която работи на същия принцип, но е по-съвременна (нещо като ERUNT на стероиди). Дори един System Restore върши работа, защото и той прави бекъп на регистри гнездата. Дори мисля, че MSFIXIT създава точка на възстановяване при стартирането си автоматично.

Иначе изглежда командата е поправила някакви системни файлове.За да видим кои са те изпълнете следната команда като администратор в CMD.exe:

findstr /c:"[SR]" %windir%\Logs\CBS\CBS.log >"%userprofile%\Desktop\sfcdetails.txt"

и прикачете лог файла sfcdetails.txt, който ще се създаде на десктопа.

Рестартирайте системата за да влезнат промените в сила.

Поздрави!

  • Харесва ми 2

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

 Не е от fix-а проблем, а от мен дето барниках без много ясна представа какво точно правя :) Иначе точно изтриването на UpperFilters и LowerFilters помогна, беше ми се случвало и преди. Бекъп-а на регистрите го направих както си предположил " export на регистрите през Registry Editor-a? ", друг път ще ползвам ERUNT или Tweaking Registry Backup :)

Качвам и log файла.

 

sfcdetails.txt

  • Харесва ми 1

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Използвали сте кофти активатор, който пачва системни файлове и сега командата е възстановила оригиналните копия на файловете от WinSxS папката и предполагам активацията на Windows-a вече няма да ви работи...Във форума не могат да се обсъждат подобни деликатни въпроси, но просто казвам да се погрижите за въпроса. ;)

Друго за съжаление, което да е свързано с проблема не е поправено...И затова ако и новия акаунт не помогне може да се наложи поправителна преинсталация или направо преинсталация на чисто.

Поздрави!

  • Харесва ми 3

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

 Мда, за съжаление си абсолютно прав :) Ще пробвам с новия акаунт и ако не става...хич не ми се преинсталира ама като няма др. начин :)

Само едно се чудя, значи със стария монитор HP LP2275W 1680x1050, не съм имал такива проблеми. В момента в който "връзвам" новия ASUS MG279Q 2560x1440 и при първото заспиване иконите се разместиха ?

p.s. Така пробвах и с нов акаунт, същата работа от ляво иконите се разместика :)

Редактирано от Bel1al (преглед на промените)
  • Харесва ми 2

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Честно казано не знам. Може да е нещо от резолюцията или друго. Пробвайте с жив диск с Windows или Linux дали там проблема остава поне да сте сигурни, че проблема е от Windows. Ако проблема го има и там, то тогава преинсталацията ще е излишна и проблема ще трябва да се търси в хардуера - видеокарта, монитор, кабелите, използваните портове и други настройки.

  • Харесва ми 2

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

След преинсталацията ако всичко е наред не го оставяй в режим заспиване а си го изключвай мое мнение

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Пробвах с LiveCD - StotinkataOS, само дето тя имаше 5 икони на кръст :) След заспиване нищо не се размести, ама доколко това доказва нещо не съм сигурен :huh:

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Няма значение колко икони са щом не се разместват преинсталирай 

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

 Малко up на темата, та пробвайки какво ли не, включително да си скапя регистрите окончателно :) Реших, че понеже може да е от резолюцията и пробвах на 1920x1080 освен че всичко беше леко размазано и голямо проблема си остана :) Та си рекох така и така си прецаках всичко и пробвах там където се настройва резолюцията - Make text and other items larger or smaller после избрах Medium 125% и поне за сега натискайки F5 иконите си стоят на местата ще видим след рестарт какво ще стане :)

Греда, след рестарта пак същата история. Макар, че сега не се местят само иконите от лявата страна ами всички отиват на ляво :) Дето се вика имам напредък..

Редактирано от Bel1al (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Регистрирайте се или влезете в профила си за да коментирате

Трябва да имате регистрация за да може да коментирате това

Регистрирайте се

Създайте нова регистрация в нашия форум. Лесно е!

Нова регистрация

Вход

Имате регистрация? Влезте от тук.

Вход

×

Информация

Поставихме бисквитки на устройството ви за най-добро потребителско изживяване. Можете да промените настройките си за бисквитки, или в противен случай приемаме, че сте съгласни с нашите условия за ползване.