Премини към съдържанието
iBonev

Проблем или фалшива тревога (Error 1603) с драйвър за RX 480

Препоръчан отговор


Здравейте,

Вчера преинсталирах конфигурацията от подписа с Windows 10 Pro x64. Инсталирах всички драйвъри от диска на дъното, пуснах актуализациите на системата и т.н.. Дойде момента за инсталиране на драйвъра на картата. Изтеглих от от официалната страница от тук и започнах с инсталацията му. В края на инсталацията се показа съобщението по-долу. Отворих доклада за инсталацията, който също съм прикачил, но не виждам грешка. Четох по-подробно за самата грешка тук и оставам с впечатлението, че грешката е фалшива, защото след като рестартирах драйвъра е инсталиран и работи нормално. Питането ми е, тези от вас които ползват карти на AMD имали ли са този проблем?

Към момента на грешката не е имало инсталиран антивирусен продукт, а Windows Defender е изключен непосредствено след инсталацията на ОС.

 

amd driver error.png

Installation Report.mht

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Стартира ли инсталатора с администраторски права? 
Зададени ли са пълни права на SYSTEM 

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Според мен е фалшива тревога. 

Вчера и на мен ми даде същата грешка и при рестарта няма проблеми.

 

ПП: Аз съм с Amd Radeon Power Color R7 370, с AMD Catalyst-a нямах този надпис.

ПП2: Пробвай под SafeMode дали ще даде грешка.

Редактирано от androns (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Връщането на тази грешка, поради липса на достатъчно права, може да е сигнал за неправилна обработка на записите в регистратурата и липса на някои от тях. Привидно може да работи, но в дадени ситуации, когато не намери нужния запис в регистратурата драйвърът (т.е. системата) да се срива или да зависва.

Редактирано от ExaFlop (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
преди 8 минути, ExaFlop написа:

Стартира ли инсталатора с администраторски права? 
Зададени ли са пълни права на SYSTEM 

Инсталатора не е стартиран с администраторски права, а правата на SYSTEM са по-подразбиране. Ще пробвам отново довечера.

 

преди 9 минути, androns написа:

ПП2: Пробвай под SafeMode дали ще даде грешка.

Ще пробвам един по един двата метода и ще пиша за резултата по-късно.


Сподели този отговор


Линк към този отговор
Сподели в други сайтове
преди 7 минути, iBonev написа:

Ще пробвам отново довечера.

Преди това деинсталирай с Display Driver Uninstaller

преди 9 минути, iBonev написа:

правата на SYSTEM са по-подразбиране

Провери ли ги? По описания в статията начин.

  • Харесва ми 1

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
преди 5 минути, ExaFlop написа:

Преди това деинсталирай с Display Driver Uninstaller

Провери ли ги? По описания в статията начин.

Имали значение дали ще деинсталирам под Windows или Safe mode?

Под "по подразбиране" имах предвид, както си е конфигурирана системата след инсталация. Аз нищо не съм променял в последствие. В момента съм на работа, но довечера ще проверя с точност, както е описано в линка.

Друго се сетих, твоето предложение за инсталиране с администраторски права, върви ли в комбинация с правата в SYSTEM или са два отделни метода?

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Има разлика - задаването на права за SYSTEM си е за този акаунт, а стартирането на инсталатоора с администраторски права го прави като да си логнат в Administrator акаунта и от там да стартираш инсталатора. 
Добре е да стартираш DDU в safe mode среда.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Преди няколко дена и аз правих преинсталация.

И аз съм с RX 480, но тази грешка не ми излезе. Бях стартирал инсталатора с администраторски права.

 

П.П. Инсталатора не ти инсталира последната версия на драйверите. После ръчно влез в контрол панела на AMD и ги обнови, понеже аз на 16.11.5 версията имах проблеми с вентилаторите на видеокартата. (като спрат да въртят изобщо не се включваха отново, или пък завъртаха на максимални обороти и пак до рестарт на системата не спираха)

  • Харесва ми 1

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

 ако ме беше слушал немаше да стане така сега си сърбай попарата .

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Добър вечер,

„Проблема“ при мен е решен! Сметнах за добре да опиша стъпките, за да бъде полезна темата на тези, които тепърва ще се сблъскат с проблема...

Значи:

1. Теглите DDU, към който @ExaFlop е предоставил линк. Файла е саморазархивиращ се и след като го стартирате единствено трябва да посочите директорията и име на папката, в която да се разархивира. Няма нужда от инсталация!

2. Влизате в Safe mod. Аз лично ползвах командата „msconfig“, която се въвежда в появилото се прозорче - The “Run” dialog box или Изпълнение, с клавишната комбинация WIN KEY + R. Появява се ново прозорче на което пише Windows Configuration. Избирате втория таб - Boot и най-долу на Boot options поставяте тикче пред Safe boot. Приложи/Apply и ОК. Рестартира се системата и чакате да ви вкара под Safe mode.

3. Когато сте под Safe mode, стартирате exe-то от папката на DDU и избирате първата или последната опция. Те са три всъщност. Аз ползвах първата. След като програмата си свърши работата, системата автоматично ще се рестартира и ще ви зареди нормално ОС.

4. Сваляте драйвър от официалната страница - линк в първия пост. В случая, аз свалих Non-WHQL-Win10-64Bit-Radeon-Software-Crimson-ReLive-17.3.2-Mar15. Сам по себе си този файл представлява нещо като архив и когато го стартирате ще ви пита къде да се екстрактне. По подразбира това е директорията - C:\AMD\Non-WHQL-Win10-64Bit-Radeon-Software-Crimson-ReLive-17.3.2-Mar15. Тук е момента да вмъкна, че непосредствено след като се разопакова, инсталатора на драйвъра ще тръгне. Тук е ключовия момента да го затворите. Обяснявам защо, дори първоначално да се стартирали файла с админисртаторски права, самият инсталатор накрая ще тръгне без такива и в края на инсталацията ще получите същата грешка. За това, след като затворите инсталатора, намерете го от пътя по-горе и го стартирайте като администратор и проблем няма да имате при финализирането.

 

Благодаря на @ExaFlop, @androns и @niki292002 за съветите и помощта! Бъдете здрави и знайте, че има хора (като мен), които ви оценяват страшно много!

 

В допълнение:

Пропуснах снощи да напиша, че през Safe mode не ми дава да инсталирам драйвъра. Появява се съобщение от сорта, че хардуера/картата не може да бъде открита.

Редактирано от iBonev (преглед на промените)
  • Харесва ми 3

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Повдигам отново темата, защото има развитие в следствие на тестове, които направих във времето и мога да заключа, че при инсталиране/актуализиране на драйвъра при DVI връзка, а не HDMI , грешка в края на инсталацията няма. След това рестартирам компютъра и сменям от DVI на HDMI сигнала.

Ще помоля занапред, когато ви се наложи да инсталирате/актуализирате драйвър, да пробвате по този начин и споделите резултата.

Редактирано от iBonev (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Регистрирайте се или влезете в профила си за да коментирате

Трябва да имате регистрация за да може да коментирате това

Регистрирайте се

Създайте нова регистрация в нашия форум. Лесно е!

Нова регистрация

Вход

Имате регистрация? Влезте от тук.

Вход

×

Информация

Поставихме бисквитки на устройството ви за най-добро потребителско изживяване. Можете да промените настройките си за бисквитки, или в противен случай приемаме, че сте съгласни с нашите условия за ползване.