Премини към съдържанието

Препоръчан отговор


Здравейте .
Искам да започна с това, че съм но в Linux.

Имам инсталиран ubuntu server 16.04 LTS със lamp,samba,Openssh,dns,apache2,Webmin

Успях да го подкарам в домашната мрежа, за да си шервам файлове от един компютър на друг, както и да хостна web страница на локално IP, която се намира в var/www/html/ папката .

Искам да достъпвам сървъра дистанционно, да имам достъм до архив от файлове чрез интернет и да хостна web страницата .
IP-то ми е динамично, опитах с noip.com да регистрирам domain name и не можах да го подкарам, като напиша външното ми IP в браузъра не зарежда страницата.
Направих опити за forwarding port на моя рутер TP-Link  Model:TL-WR740N, но се оказа че не мога да отворя нито един от портовете 80,8080,443,20,21. Може би доставчика ми е ограничил тази функция(Доставчика ми е TV/NET).
Успях да отворя портове 53 и 22.

И знам, че хостинг от домашен компютър не е добра идея от гледна точка на сигурност, няма да правя нищо мащабно а и след като го подкарам ще обърна внимание и на това.

Опрях на камък..... моля за помощ и Наздраве !

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Пробвах да сваля стените и на рутера и на сървъра и пак същото.

И да порт 22 след forward от менюто на рутера, в сайт като този "http://www.yougetsignal.com/tools/open-ports/" ми го дава отворен.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Промених порта за http на 82 и сега въвеждам domainname.com:82, а има ли начин да се настрои и да въвеждам само domainname.com ?

Инсталирах PuTTY много добра програмка .

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Няма как да накараш браузърът по подразбиране да отваря порт 82 ( трябва да се бръкне в registry Windows или в настройките дълбоко ). Тогава за всички други страници ( google.com, yahoo.com например ) ще трябва накрая да пишеш :80. Обади се на доставчика, може пък да излезе разбран :) 

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
на 27.05.2017 г. в 22:28, chris# написа:

Промених порта за http на 82 и сега въвеждам domainname.com:82, а има ли начин да се настрои и да въвеждам само domainname.com ?

Инсталирах PuTTY много добра програмка .

Този порт 82 си го пренасочил в рутерът, предполагам? Просто промени правилото всичко входящо на порт 80, да ходи към 82, на вътрешният адрес на сървъра ти. Това може да докара и някоя каша, разбира се :), просто идея. Друга идея - може да си поиграеш с noip.com и да регистрираш втори hostname, който да сочи съм адресът на рутера на порт 82.

Редактирано от RagnerBG (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Регистрирайте се или влезете в профила си за да коментирате

Трябва да имате регистрация за да може да коментирате това

Регистрирайте се

Създайте нова регистрация в нашия форум. Лесно е!

Нова регистрация

Вход

Имате регистрация? Влезте от тук.

Вход

×

Информация

Поставихме бисквитки на устройството ви за най-добро потребителско изживяване. Можете да промените настройките си за бисквитки, или в противен случай приемаме, че сте съгласни с нашите условия за ползване.