Премини към съдържанието
  • Добре дошли!

    Добре дошли в нашите форуми, пълни с полезна информация. Имате проблем с компютъра или телефона си? Публикувайте нова тема и ще намерите решение на всичките си проблеми. Общувайте свободно и открийте безброй нови приятели.

    Моля, регистрирайте се за да публикувате тема и да получите пълен достъп до всички функции.

     

(Ubuntu 17.04) Невъзможност за свързване с LAN


Препоръчан отговор


Здравейте,

Имам пробем с линукса ми - не мога да се свърша с никаква LAN мрежа. До колкото виждам от лога (прикачен по-долу) се оказва, че адаптерът е спрян, но не мога да го пусна - през мениджъра в настройките така и не ми дава като опции да го "включа", а ръчното създаване на LAN мрежа не оказа някаква промяна... Някой ако може да даде предложение как да реша този проблем ще съм Ви много благодарен!

Цитат

sudo lshw -class network
  *-network                 
       description: Wireless interface
       product: QCA9565 / AR9565 Wireless Network Adapter
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: [email protected]:08:00.0
       logical name: wlp8s0
       version: 01
       serial: --:--:--:--:--:--
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list rom ethernet physical wireless
       configuration: broadcast=yes driver=ath9k driverversion=4.10.0-32-generic firmware=N/A ip=192.168.0.104 latency=0 link=yes multicast=yes wireless=IEEE 802.11
       resources: irq:17 memory:b9500000-b957ffff memory:b9580000-b958ffff
  *-network DISABLED
       description: Ethernet interface
       product: QCA8172 Fast Ethernet
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: [email protected]:09:00.0
       logical name: enp9s0
       version: 10
       serial: --:--:--:--:--:--
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi msix bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=alx latency=0 link=no multicast=yes port=twisted pair
       resources: irq:18 memory:b9400000-b943ffff ioport:3000(size=128)

 

Линк към този отговор
Сподели в други сайтове

Опитай чрез инсталиране на други Линукс дистрибуций да решиш този проблем. Аз препоръчвам да започнеш експеримента с Убунто МАТЕ. Виж на www.distrowatch.com  или www.sourceforge.net  да си свалиш и изтеглиш подходяща и безплатна Линукс дистрибуция. Успех.

Линк към този отговор
Сподели в други сайтове

Ммм, няма ли друго решение на казуса ми от преинсталация? Не ми се иска точно в момента да сменям Linux дистрибуции, иначе знам, че има много различни flavors на Убунту.

Линк към този отговор
Сподели в други сайтове
преди 22 минути, ZeroG написа:

Гледам, че си успял да си забраниш NetworkManager.
Можеш да го пуснеш чрез:
a) десен клик върху него -> Enable Networking
b) от конзолата - sudo nmcli networking on

 

Пуснах го през конзолата, но все още без резултат :/ Все така си пише "Жична мрежа устройството не се управлява"

Линк към този отговор
Сподели в други сайтове
Цитат

sudo systemctl status NetworkManager.service

● NetworkManager.service - Network Manager
   Loaded: loaded (/lib/systemd/system/NetworkManager.service; enabled; vendor p
   Active: active (running) since Sun 2017-08-13 14:03:41 EEST; 3h 9min ago
     Docs: man:NetworkManager(8)
 Main PID: 1073 (NetworkManager)
   CGroup: /system.slice/NetworkManager.service
           ├─1073 /usr/sbin/NetworkManager --no-daemon
           └─7430 /sbin/dhclient -d -q -sf /usr/lib/NetworkManager/nm-dhcp-helpe

авг 13 17:07:30 Plamen-G510 NetworkManager[1073]: <info>  [1502633250.8789] devi
авг 13 17:07:30 Plamen-G510 NetworkManager[1073]: <info>  [1502633250.8792] devi
авг 13 17:07:30 Plamen-G510 NetworkManager[1073]: <info>  [1502633250.8794] mana
авг 13 17:07:31 Plamen-G510 NetworkManager[1073]: <info>  [1502633251.0140] mana
авг 13 17:07:31 Plamen-G510 NetworkManager[1073]: <info>  [1502633251.0142] poli
авг 13 17:07:31 Plamen-G510 NetworkManager[1073]: <info>  [1502633251.0147] devi
авг 13 17:07:31 Plamen-G510 dhclient[7430]: bound to 192.168.0.104 -- renewal in
авг 13 17:07:40 Plamen-G510 NetworkManager[1073]: <info>  [1502633260.7891] keyf
авг 13 17:07:40 Plamen-G510 NetworkManager[1073]: <info>  [1502633260.7899] blue
авг 13 17:07:40 Plamen-G510 NetworkManager[1073]: <info>  [1502633260.7906] mana

 

Цитат

ip addr

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: enp9s0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/ether --:--:--:--:--:-- brd ff:ff:ff:ff:ff:ff
3: wlp8s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether --:--:--:--:--:-- brd ff:ff:ff:ff:ff:ff
    inet 192.168.0.104/24 brd 192.168.0.255 scope global dynamic wlp8s0
       valid_lft 6711sec preferred_lft 6711sec
    inet6 ----:----:----:----:----/64 scope link
       valid_lft forever preferred_lft forever

 

Редактирано от streleca_stz (преглед на промените)

Линк към този отговор
Сподели в други сайтове
преди 22 минути, ZeroG написа:

Дали пък NetworkManager въобще управлява този интерфейс?

Дай изход от командата: sudo nmcli device status

Амии като гледам само wifi адаптера се управлява :?

Цитат

УСТРОЙСТВО         ВИД       СЪСТОЯНИЕ        CONNECTION
wlp8s0             wifi      има връзка       MyConnection 
--:--:--:--:--:--  bt        не се управлява  --         
enp9s0             ethernet  не се управлява  --         
lo                 loopback  не се управлява  --        

 

Линк към този отговор
Сподели в други сайтове

Дай изход от ifconfig .

Ако Network Manager не управлява LAN интерфейса, виж какво има в /etc/network/interfaces . Ако там има ред, в който присъства enp9s0, изтрий секцията и рестартирай (първо си правиш бекъп  - sudo cp /etc/network/interfaces /etc/network/interfaces.old , примерно).

Линк към този отговор
Сподели в други сайтове
Цитат

ifconfig

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 2663  bytes 11350654 (11.3 MB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 2663  bytes 11350654 (11.3 MB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlp8s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.0.104  netmask 255.255.255.0  broadcast 192.168.0.255
        inet6 fe80::c16e:ae0a:64ee:491b  prefixlen 64  scopeid 0x20<link>
        ether --:--:--:--:--:--  txqueuelen 1000  (Ethernet)
        RX packets 655280  bytes 865985947 (865.9 MB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 388738  bytes 107962101 (107.9 MB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

Ето я и цялата информация от файла

Цитат

# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

 

Линк към този отговор
Сподели в други сайтове
Цитат

[main]
plugins=ifupdown,keyfile

[ifupdown]
managed=false

 

Линк към този отговор
Сподели в други сайтове

Направих го, но без успех.. Все още няма връзка с LAN :/

Линк към този отговор
Сподели в други сайтове
преди 4 часа, streleca_stz написа:

Здравейте,

Имам пробем с линукса ми - не мога да се свърша с никаква LAN мрежа. До колкото виждам от лога (прикачен по-долу) се оказва, че адаптерът е спрян, но не мога да го пусна - през мениджъра в настройките така и не ми дава като опции да го "включа", а ръчното създаване на LAN мрежа не оказа някаква промяна... Някой ако може да даде предложение как да реша този проблем ще съм Ви много благодарен!

 

За лаптоп ли става въпрос ? Ако е така, провери, дали устройството не е изключено от хардуерен ключ.

Линк към този отговор
Сподели в други сайтове
преди 12 минути, ZeroG написа:

Дай пак изход от командата: sudo nmcli device status

1:1 е лога като този, който пуснах по-рано

преди 9 минути, cybercop написа:

За лаптоп ли става въпрос ? Ако е така, провери, дали устройството не е изключено от хардуерен ключ.

Да, за лаптоп става дума и не, няма хардуерен бутон, нито има директен мултимедиен (или бърз клавиш) за пускане и спиране на WI-FI / LAN.

Редактирано от streleca_stz (преглед на промените)
Линк към този отговор
Сподели в други сайтове
преди 21 минути, streleca_stz написа:

Да, за лаптоп става дума и не, няма хардуерен бутон, нито има директен мултимедиен (или бърз клавиш) за пускане и спиране на WI-FI / LAN.

Имаше ли връзка към мрежата по време на инсталацията?

Изпълни в терминал :

cat /etc/network/interfaces

и постни изхода.

Редактирано от cybercop (преглед на промените)
Линк към този отговор
Сподели в други сайтове
Цитат

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: enp9s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether --:--:--:--:--:-- brd ff:ff:ff:ff:ff:ff
    inet 192.168.0.108/24 scope global enp9s0
       valid_lft forever preferred_lft forever
    inet6 ----:----:----:----:----/64 scope link
       valid_lft forever preferred_lft forever
3: wlp8s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether --:--:--:--:--:-- brd ff:ff:ff:ff:ff:ff
    inet 192.168.0.104/24 brd 192.168.0.255 scope global dynamic wlp8s0
       valid_lft 5413sec preferred_lft 5413sec
    inet6 ----:----:----:----:----/64 scope link
       valid_lft forever preferred_lft forever

 

И изхода на interfaces

Цитат

# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

Да, по време на инсталацията използвах мрежа, но wifi, а не LAN

EDIT (да не отварям нови тема):

Между другото имам и някакъв странен проблем с bluetooth адаптера - когато стартирам системата от изключено състояние не се стартира автоматично, нито ми дава да го пусна от панела с настройки (все едно изобщо няма адаптер), но ако след това рестартирам системата - тръгва от раз ???? Ако можете да помогнете и с това ще сте супер!

Редактирано от streleca_stz (преглед на промените)
Линк към този отговор
Сподели в други сайтове
преди 13 минути, streleca_stz написа:

И изхода на interfaces

# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

Ако е само това е добре. Остава само да изтриеш всички запазени мрежи от настройките на NM и да зададеш "Aвтоматично свързаване с Ethernet", като погледни, дали не е махната отметката от "Включване на мрежата". Не се сещам за друг възможен проблем при тази по принцип най- безпроблемна връзка.

 

Линк към този отговор
Сподели в други сайтове

@ZeroG - Дори и с enabled - пак не сработва.... Не знам вече какво иска......

@cybercop - Честно казано никъде не виждам опцията "Aвтоматично свързаване с Ethernet" :? Иначе премахнах ръчно създадената от мен LAN мрежа.

Снимка от 2017-08-13 20-11-31.png

Линк към този отговор
Сподели в други сайтове

За тази опция писах.

https://s25.postimg.org/y4iklszvj/Auto_Eth.png

Единствената възможна причина за блокираната жична мрежа през NM за която се сещам е автоматично създадената връзка през ifup.

Но не виждам такава в двата реда конфигурация, която публикува.

преди 43 минути, streleca_stz написа:

auto lo
iface lo inet loopback

Надявам се да не си спестил нещо, защото си е за твоя сметка. Лека вечер ти желая !

Редактирано от cybercop (преглед на промените)
Линк към този отговор
Сподели в други сайтове

Ами то хубаво, но аз не намирам въпросната опция за автоматично свързване, предполагам, защото системата изобщо не работи с LAN модула?? И разбира се, че не спестявам нищо, защо иначе ще искам да се реши проблема и ще оставя а направим 2 страници публикации във форума.. Явно накрая ще се наложи да направя това, което kalansuv ме посъветва още в началото и ще сменя флейвъра или цялата дистрибуция... Просто не съм чак толкова напред "с материала", за да мога да определя и самичък от къде идва проблема :(

Линк към този отговор
Сподели в други сайтове
преди 7 минути, streleca_stz написа:

Явно накрая ще се наложи да направя това, което kalansuv ме посъветва още в началото и ще сменя флейвъра или цялата дистрибуция...

Можеш да стартираш система в режим Live CD за да тестваш връзката преди инсталацията.

Линк към този отговор
Сподели в други сайтове
преди 23 минути, cybercop написа:

Можеш да стартираш система в режим Live CD за да тестваш връзката преди инсталацията.

Е, поне вече разбирам, че явно има хардуерен проблем - пробвах с live версия на Ubuntu 12.04 (такова имам под ръка на диск) и така и не успях да се свържа с LAN мрежа..... малко ми е странно, защото от година почти не съм използвал жична мрежа.....

Линк към този отговор
Сподели в други сайтове

Амиии нали ще минават на гном, затова реших уж да поседя още докато излезе Ubuntu 17.10 където трябва да е вече без Unity... Но то ако ще ми прави такива "своеволия" ...........

Линк към този отговор
Сподели в други сайтове

Нищо и няма на Ubuntu като управление на хардуер. Иначе, че Unity е недъгаво нещо съм съгласен, но някои хора си го харесваха.

Тук обаче, мисля, че е очевидно, че става дума за хардуерен проблем. Щом и с ifup ръчно вдигнат интерфейс и с LiveCD не тръгва, дистрото има малко общо. Може да е някаква клавишна комбинация - lan+wifi, само lan, само wifi, на лаптопите ги има тези неща, но обикновенно искат драйвер за подобна функционалност. Може наистина да има хардуерен ключ някъде, все пак не разбрахме моделът на лаптопа. Като последна възможнот, може да има някакъв проблем с линукският драйвер за lan картата. Може да се пробва и някакъв Live Windows - WinPE, WinToGo. Ако и там не работи е ясно - изгърмяла lan. Ако там тръгва, може да се търси друг драйвер.

Линк към този отговор
Сподели в други сайтове
преди 19 часа, streleca_stz написа:

Е, поне вече разбирам, че явно има хардуерен проблем

Може ли изхода от:

cat /usr/lib/NetworkManager/conf.d/10-globally-managed-devices.conf 

 

Линк към този отговор
Сподели в други сайтове
преди 4 часа, exwol написа:

Може ли изхода от:

cat /usr/lib/NetworkManager/conf.d/10-globally-managed-devices.conf 

 

Цитат

ices.conf
[keyfile]
unmanaged-devices=*,except:type:wifi,except:type:wwan

 

Линк към този отговор
Сподели в други сайтове

Добавете отговор

Можете да публикувате отговор сега и да се регистрирате по-късно. Ако имате регистрация, влезте в профила си за да публикувате от него.

Гост
Напишете отговор в тази тема...

×   Вмъкнахте текст, който съдържа форматиране.   Премахни форматирането на текста

  Разрешени са само 75 емотикони.

×   Съдържанието от линка беше вградено автоматично.   Премахни съдържанието и покажи само линк

×   Съдържанието, което сте написали преди беше възстановено..   Изтрий всичко

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Добави ново...

Информация

Поставихме бисквитки на устройството ви за най-добро потребителско изживяване. Можете да промените настройките си за бисквитки, или в противен случай приемаме, че сте съгласни с нашите Условия за ползване