Премини към съдържанието

Препоръчан отговор


Здравейте, имам следния проблем: Линукса ми не ми засича wifi adaptera (tp-link wn722n)
Преди всичко си работеше перфектно със старата ми версия на VirtualBox (вече не помня коя беше)
Пробвах стари, нови версии, все едно и също - не ми засича адаптера..
Не мога да се свързвам към безжични мрежи, дори нямам такова меню.
В терминала като напиша iwconfig, изписва - No wireless extensions.

Някакви идеи ?

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Или нямаш драйвер за адаптер , или не е активиран . Виж в Система . При мен с Дебаин е така - Система/ Мениджър  драйвери/изтегляне от Нет/ /Активиране на адаптер. Но трябва да имаш връзка с Нета.  Аз понеже ползвам и флашка за Мобилен нет  ми е лесно, може би трябва да ползваш Нет с кабел.При някои дистрибуции има в Система позиция -активирай адаптер/име/

  • Харесва ми 1

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
преди 5 минути, bigiadri написа:

Или нямаш драйвер за адаптер , или не е активиран . Виж в Система . При мен с Дебаин е така - Система/ Мениджър  драйвери/изтегляне от Нет/ /Активиране на адаптер. Но трябва да имаш връзка с Нета.  Аз понеже ползвам и флашка за Мобилен нет  ми е лесно, може би трябва да ползваш Нет с кабел.При някои дистрибуции има в Система позиция -активирай адаптер/име/

Ами в момента съм свързан с Wi-Fi, адаптера си работи докато съм на Уин, но когато Линукса ми зареди във ВМ, адаптера спира, интернета изчезва..

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

@Crysis55 : Пакетите firmware-atheros и firmware-misc-nonfree инсталирани ли са ?

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
преди 5 минути, cybercop написа:

@Crysis55 : Пакетите firmware-atheros и firmware-misc-nonfree инсталирани ли са ?

Не съм сигурен, как се инсталират? Бях пробвал, нещо такова уж, но ми изписваше, че не може да намери някакви си неща.


Сподели този отговор


Линк към този отговор
Сподели в други сайтове
преди 10 минути, Crysis55 написа:

Не съм сигурен, как се инсталират? Бях пробвал, нещо такова уж, но ми изписваше, че не може да намери някакви си неща.

su

apt-get update

apt-get install firmware-atheros firmware-misc-nonfree

reboot

Ако пакетите не са налични, конфигурираш си хранилищата, като добавяш main, contrib и non-free за Debian Testing и повтаряш процедурата отново.

  • Харесва ми 1

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

За всеки случай провери дали нямаш това.

При теб ще е изписано името на адаптера

20170930_181617.jpg

Редактирано от bigiadri (преглед на промените)
  • Харесва ми 1

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
преди 12 минути, cybercop написа:

su

apt-get update

apt-get install firmware-atheros firmware-misc-nonfree

reboot

Ако пакетите не са налични, конфигурираш си хранилищата, като добавяш main, contrib и non-free за Debian Testing и повтаряш процедурата отново.

Дори не мога да опитам, защото по някаква причина компютъра ми се disconnect-ва от интернета ми, когато ВМ Зареди ?! ..

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Ето ти драйвъра : http://ftp.de.debian.org/debian/pool/non-free/f/firmware-nonfree/firmware-atheros_20170823-1_all.deb

Свали го и го инсталирай с инсталатора си на пакети или с dpkg -i. 

Няма неизпълнени зависимости дори в минимална Debian система.

След това рестартирай машината или извади и постави отново адаптера в USB порта.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
преди 13 минути, cybercop написа:

Ето ти драйвъра : http://ftp.de.debian.org/debian/pool/non-free/f/firmware-nonfree/firmware-atheros_20170823-1_all.deb

Свали го и го инсталирай с инсталатора си на пакети или с dpkg -i. 

Няма неизпълнени зависимости дори в минимална Debian система.

След това рестартирай машината или извади и постави отново адаптера в USB порта.

Не мога да се свържа към собствения си интернет без адаптера, по незнайни причини компютъра ми не иска да се свърже с интернета ми без адаптера (unidentified network)... 

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
преди 45 минути, Crysis55 написа:

Не мога да се свържа към собствения си интернет без адаптера, по незнайни причини компютъра ми не иска да се свърже с интернета ми без адаптера (unidentified network)... 

Ако спрете да се правите на хахор и си инсталирате някое десктоп издание на Ubuntu, вероятността да имате проблеми от подобно естество е нищожна. Другата алтернатива е да почетете малко за дистрибуцията която инсталирате и тази, върху която е базирана.

Редактирано от cybercop (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
преди 6 минути, cybercop написа:

Ако спрете да се правите на хахор и си инсталирате някое десктоп издание на Ubuntu, вероятността да имате проблеми от подобно естество е нищожна. Другата алтернатива е да почетете малко за дистрибуцията която инсталирате и тази, върху която е базирана.

Освен, че се правя на хакер, се правя и на програмист, и на какъвто кажеш, не всички сме гении като теб :)
Преди нямах проблеми, сега имам, не знам от какво е.
За първи път имам подобен проблем, мерси за малоумното изказване...

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
преди 17 минути, Crysis55 написа:

Освен, че се правя на хакер, се правя и на програмист, и на какъвто кажеш, не всички сме гении като теб :)
Преди нямах проблеми, сега имам, не знам от какво е.
За първи път имам подобен проблем, мерси за малоумното изказване...

Опитах се с по- малко малоумни, но, нещата изглежда не се получават. А, става въпрос само да си свалите един пакет, докато си пишете тук и да го инсталирате. Никаква причина не виждам да ви е необходима тази дистрибуция в качеството на програмист. Инструменти за тестване на сигурността можете да инсталирате във всяка друга дистрибуция, както е направено и в горепосочения дериват на Debian.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
преди 14 минути, Crysis55 написа:

Освен, че се правя на хакер, се правя и на програмист, и на какъвто кажеш, не всички сме гении като теб :)
Преди нямах проблеми, сега имам, не знам от какво е.
За първи път имам подобен проблем, мерси за малоумното изказване...

Излишно е да се обиждате! Отиди при рутера си и се вържи с кабел и ще имаш Нет ,тази възможност я има  при вашта дистрибуция. Изтегли си драйвера и си го монтирай.  Чрез Уиндоус да го теглиш и после да го сложеш на страничен диск и от там да инсталираш на Кали ,ще е много сложно. Все пак при Система трябва да има Мениджер за драйверите ,щом  нямаш позиция за активиране и с него всичко е много лесно !Правилото е : Майсторството се усвоява чрез решение на проблеми, само за тази идея си струва да опиташ и да си решиш проблема:)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
преди 29 минути, ZeroG написа:

Доколкото разбрах от мъглявите ти обяснения:
Имаш проблем не с Линукс драйвер на WiFi джвъчката ти, а проблем с конфигурацията за VirtualBox.
Имаш Windows Host -> VirtualBox -> Linux guest, нали така?
Еxtension Pack-a на VirtualBox инсталира ли?
А конфигурира ли си мрежовия адаптер вътре в настройките за госта си Линукс за виртуалната му машина?
Драйвер за Линукс не ти трябва, ползваш този от Уиндоуса, чрез VirtualBox

Taka e ako ползва VirtualBox.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Не е ли: нова версия на Бокса - нови виртуални добавки? Не съм го ползвал от много години и не знам.

 

"Преди всичко си работеше перфектно със старата ми версия на VirtualBox (вече не помня коя беше)"  - просто програмирането е доста вредящ на паметта процес, явно.

Редактирано от бат'начо (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Какви програмирания, какви 5 лева... Ползвам Виртуална машина, не се правя на никакъв, нямам рутер, просто Интернет адаптера ми върви на Уин, а във ВМ-а не го засича, пробвал съм какво ли не, и пак не работи, това че някой не разбира дадено нещо, не значи че се прави на някъв.. 

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

А този Virtualbox не може ли да се настои да взема интернет от машината и ОС, върху която е инстлиран, а не директно от адаптера? Пробвай VMWare - мисля че има доста повече настройки и е по-лесна за работа.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Регистрирайте се или влезете в профила си за да коментирате

Трябва да имате регистрация за да може да коментирате това

Регистрирайте се

Създайте нова регистрация в нашия форум. Лесно е!

Нова регистрация

Вход

Имате регистрация? Влезте от тук.

Вход

×

Информация

Поставихме бисквитки на устройството ви за най-добро потребителско изживяване. Можете да промените настройките си за бисквитки, или в противен случай приемаме, че сте съгласни с нашите условия за ползване.