Премини към съдържанието

    Препоръчан отговор


    Здравейте,

    Имеме Windows Server 2012 R2 във Failover Cluster. Принципно съм бая повече Linux човек и нямам идея.

    Върху клъстер-а има Archiving приложение, което не е cluster aware. В един момент Cluster rоle става във статус "Partially running", а приложението се оплаква, че конфигурационните му файлове са "Write Protected". 

    Използват се 16Gbps HP SAN суичове и 3PAR 8400. Суичовете са с Brocade FW 8.1.0C, а 3PAR-ите с 3.2.2 EMU4.

    Ще съм благодарен ако някой знае от какво може да е и как да го поправя.

    ПП: Клъстерът е от 2 нода.

    Редактирано от vstoitsov (преглед на промените)

    Сподели този отговор


    Линк към този отговор
    Сподели в други сайтове

    Нещо става в този момент с твоя клъстър и той не е 'онлайн'.

    See cluster logs and post here so that we can provide further help - Тоест дай логовете в този момент, за да се види какво става точно.

    Причини:

    1. Твоята програма за архивиране се стартира и се опитва да прави 'непозволена' за клъстъра процедура (по отваряне, преместване и т.н.)

    2. Нещо от хардуера се чупи (физически или логически) и изчезва физическата свързаност на двата нод-а. Лог на мрежата в този момент със съобщението.

    От скромния ми опит толкова като насоки към момента.

    Не бутай нищо преди да си 100% сигурен, че в него е проблема. Нещата в такава структура са 'деликатни' и се пипат 'нежно'...

    • Харесва ми 1

    Сподели този отговор


    Линк към този отговор
    Сподели в други сайтове

    Благодаря ти много. Значи ще се рови по логовете.

    Сподели този отговор


    Линк към този отговор
    Сподели в други сайтове

    Това приложение от къде накъде пише? Да не би да го блокира някаква антивирусна? Не виждам иначе връзка между чупенето на клъстера и заключването на конфигурационните файлове на third-party приложение.

    Сподели този отговор


    Линк към този отговор
    Сподели в други сайтове
    на 11/21/2017 в 13:44, badsector написа:

    Това приложение от къде накъде пише? Да не би да го блокира някаква антивирусна? Не виждам иначе връзка между чупенето на клъстера и заключването на конфигурационните файлове на third-party приложение.

    Проверих антивирусната е Symantec Endpoint, но още не е лицензирана и не работи.

    След много ровене из логовете стана ясно, че всички SAN пътища и в двете фабрики са прекъсвали.

    След, разговор с хората onsite стана ясно, че нещо са правили по суичовете.

    След рестарт на двата нода всичко е отново ок.

    Добре, че още не са продуктивни тези системи.

    Благодаря на отзовалите се.


    Сподели този отговор


    Линк към този отговор
    Сподели в други сайтове

    Проблем с трасето явно е причината за чупенето на клъстъра, но защо на това приложение са му заключени конфигурационните файлове, нямам идея :D

    Сподели този отговор


    Линк към този отговор
    Сподели в други сайтове

    Регистрирайте се или влезете в профила си за да коментирате

    Трябва да имате регистрация за да може да коментирате това

    Регистрирайте се

    Създайте нова регистрация в нашия форум. Лесно е!

    Нова регистрация

    Вход

    Имате регистрация? Влезте от тук.

    Вход


    ×

    Информация

    Този сайт използва бисквитки (cookies), за най-доброто потребителско изживяване. С използването му, вие приемате нашите Условия за ползване.