Премини към съдържанието
Visotsky

Проблем с инсталация на Gapps

Препоръчан отговор


Здраво, пичове!

Реших да пробвам как би вървял Android Oreo на моя стар Samsung Galaxy S4. Инсталирах TWRP, рестартирах в recovery mode, инстлаирах recovery image, изчистих всичко друго (с wipe), инсталирах прекрасно AOSP ROM, но след това не успявам никак да му сложа Gapps - връща ми error 20. Сиреч, операционна система има, но базовите програмки ги няма. Липсва, например, Google Play. Пробвах да я инсталирам (заедно с Google Play Services) директно от apk - инсталират се, иконката стои, но не се стартира, просто отказва.

Та, някой има ли идея какво да сторя, за да върна функционалността на телефона? Какво пропускам или не правя както трябва?

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Явно този AOSP ROM не е бил читав. 

Решението - теглиш си стоков ром (най-новата версия за модела), флашваш с Odin, и си имаш (като) чисто нов телефон :) .

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
преди 13 минути, eXceLLen7 написа:

Да не си изтеглил Gapps за друга версия Андроид? 

Не съм... В крайна сметка се върнах пак на 7.1.2. Доволен съм. Разликата не е голяма. Пробвах и "Осмицата", не е зле. Ще чакам по-читва версия на Gapps.

Благодаря на отзовалите се, можете да махате темата.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

До колкото помня, GAPPS се флашва директно след ROM, преди да се рестартира телефона, още докато си в Custom recovery. Пробвал ли си така?


Сподели този отговор


Линк към този отговор
Сподели в други сайтове
преди 1 час, Радослав Матев написа:

До колкото помня, GAPPS се флашва директно след ROM, преди да се рестартира телефона, още докато си в Custom recovery. Пробвал ли си така?

Точно така правих много пъти, но с Oreo просто не стана. Операционната система се инсталира перфектно, но Gapps - никак.

Както и да е. Вече съм със 7.1.2, която също е добра. :) Очаквам читав Gapps за Oreo 8.1 и действам отново. :)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Там, където го теглиш този custom ROM, трябва да е написано кое как се инсталира. Нещо не си прочел или не си направил както трябва. В XDA не виждам такъв ROM за S4, а най-сигурно е там да гледаш - поне хората са читави и тестват нещата, преди да ги пуснат, ако има проблеми пишат кое как се прави.

https://forum.xda-developers.com/galaxy-s4

Редактирано от Радослав Матев (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Това е някакъв проблем с AOSP-то сигурно. Я провери дали няма LineageOS 15 за твоя Самсунг ?!?

7.0 AOSP съм го пробвал на едно Lenovo, и беше стабилно.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Пробва ли тези варианти? Телефона ти трябва да е точно от моделите, описани горе.

https://forum.xda-developers.com/galaxy-s4/i9505-orig-develop/jdcteam-android-source-project-oreo-t3685231

http://rootmygalaxy.net/download-and-install-lineage-os-15-on-samsung-galaxy-s4-android-8-0-oreo/

и да изпълниш точно стъпките с Recovery и т.н., които са дадени в линковете. Дори да имаш нещо пак го изтегли/инсталирай, както е написано.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Регистрирайте се или влезете в профила си за да коментирате

Трябва да имате регистрация за да може да коментирате това

Регистрирайте се

Създайте нова регистрация в нашия форум. Лесно е!

Нова регистрация

Вход

Имате регистрация? Влезте от тук.

Вход

×

Информация

Поставихме бисквитки на устройството ви за най-добро потребителско изживяване. Можете да промените настройките си за бисквитки, или в противен случай приемаме, че сте съгласни с нашите условия за ползване.