Премини към съдържанието

Препоръчан отговор


Здравейте, доволен съм от плеъра, но ме дразни цвета на субтитрите. Искам да е ярко жълт. Настройвам го, но въпреки това излиза избледнял. Пример:

 

8005f8f9181fc0e1.png

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Поне от снимката излиза добре.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
Гост
публикувано (редактирано)

хм, ами то цвета на субтитрите, можеш да си го направиш какъвто искаш от:

snapshot4.thumb.png.787213dbfcd0dd5e812e108b86731f15.png

тъй де, плъзгаш мишката и нагласяш

Редактирано от Гост (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
публикувано (редактирано)

Отметка и на "приложи стила и върху ASS файлове". (Ако има - махни я и пак я постави, вероятно ползваш mplayer двигател).

Редактирано от бат'начо (преглед на промените)
  • Харесва ми 3

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Да ползвам темата. Някой инсталирал ли е MPlayer от източник от тук http://www.mplayerhq.hu/design7/dload.html

и в коя дистрибуция. Интересува ме, дали някоя от двете версии - 1.3 или 1.2.1 ще работи без проблеми в Debian Jessie или Ubuntu 14.04, където MPlayer не е достъпен от официалните хранилища.

Благодаря предварително за отговорите !


Сподели този отговор


Линк към този отговор
Сподели в други сайтове
преди 3 часа, cybercop написа:

Да ползвам темата. Някой инсталирал ли е MPlayer от източник от тук http://www.mplayerhq.hu/design7/dload.html

и в коя дистрибуция. Интересува ме, дали някоя от двете версии - 1.3 или 1.2.1 ще работи без проблеми в Debian Jessie или Ubuntu 14.04, където MPlayer не е достъпен от официалните хранилища.

Благодаря предварително за отговорите !

1.3 съм компилирал и на Xenial и на Trusty и на Debian Jessie, работят си без проблеми. За инсталиране на готови пакети не мога да кажа. Последно съм го качвал и ползвал на последното Manjaro. Но на rolling версиите много често сменят версии на пакети и се чупи и трябва да се прекомпилира. Докато на LTS дистрибуции не помня да съм имал такива проблеми.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
публикувано (редактирано)
преди 14 минути, RagnerBG написа:

1.3 съм компилирал и на Xenial и на Trusty и на Debian Jessie, работят си без проблеми. За инсталиране на готови пакети не мога да кажа. Последно съм го качвал и ползвал на последното Manjaro. Но на rolling версиите много често сменят версии на пакети и се чупи и трябва да се прекомпилира. Докато на LTS дистрибуции не помня да съм имал такива проблеми.

При мен дава грешка при компилирането. Кое приложение/компилатор трябва да имам за да стартира процеса ? В момента съм с Ubuntu 16.04, но доста орязано изпълнение.

master@master-laptop:~/MPlayer-1.3.0$ ./configure --enable-gui
Checking for ffmpeg/libavcodec/allcodecs.c ... found
Checking for ffmpeg/libavformat/allformats.c ... found
Checking for ffmpeg/libavfilter/allfilters.c ... found
Checking for working compiler ...
Error: Compiler is not functioning correctly. Check your installation and custom CFLAGS  .

Check "config.log" if you do not understand why it failed.
master@master-laptop:~/MPlayer-1.3.0$

 

 

Редактирано от cybercop (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
преди 4 минути, cybercop написа:

При мен дава грешка при компилиране. Кое приложение/компилатор трябва да имам за да стартира процеса ? В момента съм с Ubuntu 16.04, но доста орязано изпълнение.

По-принцип с mplayer никог не съм имал проблеми с компилацията, виж mpv е по-капризен. В сайтът са описали кои пакети са зависимости, не всичко е задължително - MPlayer Documentation, а тук е и по-подробно, макар и малко outdated - MPlayer-1.3.0 - Linux From Scratch!. Иначе не помня наизуст стъпките и за това си записвам :), въпреки че всеки път го правя малко по-различно. За Debian/Ubuntu това май трябва да са зависимостите:

sudo apt-get update
sudo apt-get build-dep libav/ffmpeg (Jessie/Xenial)
sudo apt-get build-dep mplayer2

sudo apt-get install build-essential subversion checkinstall git-core docbook-xml \
docbook-xsl xsltproc libxml2-utils

sudo apt-get install libaa1-dev libasound2-dev libcaca-dev libcdparanoia-dev libdca-dev \
libdirectfb-dev libenca-dev libesd0-dev libfontconfig1-dev libfreetype6-dev libfribidi-dev \
libgif-dev libgl1-mesa-dev libjack-jackd2-dev libopenal1 libpulse-dev libsdl1.2-dev \
libvdpau-dev libxinerama-dev libxv-dev libxvmc-dev libxxf86dga-dev libxxf86vm-dev librtmp-\
dev libsctp-dev libass-dev libfaac-dev libsmbclient-dev libtheora-dev libogg-dev \
libxvidcore-dev libspeex-dev libvpx-dev libschroedinger-dev libdirac-dev libdv4-dev \
libopencore-amrnb-dev libopencore-amrwb-dev libmp3lame-dev liblivemedia-dev libtwolame-dev \
libmad0-dev libgsm1-dev libbs2b-dev liblzo2-dev ladspa-sdk libopenjpeg-dev libfaad-dev \
libmpg123-dev libopus-dev libbluray-dev libaacs-dev

последното е ако build-dep не качи каквото трябва, иначе повечето трябва да си ги има в системата. Така съм компилирал последно на Manjaro-то, не би трябвало да е различно при другите:

svn checkout svn://svn.mplayerhq.hu/mplayer/trunk mplayer
wget http://www.mplayerhq.hu/MPlayer/releases/codecs/all-20110131.tar.bz2
wget ftp://ftp.mplayerhq.hu/MPlayer/releases/codecs/essential-amd64-20071007.tar.bz2
tar xjvf all-20110131.tar.bz2
tar xjvf essential-amd64-20071007.tar.bz2
sudo mkdir /usr/local/lib/codecs
sudo cp -v all-20110131/* /usr/local/lib/codecs/
sudo cp -v essential-amd64-20071007/* /usr/local/lib/codecs/
cd mplayer
./configure --codecsdir=/usr/local/lib/codecs --enable-dynamic-plugins --enable-menu --enable-vdpau --enable-gl
?sudo nano /mplayer/ffmpeg/libavutil/mem.c - HAVE_AVX512 = HAVE_AVX2
make -j4
sudo make install
sudo ldconfig
cd
cp Build/mplayer/etc/menu.conf .mplayer/
cp Build/mplayer/etc/input.conf .mplayer/
mplayer

Редът с "?" е поради един бъг в последните източници и сега се сещам, че може точно на него да си попаднал. Аматьорска работа - тази инструкция "AVX512" се поддържа само на Intel Xeon процесор, или само на Intel. Аз компилирах на AMD и трябваше да се замени с "AVX2". Прави се точно преди make, иначе при configure ще възроптае, че сме пипали конфигурационните файлове.

Конфигурацията, която ползвам за хардуерно ускорение е следната:

sudo nano /usr/local/etc/mplayer/mplayer.conf :
vo=vdpau
vc=ffmpeg12vdpau,ffh264vdpau,ffvc1vdpau,ffwmv3vdpau,
framedrop=yes
subcp=cp1251

Ако видеокартата поддържа h265 ускорение, във "vc=" се добавя и "ffhevcvdpau,", иначе не, че ще гърми на такива файлове. Но в никакъв случай "ffodivxvdpau,", защото е бъгаво, безсмислено от към натоварване и май работи само на NVidia карти, но дори и там нестабилно.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
преди 2 минути, RagnerBG написа:

По-принцип с mplayer никог не съм имал проблеми с компилацията, виж mpv е по-капризен. В сайтът са описали кои пакети са зависимости, не всичко е задължително - MPlayer Documentation, а тук е и по-подробно, макар и малко outdated - MPlayer-1.3.0 - Linux From Scratch!. Иначе не помня наизуст стъпките и за това си записвам :), въпреки че всеки път го правя малко по-различно. За Debian/Ubuntu това май трябва да са зависимостите:


sudo apt-get update
sudo apt-get build-dep libav/ffmpeg (Jessie/Xenial)
sudo apt-get build-dep mplayer2

sudo apt-get install build-essential subversion checkinstall git-core docbook-xml \
docbook-xsl xsltproc libxml2-utils

sudo apt-get install libaa1-dev libasound2-dev libcaca-dev libcdparanoia-dev libdca-dev \
libdirectfb-dev libenca-dev libesd0-dev libfontconfig1-dev libfreetype6-dev libfribidi-dev \
libgif-dev libgl1-mesa-dev libjack-jackd2-dev libopenal1 libpulse-dev libsdl1.2-dev \
libvdpau-dev libxinerama-dev libxv-dev libxvmc-dev libxxf86dga-dev libxxf86vm-dev librtmp-\
dev libsctp-dev libass-dev libfaac-dev libsmbclient-dev libtheora-dev libogg-dev \
libxvidcore-dev libspeex-dev libvpx-dev libschroedinger-dev libdirac-dev libdv4-dev \
libopencore-amrnb-dev libopencore-amrwb-dev libmp3lame-dev liblivemedia-dev libtwolame-dev \
libmad0-dev libgsm1-dev libbs2b-dev liblzo2-dev ladspa-sdk libopenjpeg-dev libfaad-dev \
libmpg123-dev libopus-dev libbluray-dev libaacs-dev

последното е ако build-dep не качи каквото трябва, иначе повечето трябва да си ги има в системата. Така съм компилирал последно на Manjaro-то, не би трябвало да е различно при другите:


svn checkout svn://svn.mplayerhq.hu/mplayer/trunk mplayer
wget http://www.mplayerhq.hu/MPlayer/releases/codecs/all-20110131.tar.bz2
wget ftp://ftp.mplayerhq.hu/MPlayer/releases/codecs/essential-amd64-20071007.tar.bz2
tar xjvf all-20110131.tar.bz2
tar xjvf essential-amd64-20071007.tar.bz2
sudo mkdir /usr/local/lib/codecs
sudo cp -v all-20110131/* /usr/local/lib/codecs/
sudo cp -v essential-amd64-20071007/* /usr/local/lib/codecs/
cd mplayer
./configure --codecsdir=/usr/local/lib/codecs --enable-dynamic-plugins --enable-menu --enable-vdpau --enable-gl
?sudo nano /mplayer/ffmpeg/libavutil/mem.c - HAVE_AVX512 = HAVE_AVX2
make -j4
sudo make install
sudo ldconfig
cd
cp Build/mplayer/etc/menu.conf .mplayer/
cp Build/mplayer/etc/input.conf .mplayer/
mplayer

Редът с "?" е поради един бъг в последните източници и сега се сещам, че може точно на него да си попаднал. Аматьорска работа - тази инструкция "AVX512" се поддържа само на Intel Xeon процесор, или само на Intel. Аз компилирах на AMD и трябваше да се замени с "AVX2". Прави се точно преди make, иначе при configure ще възроптае, че сме пипали конфигурационните файлове.

Конфигурацията, която ползвам за хардуерно ускорение е следната:


sudo nano /usr/local/etc/mplayer/mplayer.conf :
vo=vdpau
vc=ffmpeg12vdpau,ffh264vdpau,ffvc1vdpau,ffwmv3vdpau,
framedrop=yes
subcp=cp1251

Ако видеокартата поддържа h265 ускорение, във "vc=" се добавя и "ffhevcvdpau,", иначе не, че ще гърми на такива файлове. Но в никакъв случай "ffodivxvdpau,", защото е бъгаво, безсмислено от към натоварване и май работи само на NVidia карти, но дори и там нестабилно.

Мислех, че библиотеките са окомплектовани с плеъра. Ако ще ги инсталирам допълнително, по- добре да си сваля двуичния пакет от някое PPA за старите версии на Ubuntu. В 16.04, MPlayer е наличен в хранилищата.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Все пак се компилира. Това са developer пакети, за да може да си ги вгради при компилацията, а и както написах почти всички са налични в дистрибуциите, които съм ползвал, сложил съм си ги за ориентир. Също така сваля ffmpeg и го вгражда при компилацията. Можеш да си направиш .deb инсталатор, но там инструкциите за компилиране са малко по-различни. Правил съм го и мисля, че така не се налага да се качва нищо при инсталация на подобна система след това.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
на 28.01.2018 г. в 19:27, cybercop написа:

При мен дава грешка при компилирането. Кое приложение/компилатор трябва да имам за да стартира процеса ? В момента съм с Ubuntu 16.04, но доста орязано изпълнение.

master@master-laptop:~/MPlayer-1.3.0$ ./configure --enable-gui
Checking for ffmpeg/libavcodec/allcodecs.c ... found
Checking for ffmpeg/libavformat/allformats.c ... found
Checking for ffmpeg/libavfilter/allfilters.c ... found
Checking for working compiler ...
Error: Compiler is not functioning correctly. Check your installation and custom CFLAGS  .

Check "config.log" if you do not understand why it failed.
master@master-laptop:~/MPlayer-1.3.0$

 

 

Нямаш инсалиран dev GTK ,затова те спира.Ако премахнеш --enable-gui ще продължи...

Дори само с ./configure,make, make install ,mplayer би трябвало да работи дори на Centos 6 ,макар без GUI- компилиран от сорс и да плейва h265,h264...

Подкара ли h265 на Centos 6 или се отказа?

За по лесно тук готово  portable https://bintray.com/probono/AppImages/VLC#files

Авторите коментират,че работят успешно.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
преди 4 минути, nick_dimitrov написа:

Нямаш инсалиран dev GTK ,затова те спира.Ако премахнеш --enable-gui ще продължи...

Дори само с ./configure,make, make install ,mplayer би трябвало да работи дори на Centos 6 ,макар без GUI- компилиран от сорс и да плейва h265,h264...

Подкара ли h265 на Centos 6 или се отказа?

За по лесно тук готово  portable https://bintray.com/probono/AppImages/VLC#files

Авторите коментират,че работят успешно.

Пуснах го и със стандартна опция и не стана номера. Досега не ми се е налагало да пускам h.265 видео на компютъра с CENTOS6 защото е само за административна работа и не гледам филми на него. Записите от камерите, които преглеждам понякога с в h.264 кодировка.

Ще погледна преносимата версия.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Регистрирайте се или влезете в профила си за да коментирате

Трябва да имате регистрация за да може да коментирате това

Регистрирайте се

Създайте нова регистрация в нашия форум. Лесно е!

Нова регистрация

Вход

Имате регистрация? Влезте от тук.

Вход

×

Информация

Поставихме бисквитки на устройството ви за най-добро потребителско изживяване. Можете да промените настройките си за бисквитки, или в противен случай приемаме, че сте съгласни с нашите условия за ползване.