Премини към съдържанието

Препоръчан отговор

публикувано (редактирано)

Имам следния симптом, който не мога да си обясня:

Задавам на работния плот изглед за (голям текст и икони) в мащаб 150%
При това обстоятелство повечето икони са големи, но почти половината остават по-малки. Отварям съдържанието на малките и на големите икони с IconViewer за да видя и сравня съдържанието:

ICO-Big има следните изображения: 16, 32, 48, 64, 128, 256 пиксела, всичките 32 бита.
ICO-Small има следните изображения: 16, 32, 48, 64, 128, 256 пиксела, всичките 32 бита + още допълнителни пиксели с по-малко цветове.
Монитора ми е нагласен на 32 бита видимост.

Не мога да проумея защо се получава тази аномалия?

При десен клик "Изглед" задаване на опцията "Големи икони" прави само някои икони големи. Останалите остават същите - средни с квадрат около тях, който трябваше да бъде запълнен.

Ето ви разлика, много вероятно и вие да имате тази неразбория.

Проблемен файл, който да изследвате защо не става голям при положение, че има всичките резолюции.

2c6528d7dd51da7927e52d89ad107959.png

Редактирано от Mlechko (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Изглежда Микрософт не могат да си направят системата, а прехвърлиха няколко недоклатени уиндоуса.

И ОЩЕ! Просто вали като сняг!

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
публикувано (редактирано)

Пробвай да изтриеш кеша на иконите.
 

Spoiler
Цитат

:: Created by: Shawn Brink
:: http://www.sevenforums.com
:: Tutorial: http://www.sevenforums.com/tutorials/49819-icon-cache-rebuild.html

@echo off
set iconcache=%localappdata%\IconCache.db

echo The Explorer process must be killed to delete the Icon DB. 
echo.
echo Please SAVE ALL OPEN WORK before continuing.
echo.
pause
echo.
If exist "%iconcache%" goto delID
echo.
echo Icon DB has already been deleted. 
echo.
pause
exit /B

:delID
echo Attempting to delete Icon DB...
echo.
ie4uinit.exe -ClearIconCache
taskkill /IM explorer.exe /F 
del "%iconcache%" /A
del "%localappdata%\Microsoft\Windows\Explorer\iconcache*" /A 
echo.
echo Icon DB has been successfully deleted. Please "restart your PC" now to rebuild your icon cache.
echo.
start explorer.exe
pause
exit /B

 

Редактирано от DarkEdge (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
преди 2 часа, DarkEdge написа:

Пробвай да изтриеш кеша на иконите.

Защо? Той не е повреден. Ти също имаш малки иконки. Можеш да направиш лично експеримента на своя компютър докато сполучиш. При мен всичко се повтаря. Трудно ми е да рестартирам, затова излизам и пак влизам. Този кеш го бях трил ръчно преди, за да се поправи премахването на стрелки в иконите, на чието място се появиха черни квадрати. Явно иконата не се разпознава в DLL файла и трябваше да добавям външна. Да не би да е под друг номер?

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
публикувано (редактирано)
преди 5 часа, Mlechko написа:

Защо?

Ама ако искаш. Аз нямам малки икони, ти имаш.

С какво премахва стрелките? С промяна в регистратурата?
Пробвай с помощта на Winaero tweaker да премахнеш стрелките и да изтриеш кеша.

Редактирано от DarkEdge (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
преди 7 часа, DarkEdge написа:

С какво премахва стрелките? С промяна в регистратурата?

От първия път ми даде черни квадрати - ръчно от регистратурата.
Днес направих нов експеримент със стрелките на чисто след рестарт. Използвах рег файл със същата стойност и квадратите ги нямаше. Използвах рег файл да изтрия ключа за да се върнат стрелките. Върнаха се. Повторих стъпката този път с ръчно добавяне - квадрати нямаше. Зарадвах се. Изтрих ключа ръчно, логнах се да дойдат стрелките, дойдоха. Добавих ръчно втори път за премахване, логнах се и ето ти проблем - квадратите се завърнаха. След това колкото и да се логвам и добавям от рег файл, тези квадрати се появяват. Луда работа! Веднъж ставаше после не. И сега трябва наново да му оказвам външна икона. Имаш ли идея @DarkEdge защо се случва така?

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

За мен това е проблем с кеша на иконите. Опитай не с ръчна промяна на регистри или с добавяне от файл, а с туикъра на Winaero. Изтрий кеша и конфигурирай стрелката. И рестартирай, а не да се отписваш/вписваш. Да, знам, че отписването по принцип е достатъчно.

  • Любов 1

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Регистрирайте се или влезете в профила си за да коментирате

Трябва да имате регистрация за да може да коментирате това

Регистрирайте се

Създайте нова регистрация в нашия форум. Лесно е!

Нова регистрация

Вход

Имате регистрация? Влезте от тук.

Вход

×

Информация

Поставихме бисквитки на устройството ви за най-добро потребителско изживяване. Можете да промените настройките си за бисквитки, или в противен случай приемаме, че сте съгласни с нашите условия за ползване.