Премини към съдържанието
  • Добре дошли!

    Добре дошли в нашите форуми, пълни с полезна информация. Имате проблем с компютъра или телефона си? Публикувайте нова тема и ще намерите решение на всичките си проблеми. Общувайте свободно и открийте безброй нови приятели.

    Моля, регистрирайте се за да публикувате тема и да получите пълен достъп до всички функции.

     

Тамболианеца

Всичко за openSUSE - новини, въпроси, проблеми

Препоръчан отговор


преди 1 час, p4p написа:

Защото папката е празна, а когато има картинки в нея се показват веднага:

 

 

 

Разбрах къде греша. В папка Pictures не трябва да имам още една подпапка със тапети.

и тогава се зарежда...

screenshot.png

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Ти и мен ме разчовърка с тези тапети, бе :)
Попадна ми това: https://github.com/jacobmischka/gnome-background-xml и работи. Всъщност то е базирано на стари несъществуващи концепции от Gnome 3.8 в https://help.gnome.org/admin//system-admin-guide/3.8/backgrounds-extra.html.en , които не ги откривам в Gnome 3.26+, Gnome-аджийските дебелопери все нещо ги човърка непрекъсното да правят генерални промени. :hit:  Но пък работи без грешка включително и за Gnome 3.30, засега.

Та си наливаш всичките тапети в папка по твой избор, и стартираш този скрипт. Генерира се въпросния описващ xml файл в ~/.local/share/gnome-background-settings и трябва да бъде точно там. После рестартираш Гнома, и хоп - всичките ти тапети се появяват в таб 'Wallpapers'! В скрипта е заложено местоположение на тапетите, ~/Pictures/Wallpapers, но може да бъде практически навсякъде.

Скриптът изисква python3 и е напълно безобиден, защото ползва системните питонски библиотеки включени в дистрибуцията и не извършва нищо разрушително. Просто обхожда всичките файлове в тази папка с тапети и генерира необходимия текстови XML файл вследствие изпълнението си, вместо човек да го прави същото на ръка в нотепадовица.

Какво е предимството на цялата горна галимация? Ами тапетите са в отделна папка, а не омешани с всякакви други графични файлове в Pictures - да им имам логиката в ЮаЙя на Гномаджийте.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Здравейте и честито Рождество Христово на всички! :)
С openSUSE Leap 15 съм и имам следният проблем – при затваряне на капака на лаптопа (Fujitsu Celsius H710) Wi-Fi  връзката се губи. Човърках къде ли не – в опциите на KDE за Power Management съм задал при затваряне да не прави нищо; модифицирах и /etc/systemd/logind.conf по този начин:
 

[Login]
#NAutoVTs=6
#ReserveVT=6
#KillUserProcesses=no
#KillOnlyUsers=
#KillExcludeUsers=root
#InhibitDelayMaxSec=5
#HandlePowerKey=poweroff
#HandleSuspendKey=suspend
#HandleHibernateKey=hibernate
HandleLidSwitch=ignore
HandleLidSwitchDocked=ignore
#PowerKeyIgnoreInhibited=no
#SuspendKeyIgnoreInhibited=no
#HibernateKeyIgnoreInhibited=no
LidSwitchIgnoreInhibited=no
#HoldoffTimeoutSec=30s
#IdleAction=ignore
#IdleActionSec=30min
#RuntimeDirectorySize=10%
#RemoveIPC=no
#InhibitorsMax=8192
#SessionsMax=8192
#UserTasksMax=33%

...и пак същата работа. Рових и в BIOS за настройки - единственото, което имам ,е да изключа напълно хардуерният Power management и с това също не става. Пробвах и с промяна в /etc/Upower/Upower.conf:
 

IgnoreLid=true

– пак нищо. 
Някакви други идеи? :) Благодаря предварително! :)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Привет!

Всички настройки са по-подразбиране и връзката не прекъсва при затваряне и отваряне на капака на лаптопа (Dell 1747).

https://i.imgur.com/6o2bKEY.png

https://i.imgur.com/mt5cpqy.png

https://i.imgur.com/IzTqpVN.png


Сподели този отговор


Линк към този отговор
Сподели в други сайтове
преди 1 час, p4p написа:

Привет!

Всички настройки са по-подразбиране и връзката не прекъсва при затваряне и отваряне на капака на лаптопа (Dell 1747).

https://i.imgur.com/6o2bKEY.png

https://i.imgur.com/mt5cpqy.png

https://i.imgur.com/IzTqpVN.png

Ми да, ама не...остава да е нещо хардуерно контролирано, към което няма (лесен) достъп...

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Вероятно ползваш Бродком или друг лайнян драйвер, в КДЕ нищо не може да направиш. Първо дай изхода от

lspci | grep -i wireless

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
преди 2 часа, bvbfan написа:

Вероятно ползваш Бродком или друг лайнян драйвер, в КДЕ нищо не може да направиш. Първо дай изхода от

 

lspci | grep -i wireless

 

Тц. Atheros си е, най–добрите – AR9287/ath9k.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

За локализиране на проблема - пробвай да шунтираш всякакви конфиг файлове и GUI-та чрез изпълнение в конзолата:
iwconfig power wlan0 off ,
затвори капака на лаптопа и констатирай дали пак ти се губи пак WiFi връзката.

Ако не - направи си едно udev rule-че с тази команда, вместо да се губиш в  конфигурационни настройки, които може и да не map-ват правилно power режима на wifi-то;
Ако да - нещата са по-дебели и трябва да прегледаш кърнел параметрите за твоето WiFi в /sys/modules, за да разбереш какво точно се случва в зависимост от техните текущи стойности.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
преди 7 часа, whitepixel написа:

За локализиране на проблема - пробвай да шунтираш всякакви конфиг файлове и GUI-та чрез изпълнение в конзолата:
iwconfig power wlan0 off ,
затвори капака на лаптопа и констатирай дали пак ти се губи пак WiFi връзката.

Ако не - направи си едно udev rule-че с тази команда, вместо да се губиш в  конфигурационни настройки, които може и да не map-ват правилно power режима на wifi-то;
Ако да - нещата са по-дебели и трябва да прегледаш кърнел параметрите за твоето WiFi в /sys/modules, за да разбереш какво точно се случва в зависимост от техните текущи стойности.

iwconfig wlan0 power off

връща това:
 

Error for wireless request "Set Power Management" (8B2C) :
SET failed on device wlan0 ; Operation not supported.

 

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Жалко, че не става по лесния начин.

Еми значи, ако имаш желание можеш да почваш проби по дългия начин:
Към твоите вече пробвани конфигурационни файлове имаш още няколко допълнителни варианта с цел изключване на power management-a на WiFi-то (ако приемем, че това е проблемът за прекъсване на връзката след затваряне на капака на лаптопа):
- през конфига на NetworkingManager-a,  виж това: https://gist.github.com/jcberthon/ea8cfe278998968ba7c5a95344bc8b55
- през конфига на твоята карта - ath9k.conf, виж това: https://wiki.archlinux.org/index.php/Wireless_network_configuration#ath9k
- през допълнителен туулче tlp, виж това:  https://linrunner.de/en/tlp/tlp.html

Само да не се улисаш в туикове и да пропуснеш Нова година :)

Редактирано от whitepixel (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
преди 4 часа, whitepixel написа:

Жалко, че не става по лесния начин.

Еми значи, ако имаш желание можеш да почваш проби по дългия начин:
Към твоите вече пробвани конфигурационни файлове имаш още няколко допълнителни варианта с цел изключване на power management-a на WiFi-то (ако приемем, че това е проблемът за прекъсване на връзката след затваряне на капака на лаптопа):
- през конфига на NetworkingManager-a,  виж това: https://gist.github.com/jcberthon/ea8cfe278998968ba7c5a95344bc8b55
- през конфига на твоята карта - ath9k.conf, виж това: https://wiki.archlinux.org/index.php/Wireless_network_configuration#ath9k
- през допълнителен туулче tlp, виж това:  https://linrunner.de/en/tlp/tlp.html

Само да не се улисаш в туикове и да пропуснеш Нова година :)

Пробвах някои от нещата – не ще, така че засега го оставям за по–светли дни! :whiteflag:Благодаря и на другите за съветите!  Весело посрещане на Нова година на всички! :champagne1::emoji_smiley-95:

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Аз не разбрах какъв проблема, като затвориш и отвориш няма връзка ли?

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
преди 7 часа, bvbfan написа:

Аз не разбрах какъв проблема, като затвориш и отвориш няма връзка ли?

Да. :)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Здравейте! Пиша ви основно за информация, понеже не съм сигурен къде е бил проблема. Днес при включване на PC ми изписа, че нямам връзка с мрежата. Нищо не пипано по рутера както и по настройки на компютъра. Има WiFi, но по кабела няма връзка. Изключих и рестартирах рутера, преместих кабела в другите свободни букси, но без успех. После чрез телефона видях , че при такъв проблем се е ползвала следната команда: sudo netconfig update -f и взе, че стана. Цялата система се ъпдейтна. Нямам представа на какво се дължеше това.
 

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Ето нещо подобно на твоя проблем.  https://www.reddit.com/r/openSUSE/comments/8qaywo/opensuse_leap_15_connects_to_router_but_cannot/

 

Може би има и значение какво ползваш - wicked  или  network manager. 

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
преди 56 минути, Street Life написа:

Може би има и значение какво ползваш - wicked  или  network manager. 

Ползвам wicked. Така ми е по подразбиране. И съм по DHCP.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
на 14.01.2019 г. в 13:01, GermanecaBG написа:

Ползвам wicked. Така ми е по подразбиране. И съм по DHCP.

И аз си играх с wicked скоро, чисто за проба, само че с Wi-Fi и на мен също ми губеше връзката на следващия старт. Единственото, което трябваше да направя, е да си напиша паролата в 

/etc/sysconfig/network/

на последният ред WIRELESS_WPA_PSK=, освен, че я има на WIRELESS_WPA_PASSWORD=.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Ако някой от вас ползва Discord, моля да подскаже как да си ъпдейтна версията! Изписа ми, че има нова версия, но само в .deb и tar.gz. И не ми дава възможност да ползвам настоящата докато не я обновя. Сигурно трябва да изтегля пакета tar.gz, но от там нататък не знам как да процедирам за да инсталирам новата версия. 

 

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
преди 27 минути, p4p написа:

Ок, но при мен изписва версия 0.0.7, която е само в горепосочените пакети. И като кликна да отворя и ползвам Discord ми изкача съобщение, че има нова версия и трябва да избера кой пакет да инсталирам. Иначе официалната версия 0.0.5 я инсталирах чрез YaST

Ето и снимка

Screenshot-20190115-213000.png

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Инсталирах наличната версия.

Изтеглих новата - tar.gz. 

Разархивирах и копирах в /usr/lib64/discord.

След задаване на подходящи права тръгна:

https://i.imgur.com/R0hsTGT.png

 

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Перфектен си! Обаче аз не знам как да боравя с tar.gz. Какви са стъпките? Аз разархивирах и ми показа папка Discord. Ето какво има в нея.

Screenshot-20190115-214327.png

 

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Добавете отговор

Можете да публикувате отговор сега и да се регистрирате по-късно. Ако имате регистрация, влезте в профила си за да публикувате от него.

Гост
Напишете отговор в тази тема...

×   Вмъкнахте текст, който съдържа форматиране.   Премахни форматирането на текста

  Разрешени са само 75 емотикони.

×   Съдържанието от линка беше вградено автоматично.   Премахни съдържанието и покажи само линк

×   Съдържанието, което сте написали преди беше възстановено..   Изтрий всичко

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Добави ново...