Премини към съдържанието

Препоръчан отговор


Здравейте, ползвам убунту 18.04.1 със среда гном и вързан към него принтер Brother 20-30.Принтера много трудно тръгва от десетина опита само веднъж с успех принти.Моля за помощ как да го оправя да работи винаги когато му задам да принти нещо.Убунтуто е ъпдейтнато, принтера се отчита че е асоцииран към операционната система(това се вижда в настройките като влезна в секция "принтери"), драйвер менъджера не показва да има нужда от инсталирване на драйвер.В линукс минт 18 с който бях нямаше този проблем.Включвам принтера вкарвам юсбито в лаптопа, показва диалогов прозорец че се е асоциирал и като му задам принт - принти.В убунтото правя същото, показва си диалогов прозорец че се е асоциирал принтера но като му задам принт не всеки път иска.И започва ходене по мъките - сменям по всички юсбита, рестартирвам принтера, рестартирвам лаптопа и така по половин час докато извадя късмет и изпринти това което искам.В опциите нама нищо за настройка, само се вижда че има подкачен принтер и какъв е той(отговаря на този който му включвам) и се виждат и зададените страници за принтиране които обаче не тръгват....Трия ги от jobs след като изчакам няколко минути и не принти и пак му ги задавам или рестартирвам техниката и така до изнервяне.Моля за полмощ.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Прилича ми на проблем с драйвера,ако ненамериш  по-нов който да инсталираш пробвай с kernel 4.17 или по-висок.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

По скоро май трябва по - стар драйвер/кернрл защото със стара версия на убунту 16.04 и мента 17 и мента 18 нямаше проблем.Ама аз искам да си подкарам нещата с това убунту.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
преди 1 минута, Kopenhagen написа:

По скоро май трябва по - стар драйвер/кернрл защото със стара версия на убунту 16.04 и мента 17 и мента 18 нямаше проблем.Ама аз искам да си подкарам нещата с това убунту.

Не съм слагал  kernel назад и не знам как ще се отрази това на ОС,ама може да пробваш.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Аз не искам по стар кернел нито по нов.Не искам нищо различно от това - инсталирано стандартно Убунту 18.04.1 на което да ми тръгне принтера.


Сподели този отговор


Линк към този отговор
Сподели в други сайтове
Цитат
  1. Reinstall hplip

    
    sudo apt-get purge hplip
    sudo apt-get install hplip
    

    and

  2. add a second network printer. (Note that I had manually installed the newest hplip version in order to get the printer running which did not help and resulted in an error message after bootup, if you did not do this, maybe just step 2 is enough.)

    Even though there is a printer already shown in "Settings / Devices / Printers", I had to add a second printer as follows:

    1. Go to Settings → Devices → Printers.
    2. Additional Printer Settings
    3. Add Network Printer
    4. Choose the shown IP address or own printer name and follow the dialogues.

Това намерих в Askubuntu виж дали ще ти е от полза.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Първото преинсталира hplip и после пак същото е положението, не помогна.Второто е невъзможно да се приложи защото принтера сам си се добавя като сложа кабела а "add a second network printer" прави абсолютно същото , т.е. двете действия са еднозначни.Пробвах и това разбирасе още в началото като започнах да търся решение.Благодаря за помоща обаче :):):)

  • Харесва ми 1

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Към момента не мога да помогна, но ще проверя. В една фирма за ремонт на копирни машини, всички офис компютри са с Убунту 18.04. Ремонтират всякакви марки.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

бат'начо прав си сигурно но явно моя принтер е стар и не намирам никакви драйвери нито на официалната страница нито другаде....още пък по малко за линукс...Снощи инсталирах на чисто минт 18.3 и всичко си работи.То май новото убунту 18.04 и минт19 нещо май не са направени както трябва....Доста се оплакват по форумите и пишат че за сега е по добре да се стои на минт 18.3 Аз със новото убунту 18.04 имам проблем само с принтера, май и виното не искаше да се инсталира...абе и една две други не искаха ма не помна кои..а и да - има вграден микрокод и забрави за фирмен драйвер на нвидия, сложиш ли го и чупи системата.Радо84 е писал за това и е напълно прав.Сега се сещам, че и минт 18.3 е вече със същото ядро като убунту 18.04 - 4.15 версия, значи не е от драйвера, щом и минт 18.3 и убунту 18.04 са с абсолютно едни и същи ядра а в минт 18.3 принтера работи а в убунтут 18.04 прави проблеми.Значи е от нещо друго не е от драйвера!

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
преди 16 часа, Kopenhagen написа:

Здравейте, ползвам убунту 18.04.1 със среда гном и вързан към него принтер Brother 20-30.Принтера много трудно тръгва от десетина опита само веднъж с успех принти.Моля за помощ как да го оправя да работи винаги когато му задам да принти нещо.Убунтуто е ъпдейтнато, принтера се отчита че е асоцииран към операционната система(това се вижда в настройките като влезна в секция "принтери"), драйвер менъджера не показва да има нужда от инсталирване на драйвер.В линукс минт 18 с който бях нямаше този проблем.Включвам принтера вкарвам юсбито в лаптопа, показва диалогов прозорец че се е асоциирал и като му задам принт - принти.В убунтото правя същото, показва си диалогов прозорец че се е асоциирал принтера но като му задам принт не всеки път иска.И започва ходене по мъките - сменям по всички юсбита, рестартирвам принтера, рестартирвам лаптопа и така по половин час докато извадя късмет и изпринти това което искам.В опциите нама нищо за настройка, само се вижда че има подкачен принтер и какъв е той(отговаря на този който му включвам) и се виждат и зададените страници за принтиране които обаче не тръгват....Трия ги от jobs след като изчакам няколко минути и не принти и пак му ги задавам или рестартирвам техниката и така до изнервяне.Моля за полмощ.

Тоя принтер с един и същ драйвър ли работи и при двете дистрибуции? Ментата, мисля, че имаше и допълнителен комплект с драйвъри за хардуер.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Ами може и да си прав и да не е един и същи драйвера, но как да разбера?Ако това което пишеш е вярно значи напълно е вярно, че Минт е по добрия избор...

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Отваряш system-config-printer и проверяваш, кой драйвър е инсталиран.

През браузъра, можеш да отвориш настройките, като напишеш в адреса

localhost:631

В секция "управления на принтерите" излиза, кой принтер е добавен.

https://i.postimg.cc/tgj7XkD9/cups.png

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Е аз съм написал че там излиза че точно моя е добавен.Това съм го проверил още от самото начало.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
преди 2 часа, Kopenhagen написа:

бат'начо прав си сигурно но явно моя принтер е стар и не намирам никакви драйвери нито на официалната страница нито другаде....още пък по малко за линукс..

Когато промениш езика не предлага нищо, така ли? Имам предвид - дори и нещо пакетирано в не-deb формат, нещо което се казва driver install tool.

1302559994_.png.b972e948cd3a3bbd60041ec709722775.png

 

Всъщност търси от тук.

Може да си свалиш stacer (по-добре апимиджа) и да видиш през него дали е пуснат сервиза за cups профилактично (и за други работи става).

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Тоз принтер неще на убунту и неще...а на ментата ще...ама ментата е 18, на 19ката и на нея не ще....То пък ме кефи убунтуту а ментата не толкова...май ще сменям принтера

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
преди 6 минути, Kopenhagen написа:

Тоз принтер неще на убунту и неще...а на ментата ще...ама ментата е 18, на 19ката и на нея не ще....То пък ме кефи убунтуту а ментата не толкова...май ще сменям принтера

Значи, проблема е в новата версия на CUPS и/или драйвъра. Ако е работна машина не се изхвърляй на много нови версии. Важното е да ти върши работа.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Не е работна домашен лаптип ама по някога се налага и да принта по нещо.Не разбирам защо правят новите неща да не работят както трябва....Ето например убунту 10.04 пеше перфектно, ама перфектно!Какво им пречеше да си го поддържат само от време на време да сменят ядрото и нещата щяха да са супер.Ами гнома?Двойката - изряден от всякъде, тройката - шитня която вече няколко години никой не иска да ползава ама те продължават да си я доразработват.Създадена с идеята да е за таблети а не се ползава на нито един на планетата.Защо тогава продължават да произвеждат години наред този гном който никой не иска???Недоумявам.Махнете тези простотии, сложете лентат отдолу където и за пеленаче е ясно че е най удобно, ама те не, мъчат се с тази тяхна безсмислица и така глупуста е необятна.Май не ги интересуваме, за това така правят гнома, чешат си егото, мислят се за свтила а всъщност са дръвници.И тяхната шитня грее като десктоп по дефолт на повечето дистрибуции защото е най изгодна от всички среди защото е най довършена.КДЕто все едно че го правим ние с комшията - с по две леви ръце, бъгаво , недовършено...ама иначе великото КДЕ???Страшна глупост и недовършеност.ЛХДЕ никога не е претендирало за нещо за масово ползване а и те се отказаха от него иначе не беше лошо.ХФЦЕ...то пък там имам чувството че разработчиците го правят в почивните си дни ако им остане време.Стоят десет години на едно място.Едни икони нямат като хората.Поклон разбира се пред всички разработчици защото без тях и това нямаше да има, ама....поне свалете лентата в гнома долу, всички го казват че така искат, какво толкова да го направиш да е удобно?Никой не ме кара насила да го ползавам, ама...изделието им е тъпо.

  • Харесва ми 1

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
преди 14 минути, Kopenhagen написа:

Не е работна домашен лаптип ама по някога се налага и да принта по нещо.Не разбирам защо правят новите неща да не работят както трябва....Ето например убунту 10.04 пеше перфектно, ама перфектно!Какво им пречеше да си го поддържат само от време на време да сменят ядрото и нещата щяха да са супер.

Това лято видях на практика, че Debian 6 Squeeze е напълно използваема, ако знаеш как да надградиш ядрото и библиотеките за да върви на нея актуална версия на Firefox. Същото може да се направи и с Ubuntu 10.04 и се прави с CENTOS6. Но ти можеш просто да ползваш Ubuntu 16.04 с MATE и ще имаш актуални приложения и работещ принтер.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

16.04 на убунту мате ще се поддържа до април 2019, т.е още няколко месеца.Знам че отдолу убунту ще поддържат до април 2021 но десктопа ще се поддържа до април 2019.След това никой не може да каже кое няма да работи както трябва и дали всичко ще е наред.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Та значи, на 18.04 би трябвало да имаш инсталирано (със зависимостите) brother-lpr-drivers-laser.

Или да си свалиш Driver Install Tool/linux-brprinter-installer-2.2.1-1 (актуалната версия към днешна дата), да го разархивираш  и изпълниш в папката с файла

sudo bash linux-brprinter-installer-2.2.1-1 HL-2030

 

Говоря леко наизуст, след малък поглед в Синаптик и съдържанието на linux-brprinter-installer-2.2.1-1.

Щом ти е по-лесно да смениш принтера - направи го.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

"Щом ти е по-лесно да смениш принтера - направи го. " аз се майтапех, ама  и ти имаш чувство за хумор :):):) Това е хубаво иначе бат'начо мерси много за помоща.Проблемът е, че точно този драйвер си е инсталиран по дефолт точно тази версия.Това показва синаптика след като го добавих и него защото той отсъства в убунту.Същата версия на драйвера е и в минт 18.3 а там всичко работи.Това ме навежда на мисълта, че проблема не е от драйвера, а от друго, сигурно от това което киберкоп ми писа.Драйверите в минт 18.3 и убунту 18.04.1 за този принтер са абсолютно идентични, то и ядрата на двете дистрибуции са също идентични - версия 4.15.нещо си.Това е последния излезнал драйвер за принтера от преди години и сигурно върви в ядрата на линукс от десетки версии на ядрото назад.Този драйвер в тази си весия е на 7-8 години, сети се че сигурно същия е от версия на ядрото 2.трйсет и нещо си.....и ако сложа убунту 10.04 вътре ще е същия , но съм сигурен, че с убунту 10.04 принтера ще тръгне от раз.Не, проблемът не е в драйвера, в нещо друго е.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Накара ме да погледна повече инсталатора ;). Добави си хранилището на mono в 18.04 и опитай пак. Pinta и в аналогичната версия на Ментата крашва и тя е mono-зависима. Не знам дали ще помогне за принтера, но може да се пробва и така.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Дали не трябва да е нещо такова

sudo dpkg --add-architecture i386

sudo apt update

sudo apt install lib32ncurses5 lib32z1 lib32gcc1 lib32stdc++6 libc6-i386

sudo apt install brother-lpr-drivers-laser:i386 brother-cups-wrapper-laser:i386

 

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Добавям 386 архитектирата , но след ъпдейта като му задам следващите команди ми казава че вече са инсталирани пакетите.Иначе от предния ти пост добавих mono но нищо не се променя или аз поне не забелязвам някаква разлика в убунтуто.Ъпдейтвам и ъпгрейтвам разбира се :)И други работи из гугал пробвах и май съм омазъл убунтуту и ще го преинсталирам на чисто и ще опитам пак с твоите команди бат'начо.А Pinta за какво служи, чувал съмя но не съм запознат какво прави.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Регистрирайте се или влезете в профила си за да коментирате

Трябва да имате регистрация за да може да коментирате това

Регистрирайте се

Създайте нова регистрация в нашия форум. Лесно е!

Нова регистрация

Вход

Имате регистрация? Влезте от тук.

Вход

×

Информация

Поставихме бисквитки на устройството ви за най-добро потребителско изживяване. Можете да промените настройките си за бисквитки, или в противен случай приемаме, че сте съгласни с нашите условия за ползване.