Премини към съдържанието
  • Добре дошли!

    Добре дошли в нашите форуми, пълни с полезна информация. Имате проблем с компютъра или телефона си? Публикувайте нова тема и ще намерите решение на всичките си проблеми. Общувайте свободно и открийте безброй нови приятели.

    Моля, регистрирайте се за да публикувате тема и да получите пълен достъп до всички функции.

     

petie1

Всичко за Debian и неговите внучета - новини, въпроси, проблеми

Препоръчан отговор


преди 30 минути, malosi написа:

Ами защото до сега не съм бъркал в менюто на 40_custom  и не знам как!

А то по принцип в 40_custom няма нищо файла е празен и в него се пишат собствени менюта ето моя файл 40_custom за живи образи за манжата виж в нета

40_custom

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Значи накрая останах само със Дебиан дадох му цялото SSD  мир да е !!!  Обаче, липсва ми четеца за ел. книги  coolreader няма го из хранилищата.

Все още се бъгват някои програми като  apper   например  при стартиране излиза от ляво горе и в момента в които опитам да го преместя е до там!

Малко бавен и тромав ми се вижда при положение,че е инсталиран на SSD и компа е със добри характеристики.

Трябваше да добавям ръчно хранилища , Discover  20десет минути търси актуализации , 20десет минути!!!  Търси ама няма! Рестарт и след час самодоволно ми съобщава, че имал нам си колко

за актуализиране ! Като оставим това на страна всичко друго си е на ред, а и не знам защо все ми иска парола кат за root ?

За обобщение - различна ос,различни настройки,различна визия  харесва ми по всичко личи ,че ще остана с Дебианчо.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
преди 1 час, malosi написа:

Значи накрая останах само със Дебиан дадох му цялото SSD  мир да е !!!  Обаче, липсва ми четеца за ел. книги  coolreader няма го из хранилищата.

Пробвай fbreader. Инсталирай deb-овете, по-нова версия ще се появи (а, дано) като затрият qt4 напълно, така че по-нова версия няма да има скооро.

Или пък sudo apt install fbreader.

 

Вариант 2 - компилираш си го или като снап, щом харесваш CR.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Окуляра си е идеален четец за КДЕ другия който ти препоръчвам е калибре а за обновненията аз си ги правя през конзолата че по лесно

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
преди 1 час, бат'начо написа:

Пробвай fbreader. Инсталирай deb-овете, по-нова версия ще се появи (а, дано) като затрият qt4 напълно, така че по-нова версия няма да има скооро.

Или пък sudo apt install fbreader.

 

Вариант 2 - компилираш си го или като снап, щом харесваш CR.

Току що инсталирах fbreader  ама не мога да му намеря цаката да превърта цялата  страница със стрелките на клавиатурата  която в моят случаи е 31 реда.

А не само 20десет което е максимума в настройките .

Докогато бях на Минт инсталирах от снап cool reader 3 и нищо не се стартираше! Това за компилирането не го разбирам!

преди 15 минути, petie1 написа:

Окуляра си е идеален четец за КДЕ другия който ти препоръчвам е калибре а за обновненията аз си ги правя през конзолата че по лесно

Окуляра ще го потърся за проба. Калибрето  нещо не ме кефи! Много претрупана !

Под какво име да го търся това окуляра ?


Сподели този отговор


Линк към този отговор
Сподели в други сайтове
преди 6 минути, malosi написа:

Окуляра

Окуляр прилича на Адобе ридър и би трябввало да я има в КДЕ готова за работа

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
преди 1 час, malosi написа:

Под какво име да го търся това окуляра ?

okular

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
преди 2 минути, бат'начо написа:

Пробвай тогава това дали ще се инсталира в Дебиана или ще изреве за нещо.

Едва ли ще стане

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Ами пробвай и кажи дали може. Ти си по-напред с материала.

При мен (Xubuntu-18.04) се инсталира без нищо отгоре. Да, това е Дебиан, даже и да се инсталира, нема гаранция, че ще работи както при мен. Но какво пречи да се пробва. Нъл'?

А пък (ако помня вярно) malosi има някакви базови познания (май с ЕлементариОС).

 

Дебиан ще имам утре (вече днес) щото не щя да "захапе" caprine. А тва ми необходимо средство (вече). И ще трябва да го направя да работи (капринето).

 

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

sudo apt-get install snapd -y

sudo snap install coolreader3

Това е най лесния начин да го инсталира щот с пакетите на @бат'начо пищи за две зависимости

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
преди 3 часа, petie1 написа:

sudo apt-get install snapd -y
sudo snap install coolreader3
Това е най лесния начин да го инсталира щот с пакетите на @бат'начо пищи за две зависимости

И ти ли, Бруте?

Snapd e прикрито Зло. Ако някой има намерение да ползва snapd му препоръчвам да не го прилага в Дебиан, а по-добре да се ориентира към Убунту. А още по-добре Уиндоус, защото сигурността в Уиндоус е по-добра отколкото съчетанието Линукс + snapd, тъй като поне в Уиндоус сами си пакетират приложенията и то от професионалисти. Някой да си спомня пакетирания миньор преди година време в snap пакет? Очаквайте още такива случаи, защото отговорността за пакетиране на приложенията е на трети страни и не винаги минали през класическия контрол на дистрибуциите.
Както от лично snapcraft признават:
In the classic Ubuntu repositories, we have the great privilege to work only with software built on trusted infrastructure, from source. That has obvious advantages but also requires a very long time for new bits to show up for millions of users. Snaps enable a much more direct path for publishers to deliver their software to users across a wide range of Linux distributions, ensuring that those apps are securely confined.
Да се разбира: ние се НАДЯВАМЕ, че пакетиращите  няма да злоупотребяват.
Повече: https://snapcraft.io/blog/trust-and-security-in-the-snap-store

А защо snapd е прикрито зло? Защото ви отнема свободата на контрол върху входа на системата и ви натриса неотменими ъпдейти, които не можете да спрете досущ както в Уиндоус, и досущ както там можете само да отложите до 1 месец време през refresh.timer, или отлагане до 60 дни през referesh.hold бъдеща календарна дата. Други варианти са да се мъчите да спирате всичките наведнъж през metered конекции, или пипкате индивидуално през enable/disable за времето на ъпдейтa. Snapd демонът - или всичко или нищо, спрете ли го - спирате и всички си snap приложения също.
Да споменавам ли, че snapd напира да шунтира от употреба даже и systemd в контекста на сървиси за инсталираните от snapd приложения/сървъри?

Повече за "чудото" snap директно от извора:
https://snapcraft.io/docs/keeping-snaps-up-to-date
https://snapcraft.io/docs/system-options

Редактирано от Тамболианеца (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
преди 1 час, Тамболианеца написа:

И ти ли, Бруте?

Snapd e прикрито Зло. Ако някой има намерение да ползва snapd му препоръчвам да не го прилага в Дебиан, а по-добре да се ориентира към Убунту. А още по-добре Уиндоус, защото сигурността в Уиндоус е по-добра отколкото съчетанието Линукс + snapd, тъй като поне в Уиндоус сами си пакетират приложенията и то от професионалисти. Някой да си спомня пакетирания миньор преди година време в snap пакет? Очаквайте още такива случаи, защото отговорността за пакетиране на приложенията е на трети страни и не винаги минали през класическия контрол на дистрибуциите.
Както от лично snapcraft признават:
In the classic Ubuntu repositories, we have the great privilege to work only with software built on trusted infrastructure, from source. That has obvious advantages but also requires a very long time for new bits to show up for millions of users. Snaps enable a much more direct path for publishers to deliver their software to users across a wide range of Linux distributions, ensuring that those apps are securely confined.
Да се разбира: ние се НАДЯВАМЕ, че пакетиращите  няма да злоупотребяват.
Повече: https://snapcraft.io/blog/trust-and-security-in-the-snap-store

А защо snapd е прикрито зло? Защото ви отнема свободата на контрол върху входа на системата и ви натриса неотменими ъпдейти, които не можете да спрете досущ както в Уиндоус, и досущ както там можете само да отложите до 1 месец време през refresh.timer, или отлагане до 60 дни през referesh.hold бъдеща календарна дата. Други варианти са да се мъчите да спирате всичките наведнъж през metered конекции, или пипкате индивидуално през enable/disable за времето на ъпдейтa. Snapd демонът - или всичко или нищо, спрете ли го - спирате и всички си snap приложения също.
Да споменавам ли, че snapd напира да шунтира от употреба даже и systemd в контекста на сървиси за инсталираните от snapd приложения/сървъри?

Повече за "чудото" snap директно от извора:
https://snapcraft.io/docs/keeping-snaps-up-to-date
https://snapcraft.io/docs/system-options

Казах че е най лесния начин а не най добрия което са две различни неща освен ако не иска да човърка от сорс код или да решава зависимостите на бат'начо

 

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
преди 1 час, Street Life написа:

Здравейте всички!

Видях, че има тема за Дебиан, но съм начинаещ и въпросите си задавам тук.

Имам настолен компютър със CPU Ryzen 2600, GPU Radeon RX560 4GB, RAM 16GB. Купих си HDD Seagate Barracuda 2 TB за да си инсталирам Линукс. Основно ползвам Уиндоус, но на новия диск ще имам само Линукс. Разпеторих се каква графична среда да избера: GNOME, KDE, Xfce, Cinnamon, Mate!

Избрах GNOME, защото пишеше, че тя е била основната среда на големите компании и най-много усилия влагали там. Направих си жива флашка с Debian 10 GNOME + non-free хранилища. Разцъках го и поне преди инсталацията всичко работеше. И преди да премина към инсталация, моля за съвет.

- След като инсталирам Дебиан ще имам ли non-free хранилищата или трябва ръчно да ги добавя както е писано във форумите и показано в клипове от youtube?

- В едно видео от тубата казваха, че графичната среда GNOME имала проблеми с инсталирането на програми от Synaptic. Трябвало да се смени сесията? Това много не ми е ясно.

Благодаря ако някой ми обърне внимание!

Цитирах ти въпроса, където му е мястото.

По-долу е пълният списък от хранилищата на Debian-Buster, и който засега е удобно да държиш в един файл - /etc/apt/sources.list

# buster essential
deb http://deb.debian.org/debian/ buster main contrib non-free
deb-src http://deb.debian.org/debian/ buster main contrib non-free

# buster-security
deb http://security.debian.org/debian-security buster/updates main contrib non-free
deb-src http://security.debian.org/debian-security buster/updates main contrib non-free

# buster-updates, previously known as 'volatile'
deb http://deb.debian.org/debian/ buster-updates main contrib non-free
deb-src http://deb.debian.org/debian/ buster-updates main contrib non-free

# buster-backports, previously on backports.debian.org
deb http://deb.debian.org/debian/ buster-backports main contrib non-free
deb-src http://deb.debian.org/debian/ buster-backports main contrib non-free

# buster-backports-sloppy
# deb http://deb.debian.org/debian buster-backports-sloppy main contrib non-free # available after bullseye release
# deb-src http://deb.debian.org/debian buster-backports-sloppy main contrib # available after bullseye release

 

По въпроса за Synaptic, ако не си свикнал с него по-добре и не свиквай с тази бъгня, използвай конзолния apt или aptitude. Препоръчвам второто.
Ако все пак твърдо държиш и на графичен интерфейс, можеш да пробваш и Aptitude в TUI режим.
https://debian-handbook.info/browse/stable/sect.apt-frontends.html 

Редактирано от Тамболианеца (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

@Тамболианеца

Опитите да се обърка и вкара във филми начинаещ потребител е далеч от разбирането за помощ. Synaptic е класика за Debian. Стар, изпитан и лесен за работа графичен интерфейс за работа с APT. 

https://i.postimg.cc/DfWzmKqQ/Synaptic.png

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Ми хубаво, щом така казваш.
Значи теб да пита при проблеми като си омаже системата и не му тръгнат X/Wayland и съответно Synaptic, a трябва да инсталира нещо от презряната конзола, за да си вдигне системата пак.

Редактирано от Тамболианеца (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
преди 12 минути, Тамболианеца написа:

Ми хубаво, щом така казваш.
Значи теб да пита за проблеми като си омаже системата и не му тръгнат X/Wayland и съответно Synaptic, a трябва да инсталира нещо от презряната конзола, за да си вдигне системата пак.

Ако си омаже системата се съмнявам, че това ще стане, защото не е ползвал "Aptitude в TUI режим". Като се появи проблем, ще зададе въпрос. Ще му отговори този, който може да му реши проблема (вероятно и други, които не могат). 

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
преди 2 часа, cybercop написа:

Няма как да имаш проблеми със Synaptic под Gnome. Не знам, къде си прочел това.

 

 

 

Ето в това видео. Около 7:48'' казва, че има проблем със Синаптик в Wayland.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
преди 9 минути, Street Life написа:

Ето в това видео. Около 7:48'' казва, че има проблем със Синаптик в Wayland.

Аз съм ползвал Buster само под Xfce и X.org. И да не работи, ще ползва друго приложение. Нали имаше някакъв Gnome инсталатор.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
преди 1 час, Street Life написа:

Ето в това видео. Около 7:48'' казва, че има проблем със Синаптик в Wayland.

Това за теб означава, че ако искаш да ползваш Synaptic, но си стартирал Wayland сесия (GNOME), ще трябва да направиш logout до начален графичен екран (7:52 на видеото) и избереш "GNOME on Xorg" сесия. Има и допълнителна тъпня - GNOME с един потребител няма logout - или трябва да добавиш 2-ри потребител, за да ти се появи като възможност, или трябва да си рестартираш изцяло компа, за да стигнеш до заветното начално меню, ако си с един потребител.

Редактирано от Тамболианеца (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Ммм, така ли ми се струва или наистина Дебиан не е за начинаещи. Има си Минт Дебиан, още не е с 10-ката, който пак не е за абсолютно начинаещи, ама малко по-се ядва. А пък иначе, според мен, начинаещия трябва да е свободен да избира с какво да "се хване" ама малко да му иде отръки четенето. И да е наясно, че кой да е Линукс е Линукс, дзвер дето досега не е ползвал и не знае нищо за него.

преди 10 часа, petie1 написа:

sudo apt-get install snapd -y

sudo snap install coolreader3

Това е най лесния начин да го инсталира щот с пакетите на @бат'начо пищи за две зависимости

Има още едно хранилище за Убунту-18.04 на cr3, на което не вярвам по принцип, гледайки какво е пакетирано в другите хранилища на аркадаша и дата на добавяне на пакетите. За кои зависимости реве?

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
преди 1 час, бат'начо написа:

Ммм, така ли ми се струва или наистина Дебиан не е за начинаещи.

С Xfce си става за начинаещи с малко питане. А, от това, което Тамболианеца пише се вижда, че Gnome е претърпяла сериозна еволюция. От интуитивна среда с която може всеки да работи, до среда за потребители с висши познания в областта на софтуера, хардуера и окултното.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
преди 11 часа, petie1 написа:

sudo apt-get install snapd -y

sudo snap install coolreader3

Това е най лесния начин да го инсталира щот с пакетите на @бат'начо пищи за две зависимости

Що при мен пищи за една.

spacer.png

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Добавете отговор

Можете да публикувате отговор сега и да се регистрирате по-късно. Ако имате регистрация, влезте в профила си за да публикувате от него.

Гост
Напишете отговор в тази тема...

×   Вмъкнахте текст, който съдържа форматиране.   Премахни форматирането на текста

  Разрешени са само 75 емотикони.

×   Съдържанието от линка беше вградено автоматично.   Премахни съдържанието и покажи само линк

×   Съдържанието, което сте написали преди беше възстановено..   Изтрий всичко

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Добави ново...