Премини към съдържанието
  • Добре дошли!

    Добре дошли в нашите форуми, пълни с полезна информация. Имате проблем с компютъра или телефона си? Публикувайте нова тема и ще намерите решение на всичките си проблеми. Общувайте свободно и открийте безброй нови приятели.

    Моля, регистрирайте се за да публикувате тема и да получите пълен достъп до всички функции.

     

Препоръчан отговор


Здравейте, направих dual boot със Windows 10 и ElementaryOS(Ubuntu базирана). Проблема е, че Windows 10 зарежда автоматично без да излиза опцията да избирам, коя от ОС да се зареди при стартиране на компютъра. Във UEFI настройките при boot опциите имам избор да избера Ubuntu, или Windows boot manager, когато избера ubuntu и запазя настройките нещатата се оправят, докато не избера да се зареди Windows 10 и пак автоматична си се зарежда Windows 10 без да ме пита, докато пак не сменя boot настройката в UEFI.

Чудех се да не би проблема да е поради това, че когато правих флашката да инсталира Windows 10 избрах iso файлът да се записва в GPT формат. Използвах програмта RUFUS за да напвая флашката bootable с Windows 10 инсталацията. Както винаги първо инсталирах Windows 10, после Elementary OS.

Преди инсталирах от дискове и никога не съм имал проблеми с dual boot-а. Този път реших да използвам флашка.

 

opadopa.jpg

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

От boot менюто на линукса не можеш ли да избираш windows?

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Когато избера boot опцията да е ubuntu 1-во място всичко си е както трябва, докато не избера от GRUB да се зареди Windows 10 тогава вече автоматично ме вкарва в Windows при всяко включване или рестарт на компютъра.

Когато в UEFI сложа ubuntu на 1-во място всичко си е както трябва, подобно на картинката.

spacer.png

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

https://itsfoss.com/install-ubuntu-1404-dual-boot-mode-windows-8-81-uefi/

Накрая има команда, с която да добавиш убунту към буут менюто на бозата. Само виж дали пътя при теб е същия, както и името на файла.

Всъщност сега тествах и при мен дали ще стане това, понеже и аз съм с линукс и уиндоус на единия диск. Въведох командата с параметрите по същия начин и при стартиране ме вкарва директно в менюто на линукс.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Под Windows стартирай msconfig и в раздела Boot виж има ли запис за ubuntu.
Погледни това


Сподели този отговор


Линк към този отговор
Сподели в други сайтове

1 забрани  в windows fast startup... https://www.windowscentral.com/how-disable-windows-10-fast-startup

вариант 2 спри в биос uefi, остави само legacy, ще трябва да конвертираш диска в mbr (преди това правиш бекъп на ценната информация)  и инсталираш наново - това работи безотказно...

некадърно написаното uefi е измислено от някакви интелски глупаци:

1 ползва се несигурния фат 32

2 позволява на о.с. (само лайняндоус 8 и 10 да пипат настройки в биос)  както и ако има вирус в нея също да ги променя

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
преди 3 часа, the professor написа:

1 забрани  в windows fast startup... https://www.windowscentral.com/how-disable-windows-10-fast-startup

вариант 2 спри в биос uefi, остави само legacy, ще трябва да конвертираш диска в mbr (преди това правиш бекъп на ценната информация)  и инсталираш наново - това работи безотказно...

некадърно написаното uefi е измислено от някакви интелски глупаци:

1 ползва се несигурния фат 32

2 позволява на о.с. (само лайняндоус 8 и 10 да пипат настройки в биос)  както и ако има вирус в нея също да ги променя

И какво му е некадърното, като си го ползвам от години на различни машини и си работи супер, също спестява някоя и друга секунда при зареждане на ОС. След като си инсталирал под UEFI, можеш да смениш в BIOS на CSM и да си стартираш системата, пак ще зареди нормално. За да не се пипа в BIOS, има настройка Secure boot, а и принципно дори и без UEFI пак има вируси, които могат да "пипат" там:

https://www.howtogeek.com/116569/htg-explains-how-windows-8s-secure-boot-feature-works-what-it-means-for-linux/

Освен това съм написал начин, който му оправя проблема, като го тествах преди това.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Така като гледам няма ubuntu запис във System Configuration в boot раздела

asdag.png

Също да питам дали е възможно това да е станало заради това, че като правих флашката да е bootable с Windows 10 инсталацията, бях избрал iso файлът да се запише в GPT формат? Просто да знам за нататък просто пак да си избирам Флашката да се форматира във MBR.

Също така изключих Fast boot опцията, все още не съм си играл да видя дали всичко е наред вече, що проверя по-късно.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
преди 13 минути, NerdyBurdy написа:

Така като гледам няма ubuntu запис във System Configuration в boot раздела

 

Също да питам дали е възможно това да е станало заради това, че като правих флашката да е bootable с Windows 10 инсталацията, бях избрал iso файлът да се запише в GPT формат? Просто да знам за нататък просто пак да си избирам Флашката да се форматира във MBR.

Също така изключих Fast boot опцията, все още не съм си играл да видя дали всичко е наред вече, що проверя по-късно.

А направи ли това, което ти казах?

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
преди 4 минути, Raze написа:

А направи ли това, което ти казах?

Все още не, ще сменя пак на ubuntu от boot опциите на UEFI и ще видя дали ще се запазят този път настройките, понеже нали уж може и от fast boot да е бил проблема. Само, че не съм в нас и не мога да тествам в момента, ако не се получи ще пробвам тоя код да го напиша, който е в статията, която ми даде.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Не е код, но върши работа - на лаптопа го тествах и работи.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Премахването на Fastboot не помогна, но коментара на @Raze и командата от статията, която е постнал поправи нещатата.

https://itsfoss.com/install-ubuntu-1404-dual-boot-mode-windows-8-81-uefi/

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Добавете отговор

Можете да публикувате отговор сега и да се регистрирате по-късно. Ако имате регистрация, влезте в профила си за да публикувате от него.

Гост
Напишете отговор в тази тема...

×   Вмъкнахте текст, който съдържа форматиране.   Премахни форматирането на текста

  Разрешени са само 75 емотикони.

×   Съдържанието от линка беше вградено автоматично.   Премахни съдържанието и покажи само линк

×   Съдържанието, което сте написали преди беше възстановено..   Изтрий всичко

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Добави ново...