Премини към съдържанието
  • Добре дошли!

    Добре дошли в нашите форуми, пълни с полезна информация. Имате проблем с компютъра или телефона си? Публикувайте нова тема и ще намерите решение на всичките си проблеми. Общувайте свободно и открийте безброй нови приятели.

    Моля, регистрирайте се за да публикувате тема и да получите пълен достъп до всички функции.

     

Препоръчан отговор


Привет. Не знам дали темата е за тук или за Операционни системи . Трябва да си подкарам Django на HP-UX, проблемът е обаче че никъде не намирам инсталационен пакет за версия 3 на питон( софтуера си го  свалям и инсталирам от тук -http://hpux.connect.org.uk/  - има само някаква антична 2.7 ( а бастуните от HP препоръчват още по стара версия 2.5.2 - уж била най-добре пакетирана - не знам честно какво имат предвид) и проектът който е писан на python3 100 процента няма да тръгне, а не ми се пренаписва за версия на питоня, която лека полека ще бъде депрекейтната. Искам да ползвам HP-UX, тъй като е изключително надеждна машинка като софтуер и хардуер. Има пакет на Питон3 за AIX но за Шпукс - нъц. В крайна сметка ако няма ще трябва да дуал буутна машинката или с Джентуу или FreeBSD 10 ,тъй като тази архитектура не поддържа много ОС-и а държа проекта да не се хоства на някой надупчен x86.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Представям си, че може да стане, ако следваш някой от следните подходи:

1. Знаменития pkgsrc от NetBSD - http://wiki.netbsd.org/pkgsrc/how_to_use_pkgsrc_on_hp-ux/

2. Билднеш по-нов компилатор и библиотеки. Предполагам, че това им пречи да пуснат 3+ версия официално.

3. Крос компилинг. Може би от FreeBSD или нещо друго, което поддържа архитектурата. Ще е много трудно и занимателно, обаче.

 

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Тези играчки ми бяха жизненоважни:
python3-pip
PyQt5
paho-mqtt
 PyQt5

и минах от тук.

Index of /ftp/python/3.6.9/

spacer.png

поздрави!


Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Само дето ОС-а е HP-UX а не Linux . И компилирането гърми със сумати грешки. Реално няма инсталиран питон3, трябва да се плати за някаква шитня, от които половината неща не ми трябват.Толкова ли не можаха да направят един depot пакет... да им се невиди и бастунджиите:angry23: от х*йлет пакърд :angry22:

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Добавете отговор

Можете да публикувате отговор сега и да се регистрирате по-късно. Ако имате регистрация, влезте в профила си за да публикувате от него.

Гост
Напишете отговор в тази тема...

×   Вмъкнахте текст, който съдържа форматиране.   Премахни форматирането на текста

  Разрешени са само 75 емотикони.

×   Съдържанието от линка беше вградено автоматично.   Премахни съдържанието и покажи само линк

×   Съдържанието, което сте написали преди беше възстановено..   Изтрий всичко

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Добави ново...