Премини към съдържанието
  • Добре дошли!

    Добре дошли в нашите форуми, пълни с полезна информация. Имате проблем с компютъра или телефона си? Публикувайте нова тема и ще намерите решение на всичките си проблеми. Общувайте свободно и открийте безброй нови приятели.

    Моля, регистрирайте се за да публикувате тема и да получите пълен достъп до всички функции.

     

Проблем с Линукс райд 1


Препоръчан отговор


Експериментирам си с един компютър с 4 диска и Сент ОС 7

Имам 2х128ГБ ССД, които са разделени на

/boot - 1GB 

/ - 120 GB 

swap -3GB 

4ГБ оставени празни за релокация на клетки и съответно мд0, мд1, мд2 устройства за първите три дяла.

Има още 2 диска по 500ГБ ХДД, които образуват мд3 устройство и се монтират като /home.

Инсталирам системата и всичко е ток и жица! С уебмин контолирам нещата и райда е 6+! 

Както казах, експериментирам с това и изключвам единия диск от сата кабела. Компютъра стартира само с един диск и ми показва, че райда е разграден. Изключвам го, включвам изключения диск, стартирам и с уебмина си събирам райда. Възстановява се и всичко е ток и жица. Същата операция се повтаря и с другия диск. Деградира райда, после се възстановява и няма проблеми.

Проблема идва, когато се опитвам да имитирам ситуация със замяна на диска, поради скапване на някой от двата в процес на работата.

Буутвам от Минт лайв СД и забърсвам целия първи диск, като пускам направо нова партишън таблица и диска е вече без партишъни. Идеята е, да стартира компа и с уебмин да си направя нови партишъни на диска и да възстановя райда. Е да, ама компа не стартира! Черен екран и нищо не зарежда! Измъквам сата кабела на този изтрития диск и компа си стартира от другия с разграден райд безпроблемно. Включвам сата кабела на диска и компа не стартира!

Къде бъркам Другарчета ситуацията не разбирам :( !!!? 

Линк към този отговор
Сподели в други сайтове

Ако размениш SATA порта на зареждащия с празния диск?

Двата SSD диска еднакви ли са като марка и модел? Ако да - пробвай с различен и виж точно кой диск е указан в биос да зарежда.

4ГБ оставени празни  - може би трябва да оставяш по 10GB празни - имаш SSD 120GB и 128GB - не се знае какъв диск би намерил ако трябва да вдигаш спешно истинска машина. Разбира се винаги имаш 240-256GB и повече, но просто като идея.

Линк към този отговор
Сподели в други сайтове

Двата диска са еднаква марка и по отделно като им изключвам кабелите си буутват и системата си зарежда безпроблемно с разграден райд1. След включването на диска отново райда си остава деградирал, но с уебмин си го събирам и си възстановява. Няма проблем. Изпробвано е и с двата диска по отделно.

Аххххх! Не бях се сетил да погледна в биоса!!!! Тези двата диска са на портове сата0 и сата1. В момента е изтрит този на сата0 порта. Но пък, преди да го затрия си буутваше от него и не би трябвало в биоса да е проблема като му указва от него да буутва, а той празен. Компа е НР dc8000 SFF и би трябвало да изкара поне, че няма ос или нещо такова, ако търси да буутва от сата0 порта, на който е изтрития диск.

Линк към този отговор
Сподели в други сайтове

Именно - затова размени им SATA портовете или гледай в биоса, но два абсолютно еднакви диска, не знам как би ги разпознал.

Линк към този отговор
Сподели в други сайтове

Хм! Размених им сата кабелите и започна да зарежда системата!


Линк към този отговор
Сподели в други сайтове

След като вече стартира системата с разменените сата кабели, на затрития диск направих нови партишъни, райда се възстанови, но след като си ги размених отново не буутва. Сега си спомням, че имаше някаква команда, която се изпълнява да инсталира буутлоудера на двата диска . Беше нещо груб-инстал sda sdb но не си спомням какво беше. Експериментирал с тези неща преди повече от 5 години с убунту и дебиан.

Линк към този отговор
Сподели в други сайтове

Сега вече, благодарение на Пламен всичко се изясни и работи ток и жица :) !

Проблема е бил, че аз забърсвам първо диска, които е на сата0 порт и от ОС се чете като sda . Ос търси да буутва от sda, но там няма никой. След размяната на кабелите на двата диска, този другия застава на порт сата0 и от ОС вече той се чете като sda, а забърсания като sdb . Ос стартира и вече с Уебмин създавам дяловете и райда. След възстановяване на райда се изпълнява командата grub2-install /dev/sdb за инсталиране на груб-а. След това вече, могат да им се разменят местата и така, забърсах и втория с нови партишън таблици и нови дялове всичко работи идеално.

Темата е приключена.

Линк към този отговор
Сподели в други сайтове

Добавете отговор

Можете да публикувате отговор сега и да се регистрирате по-късно. Ако имате регистрация, влезте в профила си за да публикувате от него.

Гост
Напишете отговор в тази тема...

×   Вмъкнахте текст, който съдържа форматиране.   Премахни форматирането на текста

  Разрешени са само 75 емотикони.

×   Съдържанието от линка беше вградено автоматично.   Премахни съдържанието и покажи само линк

×   Съдържанието, което сте написали преди беше възстановено..   Изтрий всичко

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Добави ново...

Информация

Поставихме бисквитки на устройството ви за най-добро потребителско изживяване. Можете да промените настройките си за бисквитки, или в противен случай приемаме, че сте съгласни с нашите Условия за ползване