Премини към съдържанието
  • Добре дошли!

    Добре дошли в нашите форуми, пълни с полезна информация. Имате проблем с компютъра или телефона си? Публикувайте нова тема и ще намерите решение на всичките си проблеми. Общувайте свободно и открийте безброй нови приятели.

    Моля, регистрирайте се за да публикувате тема и да получите пълен достъп до всички функции.

     

pop os - компютърът се стартира сам, ако изключа и включа рутера


Гост
 Сподели

Препоръчан отговор

Заглавието казва всичко. С windows 10 го няма проблема. Проблемът се случва само и единствено, ако съм ползвал втората ос - pop os.

Няма опция wake on lan в bios/uefi, дъното от подписа не я поддържа. Най-лесният фикс е DEL, така или иначе pop os е на два дни и на диск, който е само за проба, но искам да разбера причината, преди да отиде в кофата.

рутерът е tl-wr841n.

Линк към коментара
Сподели в други сайтове

Може ли да дадеш изхода от
 

# ethtool <lan_device>

 

Линк към коментара
Сподели в други сайтове

Кое е това модерно дъно което не поддържа WOL? Моето от 1999 си я поддържа!

Първо може да погледнеш при гасене на системата от Windows и при гасене от pop os - има ли разлика в поведението на диодите на лан картата.

Също така може да опиташ с пращане на magic пакет към системата за събуждане отново при двете различни изключвания на системата - така ще видиш дали имаш активиран WOL.

Линк към коментара
Сподели в други сайтове

преди 4 минути, plamen_petrov_80 написа:

Кое е това модерно дъно което не поддържа WOL? Моето от 1999 си я поддържа!

Първо може да погледнеш при гасене на системата от Windows и при гасене от pop os - има ли разлика в поведението на диодите на лан картата.

Също така може да опиташ с пращане на magic пакет към системата за събуждане отново при двете различни изключвания на системата - така ще видиш дали имаш активиран WOL.

Аз за това му казах да пусне ethtool да видим дали WOL е пуснат, защото при някой BIOSи си е пуснато по default и опцията за ключване е скрита

Линк към коментара
Сподели в други сайтове

това са опциите в power management-a

Screenshot from 2021-11-15 12-35-21.png

sudo ethtool enp3s0
Settings for enp3s0:
    Supported ports: [ TP ]
    Supported link modes:   10baseT/Half 10baseT/Full
                            100baseT/Half 100baseT/Full
                            1000baseT/Full
    Supported pause frame use: Symmetric Receive-only
    Supports auto-negotiation: Yes
    Supported FEC modes: Not reported
    Advertised link modes:  10baseT/Half 10baseT/Full
                            100baseT/Half 100baseT/Full
                            1000baseT/Full
    Advertised pause frame use: Symmetric
    Advertised auto-negotiation: Yes
    Advertised FEC modes: Not reported
    Speed: 100Mb/s
    Duplex: Full
    Auto-negotiation: on
    Port: Twisted Pair
    PHYAD: 0
    Transceiver: internal
    MDI-X: Unknown
    Supports Wake-on: d
    Wake-on: d
        Current message level: 0x000060e4 (24804)
                               link ifup rx_err tx_err hw wol
    Link detected: yes

 

преди 41 минути, plamen_petrov_80 написа:

Кое е това модерно дъно което не поддържа WOL? Моето от 1999 си я поддържа!

Първо може да погледнеш при гасене на системата от Windows и при гасене от pop os - има ли разлика в поведението на диодите на лан картата.

Също така може да опиташ с пращане на magic пакет към системата за събуждане отново при двете различни изключвания на системата - така ще видиш дали имаш активиран WOL.

https://hardforum.com/threads/gigabyte-g1-sniper-doesnt-support-wol-how-to-with-add-on.1644122/
Първият и последен пост. Нямa wake on lan.

Линк към коментара
Сподели в други сайтове

И там пише:

ErP
Determines whether to let the system consume least power in S5 (shutdown) state. (Default: Disabled)
Note: When this item is set to Enabled, the following functions will become unavailable: PME event wake
up, power on by mouse, power on by keyboard, and wake on LAN.

Линк към коментара
Сподели в други сайтове

Прочетох го това. Първо, опцията е disabled, следователно не трябва да влияе. Второ, опцията wake on lan липсва в биос, докато при другите дъна които не са g1 sniper/assassin я има. Не знам вече какво да правя....на всеки 5-6 месеца инсталирам някое линукс дистро за пробата и все има някакъв проблем. Както и да е, отива в кофата pop os-a. След 6 месеца ще пиша пак при следващата проба.

Линк към коментара
Сподели в други сайтове

ERP
Определя дали системата да консумира най-малко мощност в състоянието S5 (изключване).(По подразбиране: изключен)
Забележка: Когато този елемент е включен, следните функции ще станат недостъпни: събуждане на събитие PME
Включване с мишката, натискане с клавиатура и събуждане по LAN.

 

преди 8 минути, manjaro написа:

Първо, опцията е disabled, следователно не трябва да влияе.

 

Може би аз чета грешно или ти .. опитай, не боли.

Пробва/провери ли останалите неща?

Линк към коментара
Сподели в други сайтове

току-що, plamen_petrov_80 написа:

Може би аз чета грешно или ти .. опитай, не боли.

Пробва/провери ли останалите неща?

Прав си за това, но вече пиша от Windows-a. Така или иначе, Supports Wake-on: d, Wake-on: d трябва да значи, че WOL e disabled. Друга е причината вероятно, но не ми се губят часове/дни за елементарни неща, които в Windows ще свърша с няколко клика. 
След 6 месеца като тествам поредното дистро...ще пиша, ако не забравя.

 

Линк към коментара
Сподели в други сайтове

ErP е опция, която напълно изключва захранването и нищо освен натискането на бутона на компютъра не може да го включи. 

Линк към коментара
Сподели в други сайтове

Има и друго. Нещата се натруват и чашата прелива. В случая беше рутера и автостартирането. Звукът редовно или изчезва или от нищото започва да изкривява/бучи...ако слушалките или колоните са увеличени, може да оглушееш. Толкова ми е писнало от този проблем, че като зареждам линукс дистро, първата ми работа е да намаля почти до край звука, че не се знае, какво ще се случи при поредния старт. С pavucontrol превключвам между опциите, докато се оправи. А ако звукът е изчезнал, само пълно изключване на машината от захранването или бутване в Windows-a, възстановява звука в линукс. Пробвано с и без дуал буут...е няма такова гоМно. Изпиши в търсачката ca0132 audio problem и гледай резултати от преди 10 години до сега.
Инсталиране на extensions/gnome, widgets/kde може да те вкара в нови приключения. Забиване на машината, понякога черен екран. Забиване на приложения. Ама като искаш функционалности, трябват extensions/widgets. Но пък писани от незнайни герои...те вкарват както казах в приключения. А бе линукс за десктоп е такова приключение, особено, ако не си готов на компромиси. А не е като да не съм пробвал 10+ дистрота.
За фонтовете, middle click scroll, hw acceleration и липсата на 1000001 програми и алтернативи да не започвам, че...изкара ме от нерви Pop OS-a.
От друга страна, безсмислено е и да пиша, защото да спориш с линукс потребител е като да спориш с антиваксър. Няма лечение.

Линк към коментара
Сподели в други сайтове

преди 3 минути, manjaro написа:

Има и друго. Нещата се натруват и чашата прелива. В случая беше рутера и автостартирането. Звукът редовно или изчезва или от нищото започва да изкривява/бучи...ако слушалките или колоните са увеличени, може да оглушееш. Толкова ми е писнало от този проблем, че като зареждам линукс дистро, първата ми работа е да намаля почти до край звука, че не се знае, какво ще се случи при поредния старт. С pavucontrol превключвам между опциите, докато се оправи. А ако звукът е изчезнал, само пълно изключване на машината от захранването или бутване в Windows-a, възстановява звука в линукс. Пробвано с и без дуал буут...е няма такова гоМно. Изпиши в търсачката ca0132 audio problem и гледай резултати от преди 10 години до сега.
Инсталиране на extensions/gnome, widgets/kde може да те вкара в нови приключения. Забиване на машината, понякога черен екран. Забиване на приложения. Ама като искаш функционалности, трябват extensions/widgets. Но пък писани от незнайни герои...те вкарват както казах в приключения. А бе линукс за десктоп е такова приключение, особено, ако не си готов на компромиси. А не е като да не съм пробвал 10+ дистрота.
За фонтовете, middle click scroll, hw acceleration и липсата на 1000001 програми и алтернативи да не започвам, че...изкара ме от нерви Pop OS-a.
От друга страна, безсмислено е и да пиша, защото да спориш с линукс потребител е като да спориш с антиваксър. Няма лечение.

Добре ли си?

Линк към коментара
Сподели в други сайтове

Аз съм напълно ок, явно не схвана поста ми, иначе нямаше да ме цитираш, не само сега, но и по-горе. Забелязвам, че не само тук, а и в хвбг, имаш проблем с разбирането и подадената ти информация. Да го кажа по-ясно - отказах се да си губя времето с неща, които мога да реша буквално с два клика и секунди в Windows.
 

Линк към коментара
Сподели в други сайтове

преди 13 минути, manjaro написа:

Аз съм напълно ок, явно не схвана поста ми, иначе нямаше да ме цитираш, не само сега, но и по-горе. Забелязвам, че не само тук, а и в хвбг, имаш проблем с разбирането и подадената ти информация. Да го кажа по-ясно - отказах се да си губя времето с неща, които мога да реша буквално с два клика и секунди в Windows.
 

Да ти го кажа и аз - имаше не повече от 15-20 мин, да пробваш всичко което се предложи, но ти нямаш време за губене! Защо изобщо пусна темата? Да губиш нашето време? И какъв беше този offtopic (лиричното отклонение) за твоя linux живот? Нищо полезно спрямо заглавието и тематиката на темата!

Ползвай си Windows и не се занимавай с глупости! Нас също.

Линк към коментара
Сподели в други сайтове

преди 21 часа, plamen_petrov_80 написа:

Да ти го кажа и аз - имаше не повече от 15-20 мин, да пробваш всичко което се предложи, но ти нямаш време за губене!

Отново си неадекватен. За последен път ти отговарям, надявам се да вденеш нещо. Това, което предложи е заобикаляне, а не решаване на проблема, защото със същата тази опция в биос, няма проблем в Windows, но има с Pop OS. Интересуваше ме, коя настройка в линукс, влияе на това.

Линк към коментара
Сподели в други сайтове

Това което предложих е да пробваш дали наистина машината пали заради WOL или е друг бъг. Ти дори не отговори на това:

на 15.11.2021 г. в 12:02, plamen_petrov_80 написа:

Първо може да погледнеш при гасене на системата от Windows и при гасене от pop os - има ли разлика в поведението на диодите на лан картата.

Чакай си тогава някои адекватен да има твоя хардиер и да ползва твоята OS, че евентуално да е имал твоя проблем и разбира се да не е бил мързел - може той да те оправи в живота.

Линк към коментара
Сподели в други сайтове

ако на загасен компютър диодите на ланката мигат значи ланкартата може да събуди компа, ако не светят значи компа не може да бъде събуден и причината е друга - примерно смущения по кабела...

пробвай следното:

конзолата пишеш:

sudo ethtool -s  enp3s0 wol d

после пак даваш poweroff, ако след това не запали при изкл. и вкл. на рутера

трябва само да измислиш как командата да се стартира при всяко пускане на компютъра (примерно пишеш редa в /etc/rc.local)

Линк към коментара
Сподели в други сайтове

Добавете отговор

Можете да публикувате отговор сега и да се регистрирате по-късно. Ако имате регистрация, влезте в профила си за да публикувате от него.

Гост
Публикацията ви съдържа термини, които не допускаме! Моля, редактирайте съдържанието си и премахнете подчертаните думи по-долу. Ако замените букви от думата със звездички или друго, за да заобиколите това предупреждение, профилът ви ще бъде блокиран и наказан!
Напишете отговор в тази тема...

×   Вмъкнахте текст, който съдържа форматиране.   Премахни форматирането на текста

  Разрешени са само 75 емотикони.

×   Съдържанието от линка беше вградено автоматично.   Премахни съдържанието и покажи само линк

×   Съдържанието, което сте написали преди беше възстановено..   Изтрий всичко

×   You cannot paste images directly. Upload or insert images from URL.

 Сподели

×
×
  • Добави ново...