Премини към съдържанието
  • Добре дошли!

    Добре дошли в нашите форуми, пълни с полезна информация. Имате проблем с компютъра или телефона си? Публикувайте нова тема и ще намерите решение на всичките си проблеми. Общувайте свободно и открийте безброй нови приятели.

    Моля, регистрирайте се за да публикувате тема и да получите пълен достъп до всички функции.

     

Кирилизация на ХР с Френски Windows


Препоръчан отговор


Знам че повечето от вас са с ЮСА или Руски но аз съм с френски и този проблем не мога да го оправя:

след като го "кирилизирам" - "малкия" проблем ече във френски прозорци вкарва някои букви на мястото на френските

ако някои се е сблъсквал с побен проблем моля да помогне

Линк към този отговор
Сподели в други сайтове

Не се притеснявай, стъпките са същите като за всеки друг, аз в момента съм испански, а сме оправили и италиански, следвай стъпките на инженера смело.

Това е начин за вадене на кирилица(познат още като трика на Инженера) в програми, които при работа с кирилични текстове вадят "маймуни"

----------------------------------------

1252=c_1251.nls

1.Променя се ключ в Регистрито:

START -> Eject -> regedit

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\

Control\Nls\CodePage

Намирате NAME - 1252 Стойността (Data) е c_1252.nls. Променяте на c_1251.nls, като се кликва два пъти с левия бутон на мишката 1252.nls.

Същото може да се направи и със стойностите 1253 i 1254 ,но не е задължително

2.START -> Panel Control -> Configuracion regional and language

(или нещо такова - не знам как се пише точно на английски) ->

Advanced Options . Тук се променя езика от English на ЗАБЕЛЕЖИ !!! Serbian (cirilic ) ,

маркираш 10007 ,20880,21025, 28595

OK и това е всичко.

Ако Уиндоуса ти е на Английски няма да имаш проблем , но ако ти е например на Испански или Немски буквите които са с ударение ще излизат некоректно , но това не е болка за умиране , да оставим че можеш да върнеш настройките когато решиш

Примера е от страницата на инжинера и е пробван милиони пъти

http://injinera.bgplus.com/programi/programi.htm

За проблема като се появи опитай със смяна на езика в лентата.

Линк към този отговор
Сподели в други сайтове

благодаря на Vliev за съвета но ако правилно съм те разбрал това не ми помага

моят проблем е в това че при промяна на езиковите настроики всички програми

работят коректно на български но на френски буквите с ударения излизат на БГ

може за теб да "не е болка за умиране " но за мен е важно и точно в това е проблема.

ПС.Явно от Microsoft не са наясно с такива незначителни подробности

Линк към този отговор
Сподели в други сайтове

Пробва ли след като смениш настройките от Regional and Language options да сложиш поддръжката на френските шрифтове. Т.е. когато избереш Bulgarian в падащият списък на страцита Advanced, сложи в последствие отметките пред нужните шрифтове (допълнително), които са ти необходими, за правилното изобразяване на френските символи.

Линк към този отговор
Сподели в други сайтове
Знам че повечето от вас са с ЮСА или Руски но аз съм с френски и този проблем не мога да го оправя:

след като го "кирилизирам" - "малкия" проблем ече във френски прозорци вкарва някои букви на мястото на френските

ако някои се е сблъсквал с побен проблем моля да помогне

<{POST_SNAPBACK}>

Не знам на кое викаш "след като го "кирилизирам"", но ако го правиш с Flex Type или нещо подобно - забрави за френския. cool.gif


Линк към този отговор
Сподели в други сайтове

под кирилизация имам предвид regionals settings и т.н. но както и да е мисля че

tragedy е прав не се бях сетил да прегледам отметките след първоначалната промяна.когато проверих днес ометки пред френския липсваха .ако в това е причината ще блгодаря лично на tragedy

Линк към този отговор
Сподели в други сайтове
под кирилизация  имам предвид regionals settings и т.н. но както и да е мисля че

tragedy е прав не се бях сетил да прегледам отметките след първоначалната промяна.когато проверих днес ометки пред френския липсваха .ако в това е причината ще блгодаря лично на tragedy

<{POST_SNAPBACK}>

Щом не си ползвал външни кирилизатори, трябва да се оправи от настройките.

PS: Ако при инсталацията не си заредил многоезикова поддръжка може да ти потрябва инсталационния диск.

PPS: За всеки случай порови из регистъра да не ти липсва нещо от това:

Language (Locale) * LCIDDecimal * LCIDHexade* Codepage. Country

Bulgarian * 1026 * 402 * 1251 * BGR

French (Belgium)* 2060* 80c * 1252* BEL

French (Cameroon)* 11276* 2c0c*

French (Canada)* 3084* c0c * 1252* CAN

French (Congo, DRC)* 9228* 240c*

French (Cote d'Ivoire)* 12300* 300c*

French (France)* 1036* 40c* 1252* FRA

French (Luxembourg)* 5132* 140c* 1252* LUX

French (Mali)* 13324* 340c*

French (Monaco)* 6156* 180c* 1252* MCO

French (Senegal)* 10252* 280c*

French (Switzerland)* 4108* 100c* 1252* CHE

French (West Indies)* 7180* 1c0c*

По принцип това, дето го пише на страницата на инжИнера е вярно, но като замениш навсякъде 1252 с 1251 разните ударения, умлаути и др. подобни потъват в дън земя...

Таблицата излезе малко объркана, но ще се ориентираш по звездичките. cool.gif

Редактирано от goblin (преглед на промените)
Линк към този отговор
Сподели в други сайтове
Пробва ли след като смениш настройките от Regional and Language options да сложиш поддръжката на френските шрифтове. Т.е. когато избереш Bulgarian в падащият списък на страцита Advanced, сложи в последствие отметките пред нужните шрифтове (допълнително), които са ти необходими, за правилното изобразяване на френските символи.

<{POST_SNAPBACK}>

Прощавай но не разбрах за кои отметки става дума Ако е за кодовата таблица активирал съм всички френски но не помага Някой програми излизат с БГ букви Плус това всички текстови файлове суб и срт стават кодирани (празни квадрати). Това са ми субтитлите за филмите .Много е досадно . Прости незнанието ми и благодаря предварително

Линк към този отговор
Сподели в други сайтове
  • 3 месеца по-късно...
Не се притеснявай, стъпките са същите като за всеки друг, аз в момента съм испански, а сме оправили и италиански, следвай стъпките на инженера смело.

  Това е начин за вадене на кирилица(познат още като трика на Инженера) в програми, които при работа с кирилични текстове вадят "маймуни"

----------------------------------------

1252=c_1251.nls

1.Променя се ключ в Регистрито:

START -> Eject -> regedit

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\

Control\Nls\CodePage

Намирате NAME - 1252 Стойността (Data) е c_1252.nls. Променяте на c_1251.nls, като се кликва два пъти с левия бутон на мишката 1252.nls.

Същото може да се направи и със стойностите 1253 i 1254 ,но не е задължително

2.START -> Panel Control -> Configuracion regional and language

(или нещо такова - не знам как се пише точно на английски) ->

Advanced Options . Тук се променя езика от English на ЗАБЕЛЕЖИ !!! Serbian (cirilic ) ,

маркираш 10007 ,20880,21025, 28595

OK и това е всичко.

Ако Уиндоуса ти е на Английски няма да имаш проблем , но ако ти е например на Испански или Немски буквите които са с ударение ще излизат некоректно , но това не е болка за умиране , да оставим че можеш да върнеш настройките когато решиш 

Примера е от страницата на инжинера и е пробван милиони пъти  

http://injinera.bgplus.com/programi/programi.htm

За проблема като се появи опитай със смяна на езика в лентата.

<{POST_SNAPBACK}>

Друг път като ме цитираш поне кажи , че си го копирал от другаде!

Но това ли казваха плагиатстване?

ЗА статистиката - прекопирал си го оттук най - безсрамно. :)

Редактирано от Castigado Pantockrator (преглед на промените)
Линк към този отговор
Сподели в други сайтове

Нещо не ми стана ясно в кои прозорци се появява проблема. Ако са с Unicode (например системните прозорци на Windows би трябвало да са такива), сигурно има някакво решение с бърникане по кодовите таблици, но ако не са, просто няма как - таблицата е само с 255 символа и не стигат за повече езици.

Така че пробвай от Control Panel\Regional and Language Options\Advanced (или както там е на твоята инсталация) да сменяш първото поле между Bulgarian и French (France) и да видиш как ще ти се държат non-Unicode програмите. Това няма да се отрази на останалата част от кирилизацията.

@tsekataa

Умлаутите на немски са същият проблем за non-Unicode, както кирилицата и ударените гласни на френски - няма място за всичко в 8-битовите варианти на ASCII.

Линк към този отговор
Сподели в други сайтове

Добавете отговор

Можете да публикувате отговор сега и да се регистрирате по-късно. Ако имате регистрация, влезте в профила си за да публикувате от него.

Гост
Напишете отговор в тази тема...

×   Вмъкнахте текст, който съдържа форматиране.   Премахни форматирането на текста

  Разрешени са само 75 емотикони.

×   Съдържанието от линка беше вградено автоматично.   Премахни съдържанието и покажи само линк

×   Съдържанието, което сте написали преди беше възстановено..   Изтрий всичко

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Добави ново...

Информация

Поставихме бисквитки на устройството ви за най-добро потребителско изживяване. Можете да промените настройките си за бисквитки, или в противен случай приемаме, че сте съгласни с нашите Условия за ползване