Инсталиране и конфигуриране на Apache, PHP, MySQL и phpMyAdmin на Ubuntu

От известно време си записвам някои нещица, които са ми полезни…относно Ubuntu.angry.gif

Става дума за това как точно аз да си инсталирам уеб сървър – Apache, PHP, MySQL, като използваме терминала (конзолата). Бързо, лесно и ефективно разбира се. Защото ме мързи да помня – предпочитам да го изпиша под формата на малка публикация.wink.gif

Стига глупости, нека да започваме. Като начало отваряме терминала и изписваме следната команда, за да не пишеме постоянно преди всяка следваща команда sudo за напред.

sudo su -
След като сме си въвели вече паролата – проверяваме дали има налични обновления:
apt-get update
След като сме ги източили – сваляме Apache2, PHP5 и библиотеката-връзка между двете:
apt-get install apache2 php5 libapache2-mod-php5
Сега се предполага, че всичко е ОК. Лично аз рестартирам:
/etc/init.d/apache2 restart
Когато командата е изпълнена, можете да проверите дали Apache работи правилно, през браузъра си. Пишеме http://localhost . Ако видите текста It works! , значи Apache работи идеално и не сме объркали нищо. До тук – добре. Имаме Apache и PHP5 вече инсталирани. Повечето модули са на лице.Сега само трябва да преместиме mod_rewrite той се намира в /etc/apache2/mods-available . Местиме го в /etc/apache2/mods-enabled
cp /etc/apache2/mods-available/rewrite.load /etc/apache2/mods-enabled
Сега да поправим 000-default .Намираме и променяме AllowOverride от None на All.
gedit /etc/apache2/sites-enabled/000-default
Трябва да се получи така:
Options Indexes FollowSymLinks MultiViews AllowOverride All Order allow,deny allow from all
Сега точим и MySQL:
apt-get install mysql-server mysql-client php5-mysql
Към края на инсталацията ще бъдете подканени да определите admin парола. Админа в даденият случай е root. Въведете желаната от вас парола. Сега точим и phpMyAdmin:
apt-get install phpmyadmin
По време на инсталацията ще бъдете помолени да изберете уеб сървър, който ще бъде използван за пускане на phpMyAdmin. Изберете Apache2. Остана само да добавим един ред в /etc/apache2/apache2.conf
gedit /etc/apache2/apache2.conf
Най отдолу добавяме
Include /etc/phpmyadmin/apache.conf
Сега рестартираме:
/etc/init.d/apache2 restart
И с това инсталирането ни приключи и вече имате един работещ сървър, който може да тормозите както си пожелаетеcool.gif Опа за малко да забравя. След като инсталацията приключи, изпълнете следната команда, за да копирате папката phpmyadmin в apache2 /etc/apache2/.(По подразбиране phpmyadmin се инсталира в /usr/share/phpmyadmin/
sudo ln -s /usr/share/phpmyadmin /etc/apache2/

Написах sudo тъй като вече съм затворил терминала, но ако не сте го затворили не го пишете.

/var/www/ това е публичната папка за вашите бъдещи проекти.




18 Коментара



Една малка забележка: пише се

sudo su -

Защо е така оставям като домашна работа :)

Сподели този коментар


Линк към коментара

Една малка забележка: пише се

sudo su -
Защо е така оставям като домашна работа :)
Става и с "su" , но трябва преди това да се смени паролата.

sudo passwd root

su

Сподели този коментар


Линк към коментара

Става и с "su" , но трябва преди това да се смени паролата.

sudo passwd rootsu
Не сте си свършили домашната работа, командата е
su -

!!!!

Сподели този коментар


Линк към коментара

Не сте си свършили домашната работа, командата е

su -
!!!!
Човече става :) Поставям парола за root и после влизам с него

sudo passwd root

su

Не казвам че не може и с
su -

Сподели този коментар


Линк към коментара

Горния ви пост показва че има доста да учите. Проверете кога какво се получава. Има сериозна разлика между двата варианта!


Сподели този коментар


Линк към коментара

Моят пример е за логване като root потребител със смяна на парола и ми върши работа.

Сподели този коментар


Линк към коментара

Моят пример е за логване като root потребител със смяна на парола и ми върши работа.

Това на което се опитвам да ви обърна внимание е ч еима разлика между

su -
и
su

И ако наистина искате да учите вместо да държите на своето започнете да четете/слушате какво ви пише/казва другия човек, който може би знае повече от вас

Сподели този коментар


Линк към коментара

Добре де разбирам Ви, разяснете тогава защо да не мога да се логвам използвайки командата "su". Защото постоянно я използвам (така се логвам).

Сподели този коментар


Линк към коментара

Добре де разбирам Ви, разяснете тогава защо да не мога да се логвам използвайки командата "su". Защото постоянно я използвам (така се логвам).

СЛед като споделихте че искате да се учите оставям сам да се разровите и да научите защо и кога се ползва едното и другото. И защо вашия вариант е подходящ в редки случаи

Сподели този коментар


Линк към коментара

СЛед като споделихте че искате да се учите оставям сам да се разровите и да научите защо и кога се ползва едното и другото. И защо вашия вариант е подходящ в редки случаи

Сега загрях :) , отсега нататък ще гледам колкото се може по-малко да се логвам по този начин. Благодаря.

Сподели този коментар


Линк към коментара

Сега загрях :) , отсега нататък ще гледам колкото се може по-малко да се логвам по този начин. Благодаря.

Браво :) Важното е да не спирате да се учите

Сподели този коментар


Линк към коментара

Защо когато се опитам да отворя phpmyadmin

/localhost/phpmyadmin и ми изписва 404 Not found. Мисълта ми е ясно защо го изписва

как може да се оправи. Направих всичко както е описано в статията. Мерси.

Сподели този коментар


Линк към коментара

опитайте така:

http://localhost/phpmyadmin

ако не стане погледнете в лога с грешките какво всъщност се опитва да достъпи апаш и съобразете къде вие сте инсталирали модула

Сподели този коментар


Линк към коментара

phpmyadmin първоначално се беше инсталирало в shared, след това го копирах в папкатa /etc/apache2/. Вмомента го сложих в /var/www/ и когато се опитах да го отворя localhost/phpmyadmin - се получи. Не съм сигурен дали е много добре phpmyadmin да е в тази папка.

Сподели този коментар


Линк към коментара

phpmyadmin първоначално се беше инсталирало в shared, след това го копирах в папкатa /etc/apache2/. Вмомента го сложих в /var/www/ и когато се опитах да го отворя localhost/phpmyadmin - се получи. Не съм сигурен дали е много добре phpmyadmin да е в тази папка.

Не, не е добра идея, в конфиг файла трябва да е дефинирана локация за целта, която евентуално трябва да се редактира. Но погледнете в логовете, там всичко пише!!!

1 човек харесва това

Сподели този коментар


Линк към коментара

Solved,

Със съдействието на Capnemo, отворих еррор лога който в моя случай се намира в /var/log/apache2/error.log

Там беше записана следната грешка:

[sun Feb 26 22:52:56 2012] [error] [client 127.0.0.1] File does not exist: /var/www/phpmyadmin

[sun Feb 26 22:52:56 2012] [error] [client 127.0.0.1] File does not exist: /var/www/favicon.ico

След това в този линк: http://webcache.goog...g&ct=clnk&gl=bg

Потребителят Lithos е написал как е разрешил подобен проблем.

За целта преработих Alias-а който в моя случай изглежда по този начин:

Alias /phpmyadmin "/etc/apache2/phpmyadmin/"

<Directory /etc/apache2/phpmyadmin>

Options FollowSymLinks

DirectoryIndex index.php

<IfModule mod_php5.c>

AddType application/x-httpd-php .php

php_flag magic_quotes_gpc Off

php_flag track_vars On

php_flag register_globals Off

php_value include_path .

</IfModule>

</Directory>

Тъй като в статията е написано да се копира phpmyadmin в директорията /etc/apache2

Рестартирах Apache след което вече като се напише localhost/phpmyadmin

И зарежда без проблем.

Не съм сигурен дали това е точният метод но работи. Поздрави.

Сподели този коментар


Линк към коментара

Solved,

Със съдействието на Capnemo, отворих еррор лога който в моя случай се намира в /var/log/apache2/error.log

Там беше записана следната грешка:

След това в този линк: http://webcache.goog...g&ct=clnk&gl=bg

Потребителят Lithos е написал как е разрешил подобен проблем.

За целта преработих Alias-а който в моя случай изглежда по този начин:

Тъй като в статията е написано да се копира phpmyadmin в директорията /etc/apache2

Рестартирах Apache след което вече като се напише localhost/phpmyadmin

И зарежда без проблем.

Не съм сигурен дали това е точният метод но работи. Поздрави.

Просто добавете следният ред, в /etc/apache2/apache2.conf

Include /etc/phpmyadmin/apache.conf

и рестартирайте апачето, за да влязат в сила настройките.

Сподели този коментар


Линк към коментара

Регистрирайте се или влезете в профила си за да коментирате

Трябва да имате регистрация за да може да коментирате това

Регистрирайте се

Създайте нова регистрация в нашия форум. Лесно е!


Нова регистрация

Вход

Имате регистрация? Влезте от тук.


Вход