Премини към съдържанието

    Препоръчан отговор


    Здравейте, вече сигурно 2-ра година държа сайт. Преди използвах XAMPP а сега съм с VertrigoServ. До сега съм нямал проблеми но днес излезна нещо много странно. Както всичко си работеше започна да излиза бял екран на хората(на мен не защото съм с рутер и се връзвам с вътрешното ИП), реших да рестартирам апачето както и цялото вертриго - без ефект. После реших и целия компютър - без ефект дори стана по-зле от както рестартирах компютъра ми изписва че порт 80 се ползва от дръга програма. Обаче там идва и странният проблем - няма програма която да ползва порт 80. С TCPView и CurrPort проверявах - няма такава програма. Процесите са ми почти всички спрени(освен тези без които не може). Също така рутера съм си го настроил за порт 80. Ако имате някакви идеи моля споделете. Благодаря!

    Сподели този отговор


    Линк към този отговор
    Сподели в други сайтове

    Коя програма съобщава, че 80 вече се използва ? Щом тя установява, че той е зает, най-вероятно наистина е така. Ако съобщението е от Apache, провери в неговите логове за описание на грешката.

    Сподели този отговор


    Линк към този отговор
    Сподели в други сайтове

    Може, също така да изпълниш в конзолата командата netstat -o за да провериш дали наистина някое приложение използва порт 80.

    Сподели този отговор


    Линк към този отговор
    Сподели в други сайтове

    Ето ми логовете от апачето. Постнал съм тези логове които не са от мен, защото в access logs има още логове които са след 14 март обаче те са само от мене.Също така проверих както казахте(и както бях направил) през cmd с командата netstat няма нито един процес който да е на порт 80. И да кажа отново проблемът стана внезапно вчера(19.03.2011) Ето и логовете: error logs:

    [Mon Mar 14 07:58:50 2011] [error] [client 86.26.20.20] Invalid URI in request \x1f\xfa&39s|+U\t\xad\xfe\xd0>\x068 [Mon Mar 14 08:18:16 2011] [error] [client 66.249.72.167] File does not exist: C:/Program Files/VertrigoServ/www/robots.txt [Mon Mar 14 09:06:05 2011] [error] [client 109.224.25.11] request failed: error reading the headers [Mon Mar 14 09:34:30 2011] [error] [client 99.251.8.193] File does not exist: C:/Program Files/VertrigoServ/www/webdav [Mon Mar 14 09:47:05 2011] [warn] (OS 121)The semaphore timeout period has expired. : winnt_accept: Asynchronous AcceptEx failed. [Mon Mar 14 10:34:18 2011] [warn] (OS 121)The semaphore timeout period has expired. : winnt_accept: Asynchronous AcceptEx failed. [Mon Mar 14 11:24:57 2011] [warn] (OS 64)The specified network name is no longer available. : winnt_accept: Asynchronous AcceptEx failed. [Mon Mar 14 11:27:00 2011] [warn] (OS 121)The semaphore timeout period has expired. : winnt_accept: Asynchronous AcceptEx failed. [Mon Mar 14 13:10:59 2011] [warn] (OS 121)The semaphore timeout period has expired. : winnt_accept: Asynchronous AcceptEx failed. [Mon Mar 14 14:38:30 2011] [error] [client 109.121.254.162] Invalid URI in request \xc1\x98^\xe3\xb2-\xbd\x93\xfawX\x16B4F\x16[\x0c>\x13 [Mon Mar 14 15:08:02 2011] [error] [client 121.54.66.9] request failed: error reading the headers [Mon Mar 14 15:32:35 2011] [error] [client 180.69.176.99] Invalid URI in request \xd3\x10`\xf5bj\xa0a\xf7^\xd6\x04\xbd2<\xcb@\xb098:i\x07R\xca [Mon Mar 14 15:56:20 2011] [error] [client 95.30.187.40] File does not exist: C:/Program Files/VertrigoServ/www/cstrike [Mon Mar 14 17:23:05 2011] [error] [client 95.30.187.40] File does not exist: C:/Program Files/VertrigoServ/www/cstrike [Mon Mar 14 17:41:28 2011] [warn] (OS 121)The semaphore timeout period has expired. : winnt_accept: Asynchronous AcceptEx failed. [Mon Mar 14 18:12:14 2011] [warn] (OS 121)The semaphore timeout period has expired. : winnt_accept: Asynchronous AcceptEx failed. [Wed Mar 16 15:21:26 2011] [error] [client 192.168.1.2] File does not exist: C:/Program Files/VertrigoServ/www/\xd1\x81\xd0\xb5\xd1\x80\xd0\xb6\xd0\xb5\xd1\x801.\xd0\xbf\xd1\x85\xd0\xbf [sat Mar 19 22:05:05 2011] [error] [client 192.168.1.2] script 'C:/Program Files/VertrigoServ/www/aligator/.index.php' not found or unable to stat, referer:

    http://192.168.1.3/aligator/ [sat Mar 19 22:05:27 2011] [error] [client 192.168.1.2] script 'C:/Program Files/VertrigoServ/www/aligator/.index.php' not found or unable to stat, referer: http://192.168.1.3/aligator/ [sat Mar 19 22:06:10 2011] [error] [client 192.168.1.2] script 'C:/Program Files/VertrigoServ/www/aligator/index.php' not found or unable to stat, referer: http://192.168.1.3/aligator/ [sat Mar 19 22:06:44 2011] [error] [client 192.168.1.2] script 'C:/Program Files/VertrigoServ/www/aligator/index.php' not found or unable to stat [sat Mar 19 22:06:45 2011] [error] [client 192.168.1.2] script 'C:/Program Files/VertrigoServ/www/aligator/index.php' not found or unable to stat [sat Mar 19 22:07:23 2011] [error] [client 192.168.1.2] File does not exist: C:/Program Files/VertrigoServ/www/aligator/www.abv.bg, referer: http://192.168.1.3/aligator/index.php?link=www.abv.bg&go=Submit [sat Mar 19 22:07:36 2011] [error] [client 192.168.1.2] File does not exist: C:/Program Files/VertrigoServ/www/aligator/www.abv.bg, referer: http://192.168.1.3/aligator/index.php?link=www.abv.bg&go=Submit [sat Mar 19 22:07:45 2011] [error] [client 192.168.1.2] File does not exist: C:/Program Files/VertrigoServ/www/aligator/www.abv.bg, referer: http://192.168.1.3/aligator/index.php?link=www.abv.bg&go=Submit [sat Mar 19 22:27:58 2011] [error] [client 192.168.1.2] File does not exist: C:/Program Files/VertrigoServ/www/New Folder [sat Mar 19 22:29:13 2011] [warn] pid file C:/Program Files/VertrigoServ/Apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run? [sat Mar 19 22:29:13 2011] [notice] Apache/2.0.63 (Win32) PHP/5.2.6 configured -- resuming normal operations [sat Mar 19 22:29:13 2011] [notice] Server built: Jan 17 2008 22:58:29 [sat Mar 19 22:29:13 2011] [notice] Parent: Created child process 276 [sat Mar 19 22:29:16 2011] [notice] Child 276: Child process is running [sat Mar 19 22:29:16 2011] [notice] Child 276: Acquired the start mutex. [sat Mar 19 22:29:16 2011] [notice] Child 276: Starting 250 worker threads. [sat Mar 19 22:35:31 2011] [warn] pid file C:/Program Files/VertrigoServ/Apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run? [sat Mar 19 22:35:32 2011] [notice] Apache/2.0.63 (Win32) PHP/5.2.6 configured -- resuming normal operations [sat Mar 19 22:35:32 2011] [notice] Server built: Jan 17 2008 22:58:29 [sat Mar 19 22:35:32 2011] [notice] Parent: Created child process 3936 Apache server shutdown initiated... Child 3936: Child process is running [sat Mar 19 22:35:33 2011] [notice] Child 3936: Acquired the start mutex. [sat Mar 19 22:35:33 2011] [notice] Child 3936: Starting 250 worker threads. [sat Mar 19 22:46:12 2011] [notice] Parent: Received shutdown signal -- Shutting down the server. [sat Mar 19 22:46:12 2011] [notice] Child 3936: Exit event signaled. Child process is ending. [sat Mar 19 22:46:13 2011] [notice] Child 3936: Released the start mutex [sat Mar 19 22:46:14 2011] [notice] Child 3936: All worker threads have exited. [sat Mar 19 22:46:14 2011] [notice] Child 3936: Child process is exiting [sat Mar 19 22:46:14 2011] [notice] Parent: Child process exited successfully. [sat Mar 19 22:58:43 2011] [notice] Apache/2.0.63 (Win32) PHP/5.2.6 configured -- resuming normal operations [sat Mar 19 22:58:43 2011] [notice] Server built: Jan 17 2008 22:58:29 [sat Mar 19 22:58:43 2011] [notice] Parent: Created child process 3384 [sat Mar 19 22:58:44 2011] [notice] Child 3384: Child process is running [sat Mar 19 22:58:44 2011] [notice] Child 3384: Acquired the start mutex. [sat Mar 19 22:58:44 2011] [notice] Child 3384: Starting 250 worker threads. [sat Mar 19 23:20:07 2011] [error] [client 66.249.72.167] File does not exist: C:/Program Files/VertrigoServ/www/robots.txt Installing the Vertrigo_Apache service The Vertrigo_Apache service is successfully installed. [sun Mar 20 00:59:26 2011] [warn] pid file C:/Program Files/VertrigoServ/Apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run? [sun Mar 20 00:59:26 2011] [notice] Apache/2.0.63 (Win32) PHP/5.2.6 configured -- resuming normal operations [sun Mar 20 00:59:26 2011] [notice] Server built: Jan 17 2008 22:58:29 [sun Mar 20 00:59:26 2011] [notice] Parent: Created child process 2680 [sun Mar 20 00:59:27 2011] [notice] Child 2680: Child process is running [sun Mar 20 00:59:27 2011] [notice] Child 2680: Acquired the start mutex. [sun Mar 20 00:59:27 2011] [notice] Child 2680: Starting 250 worker threads. [sun Mar 20 01:04:56 2011] [notice] Parent: Received shutdown signal -- Shutting down the server. [sun Mar 20 01:04:56 2011] [notice] Child 2680: Exit event signaled. Child process is ending. [sun Mar 20 01:04:57 2011] [notice] Child 2680: Released the start mutex [sun Mar 20 01:04:58 2011] [notice] Child 2680: All worker threads have exited. [sun Mar 20 01:04:58 2011] [notice] Child 2680: Child process is exiting [sun Mar 20 01:04:58 2011] [notice] Parent: Child process exited successfully.

    access logs:

    66.249.72.167 - - [13/Mar/2011:20:54:18 +0200] "GET /forum/viewtopic.php?f=40&t=76&start=10&view=print HTTP/1.1" 200 5875 86.26.20.20 - - [14/Mar/2011:07:58:50 +0200] "\x1f\xfa&39s|+U\t\xad\xfe\xd0>\x068" 400 313 66.249.72.167 - - [14/Mar/2011:08:18:16 +0200] "GET /robots.txt HTTP/1.1" 404 293 66.249.72.167 - - [14/Mar/2011:08:18:16 +0200] "GET /forum/viewtopic.php?f=6&t=179 HTTP/1.1" 200 23083 109.224.25.11 - - [14/Mar/2011:09:06:00 +0200] "l\xb8\xfc\xec<\x89\x85\xed\xf9<(\x93\xa2\x15\xe0\xe7\xe6U0[7\xd7G\xc8y\xe3\x02\xfb\xae\x85\xa8\x0c\xbd\xb1\xe97\"\xc5\x8f\t\xb7" 400 313 99.251.8.193 - - [14/Mar/2011:09:34:30 +0200] "GET /webdav/ HTTP/1.1" 404 294 95.43.95.175 - - [14/Mar/2011:09:39:15 +0200] "GET /sms1 HTTP/1.1" 301 316 95.43.95.175 - - [14/Mar/2011:09:39:18 +0200] "GET /sms1/ HTTP/1.1" 200 2901 95.43.95.175 - - [14/Mar/2011:09:39:18 +0200] "GET /icons/blank.gif HTTP/1.1" 200 148 95.43.95.175 - - [14/Mar/2011:09:39:19 +0200] "GET /icons/folder.gif HTTP/1.1" 200 225 95.43.95.175 - - [14/Mar/2011:09:39:21 +0200] "GET /icons/back.gif HTTP/1.1" 200 216 95.43.95.175 - - [14/Mar/2011:09:39:22 +0200] "GET /icons/image2.gif HTTP/1.1" 200 309 95.43.95.175 - - [14/Mar/2011:09:39:30 +0200] "GET /favicon.ico HTTP/1.1" 200 1406 92.14.139.201 - - [14/Mar/2011:10:16:52 +0200] "\x86\xfbN\xa3`Ez\xc4}\xdd\x10\xd1-\xd4\xa8\xbe\xdc\x9b\xf9\xf9\x02" 200 18 66.249.72.167 - - [14/Mar/2011:10:32:23 +0200] "GET /forum/viewforum.php?f=12&start=0 HTTP/1.1" 200 19974 216.104.15.134 - - [14/Mar/2011:10:43:03 +0200] "GET / HTTP/1.0" 200 18 66.249.72.167 - - [14/Mar/2011:13:47:22 +0200] "GET /forum/viewtopic.php?f=6&t=104 HTTP/1.1" 200 17273 220.181.108.147 - - [14/Mar/2011:14:10:29 +0200] "GET / HTTP/1.1" 200 18 66.249.72.167 - - [14/Mar/2011:14:22:24 +0200] "GET /forum/viewtopic.php?f=40&t=142&start=10 HTTP/1.1" 200 26822 192.168.1.2 - - [14/Mar/2011:14:38:28 +0200] "GET /hns_admin.php HTTP/1.1" 200 - 109.121.254.162 - - [14/Mar/2011:14:38:30 +0200] "\xc1\x98^\xe3\xb2-\xbd\x93\xfawX\x16B4F\x16[\x0c>\x13" 400 313 121.54.66.9 - - [14/Mar/2011:15:08:00 +0200] "o\xb4\xca\xe8\v-\xe6T\xa2\xc6\x95'sd\xde\x17\xe9 \xf7E\x1e\xe7B\xc56|2\x97tv\xbe\x11\xf0\xa6iL6n\x1c\x99V\xa8\x9b`(\x0c\xbao\xf0\xaa\xc5" 400 313 182.4.78.47 - - [14/Mar/2011:15:15:41 +0200] "\xb8\xb4/t\xcb\xec}\xd8\xeeq\x14\xde\x15\x01\xa2\xba\xf6\x18\xdf\xde\xd3\x12\xd8\x94Q\x8e(\xbc\x02a\x05\xba7u" 200 18 180.69.176.99 - - [14/Mar/2011:15:32:35 +0200] "\xd3\x10`\xf5bj\xa0a\xf7^\xd6\x04\xbd2<\xcb@\xb098:i\x07R\xca" 400 313 66.249.72.167 - - [14/Mar/2011:15:44:24 +0200] "GET / HTTP/1.1" 200 18 95.30.187.40 - - [14/Mar/2011:15:56:20 +0200] "GET /cstrike/addons/amxmodx/configs/users.ini HTTP/1.1" 404 327 95.30.187.40 - - [14/Mar/2011:17:23:05 +0200] "GET /cstrike/addons/amxmodx/configs/users.ini, server.cfg HTTP/1.1" 404 328 66.249.72.167 - - [14/Mar/2011:17:41:48 +0200] "GET /forum/viewtopic.php?f=9&t=353 HTTP/1.1" 200 15313 66.249.72.167 - - [14/Mar/2011:18:39:45 +0200] "GET /forum/viewtopic.php?f=39&t=81&start=0 HTTP/1.1" 200 24315 192.168.1.2 - - [14/Mar/2011:20:31:50 +0200] "GET /sms1/banlist/ HTTP/1.1" 302 - 192.168.1.2 - - [14/Mar/2011:20:31:50 +0200] "GET /sms1/banlist/view.php HTTP/1.1" 200 7799


    Сподели този отговор


    Линк към този отговор
    Сподели в други сайтове

    Регистрирайте се или влезете в профила си за да коментирате

    Трябва да имате регистрация за да може да коментирате това

    Регистрирайте се

    Създайте нова регистрация в нашия форум. Лесно е!

    Нова регистрация

    Вход

    Имате регистрация? Влезте от тук.

    Вход


    ×

    Информация

    Този сайт използва бисквитки (cookies), за най-доброто потребителско изживяване. С използването му, вие приемате нашите Условия за ползване.