Премини към съдържанието
  • Добре дошли!

    Добре дошли в нашите форуми, пълни с полезна информация. Имате проблем с компютъра или телефона си? Публикувайте нова тема и ще намерите решение на всичките си проблеми. Общувайте свободно и открийте безброй нови приятели.

    Моля, регистрирайте се за да публикувате тема и да получите пълен достъп до всички функции.

     

Манджаро тръгна само в терминален режим


Препоръчан отговор


Здравейте,

След спиране на компютъра с Ctrl + Alt + End от Cinnamon, нещо което правя от седмици, (може тук да е грешката, затова го пиша), Манджаро не тръгва в графичен режим. Вчера пуснах подобна тема, но май ми е изтрпита, може би защото заглавието било с главни букви.

Ето резултатите от няколко команди:

 

grep Xorg
Xorg.0.log

Xorg in the second line is in red.

cat ~/.xinitrc
#!/bin/bash

 

~/.xinitrc

 

Executed by startx (run your window manager from here)

userresources=$HOME/.Xresources
usermodmap=$HOME/.Xmodmap
sysresources=/etc/X11/xinit/.Xresources
sysmodmap=/etc/X11/xinit/.Xmodmap

DEFAULT_SESSION=cinnamon-session

merge in defaults and keymaps

if [ -f $sysresources ]; then
xrdb -merge $sysresources
fi

if [ -f $sysmodmap ]; then
xmodmap $sysmodmap
fi

if [ -f “$userresources” ]; then
xrdb -merge “$userresources”
fi

if [ -f “$usermodmap” ]; then
xmodmap “$usermodmap”
fi

start some nice programs

if [ -d /etc/X11/xinit/xinitrc.d ] ; then
for f in /etc/X11/xinit/xinitrc.d/?*.sh ; do
[ -x “$f” ] && . “$f”
done
unset f
fi

get_session(){
local dbus_args=(–sh-syntax --exit-with-session)
case $1 in
awesome) dbus_args+=(awesome) ;;
bspwm) dbus_args+=(bspwm-session) ;;
budgie) dbus_args+=(budgie-desktop) ;;
cinnamon) dbus_args+=(cinnamon-session) ;;
deepin) dbus_args+=(startdde) ;;
enlightenment) dbus_args+=(enlightenment_start) ;;
fluxbox) dbus_args+=(startfluxbox) ;;
gnome) dbus_args+=(gnome-session) ;;
i3|i3wm) dbus_args+=(i3 --shmlog-size 0) ;;
jwm) dbus_args+=(jwm) ;;
kde) dbus_args+=(startplasma-x11) ;;
lxde) dbus_args+=(startlxde) ;;
lxqt) dbus_args+=(lxqt-session) ;;
mate) dbus_args+=(mate-session) ;;
xfce) dbus_args+=(xfce4-session) ;;
openbox) dbus_args+=(openbox-session) ;;
*) dbus_args+=($DEFAULT_SESSION) ;;
esac

 
echo "dbus-launch ${dbus_args[*]}"

}

sudo inxi --admin --verbosity=7 --filter --no-host
System:
Kernel: 5.8.6-1-MANJARO x86_64 bits: 64 compiler: N/A
parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC
driver=nonfree nouveau.modeset=0 i915.modeset=1 radeon.modeset=1
misobasedir=manjaro misolabel=MANJARO_CINNAMON_201 quiet
systemd.show_status=1 apparmor=1 security=apparmor
Desktop: Cinnamon 4.6.7 tk: GTK 3.24.23 wm: Muffin dm: LightDM 1.30.0
Distro: Manjaro Linux
Machine:
Type: Desktop Mobo: ASUSTeK model: ROG MAXIMUS X HERO v: Rev 1.xx
serial: UEFI: American Megatrends v: 2203 date: 10/07/2019
Battery:
Device-1: hidpp_battery_0 model: Logitech Wireless Mouse MX Master 3
serial: charge: 100% (should be ignored) rechargeable: yes
status: Discharging
Memory:
RAM: total: 62.67 GiB used: 1.33 GiB (2.1%)
Array-1: capacity: 64 GiB slots: 4 EC: None max module size: 16 GiB
note: est.
Device-1: ChannelA-DIMM1 size: 16 GiB speed: 2133 MT/s type: DDR4
detail: synchronous unbuffered (unregistered) bus width: 64 bits
total: 64 bits manufacturer: Corsair part-no: CMU64GX4M4C3000C15
serial: N/A
Device-2: ChannelA-DIMM2 size: 16 GiB speed: 2133 MT/s type: DDR4
detail: synchronous unbuffered (unregistered) bus width: 64 bits
total: 64 bits manufacturer: Corsair part-no: CMU64GX4M4C3000C15
serial: N/A
Device-3: ChannelB-DIMM1 size: 16 GiB speed: 2133 MT/s type: DDR4
detail: synchronous unbuffered (unregistered) bus width: 64 bits
total: 64 bits manufacturer: Corsair part-no: CMU64GX4M4C3000C15
serial: N/A
Device-4: ChannelB-DIMM2 size: 16 GiB speed: 2133 MT/s type: DDR4
detail: synchronous unbuffered (unregistered) bus width: 64 bits
total: 64 bits manufacturer: Corsair part-no: CMU64GX4M4C3000C15
serial: N/A
CPU:
Topology: 6-Core model: Intel Core i7-8700K socket: LGA1151 bits: 64
type: MT MCP arch: Kaby Lake family: 6 model-id: 9E (158) stepping: A (10)
microcode: D6 L1 cache: 384 KiB L2 cache: 12.0 MiB L3 cache: 12.0 MiB
bogomips: 88824
Speed: 800 MHz min/max: 800/4700 MHz base/boost: 3700/8300 volts: 1.0 V
ext-clock: 100 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800
6: 800 7: 800 8: 800 9: 800 10: 800 11: 800 12: 800
Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon
art avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid
cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est
f16c flexpriority flush_l1d fma fpu fsgsbase fxsr hle ht hwp
hwp_act_window hwp_epp hwp_notify ibpb ibrs ida intel_pt invpcid
invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe mpx msr mtrr
nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln
pni popcnt pse pse36 pti pts rdrand rdseed rdtscp rep_good rtm sdbg sep
smap smep smx ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2
tpr_shadow tsc tsc_adjust tsc_deadline_timer vme vmx vnmi vpid x2apic
xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf
mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
IBRS_FW, STIBP: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort mitigation: Clear CPU buffers; SMT vulnerable
Graphics:
Device-1: Intel UHD Graphics 630 vendor: ASUSTeK driver: i915 v: kernel
bus ID: 00:02.0 chip ID: 8086:3e92
Display: server: X.Org 1.20.8 driver: intel unloaded: modesetting
alternate: fbdev,vesa display ID: :0 screens: 1
Screen-1: 0 s-res: 2560x1440 s-dpi: 96 s-size: 677x381mm (26.7x15.0")
s-diag: 777mm (30.6")
Monitor-1: HDMI2 res: 2560x1440 hz: 60 dpi: 108
size: 600x340mm (23.6x13.4") diag: 690mm (27.2")
OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 20.1.7
direct render: Yes
Audio:
Device-1: Intel 200 Series PCH HD Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:a2f0
Sound Server: ALSA v: k5.8.6-1-MANJARO
Network:
Device-1: Intel Ethernet I219-V vendor: ASUSTeK driver: e1000e v: 3.2.6-k
port: f040 bus ID: 00:1f.6 chip ID: 8086:15b8
IF: enp0s31f6 state: up speed: 100 Mbps duplex: full mac:
IP v4: type: dynamic noprefixroute scope: global
broadcast:
IP v6: type: noprefixroute scope: link
WAN IP:
Drives:
Local Storage: total: 3.67 TiB used: 3.26 TiB (88.9%)
ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 960 EVO 1TB size: 931.51 GiB
block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4
serial: rev: 3B7QCXE7 temp: 29 Celsius C scheme: GPT
SMART: yes health: PASSED on: 76d 21h cycles: 3,347
read-units: 32,256,884 [16.5 TB] written-units: 32,933,100 [16.8 TB]
ID-2: /dev/sda vendor: Toshiba model: HDWD130 family: P300 size: 2.73 TiB
block size: physical: 4096 B logical: 512 B sata: 3.0 speed: 6.0 Gb/s
rotation: 7200 rpm serial: rev: ACF0 temp: 32 C scheme: GPT
SMART: yes state: enabled health: PASSED on: 1y 51d 15h cycles: 3198
ID-3: /dev/sdb type: USB vendor: Transcend model: JetFlash Transcend 32GB
size: 29.92 GiB block size: physical: 512 B logical: 512 B
serial: rev: 8.07 scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Message: No Optical or Floppy data was found.
RAID:
Message: No RAID data was found.
Partition:
ID-1: / raw size: N/A size: 47.01 GiB used: 132.9 MiB (0.3%) fs: overlay
source: ERR-102 label: N/A uuid: N/A
ID-2: /run/media/manjaro/057b85c9-b6ff-4b9b-aca3-205852af69fc
raw size: 48.93 GiB size: 47.91 GiB (97.92%) used: 20.77 GiB (43.4%)
fs: ext4 block size: 4096 B dev: /dev/nvme0n1p1 label: N/A
uuid: 057b85c9-b6ff-4b9b-aca3-205852af69fc
ID-3: /run/media/manjaro/16fa0b3f-327b-4733-ba19-b415f916abab
raw size: 97.66 GiB size: 95.62 GiB (97.92%) used: 66.83 GiB (69.9%)
fs: ext4 block size: 4096 B dev: /dev/nvme0n1p3 label: N/A
uuid: 16fa0b3f-327b-4733-ba19-b415f916abab
ID-4: /run/media/manjaro/316D-9473 raw size: 199.0 MiB
size: 195.9 MiB (98.45%) used: 298 KiB (0.1%) fs: vfat block size: 512 B
dev: /dev/nvme0n1p2 label: N/A uuid: 316D-9473
ID-5: /run/media/manjaro/5c5a6aa0-c11d-489e-b79b-1474ff2a80a1
raw size: 784.73 GiB size: 771.42 GiB (98.30%) used: 658.95 GiB (85.4%)
fs: ext4 block size: 4096 B dev: /dev/nvme0n1p4 label: N/A
uuid: 5c5a6aa0-c11d-489e-b79b-1474ff2a80a1
ID-6: /run/media/manjaro/716ff601-4cbf-4c10-9eea-f0f1e6e791f4
raw size: 2.73 TiB size: 2.69 TiB (98.40%) used: 2.53 TiB (94.3%) fs: ext4
block size: 4096 B dev: /dev/sda1 label: N/A
uuid: 716ff601-4cbf-4c10-9eea-f0f1e6e791f4
Swap:
Alert: No Swap data was found.
Unmounted:
ID-1: /dev/sdb1 size: 2.25 GiB fs: iso9660 label: MANJARO_CINNAMON_201
uuid: 2020-09-13-00-39-29-00
ID-2: /dev/sdb2 size: 4.0 MiB fs: vfat label: MISO_EFI uuid: 760C-B302
USB:
Hub: 1-0:1 info: Full speed (or root) Hub ports: 16 rev: 2.0
speed: 480 Mb/s chip ID: 1d6b:0002
Device-1: 1-1:2 info: MosArt Wireless Keyboard/Mouse type: Keyboard,Mouse
driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 12 Mb/s
chip ID: 062a:4101
Hub: 1-5:4 info: Seagate RSS LLC Backup Plus Hub ports: 3 rev: 2.1
speed: 480 Mb/s chip ID: 0bc2:ab44
Device-1: 1-7:5 info: Logitech LX-700 Cordless Desktop Receiver
type: Keyboard,Mouse driver: logitech,usbhid interfaces: 2 rev: 1.1
speed: 1.5 Mb/s chip ID: 046d:c512
Device-2: 1-8:6 info: Logitech Unifying Receiver type: Keyboard,Mouse,HID
driver: logitech-djreceiver,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s
chip ID: 046d:c52b
Device-3: 1-14:7 info: ASUSTek AURA LED Controller type: HID
driver: hid-generic,usbhid interfaces: 1 rev: 2.0 speed: 12 Mb/s
chip ID: 0b05:1872 serial:
Hub: 2-0:1 info: Full speed (or root) Hub ports: 10 rev: 3.0 speed: 5 Gb/s
chip ID: 1d6b:0003
Hub: 3-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0
speed: 480 Mb/s chip ID: 1d6b:0002
Device-1: 3-2:2 info: Alcor Micro Flash Drive type: Mass Storage
driver: usb-storage interfaces: 1 rev: 2.0 speed: 480 Mb/s
chip ID: 058f:6387 serial:
Hub: 4-0:1 info: Full speed (or root) Hub ports: 2 rev: 3.1 speed: 10 Gb/s
chip ID: 1d6b:0003
Hub: 5-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0
speed: 480 Mb/s chip ID: 1d6b:0002
Hub: 6-0:1 info: Full speed (or root) Hub ports: 2 rev: 3.1 speed: 10 Gb/s
chip ID: 1d6b:0003
Sensors:
System Temperatures: cpu: 29.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info:
Processes: 304 Uptime: 19m Init: systemd v: 246 Compilers: gcc: 10.2.0
Packages: pacman: 1164 lib: 291 flatpak: 0 Shell: Bash (sudo) v: 5.0.18
running in: gnome-terminal inxi: 3.1.05

 

 

Линк към този отговор
Сподели в други сайтове
преди 18 минути, vpvelev написа:

А ти прочете ли двата отговора от вчера и пробва ли написаното?

Прочетох. Вече не помня точно какво ми даде, но не помогна.

Линк към този отговор
Сподели в други сайтове
преди 7 минути, vpvelev написа:

Вчера беше казал, че си сменял и пробвал с други ядра. Помниш ли след тях дали се инсталираха и драйверите за NVidia?

Не, не се инсталираха. Доколкото разбирам с малкото си познания, не може да е от това, защото системата си работеше месеци наред.


Линк към този отговор
Сподели в други сайтове

Системата може да е работила, но понякога след смяна на ядро се получава тои ефект( при NVidia)

За това пробвай в конзола да ъпдейтнеш драйвъра на видеото и пълен ъпдейт на системата

Линк към този отговор
Сподели в други сайтове
преди 2 минути, jojopara написа:

Не, не се енсталираха. Доколкото разбирам с малкото си познания, не може да е от това, защото системата си работеше месеци наред.

И моята работеше месеци наред и един прекрасен ден като се инсталира ново ядро не се обнови драйвера на NVidia. И след това, точно като при теб не испях да вляза в графичен режим. След доста четене и обикаляне по форуми разбрах проблема. И сега всеки път гледам като се инсталира ядрото дали се инсталира и драйвера на NVidia. Веднъж забелязах че това не стана и пак не успях да вляза в графичен режим. Но сега вече знаех какво да правя.

Линк към този отговор
Сподели в други сайтове
преди 5 минути, danieli написа:

Системата може да е работила, но понякога след смяна на ядро се получава тои ефект( при NVidia)

За това пробвай в конзола да ъпдейтнеш драйвъра на видеото и пълен ъпдейт на системата

Опитах

Опитах и нища не стана. Системата си работеше след обновяването на ядрото, което стана преди няколко седмици.

преди 5 минути, vpvelev написа:

И моята работеше месеци наред и един прекрасен ден като се инсталира ново ядро не се обнови драйвера на NVidia. И след това, точно като при теб не испях да вляза в графичен режим. След доста четене и обикаляне по форуми разбрах проблема. И сега всеки път гледам като се инсталира ядрото дали се инсталира и драйвера на NVidia. Веднъж забелязах че това не стана и пак не успях да вляза в графичен режим. Но сега вече знаех какво да правя.

За мен като лаик са стрпанни такива явления - изведнъж нещо да престане да работи. Ще трябва и аз да се науча! :(

Линк към този отговор
Сподели в други сайтове
преди 1 минута, vpvelev написа:

Снимай с телефона и покажи да видим какво става в конзолата и какво изписва.

Извинявай, но може ли пак да дадеш командите, че както писах постът ми е изтрит.

Линк към този отговор
Сподели в други сайтове
преди 3 часа, jojopara написа:

Intel Corporation UHD Graphics 630 (Desktop) (prog-if 00 [VGA controller])

Каква трябва да е командата на горната карта?

Горната карта не ти е проблема. Това е вграденото видео в процесора.

Нали вчера написа, че външната карта ти е NVidia. В нея е проблема.

Когато пак не влезе в графичния режим, натисни заедно Ctrl+Alt+F2 и така влизаш в терминала tty2 в случая. След това си пишеш потребителското име и след това паролата. При писане на паролата не се изписват "*". Това го казвам за всеки случай, защото един колега тук казваше че не му работела клавиатурата когато пишел паролата.

След това пишеш:

sudo pacman -S nvidia

След това рестартираш.

Линк към този отговор
Сподели в други сайтове

Сега, последно това ли ти е видео картата или envidia защото ако е интелска и е само тя е малко вероятно това да е проблема и трябва да се търси проблема някъде другаде

Линк към този отговор
Сподели в други сайтове
преди 2 минути, bulljo написа:

Сега, последно това ли ти е видео картата или envidia защото ако е интелска и е само тя е малко вероятно това да е проблема и трябва да се търси проблема някъде другаде

Много се извинявам! Простете невежеството ми!

Имам само вградена карта, която дадох по-горе.

Междувременно изхполвах timeshift - никога не съм успявал да вазстановя с него. Сега ми излиза

Error: symbol grub_is_lockdown not found         Той ще ми каже, че не намира локдаун. Да дойде и да види :)

Бях на път да преинсталирам Манджаро или да премина на FreeBSD. Ще се поборя с ваша помощ още малко и после ...

Линк към този отговор
Сподели в други сайтове

Ако няма наистина някакви данни, които да загубиш, по-добре е да преинсталираш. Щом нямаш NVidia, не зная вече какво може друго да е станало. Може и да тръгне, амам някой ден пак да стане. Така че по-добре преинсталация. Доколкото зная Манжаро вече няма Цинамон.  Даже може и да е заради това.

Линк към този отговор
Сподели в други сайтове
преди 1 минута, vpvelev написа:

Ако няма наистина някакви данни, които да загубиш, по-добре е да преинсталираш. Щом нямаш NVidia, не зная вече какво може друго да е станало. Може и да тръгне, амам някой ден пак да стане. Така че по-добре преинсталация. Доколкото зная Манжаро вече няма Цинамон.  Даже може и да е заради това.

Няма какво да загубя освен малко време за насторойки и инсталиране. Убедил съм се, че за неразбиращ като мен, е по-лесно да преинсталира.  Вече 24 ч. се мъчим да намерим решение.

Много странно За Канелата и Манджаро.

 

Благодаря на всички ви!

Линк към този отговор
Сподели в други сайтове

И аз така мисля, след манджата която си забъркал с timeshift  си омазал и bootloader няма кой да разплита конците на проблема, та ако имаш важни неща на диска с едно лайв дистро спасяваш информацията която ти трябва и преинсталирай.

Следващия път, ако имаш пак такива проблеми не бързай сам да мажеш върху тях, ами се консултирай преди това защото манджата става все по гъста и гъста.

Линк към този отговор
Сподели в други сайтове
преди 23 минути, jojopara написа:

Убедил съм се, че за неразбиращ като мен, е по-лесно да преинсталира

Taкa и така ще преинсталираш, защо не си избереш нормално дистро?
Мащай ги тез арчерски боклуци. :D

Линк към този отговор
Сподели в други сайтове

Добавете отговор

Можете да публикувате отговор сега и да се регистрирате по-късно. Ако имате регистрация, влезте в профила си за да публикувате от него.

Гост
Напишете отговор в тази тема...

×   Вмъкнахте текст, който съдържа форматиране.   Премахни форматирането на текста

  Разрешени са само 75 емотикони.

×   Съдържанието от линка беше вградено автоматично.   Премахни съдържанието и покажи само линк

×   Съдържанието, което сте написали преди беше възстановено..   Изтрий всичко

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Добави ново...

Информация

Поставихме бисквитки на устройството ви за най-добро потребителско изживяване. Можете да промените настройките си за бисквитки, или в противен случай приемаме, че сте съгласни с нашите Условия за ползване