Премини към съдържанието
  • Добре дошли!

    Добре дошли в нашите форуми, пълни с полезна информация. Имате проблем с компютъра или телефона си? Публикувайте нова тема и ще намерите решение на всичките си проблеми. Общувайте свободно и открийте безброй нови приятели.

    Моля, регистрирайте се за да публикувате тема и да получите пълен достъп до всички функции.

     

Проблем с добавяне на камери


Препоръчан отговор

Здравейте,

върнах фабричните настройки на NVR Hikvision DS-7616NI-K1

и сега съм добавил 3 камери (1 на Hikvision и 2 на Dahua).

Останалите 3 на Dahua не успявам да ги добавя.

Например камера с ип *.111 е модел IPC-HFW1220S и ми дава грешно

потребителско име или парола.

Отначало работех на самият NVR и с мишката и виртуалната клавиатура

изписвах потребителското име и парола, след това му давах да покаже

паролата, за да съм сигурен, че нямам правописна грешка и все същото.

След това преминах на компа. Там си влизам и като админ и като потребител

на камера и я виждам на живо.

След това отварям през IE NVR-a и там с изписване и също и с copy-paste изписвам

данните за добавяне и пак и пак не иска да се добави.

Подскажете други идеи какво да направя?

Прилагам снимки от мрежовите настройки на камера с ип *.120, която е добавена

и на ип *.111, която не мога да добавя. Ип-то на NVR е *.202 (вижда се от адрес бара).

111.png

120.png

spisak.png

Линк към коментара
Сподели в други сайтове

Здрасти,

Тъп въпрос задавам - камерите dahua еднакъв модел и с еднаква версия на фърмуера ли са? Питам, защото е възможно да имат разминаване във версията на ONVIF протокола. Това е едно на ръка. Второ, ONVIF credentials check не е включено по подразбиране на някои камери и ако задаваш потребител и парола, а ONVIF не ги търси, това е ефектът - не можеш да се логнеш в камерата през ONVIF. През същия порт 80 по HTTP, обаче, нямаш проблем да се логнеш, защото уеб-сървърът на камерата винаги очаква автентикация. Но за ONVIF трябва да провериш какво е настроено в менюто на камерата през IE. Не ми питай къде, не им помня менютата наизуст. :D

Третият вариант е паролите на тези камери да съдържат символ, на който NVR-ът не се кефи и не успява да се логне в камерите по тази причина. Ако смениш паролата на поне една от проблемните камери да бъде 12345678, колкото за теста, ще стане ясно.

 

Линк към коментара
Сподели в други сайтове

Здравей. Забелязах, че маските на мрежовите адреси на камерите са различни. Тези маски на камерите и на NVR трябва да са еднакви, защото са в една мрежа. Оправи маските първо, след това добавяй камери в NVR.

Линк към коментара
Сподели в други сайтове

преди 5 часа, Stoqn Petkov написа:

111.png

Маската трябва да е 255.255.255.0 ... 

Успех!

Линк към коментара
Сподели в други сайтове

преди 7 часа, mkkostov написа:

Здравей. Забелязах, че маските на мрежовите адреси на камерите са различни. Тези маски на камерите и на NVR трябва да са еднакви, защото са в една мрежа. Оправи маските първо, след това добавяй камери в NVR.

 

преди 6 часа, dioib написа:

Маската трябва да е 255.255.255.0 ... 

Успех!

Е ... нали са в една и съща мрежа? Как /16 и /24 няма да могат да си говорят в един и същи събнет? :D Маската не е драма, в случая. Нещо друго е.

Линк към коментара
Сподели в други сайтове

на 18.09.2022 г. в 22:59, Rammkopf написа:

Здрасти,

Тъп въпрос задавам - камерите dahua еднакъв модел и с еднаква версия на фърмуера ли са? Питам, защото е възможно да имат разминаване във версията на ONVIF протокола. Това е едно на ръка. Второ, ONVIF credentials check не е включено по подразбиране на някои камери и ако задаваш потребител и парола, а ONVIF не ги търси, това е ефектът - не можеш да се логнеш в камерата през ONVIF. През същия порт 80 по HTTP, обаче, нямаш проблем да се логнеш, защото уеб-сървърът на камерата винаги очаква автентикация. Но за ONVIF трябва да провериш какво е настроено в менюто на камерата през IE. Не ми питай къде, не им помня менютата наизуст. :D

Третият вариант е паролите на тези камери да съдържат символ, на който NVR-ът не се кефи и не успява да се логне в камерите по тази причина. Ако смениш паролата на поне една от проблемните камери да бъде 12345678, колкото за теста, ще стане ясно.

 

ip 109  HFW1220S , software:    2.420.0000.10.R, Build Date: 2017-03-28. Там имам onvif Authentication – on. Направих по-проста парола, но пак си дава грешен user или парола на камерата.

Ip

110  HFW1220S , Software Version  2.420.0000.10.R, Build Date: 2017-03-28, маска като nvr. Смених маската на 255.255.255.0 и също сложих парола от думи и цифри (преди това имаше и @, !, # и други такива). Пак не иска.

ip 113  добавена е. HFW1230S-S4, System Version  V2.680.0000000.11.R, Build Date: 2019-12-30 Там паролата е примерно [email protected]! и си работи.

на 19.09.2022 г. в 2:49, mkkostov написа:

Здравей. Забелязах, че маските на мрежовите адреси на камерите са различни. Тези маски на камерите и на NVR трябва да са еднакви, защото са в една мрежа. Оправи маските първо, след това добавяй камери в NVR.

опитах със 110-то ип, но не промени нещата....

на 19.09.2022 г. в 3:43, dioib написа:

Маската трябва да е 255.255.255.0 ... 

Успех!

и с нея не иска.

Линк към коментара
Сподели в други сайтове

на 18.09.2022 г. в 22:59, Rammkopf написа:

Здрасти,

Тъп въпрос задавам

то тукаа в тоя форум всеки технически въпрос вече е тъп .

Линк към коментара
Сподели в други сайтове

преди 49 минути, Stoqn Petkov написа:

ip 109  HFW1220S , software:    2.420.0000.10.R, Build Date: 2017-03-28. Там имам onvif Authentication – on. Направих по-проста парола, но пак си дава грешен user или парола на камерата.

Ip

110  HFW1220S , Software Version  2.420.0000.10.R, Build Date: 2017-03-28, маска като nvr. Смених маската на 255.255.255.0 и също сложих парола от думи и цифри (преди това имаше и @, !, # и други такива). Пак не иска.

ip 113  добавена е. HFW1230S-S4, System Version  V2.680.0000000.11.R, Build Date: 2019-12-30 Там паролата е примерно [email protected]! и си работи.

опитах със 110-то ип, но не промени нещата....

и с нея не иска.

Не ги слушай тези глупости за събнет маската, не е там проблемът. По принцип, с тези резултати, които ми даваш, започвам да мисля, че имаш проблем с версията на ONVIF. 1220 са архивни модели и вероятно поддържат ONVIF 2.2 максимум, а NVR-ът ти иска версия 2.3 или даже 2.4, от гледна точка на секюрити. Най-лесно ще разбереш, като махнеш паролите на проблемните камери. Ако и така казва, че имаш драма с username or password, работата е ясна. Ако имаш китайски NVR подръка, можеш да опиташ да ги закачиш там. Софтуерът на XiongMai работи с ONVIF между 2.0 и 2.4 безпроблемно.

Всъщност, като казах китайски NVR, що не опиташ с CMS-а им на китайците? Той позволява да се добавят поединично и камери, включително през ONVIF. Така ще разберем, дали съм прав. Можеш ли да го издърпаш от този Гугъл Драйв - https://drive.google.com/file/d/1CUfWmZ41H0Zf_r_T1xFL6g-naks18r1K/view ?

Линк към коментара
Сподели в други сайтове

преди 1 час, Rammkopf написа:

Не ги слушай тези глупости за събнет маската, не е там проблемът. По принцип, с тези резултати, които ми даваш, започвам да мисля, че имаш проблем с версията на ONVIF. 1220 са архивни модели и вероятно поддържат ONVIF 2.2 максимум, а NVR-ът ти иска версия 2.3 или даже 2.4, от гледна точка на секюрити. Най-лесно ще разбереш, като махнеш паролите на проблемните камери. Ако и така казва, че имаш драма с username or password, работата е ясна. Ако имаш китайски NVR подръка, можеш да опиташ да ги закачиш там. Софтуерът на XiongMai работи с ONVIF между 2.0 и 2.4 безпроблемно.

Всъщност, като казах китайски NVR, що не опиташ с CMS-а им на китайците? Той позволява да се добавят поединично и камери, включително през ONVIF. Така ще разберем, дали съм прав. Можеш ли да го издърпаш от този Гугъл Драйв - https://drive.google.com/file/d/1CUfWmZ41H0Zf_r_T1xFL6g-naks18r1K/view ?

То няма да ми даде празна парола. Даже опитах да сложа парола от 1 до 8 и каза, че трябва да има и втори вид символи - това през IE.

Иначе камерите работеха на този NVR, просто бяха с други ип-та. Смених ип-тата, резетнах NVR, смених на камерите паролите и сега има драма.

Опитвах да добавям камерите и с админ и паролата, но пак не става. По принцип съм направил на всяка камера потребил и с него я вкарвам в NVR.

С тази програмка нещо не мога да се оправя. Изписвам ип на камерата, но не ми намира устройство. Не намерих опция да напиша ип в самата програма....

Линк към коментара
Сподели в други сайтове

Е, сега ме уби вече. :D Щом е работело преди и само си ресетнал NVR, значи не е проблем с ONVIF.

Ето малко помощ за въпросната CMS:

1. Във функционалния панел, долу вдясно, избираш "System" и после натискаш червения бутон от Гласът на България - "Device Manager", горе вдясно.

2. В Device Manager си дефинираш някаква зона под "Zone List", след което избираш новосъздадената зона и към нея добавяш устройство.

3. В прозореца за ново устройство, задаваш име на устройството, даваш му IP адреса, порт, потребител, парола и най-важното е в падащото меню Vendor най-долу да зададеш верния протокол. Тази програмка поддържа китайския NETIP (разписан като H264DVR и избран по подразбиране), Hik, Dahua и ONVIF. Ако порта го пишеш 37777 (стига да не си го сменил в камерата, разбира се), ще можеш да я добавиш по дахуйския протокол. Иначе, за ONVIF - през 80-ти. Ако и с тази програмка не стане, виж си отново настройките на камерите.

Линк към коментара
Сподели в други сайтове

След като си ресетнал NVR-a явно стария е имал други настройки за тези камери , който не се виждат. Провери ли на тези камери портовете дали съвпадат с настройките на NVR-a?

""Default Ports: TCP: 37777 UDP: 37778 HTTP: 80 RTSP: 554 HTTPS: 443.""

Линк към коментара
Сподели в други сайтове

преди 19 часа, Rammkopf написа:

Е, сега ме уби вече. :D Щом е работело преди и само си ресетнал NVR, значи не е проблем с ONVIF.

Ето малко помощ за въпросната CMS:

1. Във функционалния панел, долу вдясно, избираш "System" и после натискаш червения бутон от Гласът на България - "Device Manager", горе вдясно.

2. В Device Manager си дефинираш някаква зона под "Zone List", след което избираш новосъздадената зона и към нея добавяш устройство.

3. В прозореца за ново устройство, задаваш име на устройството, даваш му IP адреса, порт, потребител, парола и най-важното е в падащото меню Vendor най-долу да зададеш верния протокол. Тази програмка поддържа китайския NETIP (разписан като H264DVR и избран по подразбиране), Hik, Dahua и ONVIF. Ако порта го пишеш 37777 (стига да не си го сменил в камерата, разбира се), ще можеш да я добавиш по дахуйския протокол. Иначе, за ONVIF - през 80-ти. Ако и с тази програмка не стане, виж си отново настройките на камерите.

мда. така го бях направил, просто не става. Add zone - add device.

Иначе в тази програмка на порт 37777 и h264dvr ми дава login timeout. При порт

80 и долу от падащото Onvif ми дава грешен user, passwd. А в браузъра влизам.

по-долу ще кача снимки от настройките на работещата камера със зелен тик и

от неработещата с червен "Х".

преди 18 часа, belefor написа:

След като си ресетнал NVR-a явно стария е имал други настройки за тези камери , който не се виждат. Провери ли на тези камери портовете дали съвпадат с настройките на NVR-a?

""Default Ports: TCP: 37777 UDP: 37778 HTTP: 80 RTSP: 554 HTTPS: 443.""

уж са така....

 

cms-110.png

ne1.png

ne2.png

ne3.png

ne4.png

raboti1.png

raboti2.png

Линк към коментара
Сподели в други сайтове

преди 16 минути, Stoqn Petkov написа:

мда. така го бях направил, просто не става. Add zone - add device.

Иначе в тази програмка на порт 37777 и h264dvr ми дава login timeout. При порт

80 и долу от падащото Onvif ми дава грешен user, passwd. А в браузъра влизам.

по-долу ще кача снимки от настройките на работещата камера със зелен тик и

от неработещата с червен "Х".

уж са така....

 

cms-110.png

ne1.png

ne2.png

ne3.png

ne4.png

raboti1.png

raboti2.png

Ама ако ги добавяш на порт 37777, трябва Vendor да бъде dahua, а не H264DVR. Ти си я пратил на дахуйския порт да търси китайския протокол и затова ти дава Login timeout.

Ако на порт 80 не ти дава да я закачиш през ONVIF, значи имаш някаква драма със самите камери.

Добре, искаш ли да опиташ да им спреш автентикацията през ONVIF? Спри я, после им дай Save, пак им разреши автентикацията и пак Save. Или опитай да им цъкнеш направо "Default" в ONVIF менюто. Въобще ... нещо, с което да ги "разклатиш" малко. Не ми е ясно какво им се е случило ... Сякаш конфигурацията им е "забила" в очакване на нещо, дето няма как да го получат вече (част от стара конфигурация?) и трябва да ги накараш да "изчистят" очакванията си.

Мeжду другото, виждам, че не щат и към облака да се закачат. Тези 1220-ски, случайно да не ги е тряскал някой ботнет и затова си ресетвал системата?

Линк към коментара
Сподели в други сайтове

на 22.09.2022 г. в 12:01, Rammkopf написа:

Ама ако ги добавяш на порт 37777, трябва Vendor да бъде dahua, а не H264DVR. Ти си я пратил на дахуйския порт да търси китайския протокол и затова ти дава Login timeout.

Ако на порт 80 не ти дава да я закачиш през ONVIF, значи имаш някаква драма със самите камери.

Добре, искаш ли да опиташ да им спреш автентикацията през ONVIF? Спри я, после им дай Save, пак им разреши автентикацията и пак Save. Или опитай да им цъкнеш направо "Default" в ONVIF менюто. Въобще ... нещо, с което да ги "разклатиш" малко. Не ми е ясно какво им се е случило ... Сякаш конфигурацията им е "забила" в очакване на нещо, дето няма как да го получат вече (част от стара конфигурация?) и трябва да ги накараш да "изчистят" очакванията си.

Мeжду другото, виждам, че не щат и към облака да се закачат. Тези 1220-ски, случайно да не ги е тряскал някой ботнет и затова си ресетвал системата?

Уж не е имало проблеми с вируси и тем подобни. Бяха в друга мрежа 172. 22..... временно и ги върнах в 172.16.... като смених паролите, но в нвр и през browser си ги изписвам правилно. Опитах да ги разбутам, но все същото.

Видях,че имат опция за резет и интересното е, че нищо не се случи - ип си остава 172.... , а

не 192.168.... акаунтите си остават същите. Т.е нищо не се резетва в крайна сметка

по камерата :)

Дава, че е успешно и продължавам да си цъкам по менютата. Давам изход и след

това си влизам обратно със същото ип и същият юзър. Рестартирах ги за

над минута от захранването и пак си е същото.

 

24ti.png

Линк към коментара
Сподели в други сайтове

Имаме пробив, макар и частичен.

Бях опитвал по-рано и с администраторският акаунт, но все

не искаше.

Сега направих друго - резетнах камерата през config tool и наистина

си върна настройките - ип 1.108, акаунт и всичко без дата и час.

Пак си направих моите си неща и този път поне я добавям с

администраторският акаунт, а с потребителя не иска.

Прилагам снимки при тези камери как изглеждат нещата с

юзъра. При другите е по-различно оформлението, но по принцип

нищо не съм пипал там.

admin.png

group.png

user.png

Линк към коментара
Сподели в други сайтове

Аз това щях да питам - с какво ги ресетваш. После видях в другия пост, че с инструмента си ги ошетал.

Сега, потребителят е в група с ограничени права, вероятно. Иди в таба Group, избери "user" групата, отвори я за редакция и виж какви права има. Пише само "Live" в бързото описание под юзърите, т.е. можеш да я гледаш на живо, но не е ясно през какви канали. Не помня наизуст какви бяха отделните привилегии на групите, хубаво е да ги разгледаш.

 

EDIT: Видях привилегиите в screenshot-овете по-горе. Според мен, трябва да дадеш на потребителската група права General и Video/Audio.

Линк към коментара
Сподели в други сайтове

на 24.09.2022 г. в 23:15, Rammkopf написа:

Аз това щях да питам - с какво ги ресетваш. После видях в другия пост, че с инструмента си ги ошетал.

Сега, потребителят е в група с ограничени права, вероятно. Иди в таба Group, избери "user" групата, отвори я за редакция и виж какви права има. Пише само "Live" в бързото описание под юзърите, т.е. можеш да я гледаш на живо, но не е ясно през какви канали. Не помня наизуст какви бяха отделните привилегии на групите, хубаво е да ги разгледаш.

 

EDIT: Видях привилегиите в screenshot-овете по-горе. Според мен, трябва да дадеш на потребителската група права General и Video/Audio.

Пусто не става и не става - все дава грешен потребител/парола. Направих друг юзър, вкарах го група админ, избрах му

всички отметки и пак не иска.

Първо беше nvr, новият го кръстих test и все не иска. Останалите камери са с username: nvr.

С админ си влиза от раз, но тест или нвр не иска и не иска...

1.png

2.png

3.png

Линк към коментара
Сподели в други сайтове

Явно нещо се лигави с автентикацията по ONVIF на тези модели. Нямам идея с какво друго мога да помогна насляпо, настина.

Линк към коментара
Сподели в други сайтове

преди 3 часа, Rammkopf написа:

Явно нещо се лигави с автентикацията по ONVIF на тези модели. Нямам идея с какво друго мога да помогна насляпо, настина.

и аз нямам идея. Подкарах ги с админ акаунта, но не ме кефи това решение.

Все пак нвр е с актален firmware и дълга и сложна админ парола, та дано не реши някой, че иска да го хакне...

Линк към коментара
Сподели в други сайтове

Добавете отговор

Можете да публикувате отговор сега и да се регистрирате по-късно. Ако имате регистрация, влезте в профила си за да публикувате от него.

Гост
Публикацията ви съдържа термини, които не допускаме! Моля, редактирайте съдържанието си и премахнете подчертаните думи по-долу. Ако замените букви от думата със звездички или друго, за да заобиколите това предупреждение, профилът ви ще бъде блокиран и наказан!
Напишете отговор в тази тема...

×   Вмъкнахте текст, който съдържа форматиране.   Премахни форматирането на текста

  Разрешени са само 75 емотикони.

×   Съдържанието от линка беше вградено автоматично.   Премахни съдържанието и покажи само линк

×   Съдържанието, което сте написали преди беше възстановено..   Изтрий всичко

×   You cannot paste images directly. Upload or insert images from URL.

 Сподели

×
×
  • Добави ново...