Премини към съдържанието
RudeBoy

Windows 10 не ми разпознава SDHC карта

Препоръчан отговор


Имам една мемори карта, SDHC 8GB, няма марка. Беше ми подарък с фотоапарата. На около 4.5 години е, но е ползвана рядко, основно стои в резерв. От вчера компютърът с Windows 10 x64 LTSB отказва да я разпознае. Ползвам четец за карти, също неизвестен китаец, който не си знае годините :) . Нормално бих изхвърлил картата и/или четеца, без да се замислям много. Но:

1) Картата работи нормално във фотоапарата. Форматира се, снимките се запомнят на нея, апаратът ги възпроизвежда.

2) На същия компютър имам и Linux Mint, dual boot с Windows 10. На Linux-а картата със същия четец работи безпроблемно. Прехвърлих си от нея снимките, след това качих видеоклип.

3) Картата работи и на телевизора, със и без карт рийдъра. Гореспоменатият качен видеоклип се възпроизведе.

4) На същия Windows, същият карт рийдър без никакви проблеми работи с други мемори карти! 

5) Мемори картата, включена към USB-то с четеца, се вижда в Device Manager, както и от EaseUS Partition Master. Но не и от Windows Explorer! Той вижда само четеца, все едно няма нищо в него. Съответно не мога да отворя картата, да я форматирам, да я извадя безопасно - нищо.

Не знам вече какво да правя. Ако имате съвети - приемам ги, благодаря предварително.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Явно няма драйвери за четеца?

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Е тогава как четецът работи с другите две мемори карти? И защо картата се вижда като устройство в DIsk management, но не и в Windows Explorer?

Ще пробвам да преинсталирам драйверите, за всеки случай.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Провери в diskmgmt.msc вижда ли се дела и му назначи буква.
Другият вариант е при включен кард рийдър в devmgmt.msc деинсталирай устроийството (кард рийдъра)

Редактирано от DarkEdge (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
преди 28 минути, DarkEdge написа:

Провери в devmgmt.msc вижда ли се дела и му назначи буква.

:huh:

Къде да погледна, тук ли?

878750.jpg

Не виждам възможност за задаване на буква.

Това е в Windows Explorer, картата е закачена към USB-то:

878751.jpg

 

А това е картинката в Disk Managemet, при опит да форматирам или сменя буквата:

878752.jpg

 

А това е Explorer-ът, с друга карта, със същия четец в същото USB:

878753.jpg

 

преди 28 минути, DarkEdge написа:

Другият вариант е при включен кард рийдър в devmgmt.msc деинсталирай устроийството (кард рийдъра)

Изпълнено. И рестартирах след това, за да може Windows да му намери драйвер.

Няма промяна.

преди 38 минути, Eclipse2G написа:

Явно няма драйвери за четеца?

Единствените драйвери, които намирам, са на диска, дошъл ми с дънната платка. Според Windows те са същите като сегашните ми.


Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Омазан Windows. Преинсталираш. Ако е извадена неправилно или се е случило да не се премахне правилно затова Windows не я и разпознава. 

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Проблемът е решен.

През Linux, който вижда картата, записах на нея ISO с Mint 18.3, и я направих буутваща. След което Windows успя да я разпознае. С помощта на EaseUS Partition Master изтрих всички дялове на нея, създадох на чисто един дял с размер цялото свободно място, зададох му буква - и всичко е точно :cool: .

Благодаря на всички, които се включиха в темата :beer: 

 

преди 14 минути, Емил Костов написа:

Омазан Windows. Преинсталираш. Ако е извадена неправилно или се е случило да не се премахне правилно затова Windows не я и разпознава. 

Логично предположение, но в случая е грешно. Този Win го инсталирах наскоро, и още не съм успял да го омажа :) .

А и много внимавам с карти и флашки, винаги ги вадя след "Safe Remove".

  • Харесва ми 1

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
преди 3 минути, RudeBoy написа:

Проблемът е решен.

През Linux, който вижда картата, записах на нея ISO с Mint 18.3, и я направих буутваща. След което Windows успя да я разпознае. С помощта на EaseUS Partition Master Изтрих всички дялове на нея, създадох на чисто един дял с размер цялото свободно място, зададох му буква - и всичко е точно :cool: .

Благодаря на всички, които се включиха в темата :beer: 

 

Логично предположение, но в случая е грешно. Този Win го инсталирах наскоро, и още не съм успял да го омажа :) .

А и много внимавам с карти и флашки, винаги ги вадя след "Safe Remove".

Не ме разбра! НЕ си го омазал ти. Той може и сам да се омаже. А казаното от теб потвърждава моето мнение. По някаква причина картата не се е премахнала правилно. 

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
преди 28 минути, RudeBoy написа:

винаги ги вадя след "Safe Remove".

Оказва се, че това не винаги върши работа, ако не е указано изрично да се спира захранванео на устройсвото:

reg add "HKLM\SYSTEM\CurrentControlSet\Services\usbhub\HubG" /f /v "DisableOnSoftRemove" /t REG_DWORD /d 1

Влиза в сила след рестарт.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Регистрирайте се или влезете в профила си за да коментирате

Трябва да имате регистрация за да може да коментирате това

Регистрирайте се

Създайте нова регистрация в нашия форум. Лесно е!

Нова регистрация

Вход

Имате регистрация? Влезте от тук.

Вход

×

Информация

Поставихме бисквитки на устройството ви за най-добро потребителско изживяване. Можете да промените настройките си за бисквитки, или в противен случай приемаме, че сте съгласни с нашите условия за ползване.