Премини към съдържанието
  • Добре дошли!

    Добре дошли в нашите форуми, пълни с полезна информация. Имате проблем с компютъра или телефона си? Публикувайте нова тема и ще намерите решение на всичките си проблеми. Общувайте свободно и открийте безброй нови приятели.

    Моля, регистрирайте се за да публикувате тема и да получите пълен достъп до всички функции.

     

Създаване на Appimage от проект на QT


Препоръчан отговор


Здравейте, написах си програмка на Кюти с връзка към база данни но не мога да разбера как да си направя Appimage от нея? Официалното ръководство на probonopd е много неясно та ако може да дадете линк или да ми обясните как става? Разбрах че трябва да имам AppDir със съоветната структура само не разбирам трябва ли да копирам програмата и библиотеките в тази структура или linuxdeployqt ще го свърши? Както и къде да стартирам linuxdepoloyqt в папката на проекта ли или другаде? Затрднен съм защото е даден такъв начин на стартиране

linuxdeployqt-continuous-x86_64.AppImage path/to/AppDir/usr/share/applications/your_app.desktop

 

Линк към този отговор
Сподели в други сайтове

Документацията се оказа пълен т*шак... Никакви структури не трябват само три файла, изпълнимия иконата и десктоп файла и тогава пускаме

linuxdeployqt-continuous-x86_64.AppImage your_app.desktop -appimage	

Естевенно е добре да посочим пътят до десктоп файла......

Линк към този отговор
Сподели в други сайтове

Сега сваалям Федора 33 че тоя appimage дето го направих пали само на новите дистрибуции... :)  Та да видим дали няма някой чалъм да тръгре и на по дъртите ама първо да видим дали пали под федора33

Линк към този отговор
Сподели в други сайтове

Appimage-а не е идеален, той бъндълва една част от зависимостите, но не всички. Т.е. на клиентската машина трябва да имаш един минимум от библиотеки и версии. Flatpak е малко по-добре, като той използва контейнер, за да стартира приложенията и те са доста по-универсални, но самият той иска базови библиотеки и версии, което е горе-долу същото, откъм зависимости.

Линк към този отговор
Сподели в други сайтове
преди 12 часа, bvbfan написа:

Appimage-а не е идеален, той бъндълва една част от зависимостите, но не всички. Т.е. на клиентската машина трябва да имаш един минимум от библиотеки и версии. Flatpak е малко по-добре, като той използва контейнер, за да стартира приложенията и те са доста по-универсални, но самият той иска базови библиотеки и версии, което е горе-долу същото, откъм зависимости.

Разбира се че е така ама аз съм си любопитко та затова и се опитвам и така и научавам все повече за Линукс и двете си любими дистрота  Дебиан и openSUSE което повече ме кара да се възхишавам на Линукс , при Федора 33 например пищи за xcb


Линк към този отговор
Сподели в други сайтове
преди 12 минути, petie1 написа:

при Федора 33 например пищи за xcb

https://fedora.pkgs.org/33/rpm-sphere-x86_64/xcb-2.5-377.1.x86_64.rpm.html

Линк към този отговор
Сподели в други сайтове
преди 3 минути, p4p написа:

Мерси реших го още снощи а тази тема я ползвам като шоу какви проблеми може да възникнат с един appimage при различните дистрота :)

Линк към този отговор
Сподели в други сайтове

Добавете отговор

Можете да публикувате отговор сега и да се регистрирате по-късно. Ако имате регистрация, влезте в профила си за да публикувате от него.

Гост
Напишете отговор в тази тема...

×   Вмъкнахте текст, който съдържа форматиране.   Премахни форматирането на текста

  Разрешени са само 75 емотикони.

×   Съдържанието от линка беше вградено автоматично.   Премахни съдържанието и покажи само линк

×   Съдържанието, което сте написали преди беше възстановено..   Изтрий всичко

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Добави ново...

Информация

Поставихме бисквитки на устройството ви за най-добро потребителско изживяване. Можете да промените настройките си за бисквитки, или в противен случай приемаме, че сте съгласни с нашите Условия за ползване