Премини към съдържанието
15 години Kaldata.com – време е да почерпим! Прочети още... ×
Greak

Въпроси и проблеми с CentOS 6.4

Препоръчан отговор


Чувствам се "неудобно" да питам в общата тема, за това пускам специална тема в която ще задам няколко въпроса за тази дистрибуция. Предварително да кажа, че преди да попитам за всеки въпрос се консултирах с google и не открих решение. CentOS 6.4 x64

 

1. Как да дам постоянни права на това:

 

http://i.imgur.com/PA9bFWu.png , защото всеки път, когато сменям честотата ми иска root паролата ?

 

 

3. Исках да инсталирам Chrome, но не можах и следвах стъпките в интернет от тук - http://www.tecmint.com/install-google-chrome-on-redhat-centos-fedora-linux/ , но накрая ми върна това:

[root@localhost Yoan]# google-chrome &[1] 10317[root@localhost Yoan]# bash: google-chrome: command not found[1]+  Exit 127                google-chrome[root@localhost Yoan]#

Изпълнявах всяка команда внимателно и следвах всички стъпки ама уви...

 

3. Същото и със skype - http://www.if-not-true-then-false.com/2012/install-skype-on-fedora-centos-red-hat-rhel-scientific-linux-sl/

 

Връща ми:

[root@localhost lib]# skype/usr/bin/skype: /opt/skype/skype: /lib/ld-linux.so.2: bad ELF interpreter: No such file or directory[root@localhost lib]# [root@localhost lib]#
Редактирано от Greak (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

2. find / -name google-chrome

3. find / -name skype -type f -exec ldd {} ;

 

Изпълнявах ги като root.

 

2.

[Yoan@localhost ~]$ suPassword:[root@localhost Yoan]# find / -name google-chrome/var/lib/yum/repos/x86_64/6/google-chrome/var/cache/yum/x86_64/6/google-chrome[root@localhost Yoan]#

3.

[Yoan@localhost ~]$ suPassword:[root@localhost Yoan]# find / -name skype -type f -exec ldd {} ;        not a dynamic executable        not a dynamic executable[root@localhost Yoan]#
Редактирано от Greak (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

 

2.

 

http://i.imgur.com/F89yWG7.png

 

 

3.

[root@localhost Yoan]#  find / -name skype -type f/opt/skype/skype/usr/bin/skype[root@localhost Yoan]#

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Мисля, че четох някъде, че google-chrome вече не се издава за CENT OS.

  • Харесва ми 1

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

2. yum install libstdc++

3. ls -l /usr/bin/skype

file /usr/bin/skype

2:

[root@localhost Yoan]#  yum install libstdc++Loaded plugins: fastestmirror, refresh-packagekit, securityLoading mirror speeds from cached hostfile * base: mirror.telepoint.bg * extras: mirror.telepoint.bg * rpmforge: mirror1.hs-esslingen.de * updates: mirror.telepoint.bgSetting up Install ProcessPackage libstdc++-4.4.7-3.el6.x86_64 already installed and latest versionNothing to do[root@localhost Yoan]#

3:

[root@localhost Yoan]# ls -l /usr/bin/skype-rwxr-xr-x. 1 root root 88 Aug  5 14:11 /usr/bin/skype[root@localhost Yoan]# file /usr/bin/skype/usr/bin/skype: POSIX shell script text executable[root@localhost Yoan]#

Мисля, че четох някъде, че google-chrome вече не се издава за CENT OS.

 

Вярно е

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

зА skype

(~)% yum whatprovides ld-linux.so.2                                          :)Loaded plugins: fastestmirror, langpacks, refresh-packagekitLoading mirror speeds from cached hostfile * fedora: fr2.rpmfind.net * rpmfusion-free: fr2.rpmfind.net * rpmfusion-free-updates: fr2.rpmfind.net * rpmfusion-nonfree: fr2.rpmfind.net * rpmfusion-nonfree-updates: fr2.rpmfind.net * updates: fr2.rpmfind.netglibc-2.17-4.fc19.i686 : The GNU libc librariesRepo        : fedoraMatched from:Provides    : ld-linux.so.2
Инсталирай това:su -c 'yum install glibc' 

И после в терминал,  $ skype и ако има проблем покажи какво пише в терминал

Редактирано от ivoarch (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

пробвайте с това и след него инсталация на хром

yum install compat-libstdc++-33

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

 

зА skype

(~)% yum whatprovides ld-linux.so.2                                          :)Loaded plugins: fastestmirror, langpacks, refresh-packagekitLoading mirror speeds from cached hostfile * fedora: fr2.rpmfind.net * rpmfusion-free: fr2.rpmfind.net * rpmfusion-free-updates: fr2.rpmfind.net * rpmfusion-nonfree: fr2.rpmfind.net * rpmfusion-nonfree-updates: fr2.rpmfind.net * updates: fr2.rpmfind.netglibc-2.17-4.fc19.i686 : The GNU libc librariesRepo        : fedoraMatched from:Provides    : ld-linux.so.2
Инсталирай това:su -c 'yum install glibc'
[root@localhost Yoan]# su -c 'yum install glibc'Loaded plugins: fastestmirror, refresh-packagekit, securityLoading mirror speeds from cached hostfile * base: mirror.telepoint.bg * extras: mirror.telepoint.bg * rpmforge: archive.cs.uu.nl * updates: mirror.telepoint.bgSetting up Install ProcessPackage glibc-2.12-1.107.el6_4.2.x86_64 already installed and latest versionNothing to do[root@localhost Yoan]#

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

 

зА skype

(~)% yum whatprovides ld-linux.so.2                                          :)Loaded plugins: fastestmirror, langpacks, refresh-packagekitLoading mirror speeds from cached hostfile * fedora: fr2.rpmfind.net * rpmfusion-free: fr2.rpmfind.net * rpmfusion-free-updates: fr2.rpmfind.net * rpmfusion-nonfree: fr2.rpmfind.net * rpmfusion-nonfree-updates: fr2.rpmfind.net * updates: fr2.rpmfind.netglibc-2.17-4.fc19.i686 : The GNU libc librariesRepo        : fedoraMatched from:Provides    : ld-linux.so.2
Инсталирай това:su -c 'yum install glibc'

това е инсталирано :) без него линукса няма да работи :)

  • Харесва ми 1

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

пробвайте с това и след него инсталация на хром

yum install compat-libstdc++-33

[root@localhost Yoan]# yum install compat-libstdc++-33Loaded plugins: fastestmirror, refresh-packagekit, securityLoading mirror speeds from cached hostfile * base: mirror.telepoint.bg * extras: mirror.telepoint.bg * rpmforge: mirror.nl.leaseweb.net * updates: mirror.telepoint.bgSetting up Install ProcessPackage compat-libstdc++-33-3.2.3-69.el6.x86_64 already installed and latest versionNothing to do[root@localhost Yoan]#

Пак дава грешка при инсталцията на хром:

google-chrome-stable-28.0.1500.95-213514.x86_64 requires libstdc++.so.6(GLIBCXX_3.4.15)(64bit)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
[root@localhost Yoan]# yum install compat-libstdc++-33Loaded plugins: fastestmirror, refresh-packagekit, securityLoading mirror speeds from cached hostfile * base: mirror.telepoint.bg * extras: mirror.telepoint.bg * rpmforge: mirror.nl.leaseweb.net * updates: mirror.telepoint.bgSetting up Install ProcessPackage compat-libstdc++-33-3.2.3-69.el6.x86_64 already installed and latest versionNothing to do[root@localhost Yoan]#

Пак дава грешка при инсталцията на хром:

google-chrome-stable-28.0.1500.95-213514.x86_64 requires libstdc++.so.6(GLIBCXX_3.4.15)(64bit)

тогава остава играта с deb пакет и конвертиране с alien

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

тогава остава играта с deb пакет и конвертиране с alien

 

 

 

Мислех си одеве, сега ще си пойграя малко и с alien :D

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

това е инсталирано :) без него линукса няма да работи :)

Айде бе. (може)

 

Я инсталирай всичко това.

 su -c  'yum install glibc alsa-lib libXv libXScrnSaver qt qt-x11' 

Ако за един смотан skype и играш със alien незнам какво ще правиш по нататък.

Не може да не може д асе инсталира без този alien.

Редактирано от ivoarch (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Инсталирай си 32 битова среда ако нямаш

 

Хром не работи с потребител "root" само с по нисш ранг

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Айде бе. (може)

 

Я инсталирай всичко това.

 su -c  'yum install glibc alsa-lib libXv libXScrnSaver qt qt-x11' 

Ако за един смотан skype и играш със alien незнам какво ще правиш по нататък.

Не може да не може д асе инсталира без този alien.

точно glibc е стандартно

[root@bigi1 ~]# rpm -qa|wc -l216[root@bigi1 ~]# rpm -qa|grep glibcglibc-2.12-1.107.el6_4.2.x86_64glibc-common-2.12-1.107.el6_4.2.x86_64

Нали се сещаш каква инсталация е това (с 216 пакета)?

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

точно glibc е стандартно

[root@bigi1 ~]# rpm -qa|wc -l216[root@bigi1 ~]# rpm -qa|grep glibcglibc-2.12-1.107.el6_4.2.x86_64glibc-common-2.12-1.107.el6_4.2.x86_64

Нали се сещаш каква инсталация е това (с 216 пакета)?

Base!!

 

За glibc, идва си default, но явно му лиспват некои от Development Tools. 

и тогава какъв му е проблема със  ld-linux.so.2   

http://www.if-not-true-then-false.com/2012/install-skype-on-fedora-centos-red-hat-rhel-scientific-linux-sl/

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Base!!

 

За glibc, идва си default, но явно му лиспват некои от Development Tools. 

и тогава какъв му е проблема със  ld-linux.so.2   

http://www.if-not-true-then-false.com/2012/install-skype-on-fedora-centos-red-hat-rhel-scientific-linux-sl/

Minimal

Вероятно 32битови версии на някои библиотеки

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Айде бе. (може)

 

Я инсталирай всичко това.

 su -c  'yum install glibc alsa-lib libXv libXScrnSaver qt qt-x11' 
[Yoan@localhost ~]$ su -csu: option requires an argument -- 'c'Try `su --help' for more information.[Yoan@localhost ~]$ suPassword:[root@localhost Yoan]# yum install glibc alsa-lib libXv libXScrnSaver qt qt-x11Loaded plugins: fastestmirror, refresh-packagekit, securityLoading mirror speeds from cached hostfile * base: mirror.telepoint.bg * extras: mirror.telepoint.bg * rpmforge: mirror.nl.leaseweb.net * updates: mirror.telepoint.bgSetting up Install ProcessPackage glibc-2.12-1.107.el6_4.2.x86_64 already installed and latest versionPackage alsa-lib-1.0.22-3.el6.x86_64 already installed and latest versionPackage libXv-1.0.7-2.el6.x86_64 already installed and latest versionPackage libXScrnSaver-1.2.2-2.el6.x86_64 already installed and latest versionPackage 1:qt-4.6.2-26.el6_4.x86_64 already installed and latest versionPackage 1:qt-x11-4.6.2-26.el6_4.x86_64 already installed and latest versionNothing to do[root@localhost Yoan]#

А с alien не знам синтаксиса на комадите и много рядко се получава.

Редактирано от Greak (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Minimal

Вероятно 32битови версии на някои библиотеки

Ok де minimal , base , рабрахме се :)

 

иначе онова линкче където дадох горе има показани зависимости на скайпе.

 

Да пробва така.

su -c 'yum install alsa-lib fontconfig freetype glib2 libSM libXScrnSaver libXi libXrandr libXrender libXv libstdc++ pulseaudio-libs qt qt-x11 zlib'

 

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

 

su -c 'yum install alsa-lib fontconfig freetype glib2 libSM libXScrnSaver libXi libXrandr libXrender libXv libstdc++ pulseaudio-libs qt qt-x11 zlib'
[root@localhost Yoan]# yum install alsa-lib fontconfig freetype glib2 libSM libXScrnSaver libXi libXrandr libXrender libXv libstdc++ pulseaudio-libs qt qt-x11 zlibLoaded plugins: fastestmirror, refresh-packagekit, securityLoading mirror speeds from cached hostfile * base: mirror.telepoint.bg * extras: mirror.telepoint.bg * rpmforge: mirror.nl.leaseweb.net * updates: mirror.telepoint.bgSetting up Install ProcessPackage alsa-lib-1.0.22-3.el6.x86_64 already installed and latest versionPackage fontconfig-2.8.0-3.el6.x86_64 already installed and latest versionPackage freetype-2.3.11-14.el6_3.1.x86_64 already installed and latest versionPackage glib2-2.22.5-7.el6.x86_64 already installed and latest versionPackage libSM-1.2.1-2.el6.x86_64 already installed and latest versionPackage libXScrnSaver-1.2.2-2.el6.x86_64 already installed and latest versionPackage libXi-1.6.1-3.el6.x86_64 already installed and latest versionPackage libXrandr-1.4.0-1.el6.x86_64 already installed and latest versionPackage libXrender-0.9.7-2.el6.x86_64 already installed and latest versionPackage libXv-1.0.7-2.el6.x86_64 already installed and latest versionPackage libstdc++-4.4.7-3.el6.x86_64 already installed and latest versionPackage pulseaudio-libs-0.9.21-14.el6_3.x86_64 already installed and latest versionPackage 1:qt-4.6.2-26.el6_4.x86_64 already installed and latest versionPackage 1:qt-x11-4.6.2-26.el6_4.x86_64 already installed and latest versionPackage zlib-1.2.3-29.el6.x86_64 already installed and latest versionNothing to do[root@localhost Yoan]#

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

 

Ok де minimal , base , рабрахме се :)

 

иначе онова линкче където дадох горе има показани зависимости на скайпе.

 

Да пробва така.

su -c 'yum install alsa-lib fontconfig freetype glib2 libSM libXScrnSaver libXi libXrandr libXrender libXv libstdc++ pulseaudio-libs qt qt-x11 zlib'

Да, но доколкото разбирам трябва да са 32битови (библиотеките)

[root@localhost Yoan]# yum install alsa-lib fontconfig freetype glib2 libSM libXScrnSaver libXi libXrandr libXrender libXv libstdc++ pulseaudio-libs qt qt-x11 zlibLoaded plugins: fastestmirror, refresh-packagekit, securityLoading mirror speeds from cached hostfile * base: mirror.telepoint.bg * extras: mirror.telepoint.bg...

добави на всяка библиотека .i386

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
[root@localhost Yoan]# yum install alsa-lib fontconfig freetype glib2 libSM libXScrnSaver libXi libXrandr libXrender libXv libstdc++ pulseaudio-libs qt qt-x11 zlibLoaded plugins: fastestmirror, refresh-packagekit, securityLoading mirror speeds from cached hostfile * base: mirror.telepoint.bg * extras: mirror.telepoint.bg * rpmforge: mirror.nl.leaseweb.net * updates: mirror.telepoint.bgSetting up Install ProcessPackage alsa-lib-1.0.22-3.el6.x86_64 already installed and latest versionPackage fontconfig-2.8.0-3.el6.x86_64 already installed and latest versionPackage freetype-2.3.11-14.el6_3.1.x86_64 already installed and latest versionPackage glib2-2.22.5-7.el6.x86_64 already installed and latest versionPackage libSM-1.2.1-2.el6.x86_64 already installed and latest versionPackage libXScrnSaver-1.2.2-2.el6.x86_64 already installed and latest versionPackage libXi-1.6.1-3.el6.x86_64 already installed and latest versionPackage libXrandr-1.4.0-1.el6.x86_64 already installed and latest versionPackage libXrender-0.9.7-2.el6.x86_64 already installed and latest versionPackage libXv-1.0.7-2.el6.x86_64 already installed and latest versionPackage libstdc++-4.4.7-3.el6.x86_64 already installed and latest versionPackage pulseaudio-libs-0.9.21-14.el6_3.x86_64 already installed and latest versionPackage 1:qt-4.6.2-26.el6_4.x86_64 already installed and latest versionPackage 1:qt-x11-4.6.2-26.el6_4.x86_64 already installed and latest versionPackage zlib-1.2.3-29.el6.x86_64 already installed and latest versionNothing to do[root@localhost Yoan]#

Сега в терминал skype ,какво излиза?

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Регистрирайте се или влезете в профила си за да коментирате

Трябва да имате регистрация за да може да коментирате това

Регистрирайте се

Създайте нова регистрация в нашия форум. Лесно е!

Нова регистрация

Вход

Имате регистрация? Влезте от тук.

Вход

×

Информация

Поставихме бисквитки на устройството ви за най-добро потребителско изживяване. Можете да промените настройките си за бисквитки, или в противен случай приемаме, че сте съгласни с нашите условия за ползване.