Премини към съдържанието
  • Добре дошли!

    Добре дошли в нашите форуми, пълни с полезна информация. Имате проблем с компютъра или телефона си? Публикувайте нова тема и ще намерите решение на всичките си проблеми. Общувайте свободно и открийте безброй нови приятели.

    Моля, регистрирайте се за да публикувате тема и да получите пълен достъп до всички функции.

     

Препоръчан отговор

Що бре ?Това е много полезно за хора ,които сега за пръв път стартират Fedora .Що се отнася за теб,това е твое мнение ,а и ти си избираш какво да ти инсталира,какво толкова дали ще напишеш yum install -y skype или вметнеш една отметка на Skype и да ти инсталира не е ли едно и също ?Понякога ти спестява доста време.

Аз го намирам за доста практично и удобно.

Инсталирането на кодеци ,вместо да пиша всичките кодеци които са нужни и заедно с плейърите yum install ................. ,просто слагам едно тикче и всичките кодеци са инсталирани и плейъра.

Редактирано от acnekt (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Що бре ?Това е много полезно за хора ,които сега за пръв път стартират Fedora .

Само така ти се струва. Няма нищо послезно във това, полезно е гогато прочетеш как става дадено нещо и си го направиш за теб.

 

Какво е полeзното тук, на нещо да те учи, или да ти показва нещо, как се прави във федора?(НЕ) 

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Само така ти се струва. Няма нищо послезно във това, полезно е гогато прочетеш как става дадено нещо и си го направиш за теб.

 

Какво е полeзното тук, на нещо да те учи, или да ти показва нещо, как се прави във федора?(НЕ) 

Що при Уиндоус като свалиш EXE файл учи ли те как е направена програмата ,как е опакована,какво има вътре ,какво е DLL,какво е регистър,какво е thread,какво е процес,какво е adware ,просто NEXT,NEXT,NEXT и вече ползваш програмата.

Редактирано от acnekt (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Що при Уиндоус като свалиш EXE файл учи ли те как е направена програмата ,как е опакована,какво има вътре ,какво е DLL,какво е регистър,каквое thread,какво е процес,какво е adware ,просто NEXT,NEXT,NEXT и вече ползваш програмата.

Не :), но нали това е разликата между Линукс и Уин? 

Във Уин нема отворен код за да прочетеш как става едно нещо, във Линукс има отворен код, и във Луникс учиш как стават нещата и може да ги подубряваш и наместваш според твоите нужди ;)


Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Не :), но нали това е разликата между Линукс и Уин? 

Във Уин нема отворен код за да прочетеш как става едно нещо, във Линукс има отворен код, и във Луникс учиш как стават нещата и може да ги подубряваш и наместваш според твоите нужди ;)

Прав си,аз просто исках да помогна.Моя грешка .Извини ме,не бях помислил затова.

Редактирано от acnekt (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Прав си,аз просто исках да помогна.Моя грешка .Извини ме,не бях помислил затова.

Нема за какво да се извиняваш, просто исках да ти кажа, че тези програмки повече вредът отколкото д ати помагат за в бъдеще.

 

Поздрави.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

"За пичовете които използват Nvidia видео карти във Fedora Linux."

 

Както повечето знаят във федора ъпдейтите на кернели е честа, и доста често след ъпдейт на нов kernel, дава грешки и kernel panic, за това е не лоша идея, за тези които имат подобни проблеми, да знаят, че могът да конфигурират ъпдейтите на kernel да стават когато те искат, а останалата част от системата да се актуализира нормално.

 

Как става?

 

1). Влезнете като Root във системата.

 

Отворете терминал:

$> su

2). Изпълнете следнта команда:

#> echo "exclude=kernel*" >> /etc/yum.conf

3). Актуализирайте системата без да се притеснявате :)

$> su -c 'yum update'

===

 

Ако някога решите да актуализирате кернела.

 

1). Отново като Root във системата.

 

Отворете терминал.

$> su

2). Изпълнете следната команда.

#> sed -i '/exclude=kernel*/d' /etc/yum.conf

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Направо е***те майката на темата която създадох.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Направо е***те майката на темата която създадох.

 

Какво имаш предвид?

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Какво имаш предвид?

 Идеята на темата беше съвсем  различна.Тук не е място за дискусии!Тук се дават решения в "писания".Демек как стават нещата под команден ред,а не ползването на gui,което искрено не препоръчвам ако някой иска някога да се научи как стават нещата и как работят нещата "под капака".

Последните коментари от темата са някакви дискусии и коментари подходящи за  лични съобщения.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Да така е, но грешки стават и колегата се е объркал, трябваше да се изясни темата и сега всичко е по старо му. (Заради една грешка да се цетират всички е прекалено)

 

Относно моите теми, са полезни/решения и то конзолни. (Да, последните два поста са за Федора, но така се е паднало).

Финал, не виждам какъв е проблема.

 

Поздрави tux.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Чакай бе,набираш като балканче.Не съм ти се карал.Никой не е казал че,коментарите ти са безполезни.Просто се отклонихте  в дискусии ;)

Финал - Не виждам какъв е проблема ;)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Здравейте на всички.

Исках само да кажа следното : нека не умира тази тема, твърде полезна е за нас, които не сме толкова на "Ти" с UNIX/Linux базираните дистрибуции.

Тема като тази, трябва да остане жива и да се пишат нови и нови решения постоянно, благодарим Ви за дадените ни дотук конзолни решения и се надяваме ( поне аз де ) да има още и занапред :)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Скрипт за инсталиране на Емакс 24 във Centos 6...

 

 

Изпълни в терминал.

 

./install-emacs.sh 24.3

#!/bin/sh# Emacs from source (Centos)if [ ! $( id -u ) -eq 0 ]; thenecho "Please run this script as sudo/root..."    exitfiecho -e "Downloading emacs..."if [ ! $# -eq 1 ];thenecho "usage: sh $0 VERSION"   exit;fiVERSION=$1LOCAL=/usr/local/emacs/$VERSIONmkdir -p /usr/local/emacscd /usr/local/srcwget http://ftp.gnu.org/gnu/emacs/emacs-$VERSION.tar.gztar xvfz emacs-$VERSION.tar.gzcd /usr/local/src/emacs-$VERSIONecho -e "Installing emacs dependencies..."yum groupinstall -y "Development Tools"yum install -y gtk+-devel gtk2-develyum install -y libXpm-devel libpng-devel giflib-devel libtiff-devel libjpeg-develyum install -y ncurses-develecho -e "Installing emacs..."./configure --prefix=$LOCALmake installcdln -sf /usr/local/emacs/$VERSION/bin/emacs /usr/local/bin/emacsecho -e "Completed!"
Редактирано от ivoarch (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

 

Скрипт за инсталиране на Емакс 24 във Centos 6...

........

1. Защо версията е закована в скрипта

2. зашо тази версия, има си готова: http://centos.telecoms.bg/6.5/os/x86_64/Packages/emacs-23.1-25.el6.x86_64.rpm

3. за да инсталирате така ви трябват компилатори и т.н. неща

4. Това не е RH начина, правите си rpm пакет и го инсталирате него

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

1. Защо версията е закована в скрипта

2. зашо тази версия, има си готова: http://centos.telecoms.bg/6.5/os/x86_64/Packages/emacs-23.1-25.el6.x86_64.rpm

3. за да инсталирате така ви трябват компилатори и т.н. неща

4. Това не е RH начина, правите си rpm пакет и го инсталирате него

1, Така ми е по удобно, при налична друга версия, само се сменява и тва е

2, Има готова да, но е Emacs 23, а не последната версия на емакс, 24

3. Да но аз не се боя да компилирам

4, Знам, но предпочитам да си го компилирам, пробвал съм да права пакети Rpm, и не е ставало нищо.

(Не съм ги схванал още, как трябва) виж във Арч е по лесно.

Редактирано от ivoarch (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

1, Така ми е по удобно, при налична друга версия, само се сменява и тва е

2, Има готова да, но е Emacs 23, а не последната версия на емакс, 24

3. Да но аз не се боя да компилирам

4, Знам, но предпочитам да си го компилирам, пробвал съм да права пакети Rpm, и не е ставало нищо.

(Не съм ги схванал още, как трябва) виж във Арч е по лесно.

1. това не е начина за писане :)

2. По-добре ползвайте наличната, така ще се следят зависимости, версии, пачове и т.н.

3. Не, въпроса е че не проверявате никъде дали са инсталирани компилатори, библиотеки и т.н.

4. Научете се, не са космически технологии :)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Немога да те разбера, капитане.

 

1. Защо да не е?

2. Защо версия която е стара, при положение че, емакс 24 е стабилна версия. И какво лошо има да си компилираш на ръка?

3. При току що инсталиран Centos ги няма пакетите кoито са ми нужни. (Идори и даго има даден пакет, с какво ще навреди това)

4. За вскичко си има време. Чак пък космическа.

Редактирано от ivoarch (преглед на промените)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Немога да те разбера, капитане.

 

1. Защо да не е?

2. Защо версия която е стара, при положение че, емакс 24 е стабилна версия. И какво лошо има да си компилираш на ръка?

3. При току що инсталиран Centos ги няма пакетите кoито са ми нужни.

4. За вскичко си има време.

1. защото с това (и не само) скрипта става лош. Не е и малко универсален, на ръка трябва да се редактира

2. Губят се зависимости, това е основно нещо в една дистрибуция. Освен това не мисля че ползвате което и да е от нововъведенията на новата версия :)

3. Хубаво де, значи трябва да се инсталира С компилатор, евентуално С++, развойни библиотеки и още 100 програми. Т.е. скрипта работи в много конкретни условия, което не е добра политика

4. Ако ще ползвате CentOS това е едно от първите неща, които трябва да научите. И ползвайте спек файла от сорса на по-старата версия

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

1.) Оправено.2.) Какви зависимости се губят, не мога да ви разбера? (Нима вие не компилирате from source) Да разбира се че, не ползвам всичко от новото във версия 24, но само заради това не смятам да ползвам софтуер от пантивека, при условия че, имa версия 24 е  стабилна версия от 2012 година.3)Ако говорите за инсталираването на "Development Tools" да много пакети са, но все некой ден, ще ви потрябва нещо от там, особенно аko се занимавате с компилиране и други.4)Да, нe само при Centos, Redhat, Fedora и кoято и да е друга дистрибуция. Да ще хвърля едно око на .spec файла.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Ей ти едно предложение

 

PKG=emacsPKG_VERS=${PKG_VERS:-$(echo $PKG-*.tar.?z* | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}

Трябва ти само сорса да във CWD и си готов за компилиране ;)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

1.) Оправено.2.) Какви зависимости се губят, не мога да ви разбера? (Нима вие не компилирате from source) Да разбира се че, не ползвам всичко от новото във версия 24, но само заради това не смятам да ползвам софтуер от пантивека, при условия че, имa версия 24 е  стабилна версия от 2012 година.3)Ако говорите за инсталираването на "Development Tools" да много пакети са, но все некой ден, ще ви потрябва нещо от там, особенно аko се занимавате с компилиране и други.4)Да, нe само при Centos, Redhat, Fedora и кoято и да е друга дистрибуция. Да ще хвърля едно око на .spec файла.

2.Всеки пакет зависи от други пакети, както и пакети зависят от него. Например инсталацията на готови макроси за емакс няма да протече при горната постановка според очакванията

3. Но говоря за това че са много пакети а че в скрипта не проверявате дали са инсталирани. И не, не е задължително да ми потрябват, например на никой от служебните сървъри няма компилатор и развойни библиотеки

4. Дерзайте :)

 

 

Ей ти едно предложение

 

PKG=emacsPKG_VERS=${PKG_VERS:-$(echo $PKG-*.tar.?z* | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}

Трябва ти само сорса да във CWD и си готов за компилиране ;)

 

Да се разчита на името на файла за версия рядко е разумно :)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Аз редактирах скрипта, само горната част, сега разчита версията ето така:

 

usage: sh ./emacs-install.sh VERSION

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

...

 

Да се разчита на името на файла за версия рядко е разумно :)

Ако само въпросния emacs е в директорията става,ако има пачове пак става (дори и със същото име да са) - те трябва да  са в отделна директория и да се аплайват само.Иначе сте прав.

Всъщност пак да го кажа капитана е доста прав (нищо че сега може да лежи по гръб ;) )Ами ако имам въпросните зависимости инсталирани?За новия emacs може да се желаят по-нови версии на дадена библиотека и това да прецака нещата и да стане един кръговрат.....

 

пп

За това такива експерименти само на Слакуер там нЕмаш пакетен "нещо си" ;) и да се о*сер* нещо вкараваш ДВД диска и наново :)

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Добавете отговор

Можете да публикувате отговор сега и да се регистрирате по-късно. Ако имате регистрация, влезте в профила си за да публикувате от него.

Гост
Напишете отговор в тази тема...

×   Вмъкнахте текст, който съдържа форматиране.   Премахни форматирането на текста

  Разрешени са само 75 емотикони.

×   Съдържанието от линка беше вградено автоматично.   Премахни съдържанието и покажи само линк

×   Съдържанието, което сте написали преди беше възстановено..   Изтрий всичко

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Добави ново...