Премини към съдържанието
  • Добре дошли!

    Добре дошли в нашите форуми, пълни с полезна информация. Имате проблем с компютъра или телефона си? Публикувайте нова тема и ще намерите решение на всичките си проблеми. Общувайте свободно и открийте безброй нови приятели.

    Моля, регистрирайте се за да публикувате тема и да получите пълен достъп до всички функции.

     

petie1

Всичко за Debian и неговите внучета - новини, въпроси, проблеми

Препоръчан отговор


преди 10 часа, petie1 написа:

Е в Арч явно на сигурноста се гледа през пръсти за разлика от Дебиан:)

Просто трябва ръчно да си напишеш root. Иначе по подразбиране ти показва потребителя, който си създал по време на инсталацията. А ако пък случайно не ти позволи така, винаги има ctrl+alt+F2...

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
на 13.07.2019 г. в 20:09, yogle написа:
[email protected]:~$ su
Парола: 
[email protected]:/home/yogle1# apt install firmware-realtek_20190114-1_all
Четене на списъците с пакети... Готово
Изграждане на дървото със зависимости       
Четене на информацията за състоянието... Готово
E: Пакетът firmware-realtek_20190114-1_all не може да бъде намерен
[email protected]:~/Свалени$ su
Парола: 
[email protected]:/home/yogle1/Свалени# dpkg -i deb firmware-realtek_20190114-1_all.deb 
dpkg: warning: 'ldconfig' not found in PATH or not executable
dpkg: warning: 'start-stop-daemon' not found in PATH or not executable
dpkg: error: 2 expected programs not found in PATH or not executable
Note: root's PATH should usually contain /usr/local/sbin, /usr/sbin and /sbin
[email protected]:/home/yogle1/Свалени# apt install ldconfig
Четене на списъците с пакети... Готово
Изграждане на дървото със зависимости       
Четене на информацията за състоянието... Готово
E: Пакетът ldconfig не може да бъде намерен
[email protected]:/home/yogle1/Свалени# apt install -f
Четене на списъците с пакети... Готово
Изграждане на дървото със зависимости       
Четене на информацията за състоянието... Готово
0 актуализирани, 0 нови инсталирани, 0 за премахване и 0 без промяна.
[email protected]:/home/yogle1/Свалени# 

Досега с дебиан не съм имал срещи и почва да ме амбицира

Но това , че не мога да инсталирам деб пакет с gdebi или в терминал нещо ме смущава. 

ПС Разхвърлях ръчно файловете от деб пакета и wi-fi-то тръгна. Тепърва ще го разучавам :)

 

Разрешаваш non-free хранлищата.

su

apt update

apt install firmware-realtek

Това е. Доказано става, защото съм инсталирал десетката още преди да излезе. Аз също ползвам за лаптопа firmware-atheros и firmware-realtek.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

След време ще му потрябва и headers-и за ядрото, вероятно, та най-добре е с четене, преди питане.

преди 7 часа, bigiadri написа:

Кажете  си мнението за това

Не е това на което му викат Дебиан. За мен е по-зле и от МинтДЕ. Руснаците винаги, ама винаги (наследство от ползването на Уйн, явно) искат да има от всичко по много. Което (за мен) е ненужно. Няма как да угодиш на всеки. А така (за мен) е манджа с грозде.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
преди 11 часа, rado84 написа:

Просто трябва ръчно да си напишеш root. Иначе по подразбиране ти показва потребителя, който си създал по време на инсталацията. А ако пък случайно не ти позволи така, винаги има ctrl+alt+F2...

Мислиш ли че не съм го пробвал? На всяко дистро инсталирано по учебник е така, пак казвам с цел сигурност е направено така и не е само в Дебиан

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
преди 8 минути, petie1 написа:

Мислиш ли че не съм го пробвал? На всяко дистро инсталирано по учебник е така, пак казвам с цел сигурност е направено така и не е само в Дебиан

Аз пък не инсталирам по учебници.


Сподели този отговор


Линк към този отговор
Сподели в други сайтове
преди 14 часа, bigiadri написа:

Кажете  си мнението за това:https://rutracker.net/forum/viewtopic.php?t=5754763

Гледам има добри отзиви!Лично аз ще чакам авторът на тази девятка да пусне своя разработка.https://rutracker.net/forum/viewtopic.php?t=5405154

Неговите Дебиани са много добре изпипани. Удобни за  ползване от обикновени потребители!

Ами то Дебиан си е достатъчно лесен за ползване особенно с новата Плазма 5 е направо детска игра

@Тамболианеца в Дебиан 10 бъга със su го реших така /usr/sbin/команда ако ползваш su - си става root и проблем няма

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Инсталирах за спорта Debian 10 Cinnamon на другия ми дял. Свикнал на лесното от LM потърсих аплета "Диспечер на актуализациите" (щитчето), няма го. В контролния център също така не присъстват подразделите "Софтуерни източници" и "Управление на драйвърите". Без тези липсващи глезотийки дори LMDE ми бе по-интуитивен и близък до стандартния LM, като общото между тях 3-те е средата Cinnamon.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
преди 5 минути, svetliof написа:

Инсталирах за спорта Debian 10 Cinnamon на другия ми дял. Свикнал на лесното от LM потърсих аплета "Диспечер на актуализациите" (щитчето), няма го. В контролния център също така не присъстват подразделите "Софтуерни източници" и "Управление на драйвърите". Без тези липсващи глезотийки дори LMDE ми бе по-интуитивен и близък до стандартния LM, като общото между 3-те е средата Cinnamon.

Виж да не се казват по друг начин? Версията е 3.8

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Не четеш ли какво се пише? Той е бъдещият потребител на предложените от bigiadri.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

@petie1, и понеже не инсталирам по учебници, тази сутрин оправих всичките простотии на КДЕ-то, като инсталирах Канелата като secondary среда. И почти всичко, което не работеше както трябва в КДЕ-то и за което поствах снимки в другия форум, изведнъж заработи както трябва. Така че сега КДЕ-то е само за игри, Канелката - за всичко останало. Останаха 1-2 дребни нещица за дооправяне, но и с тях ще се справя - отново без учебници. :D 

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
преди 1 час, rado84 написа:

@petie1, и понеже не инсталирам по учебници, тази сутрин оправих всичките простотии на КДЕ-то, като инсталирах Канелата като secondary среда. И почти всичко, което не работеше както трябва в КДЕ-то и за което поствах снимки в другия форум, изведнъж заработи както трябва. Така че сега КДЕ-то е само за игри, Канелката - за всичко останало. Останаха 1-2 дребни нещица за дооправяне, но и с тях ще се справя - отново без учебници. :D

И след два дена мяуу тва не работи онова не работи

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
преди 1 час, petie1 написа:

И след два дена мяуу тва не работи онова не работи

... ама надали.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Натъкнах се на нов проблем не разпознават export Дебиан 9 и 10

Конзолата под KDE има проблем с locale

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Ама и ти почнА да словоредиш по Джедайски.
Ми ...

Дебиан ескпорт не разпознава кой, хм?
В /etc/local.gen локал от интерес си разкоменирал, а?
Прегенерация е важна после направиш също, да.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
преди 4 минути, Тамболианеца написа:

Ама и ти почнА да словоредиш по Джедайски.
Ми ...

Дебиан ескпорт не разпознава кой, хм?
В /etc/local.gen локал от интерес си разкоменирал, а?
Прегенерация е важна после направиш също, да.

Нищо не съм разкоментирал просто като река да инсталирам пакет и вади такава грешка

perl: warning: Setting locale failed.   
perl: warning: Please check that your locale settings:   
        LANGUAGE = "en_US:en",   
        LC_ALL = (unset),   
        LC_MESSAGES = "en_US.UTF-8",   
        LANG = "en_US.UTF-8"   

само че при мен е bg_Bg.UTF-8

sudo export LANG=bg_Bg.UTF-8 вади bash command export not found

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Правилно ти пищи.
1. такъв локал LANG=bg_Bg.UTF-8 не съществува, но пък има LANG=bg_BG.UTF-8
2. препоръчах ти да погледнеш /etc/locale.gen да видиш кои локали си разрешил, т.е. разкоментирал
или пък можеш по мързливия начин да провериш с locale -a, чийто изход  обаче зависи от това дали си направил 3.
3. когато разрешаваш локал, прегенерираш с locale-gen - пише си го в началото на /etc/locale.gen
Повече за локалите: https://wiki.debian.org/Locale

А таква изумителна комбинация sudo export - не съществува.
export e вътрешна команда (built-in) за bash, няма бинарен еквивалент и не може да бъде извиквана със sudo. export се ползва в скрипт, в твоя случай .bashrc
Повече за вътрешните команди: man -P 'less -p "^SHELL BUILTIN COMMANDS"' bash

 

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

А оказа се че  упътването дето съм чел е грешно и не е правилно,  @Тамболианеца благодаря за подзказката

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Вчера ми се случи да инсталирам Viber Desktop директно върху чист ( не ъпгрейдван от Стреч) Дебиан 10, и се натресох пак на същите пачи яЙца, та да споделя изчистената процедура за инсталация

 

Инсталация на Viber Desktop в Debian 10 / Devuan 10
--------------------------------------------------------------------------------------

Умниците от Viber продължават да линкват към libssl.1.0.0, библиотека която е изхвърлена от Дебиан 10 даже и за версия 1.0.2.
Резултатът е, че по нормален начин Viber Desktop не може да бъде инсталиран в Debian 10 / Devuan 10.

Как да инсталираме:
1. Сваляне Viber, Ubuntu варианта от https://www.viber.com/download/
Към днешна дата версията на Viber Desktop е 10.3.0.37

2. Сваляне на старата libssl1.0.2 библиотека от Stretch/ASCII за архитектура amd64
   https://packages.debian.org/stretch/libssl1.0.2

3. Инсталиране на библиотеката  

sudo dpkg -i libssl1.0.2_1.0.2s-1~deb9u1_amd64.deb

4. Създаване на линкове от версия 1.0.2 към 1.0.0, в директория /usr/lib/x86_64-linux-gnu се изпълнява:

sudo ln -s libssl.so.1.0.2 libssl.so.1.0.0
sudo ln -s libcrypto.so.1.0.2 libcrypto.so.1.0.0

5. Инсталиране Viber Desktop  

sudo dpkg -i viber.deb

Инсталацията ще писне, че му няма 'my precious'  libssl.1.0.0, игнорирате писъците

6. Стартиране Viber от /opt/viber/Viber и връзка към съответия акaунт

След проверена работоспособност на Viber, следва тричане на libssl1.0.0
7. Изхвърляне нa 'my precious' libssl.1.0.0 от dpkg:
7.1 Отваряне като root на файл /var/lib/dpkg/status
7.2 Търсене "Package: viber" или само viber
7.3 В Depends: Изтриване 'my precious' низа libssl1.0.0 и запетаята след него. Запазване.
7.4 Извършване реконфигурация за Viber:  

sudo dpkg --configure viber

 

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
на 23.07.2019 г. в 10:52, petie1 написа:

А оказа се че  упътването дето съм чел е грешно и не е правилно,  @Тамболианеца благодаря за подзказката

Провери автора на упътването, може да се окаже, че го е писало онова мрънкало, дето сменяло гребена с очила. :D

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
на 27.07.2019 г. в 11:29, Тамболианеца написа:

Вчера ми се случи да инсталирам Viber Desktop директно върху чист ( не ъпгрейдван от Стреч) Дебиан 10, и се натресох пак на същите пачи яЙца, та да споделя изчистената процедура за инсталация

 

Инсталация на Viber Desktop в Debian 10 / Devuan 10
--------------------------------------------------------------------------------------

Умниците от Viber продължават да линкват към libssl.1.0.0, библиотека която е изхвърлена от Дебиан 10 даже и за версия 1.0.2.
Резултатът е, че по нормален начин Viber Desktop не може да бъде инсталиран в Debian 10 / Devuan 10.

Как да инсталираме:
1. Сваляне Viber, Ubuntu варианта от https://www.viber.com/download/
Към днешна дата версията на Viber Desktop е 10.3.0.37

2. Сваляне на старата libssl1.0.2 библиотека от Stretch/ASCII за архитектура amd64
   https://packages.debian.org/stretch/libssl1.0.2

3. Инсталиране на библиотеката  

sudo dpkg -i libssl1.0.2_1.0.2s-1~deb9u1_amd64.deb

4. Създаване на линкове от версия 1.0.2 към 1.0.0, в директория /usr/lib/x86_64-linux-gnu се изпълнява:

sudo ln -s libssl.so.1.0.2 libssl.so.1.0.0
sudo ln -s libcrypto.so.1.0.2 libcrypto.so.1.0.0

5. Инсталиране Viber Desktop  

sudo dpkg -i viber.deb

Инсталацията ще писне, че му няма 'my precious'  libssl.1.0.0, игнорирате писъците

6. Стартиране Viber от /opt/viber/Viber и връзка към съответия акaунт

След проверена работоспособност на Viber, следва тричане на libssl1.0.0
7. Изхвърляне нa 'my precious' libssl.1.0.0 от dpkg:
7.1 Отваряне като root на файл /var/lib/dpkg/status
7.2 Търсене "Package: viber" или само viber
7.3 В Depends: Изтриване 'my precious' низа libssl1.0.0 и запетаята след него. Запазване.
7.4 Извършване реконфигурация за Viber:  

sudo dpkg --configure viber

 

При мен на Девуан трябваше да разархивирам пакета да променя депендънисто от Libcurl3 на Libcurl4 да го пакетирам пак  и стана работата. 

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

;) и го инсталира с gdebi-gtk...

Не ползвам viber, но нали уж го бяха оправили проблема със зависимоста, или след това пак са издали нова версия която пак е със старата зависимост.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
Гост

Аз пък я инсталирах от тука и после viber с gdebi-gtk.

spacer.png

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

cat /etc/os-release

Ще може ли изхода от командата или ... снимка от графата статус/ръчно инсталирани.

 

 

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Добавете отговор

Можете да публикувате отговор сега и да се регистрирате по-късно. Ако имате регистрация, влезте в профила си за да публикувате от него.

Гост
Напишете отговор в тази тема...

×   Вмъкнахте текст, който съдържа форматиране.   Премахни форматирането на текста

  Разрешени са само 75 емотикони.

×   Съдържанието от линка беше вградено автоматично.   Премахни съдържанието и покажи само линк

×   Съдържанието, което сте написали преди беше възстановено..   Изтрий всичко

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Добави ново...