Премини към съдържанието
  • Добре дошли!

    Добре дошли в нашите форуми, пълни с полезна информация. Имате проблем с компютъра или телефона си? Публикувайте нова тема и ще намерите решение на всичките си проблеми. Общувайте свободно и открийте безброй нови приятели.

    Моля, регистрирайте се за да публикувате тема и да получите пълен достъп до всички функции.

     

enuff

проблем с видео при Elementary OS

Препоръчан отговор


Здравейте, от 1 седмица се върнах на Линукс като в случая си сложих Elementary OS. Успях да си наглася всичко и най-накрая си казах, че този път може да издържа и без Уиндоус и се получи следния проблем - като пусна видео и ми излиза следния размазан прозорец. Проблемът не е във VLC, защото го преинсталирах, а освен това пробвах и с друг плеър и положението е същото. Някакви идеи как да го оправя?

 

Screenshot from 2018-03-23 14.56.49.png

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

С какво друго си пробвал?

Само това видео ли е така или и други?

Какви са параметрите на видео файловете?

Другаде вървят ли нормално?

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Пробвах с видео плеъра, който си върви с дистрибуцията. 3 различни видео файлове пробвах и надсякъде така. Този точно е .mkv и го гледах сутринта на ТВ бокса и там си вървеше идеално. 

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
преди 12 минути, enuff написа:

Пробвах с видео плеъра, който си върви с дистрибуцията. 3 различни видео файлове пробвах и надсякъде така. Този точно е .mkv и го гледах сутринта на ТВ бокса и там си вървеше идеално. 

Пробвай как е с SMPlayer, VLC на някои дистра има проблем с възпроизвеждане на н264 и н265 видое форматите.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Така обикновено  се получава, когато не се ползва хардуерно ускорение от видео картата. Каква е машината? 


Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Стара е - Dell Optiplex 980 - но не чак толкова че да не вървят филми. Как да го пусна хардуерното ускорение?

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Възможностите са бъгава библиотека или видеодрайвър. Може да се опиташ да заобиколиш, като промениш настройките за възпроизвеждане или сложиш различен видеодрайвър. Ако се окаже че е от библиотека, както си мисля, смяната на приложението може и да не помогне, защото се случва няколко различни плейъра да ползват една и съща външна библиотека. Навярно ще я обновят скоро и проблемът ще изчезне. Засега просто промени каквото е достъпно от настройките.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Видеото трябва да е способно на хардуерно декодиране на повечето нови формати. По скоро прилича на проблем при грешни настройки на хардуерното декодиране, примерно ако използва OpenGL за изход, но се пробва на GL ES2.0, а не чистият GL. По принцип интелските видеа под Linux ползват VA-API, или wrapper към vdpau (трябва да се инсталира) и всичко това го има в настройките на VLC, ако е детектнато коректно. Това е за отвореният драйвер, но затворената им технология под Linux (QuickSync) е такова извинение и лицензно недоразумение, че само човек с много свободно време би се заел да я подкарва, че и не работи (според чужди мнения) толкова добре за декодиране, колкото отворените драйвери. Аз бих пробвал чистият OpenGL изход и изрично задаване на OpenGL, за да не превключи на ES2.0. Или в краен случай изключване на хардуерното ускорение, процесорът също е достатъчно мощен и само 4K би го сбозило, защото може наистина и вградената ffmpeg библиотека да има някакви проблеми. Както и варианти с други плеъри, колкото искаш, стига да има желание ако се наложи компилация на mplayer, или mpv.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

С mpv не тръгва, a с mplayer върви, но все едно фрейм по фрейм. Не мисля, че проблемът е хардуерен, защото до вчера гледах всякакви видеа на същата машина. 

Не ползвам интегрираното видео, защото компютърът е със старо поколение i7, който не поддържа видео. Ползвам 2 карта ATI Radeon понеже имам вързани 3 монитора. Търсих драйвери за Линукс за ATI Radeon, но това което намерих в сайта им следвайки инструкциите за инсталиране стигнах до 'unsupported OS'. Под Уиндоус и 4К съм подкарвал без проблеми. Общо взето със SSDто върви достъчно бърза, че да не се замислям за упрейд все още, защото не ползвам някакъв специален софтуер, които да изисква много ресурс. 

Сега като се замисля снощи попаднах на статитя от сорта '24 must have apps for Linux' и инсталирах Stacer, който има функция System Cleaner и махна близо 1ГБ 'ненужни' файлове и след това нямам спомен дали съм пускал друго видео така че нищо чудно и от там да е тръгнал проблема. 

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
преди 1 час, RagnerBG написа:

По скоро прилича на проблем при грешни настройки на хардуерното декодиране, примерно ако използва OpenGL за изход, но се пробва на GL ES2.0, а не чистият GL.

Няма как да е специално от хардуерното декодиране. Ако то беше изключено, щеше само да бави или да върви кадър по кадър, съпроводено с греене на процесора. Също няма как библиотеките да се объркат. Възможно е 1) грешка в библиотеката за декодиране на видеото или 2) грешка в библиотеката на драйвъра /примерно за OpenGL или vdpau/. 1 е много по-вероятно от 2. Също така, драйвърните библиотеки се компилират от производителите и обикновено има по-малко бъгове.

Явно не е видяна, защото при тестерите настройките са били различни. Следователно следва да се опита с различни настройки за ускорение и проблема може да изчезне.

Второ, ако случайно се ползва отворен драйвър за видеото е добре да се опита с фирмения. Но да се инсталира от пакетния мениджър.

преди 33 минути, enuff написа:

a с mplayer върви, но все едно фрейм по фрейм

Пусни го с настройки за ускорение. На SMPlayer има специална опция, която трябва да се активира. Предполагам и на чистия mplayer не тръгва директно по подразбиране.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Значи на VLC беше на automatic, но пробвах ръчн да сменя поне 5 различни output-a и с нито един не тръгна. 

Сега инсталирах SM Player и с него тръгнa без да променям нищо. 

В AppCenter-а няма никакви драйвъри. В тази нова дистрибуция е доста орязано, AppCenter-a вече дори не поддържа .deb, а се инсталират през някакво допълнително приложение Eddy.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Пробвай колега да вдигнеш VLC до по-горна версия. Моята под Linux Mint 18.3 бе 2.2.2, сега вече е 2.2.7 и плейва mkv файлове:

sudo add-apt-repository ppa:videolan/stable-daily
sudo apt-get update
sudo apt-get install vlc

С долните настройки нямам проблем с VLC изобщо (при интелска вградена карта):

От Инструменти > Настройки > Видео > Извеждане >
"OpenGL GLX видео извеждане(XCB)", запис и рестарт на VLC.

Ако искаме хардуерно ускорение от Intel processor
От Инструменти > Настройки > Въвеждане/Кодеци > Hardware-accelerated decoding >
"VA-API video decoder via X11", запис и рестарт на VLC.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

И с версия 2.2.7 е същото.

С тази настройка също не тръгва номрално: Инструменти > Настройки > Въвеждане/Кодеци > Hardware-accelerated decoding >
"VA-API video decoder via X11" 

И с другите опции от тази секция настройки също не потегля. 

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
преди 2 минути, enuff написа:

И с версия 2.2.7 е същото.

С тази настройка също не тръгва номрално: Инструменти > Настройки > Въвеждане/Кодеци > Hardware-accelerated decoding >
"VA-API video decoder via X11" 

И с другите опции от тази секция настройки също не потегля. 

Има ли нещо подобно на "X11 видео изход" в настройките ?

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Има да, но го пробвах и няма промяна. 

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Защо точно Elementary OS?

"Ползвам 2 карта ATI Radeon ..." - малко по подробно какви карти ползваш?

Пробвал ли си ако само едната карта е налична/активна?

 

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Защото като напишеш The best Linux distros of 2018 и Елементъри излиза на 1во място. 

Не съм пробвал с едната видео карта, но не мисля да правя експерименти с хардуера при положение, че до вчера работеше както е и днес вече също заработи нормално с SMPlayer. Явно проблемът е софтуерен. 

Ще чакам ъпдейт и през това време няма да ползвам VLC, пък ако не зарабоди се връщам на 10ката. 

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
преди 2 минути, enuff написа:

Защото като напишеш The best Linux distros of 2018 и Елементъри излиза на 1во място. 

Това е примерна класация.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
преди 6 минути, Pavel! написа:

AppCenter на Elementary е безполезен. Инсталирай през конзолата. И като цяло това е омазана дистрибуция, по-добре Убунту или поне Минт.

От там инсталирах. 

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
преди 5 минути, bvbfan написа:

Това е примерна класация.

Ясно е, че са субективни класациите, но навсякъде я слагат на челните места. Преди година сигурно пак я бях сложил и тогава май беше доста по окей. 

преди 1 минута, bvbfan написа:

Последно, върви ли видеото?

С VLC и плеърът на Elementary не. С SMPlayer да. 

Сподели този отговор


Линк към този отговор
Сподели в други сайтове
преди 3 часа, enuff написа:

Не ползвам интегрираното видео, защото компютърът е със старо поколение i7, който не поддържа видео. Ползвам 2 карта ATI Radeon понеже имам вързани 3 монитора. Търсих драйвери за Линукс за ATI Radeon, но това което намерих в сайта им следвайки инструкциите за инсталиране стигнах до 'unsupported OS'.

Ясно къде е проблемът. Какви са ATI картите, наистина ли архаични ATI, или поне AMD? Само картата, на която е основният монитор би трябвало да е активна за видеоускорение и да се ползват нейните GL библиотеки. За тях трябва да е зареден radeon модулът и да се инсталират пакетите за видеоускорение - xf86-video-ati и mesa-vdpau, както посочиха. С vainfo и vdpauinfo може да се провери какво се поддържа за видеоускорение. Може да се наложи и конфигурация на Xorg, за да зареди правилните модули. Ако картата е по-нова, може да се инсталира и новият amdgpu драйвер, който дава по-добри резултати от стария radeon. Иначе от сайта на AMD няма смисъл, предполагам, че дистрото е ново, с ядро над 4 и там затвореният fglrx/amdgpupro драйвер не работи. Плюс това е рисковано да се инсталират пакети от там, почти 100% ще се счупи графичната среда. Само от хранилищата.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

За да се абстрахираш частично от системата изтегли и стартирай VLC-2.2.3.glibc2.12-x86_64.AppImage

https://bintray.com/probono/AppImages/VLC/2.2.3.glibc2.12#files

Правиш файла изпълним и го нацъкваш..

Vlc AppImage си има всичко нужно,за да работи правилно без  да имаш инсталирани кодеци и т.н

Евентуално може да иска  Qt,но в по новите  дистрибуции го има след чист инстал.

Нали работи Smplayer,който така или иначе е mplayer с неговите си кодеци.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Май се отказвам от Линукса засега. Не заради видеото, а по-скоро че още не е станал толкова user-friendly, колкото ми се иска. За мен не е окей да трябва 20мин да четеш по форумите и да пускаш някакви неща през конзола, за да си смениш скоростта на scroll-a на мишката, а освен това да се окаже, че smooth-scrolling въобще няма. Това го давам само за пример, иначе +овете спрямо Уиндоус също са налице. 

 

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Примерно Linux Mint идва с инсталирани доста неща.Доста хора я предпочитат.

Сподели този отговор


Линк към този отговор
Сподели в други сайтове

Добавете отговор

Можете да публикувате отговор сега и да се регистрирате по-късно. Ако имате регистрация, влезте в профила си за да публикувате от него.

Гост
Напишете отговор в тази тема...

×   Вмъкнахте текст, който съдържа форматиране.   Премахни форматирането на текста

  Разрешени са само 75 емотикони.

×   Съдържанието от линка беше вградено автоматично.   Премахни съдържанието и покажи само линк

×   Съдържанието, което сте написали преди беше възстановено..   Изтрий всичко

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Добави ново...