Премини към съдържанието
  • Добре дошли!

    Добре дошли в нашите форуми, пълни с полезна информация. Имате проблем с компютъра или телефона си? Публикувайте нова тема и ще намерите решение на всичките си проблеми. Общувайте свободно и открийте безброй нови приятели.

    Моля, регистрирайте се за да публикувате тема и да получите пълен достъп до всички функции.

     

Всичко за Debian - новини, въпроси, проблеми.


petie1
 Сподели

Препоръчан отговор

Какво се опитвате да направите?

Че мен ме обвиниха че не съм с Дебиан и не съм Линукс фен? :(

Линк към коментара
Сподели в други сайтове

преди 2 часа, p4p написа:

 

преди 2 часа, cybercop написа:

Пробвах:

- добавих хранилищата за bullseye:

https://wiki.debian.org/SourcesList

- инсталирах:

sudo apt install live-build

- разрешението:

sudo lb config --debian-installer-gui true

- инсталирах:

sudo apt install debian-installer-launcher

и го стартирах.

Добрата новина е, че тръгна.

Но има и лоша. Даде грешка:

Цитат

no suitable d-i initrd image found

umount: /run/live/installer no mount point ...

Гледам снукър и няма да ровя из:

https://www.google.com/search?client=opera&q=no+suitable+d-i+initrd+image+found+umount%3A+%2Frun%2Flive%2Finstaller+no+mount+point+...&sourceid=opera&ie=UTF-8&oe=UTF-8

Вероятно трябва по-пълна конфигурация на lb config:

https://manpages.debian.org/bullseye/live-build/lb_config.1.en.html

 

Толкова от мен, любителя.

:cheers:

преди 2 часа, petie1 написа:

Какво се опитвате да направите?

Виж предната страница!

Линк към коментара
Сподели в други сайтове

Трябва да се редактира самото исо и да му се набие  този инсталатор според мен ако става дума за debian-standart.iso

Линк към коментара
Сподели в други сайтове

преди 9 часа, petie1 написа:

Какво се опитвате да направите?

Че мен ме обвиниха че не съм с Дебиан и не съм Линукс фен? :(

Е то и аз съм с Debian ама примерно съм достатъчно добър и с Arch Linux. Не им обръщай внимание.

Аз лично съм избрал Debian заради неговата стабилност, защото за мен това е важно. Към този момент няма дистрибуция, която да осигурява толкова стабилна работа, както Debian. Разбира се има и много други преимущества.

Линк към коментара
Сподели в други сайтове

преди 5 часа, ntm7iv написа:

Е то и аз съм с Debian ама примерно съм достатъчно добър и с Arch Linux. Не им обръщай внимание.

Аз лично съм избрал Debian заради неговата стабилност, защото за мен това е важно. Към този момент няма дистрибуция, която да осигурява толкова стабилна работа, както Debian. Разбира се има и много други преимущества.

То Дебиан не е само стабилен ами и много лесно може да си правиш каквото решиш :)

Линк към коментара
Сподели в други сайтове

преди 15 часа, p4p написа:

 

Толкова от мен, любителя.

:cheers:

 

Благодаря за отделеното време ! 

Линк към коментара
Сподели в други сайтове

Firefox 91.5 esr цъфна в Дебиан 10

Линк към коментара
Сподели в други сайтове

 

 

 

на 10.01.2022 г. в 14:13, cybercop написа:

Ако инсталираш

xserver-xorg-video-nouveau + libgl1-mesa-dri 

няма ли да си спестиш главоболието с тези стари драйвъри ?

 

не. исках да играя в steam... обаче се оказа че 8800gt не става за black mesa - явно енджина и самата игра са прекалено тежки за служебния ми компютър... та ще си ги играя само на тоя от подписа :)

 

на 11.01.2022 г. в 18:21, cybercop написа:

Един въпрос за изданието на Debian Live без графична среда. Като избера от стартовите опции Live сесия и вляза в tty режим, как мога да стартирам инсталатора ? За да разберете защо просто не рестартирам и не избера инсталатора от стартовите опции, ще ви кажа, че в Live режим, редактирам източниците с хранилища с nano и инсталирам f2fs-tools. Веднъж стартиран, инсталаторът няма опция за добавяне на пакети от хранилищата.

Благодаря предварително за отговорите !

а защо първо не си добавиш хранищата и после инсталацията:
mount.sh

sudo mount -t proc proc squashfs-root/proc
sudo mount -t sysfs sys squashfs-root/sys
sudo mount -o bind /dev squashfs-root/dev
sudo mount -t devpts pts squashfs-root/dev/pts
sudo cp /etc/resolv.conf squashfs-root/etc/
sudo chroot squashfs-root

umount.sh

sudo umount squashfs-root/proc
sudo umount squashfs-root/sys
sudo umount squashfs-root/dev/pts
sudo umount squashfs-root/dev
sudo rm squashfs-root/etc/resolv.conf
sudo rm filesystem.squashfs
sudo mksquashfs squashfs-root filesystem.squashfs -b 1048576 -comp xz -Xdict-size 100%

копираш filesystem.squashfs в празна директория, копираш двата файла в нея правиш ги изпълнини, после стартираш mount.sh, правиш каквото искаш, после exit и накрая стартираш umount.sh и след това си заместваш с новия filesystem.squashfs във флашката (която си я правш не с dd ами с syslinux, grub-uefi или grub4dos)

на 13.01.2022 г. в 7:06, ntm7iv написа:

Е то и аз съм с Debian ама примерно съм достатъчно добър и с Arch Linux. Не им обръщай внимание.

Аз лично съм избрал Debian заради неговата стабилност, защото за мен това е важно. Към този момент няма дистрибуция, която да осигурява толкова стабилна работа, както Debian. Разбира се има и много други преимущества.

ми аз и него съм забивал... за мен са на 1 ниво с лубунту... но debian е една идея по бърз (поне на на geekbench) другия голям плюс е че ъпдейтите не са автоматични, докато на lubuntu трябва един куп неща да chmod -x (update-notifier...) 

преди 17 часа, petie1 написа:

Firefox 91.5 esr цъфна в Дебиан 10

аз затова разкарах тоя от репото и си сложих моя модификация - предпочитам да си проверявам за ъпдейт от самия браузър (е после ще пише, че пакета е стар и ще иска да го обнови че проверката за ъпдейти не е по съдържание на пакета, а по версията, която е пакета...)...

Линк към коментара
Сподели в други сайтове

на 12.01.2022 г. в 20:17, cybercop написа:

 Ако някой успее да стартира инсталация от Live режим под tty, ще съм благодарен да ми пише в тази тема.

Качих това.Работи.Каква е идеята да се инсталира f2fs-tools по този начин?

 

Линк към коментара
Сподели в други сайтове

преди 22 минути, nick_dimitrov написа:

Каква е идеята да се инсталира f2fs-tools по този начин?

Това не се ли инсталира от опцията за експерти на графичния инсталатор?

Линк към коментара
Сподели в други сайтове

преди 14 часа, nick_dimitrov написа:

Качих това.Работи.Каква е идеята да се инсталира f2fs-tools по този начин?

 

По този начин - не. Благодаря, точно това ми трябваше! Как да стартирам инсталатора. Преди това, просто ще редактирам списъка с хранилищата и ще добавя поддръжката на файловата система. 

преди 14 часа, petie1 написа:

Това не се ли инсталира от опцията за експерти на графичния инсталатор?

Експертното разделяне на диска ли имаш предвид ?

Линк към коментара
Сподели в други сайтове

преди 4 часа, cybercop написа:

Експертното разделяне на диска ли имаш предвид ?

Не имах предвид ето това

 

odseki.png

Линк към коментара
Сподели в други сайтове

преди 2 часа, petie1 написа:

Не имах предвид ето това

 

odseki.png

Нещо сбъркано има. Това не е поддръжката на f2fs. Истинската поддръжка - f2fs-tools, поне доскоро беше в DVD-2. Така и така си почнал, стигни до стъпка "Избор на файлова система" да видиш, дали f2fs е в списъка с достъпните файлови системи, след, като добавиш тези модули.

Линк към коментара
Сподели в други сайтове

преди 21 часа, nick_dimitrov написа:

Качих това.Работи.Каква е идеята да се инсталира f2fs-tools по този начин?

 

значи това било решението за "no suitable d-i initrd image found, aborting" много благодаря :)

Линк към коментара
Сподели в други сайтове

преди 2 часа, cybercop написа:

Нещо сбъркано има. Това не е поддръжката на f2fs. Истинската поддръжка - f2fs-tools, поне доскоро беше в DVD-2. Така и така си почнал, стигни до стъпка "Избор на файлова система" да видиш, дали f2fs е в списъка с достъпните файлови системи, след, като добавиш тези модули.

Не, няма я но това на снимката е нет инсталатора ето виж сам

odseki1.png

Имаме файловата система на openSUSE

Линк към коментара
Сподели в други сайтове

преди 11 часа, petie1 написа:

Не, няма я но това на снимката е нет инсталатора ето виж сам

odseki1.png

Имаме файловата система на openSUSE

Ако имаш предвид XFS, тя се спонсорира от Red Hat, а не от SLE и е вкарана в инсталационният диск от години. Все пак, тя е много стара (от 1993г.), независимо, че сравнително късно навлезе в Linux. Съмнявам се, че изобщо ще могат да я оптимизират за SSD на достатъчно добро ниво. Освен това, този, който е писал опциите на инсталатора е посочил btrfs, като "журнализирана", а тя е COW.

Линк към коментара
Сподели в други сайтове

на 13.01.2022 г. в 21:27, petie1 написа:

Firefox 91.5 esr цъфна в Дебиан 10

spacer.png

Може ли ние от бъдещото за въпрос?
Гледам, че си разцъкал инсталатора на Debian 11. Интересуваме какво печеля, ако мина от 10-ката на 11. Конкретно сървър!
Предполагам питон е рипнал нагоре 🤣

 

 

Линк към коментара
Сподели в други сайтове

преди 7 часа, cybercop написа:

btrfs

Ето тази файлова система имам предвид а тя в момента се ползва под подразбиране в openSUSE :)  И липсваше в Бъстър

преди 3 часа, Profruit написа:

spacer.png

Може ли ние от бъдещото за въпрос?
Гледам, че си разцъкал инсталатора на Debian 11. Интересуваме какво печеля, ако мина от 10-ката на 11. Конкретно сървър!
Предполагам питон е рипнал нагоре 🤣

 

 

https://www.debian.org/releases/stable/amd64/release-notes/ch-whats-new.html

Мисля  че таблицата отговаря на въпроса ти :)

Линк към коментара
Сподели в други сайтове

преди 55 минути, petie1 написа:

Ето тази файлова система имам предвид а тя в момента се ползва под подразбиране в openSUSE :)  И липсваше в Бъстър

https://www.debian.org/releases/stable/amd64/release-notes/ch-whats-new.html

Мисля  че таблицата отговаря на въпроса ти :)

Как да е липсвала? Лаптопът ми още е под нея с Buster + Xfce. Със сигурност беше включена и в инсталатора на Stretch. Може би и в Jessie, но, тук, вече паметта ми изневерява. 

Линк към коментара
Сподели в други сайтове

преди 5 часа, cybercop написа:

Как да е липсвала? Лаптопът ми още е под нея с Buster + Xfce. Със сигурност беше включена и в инсталатора на Stretch. Може би и в Jessie, но, тук, вече паметта ми изневерява. 

Е може и аз да греша ама ще разцъкам инсталатора на Бъстър да видя някой път :)

Линк към коментара
Сподели в други сайтове

Хм интересно под Дебиан 10 си направих пакет за RPM базирани дистрота ама си има чалъм за разлика от Дашната Сузи :)

Дебиан си остава най великото дистро засега

Линк към коментара
Сподели в други сайтове

на 10.01.2022 г. в 13:36, the professor написа:

то като вкарах репото и при опит за инсталация ми написа че картата не се поддържа (geforce-8800gt и geforce 620gt), това с 340xx.108-12, 108-10 изобщо не ми го предлага, а той работи... другото странно е че на компютър без nvidia (ati) драйвера се инсталира, въпреки че и там няма съвместима карта...

eто го правилния вариант, да си инсталирате nvidia-legacy-340xx https://forums.debian.net/viewtopic.php?p=748427#p748427

As they are no longer available on Bullseye, you can use them from Sid, but not every version seems to work correctly:
- nvidia-legacy-340xx-*_340.108-12_amd64.deb: again, kernel crashes (NULL pointer in drm_pci_set_busid)
- nvidia-legacy-340xx-*_340.108-11_amd64.deb: seems to work like a charm !

As they are no longer available on Bullseye, you can use them from Sid, but not every version seems to work correctly:
- nvidia-legacy-340xx-*_340.108-12_amd64.deb: again, kernel crashes (NULL pointer in drm_pci_set_busid)
- nvidia-legacy-340xx-*_340.108-11_amd64.deb: seems to work like a charm !

явно нещо са се оакали с 340.108-12... аз изпълних точките от 2 до 5 с лека промяна (ползвах apt-get за да мога да си имам пакетите в /var/cache/apt/archives):

2) install everything generic for nvidia blobs
sudo apt-get install dkms linux-headers-amd64 nvidia-installer-cleanup nvidia-support glx-alternative-nvidia libvdpau1 nvidia-modprobe nvidia-kernel-common

3) patch your depot source to access nvidia-legacy-340xx-*_340.108-11_amd64.deb (snapshot.debian.org, prior to 20211228 update that introduced nvidia-legacy-340xx-*_340.108-12_amd64.deb)
echo "deb http://snapshot.debian.org/archive/debian/20211227/ sid main contrib non-free" >> /etc/apt/sources.list

4) install nvidia-legacy-340xx-*_340.108-11_amd64.deb
sudo apt-get -o Acquire::Check-Valid-Until=false update
sudo apt-get install nvidia-legacy-340xx-driver nvidia-legacy-340xx-smi

5) restore your depot source to pure Bullseye

сега остава да пробвам steam отново...

Линк към коментара
Сподели в други сайтове

  • 2 месеца по-късно...

Стоя си на Firefox ESR и не виждам причина да минавам на стандартната версия.

=============================================================

Имам един странен проблем но той се проявява не само под Debian. Ако някои има идея да помогне ще се радвам.

Нови компютърни тонколони Logitech. Включени в изход за слушалки на лаптоп.

Audio:
  Device-1: Intel Broadwell-U Audio driver: snd_hda_intel
  Device-2: Intel Wildcat Point-LP High Definition Audio
  driver: snd_hda_intel
  Sound Server: ALSA v: k5.10.0-12-amd64

Проблема е, че тонколоните си работят определено време и в даден момент просто спират да свирят. При промяна на нивото на звука за цялата система, примерно усилване до определено ниво звука се активира отново. Същия проблем съм забелязал и при друг модел тонколони на същия производител. По интересното е, че ефекта се наблюдава и под Windows. Ето примерно сега докато пиша спряха да свирят. Сега съм с Audacious и слушам онлайн стриим. Усилих звука от самия плеер и тонколоните засвириха отново.

Тонколоните имат и собствен регулатор за силата на звука. Мислех си ако примерно ги намаля от техния регулатор а усилването на лаптопа и съответните приложения да е на по-високо ниво, дали няма да реши проблема.

Да не е някакъв специфичен режим на енергоспестяване на самите тонколони?

Иначе съм много доволен от системата 40 вата бас и много добро качество на звука. Имам опция за вход със чинчове но в случая трябва да ползвам преходник жак за слушалки към чинч.

Пробвах  с това но не помогна.

echo "options snd_hda_intel power_save=0" | sudo tee -a /etc/modprobe.d/audio_disable_powersave.conf

Линк към коментара
Сподели в други сайтове

С преходник от жак слушалки към камбанки си реших проблема. От два часа звука не е спирал. Явно това е някаква опция на производителя.

Извинявам се, че не съм съвсем по темата.

Иначе с този параметър на ядрото, който споделих по горе се избягва досадното препукване на звука заради енергоспестяващия режим. Този режим е активиран по подразбиране в повечето нови дистрибуции. Надявам се на някои да е полезно. :)

Линк към коментара
Сподели в други сайтове

Ако някой реши да си купува тонколони на Logitech, ето това, което открих току-що. Повечето нови модели имат вградена система за енергоспестяване. Ако входното ниво на звука не се променя в рамките на два часа тонколоните заспиват. Събуждат се с промяна във входящото ниво на звука. Някои потребители споделят, че ако входящото ниво на звука е достатъчно силно то тонколоните не влизат в енергоспестяващ режим. Идеята е подобна на тази, която предположих по горе. По големи стойности за сила на звука на компютъра и плеера и намаляване на звука от потенциометъра на самите тонколони.

Извода е, че и прехода, който ползвах като алтернатива не ми свърши работа но не е лошо да го имам.

Предполагам енергоспестяващия режим на ядрото на Linux работи на подобен принцип но с други параметри.

Линк към коментара
Сподели в други сайтове

Добавете отговор

Можете да публикувате отговор сега и да се регистрирате по-късно. Ако имате регистрация, влезте в профила си за да публикувате от него.

Гост
Публикацията ви съдържа термини, които не допускаме! Моля, редактирайте съдържанието си и премахнете подчертаните думи по-долу. Ако замените букви от думата със звездички или друго, за да заобиколите това предупреждение, профилът ви ще бъде блокиран и наказан!
Напишете отговор в тази тема...

×   Вмъкнахте текст, който съдържа форматиране.   Премахни форматирането на текста

  Разрешени са само 75 емотикони.

×   Съдържанието от линка беше вградено автоматично.   Премахни съдържанието и покажи само линк

×   Съдържанието, което сте написали преди беше възстановено..   Изтрий всичко

×   You cannot paste images directly. Upload or insert images from URL.

 Сподели

×
×
  • Добави ново...